ПО «PowerGraph»

Copyright © D.Izmailov, 2002-2012

Программное обеспечение «PowerGraph»®

Программное обеспечение (ПО) «PowerGraph» предназначено для записи, визуализации, обработки и хранения аналоговых сигналов, регистрируемых с помощью Аналого-Цифровых Преобразователей (АЦП).

ПО «PowerGraph» позволяет использовать персональный компьютер в качестве стандартных измерительных и регистрирующих приборов - вольтметров, самописцев, осциллографов, спектроанализаторов и др.

Назначение ПО «PowerGraph»:

  • Сбор данных с различных измерительных устройств.
  • Регистрация, визуализация и обработка сигналов в режиме реального времени.
  • Редактирование, математическая обработка и анализ данных.
  • Хранение, импорт и экспорт данных.

Функциональные возможности ПО «PowerGraph»:

1. Поддержка любых устройств сбора данных:

  • расширяемая библиотека драйверов, включающая платы и модули АЦП, измерительные приборы, виртуальные генераторы сигналов, компьютерные устройства ввода и звукозаписи;
  • возможность подключения новых устройств и источников сигналов;
  • поддержка управляющих компонентов устройств (цифровые входы/выходы, ЦАП’ы и др.).

2. Регистрация данных:

  • предварительный мониторинг входных сигналов;
  • индивидуальная настройка и калибровка каналов;
  • использование любых единиц измерения сигналов;
  • выбор произвольного набора каналов для регистрации;
  • использование произвольной частоты регистрации данных (частоты оцифровки);
  • аппаратная и программная синхронизация сбора данных (счетчики, таймеры, по уровню сигнала с записью пред- и пост-истории);
  • сохранение и отображение параметров сбора данных (тип устройства, дата, время, частота и длительность регистрации);
  • запись серии независимых измерений (блоков данных) в один файл;
  • установка текстовых меток (комментариев) на ленте записи;
  • ввод и хранение текстовой информации (заметки, примечания, протокол измерений) для каждого блока данных и для всего файла.

3. Визуализация данных:

  • визуализация сигналов в режимах самописца и осциллографа;
  • эффективная система графического представления больших объемов данных;
  • выбор формата значений шкалы времени (часы, минуты, секунды и т.д.);
  • выбор произвольного набора каналов для отображения;
  • независимое позиционирование и масштабирование графиков;
  • изменение цвета и стиля графиков и сетки.

4. Редактирование данных:

  • выделение любого участка данных для редактирования и анализа;
  • добавление к текущему файлу данных из других файлов;
  • изменение последовательности блоков данных в файле;
  • прореживание и усреднение данных по времени;
  • корректировка данных с использованием статистических значений;
  • графическое редактирование отдельных значений сигнала.

5. Обработка данных:

  • обширная библиотека функций математической и цифровой обработки сигналов: калибровка и корректировка, частотная и амплитудная фильтрация, дифференцирование и интегрирование, расчет параметров циклических сигналов, вычисление полинома, арифметические и логические операции, тригонометрические, логарифмические и другие математические функции;
  • обработка сигналов в режиме реального времени;
  • создание новых каналов с расчетными данными;
  • неограниченное количество промежуточных вычислений;
  • запись протокола вычислений для повторного использования комплексных алгоритмов обработки сигналов.

6. Анализ данных:

  • определение параметров сигналов по графикам с помощью скользящих маркеров;
  • дополнительные графические построения - проекции, касательные, статистические уровни и расчетные прямые;
  • многофункциональный спектроанализатор - построение различных типов спектральных графиков, расчет статистических значений в заданных частотных полосах, непрерывная регистрация данных с построением спектров в режиме реального времени;
  • двухкоординатный осциллограф - построение графиков межканальных зависимостей, в том числе в режиме реального времени;
  • гистограмма распределения сигналов по амплитуде;
  • библиотека статистических и информационных функций анализа данных.

7. Печать данных:

  • печать графиков и сетки в масштабе миллиметровой бумаги;
  • печать данных всего файла, отдельного блока или выделенного участка;
  • печать нескольких блоков данных на одном листе или каждого блока на отдельных листах;
  • печать в режимах независимых графиков, совмещения сеток и совмещения нулевых уровней графиков;
  • выбор печатаемых элементов страницы (имя файла, оси X и Y, заголовки и параметры блоков данных, текстовые заметки);
  • экспорт страниц печати в формате масштабируемых векторных рисунков (метафайлов).

8. Файлы, экспорт и импорт данных:

  • эффективный формат файлов, позволяющий хранить вместе с данными различные настройки, дополнительный текст и таблицы расчетных значений;
  • сохранение и использование индивидуальных настроек для каждого типа измерений;
  • импорт и экспорт текстовых файлов;
  • импорт и экспорт звуковых файлов;
  • импорт и экспорт двоичных файлов;
  • импорт и экспорт данных в текстовом формате через буфер обмена.

Дополнительные утилиты:

  • «Digital Voltmeter» (Цифровой Вольтметр) – предназначена для отображения численных значений входных сигналов и позволяет использовать АЦП в качестве обычного цифрового вольтметра. Поддерживается до 16 цифровых дисплеев, калибровка входных сигналов, однократный и циклический режимы измерений.
  • «File Recorder» (Запись Файлов) – предназначена для непосредственной регистрации сигналов в файл. Позволяет осуществлять автоматическую запись серии файлов с синхронизацией по времени, счетчику значений и уровню сигналов. Может использоваться для автономного сбора данных, не требующего присутствия оператора.
  • «File Viewer» (Просмотр Файлов) - предназначена для быстрого просмотра и поиска файлов, содержащих аналоговые сигналы. Позволяет одновременно визуализировать данные в режимах осциллограммы и спектрограммы, экспортировать данные в текстовом, звуковом и двоичном форматах, а также разделять длинные файлы на серию файлов меньшего размера с заданным шагом.

Для получения более подробной информации, смотри соответствующие разделы данного справочного руководства.

Минимальные требования:

  • Операционная система Windows (98, ME, 2000, XP, Vista, 7).
  • 128 Мб оперативной памяти.
  • 50 Мб дискового пространства.


Версии и редакции ПО «PowerGraph»

Версия 2.x программного обеспечения «PowerGraph» является бесплатной и распространяется свободно по принципу "как есть".

Версии 3.x программного обеспечения «PowerGraph» выпускается в следующих редакциях:

  • Demo - демонстрационная версия без возможности сохранения и экспорта данных.
  • Professional - коммерческая версия с полным набором функций регистрации, обработки, анализа, импорта и экспорта данных.
  • Analysis - коммерческая версия с функциями обработки, анализа, импорта и экспорта данных, но без возможности регистрации данных.

Сравнительная таблица версий

Операции | 2.x | 3.x
 |  | Demo | Professional | Analysis
Регистрация данных | + | + | + | -
Сохранение данных в файл | + | - | + | +
Редактирование данных | + | + | + | +
Обработка данных | + | + | + | +
Обработка данных в режиме реального времени | - | + | + | -
Анализ данных | + | + | + | +
Анализ данных в режиме реального времени | - | + | + | -
Импорт текстовых файлов | - | + | + | +
Импорт звуковых файлов | - | + | + | +
Импорт двоичных файлов | - | + | + | +
Экспорт данных в текстовом формате | + | - | + | +
Экспорт данных в звуковом формате | - | - | + | +
Экспорт данных в двоичном формате | - | - | + | +


Что нового в ПО «PowerGraph»

Данный раздел содержит информацию о новых возможностях и функциях программного обеспечения «PowerGraph».
Версии |
3.3.x: | 3.3.0 | 3.3.1 | 3.3.2 | 3.3.3 | 3.3.4 | 3.3.5 | 3.3.6 | 3.3.7 | 3.3.8
3.2.x: | 3.2.0 | 3.2.1 | 3.2.2 | 3.2.3 |  |  |

Версия 3.3.8

Управление аналоговыми выходами

Добавлена возможность управления аналоговыми выходами устройства:
  • изменение выходных аналоговых сигналов;
  • автоматическое изменение выходных аналоговых сигналов при запуске и остановке регистрации данных;
  • автоматическое управление выходными аналоговыми сигналами по уровню регистрируемых сигналов.
Далее см. - Управление аналоговыми выходами

Многоканальный X-Y Осциллограф

В X-Y Осциллограф добавлена возможность использовать до 4 каналов X.
Добавлена возможность использования фонового изображения.
Далее см. - X-Y Осциллограф

Гистограмма распределения

Добавлены новые функции построения гистограммы распределения значений сигнала:
  • выбор блока анализируемых данных;
  • анализ данных всего блока, данных в области выделения или только точек комментариев;
  • построение гистограммы количества значений и гистограммы плотности распределения;
  • построение дифференциальной и интегральной форм гистограммы распределения;
  • исключение из анализа нулевых значений и значений моды исходных данных.
Далее см. - Гистограмма

Интерполяция данных

Добавлена возможность интерполяции сигналов - повышение частоты дискретизации в целое число раз за счет добавления промежуточных значений. Новое окно Интерполяция данных позволяет использовать три варианта интерполяции - гладкая, линейная и ступенчатая.
Далее см. - Интерполяция данных

Функции математической обработки сигналов

Математические функции

В категорию Math (Математические) добавлены новые функции: ReciproCalibrate - линейная калибровка обратного значения числа, SqrtCalibrate и CalibrateSqrt - совмещение линейной калибровки и квадратного кореня.
Далее см. - Функции: Math

КИХ-фильтры

Добавлена дополнительная категория FIRN Filters (БИХ-фильтры), содержащая функции частотной фильтрации с управляемым количеством коэффициентов фильтра.
Далее см. - Функции: FIRN Filters

БИХ-фильтры

В категорию IIR Filters (БИХ-фильтры) добавлена новая функция FilterRC - универсальный фильтр RC-цепи. Аргументами функции являются коэффициенты БИХ-фильтра первого порядка.
Далее см. - Функции: IIR Filters

Циклические функции

В категорию Cyclic (Циклические) добавлены новые функции обработки циклических сигналов - CycleExtremum, CyclePointMax, CyclePointMin, CycleMinMax, CycleMiddle и CycleRMS.
Далее см. - Функции: Cyclic

Циклические функции

Добавлена дополнительная категория циклических функций CyclicA, в которых в качестве фильтра циклов используется наименьшая разница между максимальным и минимальным значениями цикла. Функции этой категории позволяют исключать из обработки шум, амплитуда которого меньше амплитуды полезного сигнала.
Далее см. - Функции: CyclicA

Функции смещения

В категорию Shift (Смещение) добавлены новые функции ShiftLeftFill и ShiftRightFill - смещение данных с заполнением начального или конечного участка первым или последним значением.
Далее см. - Функции: Shift

Функции уровней

В категорию Levels (Уровни) добавлены новые функции Sum, SumAbs, SumPositive и SumNegative - вычисление суммы всех, абсолютных, положительных и отрицательных значений сигнала.
Далее см. - Функции: Levels

Статистический анализ комментариев

В окно Таблица значений добавлены функции статистического анализа комментариев - RMS, RMSSD, Interval RMS и Interval RMSSD.
Далее см. - Таблица значений: Комментарии

Комментарии

Максимальное количество комментариев в блоке увеличено до 20000.
Добавлено отображение значений сигналов в точках комментариев.
Далее см. - Комментарии

Панели значений

В программу PowerGraph добавлены панели значений.
Далее см. - Панели значений

Синхронизация сбора данных

Добавлена автоматическая загрузка последних настроек синхронизации при запуске программы.

Импорт данных

Добавлен импорт данных из файлов WinDaq (DATAQ Instruments, Inc.) и Axon Binary (Axon Instruments, Inc.).

Настройки

Для команд Загрузить настройки и Сохранить настройки в меню Файл добавлена автоматическая загрузка и сохранение настроек синхронизации, а также настроек управления цифровыми и аналоговыми выходами.

Выбор языка справки

Во все программы ПО «PowerGraph» добавлена возможность выбора языка справочного руководства с помощью команд Язык справки меню Помощь. Доступные варианты выбора языка справочного руководства: Автоматически, Русский и Английский.

Утилита «File Recorder»

В параметры синхронизации утилиты File Recorder добавлена возможность записи синхронизированных данных в один файл.
Далее см. - Утилиты: «File Recorder»

Версия 3.3.7

Автокомментарии

Добавлена возможность автоматической установки комментариев в определенных точках сигнала. Новое окно Автокомментарии позволяет устанавливать комментарии через равные интервалы времени, в точках пересечения сигналом контрольного уровня, а также в локальных минимумах и максимумах сигнала.
Далее см. - Автокомментарии

Статистический анализ комментариев

В окно Таблица значений добавлены функции статистического анализа комментариев. Новые функции позволяют вычислять статистические параметры амплитуды сигнала в точках комментариев, а также статистические параметры временных интервалов между комментариями.
Далее см. - Таблица значений: Комментарии

Экспорт комментариев в текстовом формате

Добавлена возможность экспорта в текстовом формате отдельных точек данных, в которых установлены комментарии.
Далее см. - Экспорт данных в текстовом формате

Удаление выделенных данных

Добавлена возможность удаления выделенного участка данных внутри блока без разделения блока.
Далее см. - Редактирование данных

Объединение блоков

Добавлена возможность объединения данных двух соседних блоков, имеющих идентичные параметры.
Далее см. - Редактирование данных

Дублирование данных

Добавлена возможность обмена данными между блоками. Новое окно Дублирование данных позволяет копировать данные в другие каналы и блоки с применением дополнительной математической обработки копируемых сигналов.
Далее см. - Обработка: Дублирование данных

Утилита «File Recorder»

Новая версия утилиты File Recorder (Запись файлов):
  • визуализация любого набора каналов;
  • масштабирование и позиционирование графиков;
  • предварительный мониторинг и линейная калибровка входных сигналов;
  • сохранение и загрузка настроек каналов и параметров синхронизации;
  • синхронизация записи файлов по уровню входного сигнала;
  • автоматическая запись файлов в отдельную папку с текущей датой;
  • автоматический запуск утилиты при включении и перезагрузке компьютера;
  • автоматический запуск регистрации данных при запуске утилиты;
  • автоматический запуск других программ для обработки записанных файлов;
  • автоматическое управление состоянием цифровых выходов в процессе регистрации.
Далее см. - Утилиты: «File Recorder»

Утилита «Digital Voltmeter»

Новая версия утилиты Digital Voltmeter (Цифровой вольтметр):
  • выбор от 1 до 16 цифровых дисплеев;
  • выбор индивидуального стиля для каждого дисплея;
  • линейная калибровка входных сигналов;
  • сохранение и загрузка настроек.
Далее см. - Утилиты: «Digital Voltmeter»

Версия 3.3.6

Синхронизация сбора данных

Добавлены новые возможности синхронизации:
  • автоматическая запись серии блоков по условиям синхронизации;
  • синхронизация сбора данных по системным часам компьютера;
  • регистрация данных в режиме "скользящего" блока ограниченного размера;
  • удаление предварительных данных в процессе ожидания синхронизации.
Далее см. - Регистрация данных: Синхронизация

Функции математической обработки сигналов

Арифметические функции

В категорию Arithmetics (Арифметические) добавлены новые функции: Quotient - целое частное от деления одного канала на другой, Remainder - остаток от целочисленного деления одного канала на другой.
Добавлены также новые функции, совмещающие арифметические операции и калибровку: AddCalibrate, SubCalibrate, MpyCalibrate, DivCalibrate - сложение, вычитание, умножение и деление сигналов с последующей калибровкой результата; CalibrateAdd, CalibrateSub, CalibrateMpy, CalibrateDiv - калибровка сигналов с последующим их сложением, вычитанием, умножением и делением.
Далее см. - Функции: Arithmetics

Математические функции

В категорию Math (Математические), добавлена новая функция Reciprocal - вычисление обратной величины сигнала.
Далее см. - Функции: Math

Фильтры

В категорию Filters (Фильтры), добавлена новая функция ACSelectMax - выделение из сигнала составляющей с максимальной амплитудой в заданном диапазоне частот.
Далее см. - Функции: Filters

Преобразование Гильберта

В категорию Hilbert Filters (Фильтры Гильберта) добавлены новые функции определения фазы гармонического сигнала - HilbertPhase и HilbertPhasePI.
Изменились названия функций, вычисляющих амплитудную огибающую сигнала - HilbertMag, HilbertMagDC и HilbertMagNoDC
Далее см. - Функции: Hilbert Filters

Обработка в реальном времени

Расширен набор функций, используемых для обработки сигналов в процессе регистрации данных (в режиме реального времени): все функции категорий Arithmetics (Арифметические), Math (Математические) и Comparison (Сравнение), а также функция MedianFilter (медианный фильтр) в категории Filters (Фильтры).

Устройства сбора данных

Добавлена возможность регистрации данных от GPS-приемников, передаваемых по стандартному протоколу NMEA. Новый системный драйвер GPS-NMEA позволяет регистрировать перемещение, скорость и направление по данным GPS.
Далее см. - Системные прототипы АЦП: GPS-NMEA

Версия 3.3.5

Библиотека импорта данных

В состав ПО «PowerGraph» включена программная библиотека импорта данных - PowerGraph Import Library, предоставляющая возможность чтения данных из любых поддерживаемых файловых форматов. Библиотека PowerGraph Import Library представляет собой набор COM-компонентов доступа к данным и обладает следующими преимуществами:
  • Универсальность чтения данных из любых файловых форматов, поддерживаемых в ПО «PowerGraph». Для чтения данных из различных файловых форматов используется единый набор свойств и методов, все особенности и различия файловых форматов учитываются в самой библиотеке и скрыты от программиста.
  • Независимость от используемого языка программирования. Для чтения данных из файлов ПО «PowerGraph» могут быть использованы любые программные средства, поддерживающие работу с COM и ActiveX компонентами (MS Office VBA, MS Visual Basic, MS Visual C++, Borland C++, Delphi, LabView и др.).
Библиотека импорта данных позволяет пользователям, разрабатывающим собственные специализированные программы обработки и анализа данных, считывать данные непосредственно из файлов ПО «PowerGraph», минуя промежуточные стадии конвертирования данных в текстовый и другие общедоступные форматы файлов. Использование собственных файлов ПО «PowerGraph» обеспечивает получение наиболее полной и точной информации о записанных данных и условиях проведения измерений.

Запуск внешних программ

Добавлена возможность автоматического запуска указанных пользователем программ после сохранения и экспорта данных в файлы. Запускаемым программам в качестве аргументов командной строки передаются полный путь и имена создаваемых файлов.
Запуск внешних программ, наряду с использованием библиотеки импорта данных, позволяет пользователям ПО «PowerGraph» автоматизировать процесс обработки и анализа данных с помощью дополнительного программного обеспечения.
Далее см. - Дополнительные параметры: Автозапуск

Функции математической обработки сигналов

Добавлена новая категория IIR Filters (БИХ фильтры), включающая функции рекурсивной частотной фильтрации: LowPassRC и HighPassRC - аналоги электронных RC-цепей, а также NarrowBandPass и NarrowBandStop - узкополосные фильтры.
Далее см. - Функции: IIR Filters

Печать полной шкалы Y

Добавлена возможность печати шкалы Y каждого графика на всю высоту страницы.
Далее см. - Печать данных

Печать в окне X-Y Осциллографа

Добавлена возможность печати графиков в окне X-Y Осциллограф.
Далее см. - Анализ: X-Y Осциллограф

Прореживание данных

Добавлены дополнительные способы прореживания (децимации) данных - вычисление максимального, минимального, медианы, а также использование первого, последнего и центрального значения из каждых N значений исходных данных.
Далее см. - Обработка: Прореживание данных

Управление цифровыми выходами

Добавлена возможность сохранения и загрузки настроек автоматического управления состоянием цифровых выходов в процессе регистрации.
Далее см. - Цифровые выходы

Справка

Добавлено описание выбора языка пользовательского интерфейса ПО «PowerGraph» с помощью настроек операционной системы.
Далее см. - Интерфейс программы: Выбор языка

Версия 3.3.4

Печать

Добавлены новые возможности печати данных:
  • Печать данных всего файла, отдельного блока или области выделения.
  • Печать нескольких блоков на одном листе или каждого блока на отдельных листах.
  • Печать в режимах независимых графиков, совмещения сеток и совмещения нулевых уровней.
  • Изменение положения графиков на странице.
  • Печать текстовых заметок блоков.
  • Выбор и настройка элементов разметки страницы: имя файла, оси X и Y, заголовки и параметры блоков данных, текстовые заметки.
  • Изменение размера полей страницы.
  • Экспорт страниц печати в формате масштабируемых векторных рисунков (метафайлов).
Далее см. - Печать данных

Визуализация сигналов

В главном окне программы и в окне спектроанализатора добавлена возможность увеличения масштаба шкалы X до значения 1:20.
Далее см. - Блоки данных: Изменение масштаба шкалы

Изменение частоты регистрации

Добавлена возможность ввода частоты регистрации в единицах времени между соседними значениями, а также изменения частоты регистрации всех блоков.
Далее см. - Блоки данных: Изменение частоты регистрации

Дополнительные параметры программы

Добавлена возможность отображения значения времени комментариев на ленте записи.
Далее см. - Дополнительные параметры: Вид
Добавлена возможность округления значений амплитуды до заданного количества значащих или десятичных цифр.
Далее см. - Дополнительные параметры: Формат
Добавлены параметры печати данных.
Далее см. - Дополнительные параметры: Печать
Добавлено значение частоты регистрации, используемое по умолчанию при импорте данных.
Далее см. - Дополнительные параметры: Общие

Справка

В раздел Приложения добавлены новые описания:
  • Приложение Б - функции вычисления скользящего значения.
  • Приложение Г - особенности обработки сигналов в режиме реального времени.

Версия 3.3.3

Таблица значений

Модифицировано окно Таблица значений:
  • добавлена возможность выбора и вычисления нескольких функций;
  • добавлена общая таблица значений, позволяющая вычислять несколько выбранных функций во всех блоках файла;
  • добавлена возможность копирования и сохранения таблиц значений нескольких выбранных блоков.
Далее см. - Анализ: Таблица значений

X-Y Осциллограф

Добавлены новые возможности окна X-Y Осциллограф:
  • копирование и сохранение видимого участка данных в текстовом формате;
  • перемещение графиков с помощью клавиатуры.
Далее см. - Анализ: X-Y Осциллограф

Функции математической обработки сигналов

Добавлены новые функции математической обработки сигналов:

Преобразование Гильберта

Добавлена новая категория функций Hilbert Filters (Фильтры Гильберта), осуществляющих выделение огибающей амплитудно-модулированного сигнала с помощью преобразования Гильберта.
Далее см. - Функции: Hilbert Filters

Арифметические функции

В категорию Arithmetics (Арифметические) добавлена функция Magnitude - вычисление модуля двух сигналов.
Далее см. - Функции: Arithmetics

Статистические функции

В категорию Statistic (Статистические) добавлены новые функции: StdDevPt - вычисление скользящего стандартного отклонения, MaxPt - вычисление скользящего максимального значения, MinPt - вычисление скользящего минимального значения, RangePt - вычисление скользящего диапазона значений, CrossCorrelationPt - вычисление скользящего коэффициента корреляции.
Далее см. - Функции: Statistic

Сравнение сигналов

В категорию Comparison (Сравнение) добавлены новые логические функции RangeIn и RangeOut, позволяющие определить принадлежность значений сигнала заданному диапазону амплитуды.
Далее см. - Функции: Comparison

Функции обработки циклических сигналов

Ко всем функциям категории Cyclic (Циклические) добавлен новый аргумент - Количество точек, позволяющий указать наименьший размер циклов, на которые разбивается сигнал. Ограничение наименьшего размера циклов позволяет исключить из обработки случайные выбросы и высокочастотные шумы.
Далее см. - Функции: Cyclic

Версия 3.3.2

Режим осциллографа

Добавлена возможность визуализации регистрируемых данных в режиме осциллографа. В отличие от режима самописца (движение ленты записи), в режиме осциллографа сигналы отображаются слева-направо в виде неподвижных графиков.
Далее см. - Регистрация данных

Вычисление полинома

Появилась возможность обработки сигналов по формуле полинома.
Далее см. - Обработка: Полином

Спектроанализатор

Перемещение области выделения

Появилась возможность перемещения области выделения с помощью клавиатуры.

Копирование отдельных значений спектра

Появилась возможность копирования отдельных значений спектра в "Таблицу значений".

Уровень звукового давления

Добавлена возможность вычисления среднего и суммарного уровней звукового давления в частотных полосах.
Далее см. - Анализ: Спектроанализатор

Утилита «File Viewer»

В утилиту «File Viewer» добавлена возможность построения спектрограммы сигналов. Спектрограмма позволяет определить изменение частотных составляющих на различных участках сигнала.
Далее см. - Утилиты: «File Viewer»

Версия 3.3.1

Добавление текстовых меток данных

Появилась возможность устанавливать на ленте записи комментарии - текстовые метки, обозначающие определенную точку данных внутри блока. Использование комментариев позволяет:
  • фиксировать различные события, возникающие в процессе регистрации данных;
  • разделять непрерывный набор данных блока на логические участки;
  • отмечать на ленте записи отдельные значения сигнала (например, максимальное или минимальное).
Комментарии отображаются на графиках как вертикальные линии и пояснительный текст, расположенные в заданных точках шкалы времени. Программа «PowerGraph» позволяет редактировать текст комментариев, удалять существующие и добавлять в блок новые комментарии, а также использовать текстовые файлы для хранения списков комментариев.
Далее см. - Комментарии

Работа с файлами

Несколько экземпляров программы

Появилась возможность запускать несколько экземпляров программы «PowerGraph» для одновременного анализа и обработки нескольких файлов.

Запуск программы при выборе файла

Добавлена возможность автоматического запуска программы «PowerGraph» при двойном щелчке на имени файла.

Операции "Drag&Drop"

Добавлена поддержка операций "Drag&Drop" (Переместить и Отпустить) для открытия файлов.

Настройки каналов

Атрибуты каналов

Добавлены новые атрибуты каналов, позволяющие включать регистрацию скрытых каналов и отключать сохранение расчетных данных.

Уровни амплитуды

Добавлены дополнительные графические построения уровней амплитуды, позволяющие отображать на графиках возможные или допустимые диапазоны изменения сигналов, а также определять точки, в которых сигнал достигает заданного значения.
Далее см. - Настройки каналов

Дополнительные параметры программы

Графические элементы

Добавлена возможность отображения дополнительных графических элементов: нулевые линии графиков, уровни амплитуды, названия и разделительные линии блоков, линии и текст комментариев.

Индексы точек

Добавлена возможность отображения индексов точек на шкале времени.

Автосохранение вычислений

Добавлена возможность автоматического сохранения расчетных данных.
Далее см. - Дополнительные параметры

Функции математической обработки сигналов

Добавлены новые функции математической обработки сигналов:

Сравнение сигналов

В категорию Comparison (Сравнение) добавлены новые функции выбора значения из двух сравниваемых каналов: SelectMax - выбор большего значения, SelectMin - выбор меньшего значения.
Далее см. - Функции: Comparison

Копирование изображения

Добавлена возможность копирования в буфер обмена (Clipboard) изображения графического дисплея (команда Копировать изображение в меню Правка).
Далее см. - Меню и панели инструментов

Версия 3.3.0

Русифицированный интерфейс

Добавлена поддержка русского языка - при использовании русифицированной версии операционной системы все программы, входящие в ПО «PowerGraph», также имеют русифицированный пользовательский интерфейс. В остальных случаях язык пользовательского интерфейса - английский.
Далее см. - Меню и панели инструментов

Новая утилита «File Viewer»

Появилась новая утилита «File Viewer» (Просмотр файлов), предназначенная для быстрого просмотра двоичных файлов, записанных утилитой «File Recorder» (Запись файлов). Утилита «File Viewer» позволяет также разделять длинные файлы на серию файлов меньшего размера и экспортировать данные в текстовом формате.
Далее см. - Утилиты: «File Viewer»

Новая утилита «License Query»

Появилась новая утилита «License Query» (Запрос лицензии), предназначенная для создания запроса в службу технической поддержки ПО «PowerGraph» на получение лицензий для устройств сбора данных.
Далее см. - Утилиты: «License Query»

Синхронизация сбора данных

Добавлена возможность синхронизации по уровню сигнала в расчетном канале. Для запуска и остановки регистрации могут быть использованы расчетные данные, полученные в результате обработки сигналов в режиме реального времени.
Далее см. - Регистрация данных: Синхронизация

Функции математической обработки сигналов

Добавлены новые функции математической обработки сигналов:

Data

В категорию Data (Данные) добавлена новая функция Nothing, позволяющая удалить расчетные данные канала. Функция Nothing дублирует команду удаления расчетных данных в меню канала, но может быть использована при работе с алгоритмами (списками формул) для удаления промежуточных вычислений.
В эту категорию также добавлены новые функции для нормализации данных по времени или частоте регистрации: функция NormalizeByRate - позволяет разделить данные на частоту регистрации (умножить на время между двумя соседними значениями); функция NormalizeByTime - позволяет разделить данные на время между двумя соседними значениями (умножить на частоту регистрации).
Далее см. - Функции: Data

Differential

В категорию Differential (Дифференцирование) добавлены функции дифференцирования сигналов с нормализацией по времени (деление дифференциала на шаг по времени dT): Diff1PtNorm, Diff3PtNorm и Diff5PtNorm.
Далее см. - Функции: Differential

Integral

В категорию Integral (Интегрирование) добавлена функция интегрирования сигнала с нормализацией по времени (умножение интеграла на шаг по времени dT) - Integral1PtNorm.
Далее см. - Функции: Integral

Версия 3.2.3

Управление цифровыми выходами

Добавлена возможность управления состоянием цифровых выходов устройства:
  • изменение состояния отдельных цифровых выходов;
  • автоматическое изменение состояния цифровых выходов при запуске и остановке регистрации данных;
  • автоматическое управление состоянием цифровых выходов по уровню входных сигналов в процессе регистрации данных.
Далее см. - Управление цифровыми выходами

Версия 3.2.2

Спектральный анализ

Модифицировано окно спектрального анализа сигналов:
  • размер Фурье преобразования увеличен до 1048576 значений (2 в степени 20);
  • добавлена возможность усреднения спектров длинных сигналов с различными способами перекрытия;
  • увеличено количество весовых функций, добавлена возможность визуального сравнения и выбора весовых функций;
  • добавлена возможность одновременного расчета и визуализации спектров сигналов и статистических значений в заданных частотных полосах;
  • добавлено окно осциллографа для просмотра исходных сигналов и выделения участков сигнала для анализа;
  • добавлена возможность регистрации и мониторинга сигналов в режиме спектроанализатора.
Далее см. - Анализ: Спектроанализатор

Версия 3.2.1

Математическая обработка сигналов

Модифицировано окно функций математической обработки сигналов. Оптимизирована система использования алгоритмов (наборов формул) вычислений. Расширен формат функций обработки сигналов:
  • использование нескольких каналов;
  • использование нескольких числовых аргументов.
Далее см. - Математическая обработка сигналов

Функции математической обработки сигналов

Добавлены новые функции обработки сигналов:

Data

В категорию Data (Данные) добавлена новая функция калибровки сигнала Calibrate, являющаяся комбинацией функций Scale (умножение на число) и Offset (прибавление числа).
Далее см. - Функции: Data

Filters

В категорию Filters (Фильтры) добавлена новая функция копирования значений в заданном диапазоне амплитуды RangeFilter, являющаяся комбинацией функций Above и Below.
Далее см. - Функции: Filters

FIR Filters

В категорию FIR Filters (частотные КИХ-фильты) добавлена группа полосовых фильтров BandPass (пропускающие) и BandStop (задерживающие).
Далее см. - Функции: FIR Filters

Statistic

В категорию Statistic (Статистические) добавлена новая функция CrossCorrelation для расчета коэффициентов взаимной корреляции двух сигналов.
Далее см. - Функции: Statistic

Integral

В категорию Integral (Интегральные) добавлены новые функции расчета относительной площади под кривой AreaPositivePt и AreaNegativePt.
Далее см. - Функции: Integral

Generators

Добавлена новая категория Generators (Генераторы) содержащая функции-генераторы сигналов различной формы.
Далее см. - Функции: Generators

Формат шкалы времени

Добавлена возможность выбора формата отображения значений на шкале времени (часы, минуты, секунды, миллисекунды, микросекунды).
Далее см. - Дополнительные параметры

Осциллографический режим

Добавлена возможность управления скоростью обновления графиков в процессе регистрации данных, что позволяет использовать вместо плавного движения ленты самописца режим обновления статичного изображения через заданный интервал времени.
Далее см. - Дополнительные параметры

Таблица значений

В окно Таблица значений добавлены функции суммирования значений сигнала - категория функций Sum.
Далее см. - Анализ: Таблица значений

Импорт данных из буфера обмена

Добавлена возможность импорта данных в текстовом формате из буфера обмена - команда Paste from Clipboard в меню Edit.

Версия 3.2.0

Поддержка 32 каналов

В версии 3.2 программного обеспечения «PowerGraph» общее количество каналов расширено до 32. В процессе работы с программой общее количество наборов данных может достигать 64, так как каждый канал позволяет использовать 2 независимые копии данных: основные (записанные с АЦП) и расчетные (полученные в результате математической обработки).

Операции с каналами

Добавлены новые функции для работы с данными каналов:
  • полный пересчет всех каналов по установленным формулам;
  • полное удаление всех данных канала во всех блоках;
  • определение последовательности обработки каналов.
Далее см. - Работа с каналами

Математическая обработка сигналов

Модифицировано окно функций обработки сигналов. Оптимизирована система регистрации, сохранения и использования протоколов вычислений.
Добавлена возможность сохранения в канале последней формулы вычислений.
Далее см. - Математическая обработка сигналов

Математическая обработка сигналов в реальном времени

В версию 3.2 добавлена возможность проведения математической обработки сигналов в процессе регистрации данных (в режиме реального времени). Расширенные настройки позволяют определить для каждого канала математическую формулу, используемую для заполнения расчетных данных в процессе регистрации.
Далее см. - Настройки каналов

Функции обработки сигналов

Добавлено более 30 новых функций математической обработки сигналов:

Data

В категорию Data (Данные) добавлена новая функция RawData, расширяющая спектр операций с наборами данных и позволяющая загружать основные данные одного канала в расчетные данные другого.
Добавлены также новые функции OffsetMedian (смещение амплитуды сигнала на величину медианы) и OffsetMiddle (центровка сигнала относительно нуля).
Далее см. - Функции: Data

Math

В категорию Math (Математические) добавлены новые функции Power (возведение значений в произвольную степень) и Power2 (возведение значений в квадрат).
Далее см. - Функции: Math

Levels

В новую категорию Levels (Уровни) выделены функции, заполняющие данные канала одним значением - уровнем сигнала. В качестве уровня сигнала могут быть использованы расчетные статистические значения (максимальное, минимальное, среднее и др.), а также пользовательские и математические константы.
Далее см. - Функции: Levels

Filters

В категорию Filters (Фильтры) добавлена новая функция MedianFilter (медианный фильтр).
Далее см. - Функции: Filters

FIR Filters

Новая категория FIR Filters (КИХ-фильты) содержит функции фильтрации сигналов, представляющие собой нерекурсивные частотные фильтры (фильтры с конечной импульсной характеристикой).
Далее см. - Функции: FIR Filters

Smoothing

В новую категорию Smoothing (Сглаживание) выделены функции сглаживания (усреднения) сигналов с использованием алгоритма скользящего среднего. В эту категорию также добавлены новые функции, использующие различные весовые коэффициенты усреднения.
Далее см. - Функции: Smoothing

Statistic

В категорию Statistic (Статистические) добавлена новая функция AutoCorrelation (расчет автокорреляционной функции сигнала).
Далее см. - Функции: Statistic

Shift

В категорию Shift (Смещение) добавлены функции сортировки данных по амплитуде - SortAsc (сортировка значений в порядке возрастания) и SortDesc (сортировка значений в порядке убывания).
Далее см. - Функции: Shift

Анализ данных

Таблица значений

Появилась возможность использовать для каждого блока индивидуальную таблицу значений (значения отдельных точек, расчетные статистические значения, параметры блока и области выделения и др.). Таблицы значений сохраняются в файл вместе с данными блоков.
Далее см. - Анализ: Таблица значений

Спектральный анализ

Добавлена возможность расчета статистических значений в третьоктавных полосах.
Далее см. - Анализ: Спектроанализатор

Построение зависимостей

Появилось многоканальное окно X-Y Осциллограф для построения графиков зависимости нескольких каналов. Добавлена возможность построения графиков зависимости в процессе регистрации данных (в режиме реального времени).
Далее см. - Анализ: X-Y Осциллограф

Синхронизация сбора данных

Появилась возможность просмотра сигналов до момента включения стартового триггера синхронизации. Визуализация данных начинается непосредственно с момента запуска регистрации, при возникновении события синхронизации предшествующие данные удаляются.
Сняты максимальные ограничения счетчиков значений пред- и пост-истории при синхронизации по уровню сигнала и счетчика записанных данных.
Далее см. - Регистрация данных: Синхронизация

Прореживание данных

Модифицировано окно прореживания данных (Decimation). Добавлена возможность создания нового блока при прореживании.
Далее см. - Обработка: Прореживание данных

Файлы

Улучшены параметры быстродействия при работе с файлами. Расширенный формат файлов позволяет теперь хранить вместе с данными таблицы расчетных значений и формулы математической обработки сигналов.

Настройки

Оптимизирована система использования настроек. В меню File появились дополнительные команды загрузки, сохранения и сброса настроек. При каждом запуске программы осуществляется загрузка последней сохраненной конфигурации.
Далее см. - Настройки каналов

Автосохранение

Добавлены функции автоматического сохранения настроек и данных.
Далее см. - Дополнительные параметры

Импорт и экспорт данных

Текстовые файлы

Добавлена возможность экспорта в текстовом формате с индексами точек в первом столбце.
Добавлена возможность выбора количества знаков после запятой при экспорте в текстовом формате.
Далее см. - Текстовые файлы

Двоичные файлы

Добавлена возможность экспорта данных в формате бинарных файлов утилиты «File Recorder» (файлы .bin).
Добавлена возможность экспорта данных в двоичном формате (файлы .dat).
Добавлена полная поддержка (импорт и экспорт) файлов программы «L-Graph» (файлы .dat и .par)
Далее см. - Двоичные файлы

Утилита «File Recorder»

В утилиту File Recorder добавлена возможность ограничения длительности файлов по счетчику записанных значений.
Далее см. - Утилиты: «File Recorder»


С чего начать?

Рекомендация: Начните свое знакомство с программным обеспечением «PowerGraph» с изучения интерфейса программы и описания команд меню и панелей инструментов.

Выбор устройства регистрации данных

Работа с программой «PowerGraph» начинается с выбора устройства, которое Вы будете использовать для регистрации данных (подробное описание процесса выбора устройства смотри в разделе Выбор АЦП).
На первых этапах работы с «PowerGraph» Вы можете использовать виртуальное устройство F-Generator ("генератор функций"). Этот драйвер математически генерирует гармонические сигналы и позволяет менять их амплитуду и частоту.
Выбор драйвера АЦП

Регистрация данных

После загрузки программа полностью готова к регистрации.

В правом нижнем углу окна программы расположена кнопка Старт (Start).

  1. Нажмите кнопку Старт для запуска процесса регистрации.
  2. Нажмите эту кнопку еще раз для остановки регистрации.
Сверху над кнопкой запуска и остановки регистрации расположен список записанных блоков данных - программа «PowerGraph» позволяет последовательно записывать в один файл серию измерений. 		Список блоков и кнопка запуска/остановки регистрации

Изменение частоты регистрации

Меню частоты регистрации В правом верхнем углу главного окна программы расположена кнопка выбора частоты регистрации данных.
  1. Нажмите эту кнопку - появилось меню, показанное на рисунке справа.
  2. Выберите в меню другое значение частоты регистрации.
  3. Снова запустите регистрацию (см. выше).
Попробуйте записать несколько блоков данных с различной частотой, например - 20, 50, 100,... (эти цифры соответсвуют количеству значений записанных в секунду для каждого канала). Все записанные блоки появятся в списке над кнопкой Старт.
Перемещайте курсор мыши над графиками - при этом Вы сможете определить значения времени и амплитуды для каждого графика в точке под курсором. Информация о блоке будет отображаться над списком блоков.

Мониторинг входных сигналов

Нажмите на панели инструментов кнопку Входной усилитель или в меню Сервис выберите команду Входной Усилитель... (Input Amplifier). Появится дополнительное окно Входной Усилитель, в котором Вы можете поочередно просматривать входные сигналы всех каналов АЦП, а также изменять их настройки:

Изменение параметров сигналов

Нажмите на панели инструментов кнопку Параметры АЦП или в меню Сервис выберите команду Настройки "F-Generator".... Появится окно настроек генератора функций:

Измените параметры каналов генератора функций. Посмотрите с помощью "Входного Усилителя", как изменились сигналы. Попробуйте записать несколько блоков данных и определить изменения сигналов на графиках.

Изменение параметров графиков

У левой границы окна программы расположены служебные кнопки каждого из графиков. Нажмите одну из кнопок, чтобы появилось меню соответствующего графика:

Выберите последнюю команду Настройки... (Settings), при этом откроется дополнительное окно программы Настройки канала:

Свойства Канала: Общие

Текстовые поля Имя (Title) и Ед. (Unit) на вкладке Общие (General) позволяют указать название канала и единиц измерения сигнала.

На вкладке Вид (View) Вы можете выбрать цвет и стиль заливки графика канала:

Свойства Канала: Вид

См. также
Интерфейс программы, Меню и панели инструментов


Интерфейс программы

Главное окна программы «PowerGraph» состоит из следующих функциональных частей:
  1. Меню и панели инструментов - в верхней части главного окна программы.
  2. Графический дисплей - в центральной части главного окна программы.
  3. Шкала амплитуды - слева от графического дисплея.
  4. Шкала времени - под графическим дисплеем.
  5. Информационная панель - справа сверху от графического дисплея.
  6. Панель записи - справа снизу от графического дисплея.
  7. Строка состояния - в нижней части главного окна программы.
Меню и панели инструментов
Шкала амплитуды Графический дисплей
Шкала времени
Строка состояния

Меню и панели инструментов

См. Меню и панели инструментов

Графический дисплей

Графический дисплей содержит графики всех записанных данных в виде последовательности блоков. Для лучшего понимания работы графического дисплея его можно представить в качестве ленты самописца, содержащей координатную сетку и графики каналов.
Графический дисплей позволяет выделять любую область данных внутри блока для редактирования и анализа. При перемещении курсора мыши над графическим дисплеем, по каждому из графиков перемещается маркер, указывающий соответствующую точку данных. Численное значение амплитуды сигнала в точке под маркером отображается на шкале амплитуды.

Шкала амплитуды

Шкала амплитуды содержит кнопки управления каналами и графиками, имеющие цветовую маркировку. Слева от кнопки графика указывается номер канала, сверху - название канала, справа - масштаб шкалы для данного канала или текущее значение амплитуды сигнала под маркером. Шкала амплитуды позволят с помощью мыши изменять положение каждого графика по вертикали.

Шкала времени

Шкала времени содержит ось времени и горизонтальную полосу прокрутки, позволяющую пролистывать ленту записи вперед и назад. Слева от полосы прокрутки расположены кнопки, позволяющие изменять масштаб шкалы времени. Для каждого блока данных на оси времени указывается его порядковый номер.

Информационная панель

Информационная панель отображает дополнительную служебную информацию - параметры блоков данных и области выделения, а также текущие значения сигналов в процессе регистрации. В верхней части информационной панели расположена кнопка быстрого доступа к меню выбора частоты регистрации данных.

Панель записи

Панель записи содержит список всех записанных блоков и кнопки управления процессом регистрации данных. В верхней части панели записи расположена кнопка быстрого доступа к меню операций с блоками.

Строка состояния

Строка состояния содержит контекстную информацию о текущем состоянии программы и файла:
Элемент | Показывает
# | Количество включенных графиков.
Ch# | Активный канал.
#‡ | Масштаб шкалы Y активного канала.
#,#% | Видимая часть ленты записи.
... | Текущая операция.
S: # ### | Общий размер файла (количество значений).
V: #,### KB | Общий объем файла (в байтах).
DD.MM.YY | Текущая дата.

Начало страницы

См. также
Меню и панели инструментов, Сочетания клавиш


Меню и панели инструментов

Файл Правка Вид Сервис Канал Блок Обработка Анализ Помощь
Создать новый файл Добавить файлы к текущей записи Сохранить файл под новым именем Предварительный просмотр печатных страниц Сохранить блок данных в файл (экспорт) Сохранить выделенный участок данных в файл (экспорт) Копировать блок данных (экспорт) Копировать выделенный участок данных (экспорт) Индивидуальные настройки АЦП Функции математической обработки сигналов
Общее меню каналов и графиков Установить базовый уровень Уменьшить масштаб шкалы Y Увеличить масштаб шкалы Y Распределить графики по вертикали Совместить базовые уровни графиков Совместить сетки графиков Переместить блок в начало Переместить блок назад Переместить блок вперед Переместить блок в конец Создать копию блока Копировать выделенный участок данных в новый блок Удалить выделенный участок данных
Индивидуальное меню канала
Переход к началу записи Переход к предыдущей странице Переход к следующей странице Переход к концу записи Масштаб шкалы X

Файл Файловые операции
Новый файл | Создать | Создать новый файл
Открыть файл | Открыть... | Открыть файл
Добавить файлы | Добавить... | Добавить данные из других файлов
Сохранить файл | Сохранить | Сохранить файл
Сохранить файл под другим именем | Сохранить как... | Сохранить файл под другим именем
Сохранить блок | Сохранить блок... | Сохранить в файл данные активного блока (экспорт)
Сохранить область выделения | Сохранить выделение... | Сохранить в файл данные области выделения (экспорт)
Параметры страницы... | Параметры печатной страницы
Предварительный просмотр перед печатью | Предварительный просмотр... | Предварительный просмотр печатных страниц
Печать | Печать... | Печать графических данных
Заметки | Заметки... | Вызвать окно заметок и примечаний для всего файла
Загрузить настройки | Загрузить сохраненные ранее настройки (выбор из списка)
Сохранить настройки... | Сохранить текущие настройки
Сбросить настройки | Сбросить текущие настройки
Выход | Завершение работы программы
Правка
Копировать блок | Копировать блок... | Копировать в буфер обмена данные активного блока (экспорт данных)
Копировать область выделения | Копировать выделение... | Копировать в буфер обмена данные области выделения (экспорт данных)
Копировать изображение | Копировать изображение | Копировать в буфер обмена изображение графического дисплея
Вставить из буфера обмена | Вставить данные из буфера обмена в новый блок (импорт данных)
Создать блок из области выделения | Дублировать выделение в блок | Копировать выделенный участок данных в новый блок
Удалить данные в области выделения | Удалить выделенные данные | Удалить выделенный участок данных с разделением блока
Вырезать выделенные данные | Вырезать выделенный участок данных без разделения блока
Добавить комментарий | Добавить комментарий... | Добавить комментарий в выделенный участок данных
Удалить комментарии | Удалить комментарии | Удалить все комментарии в выделенном участке данных
Автокомментарии... | Вызвать окно Автокомментарии
Вид
Панели значений | Меню управления панелями значений.
Каскадом | Расположить все открытые панели значений в каскадном порядке.
Закрыть все | Скрыть все панели значений.
Время | Показать панель времени.
#: [Имя канала] | Показать панель значений соответствующего канала (список каналов от 1 до 32).
Панель инструментов | Скрыть/показать панель инструментов
Chart mode | Самописец | Графический режим самописца
Scope mode | Осциллограф | Графический режим осциллографа
Просмотр при записи | Режим просмотра записанных данных в процессе регистрации
Изменить масштаб шкалы времени | Масштаб шкалы X | Выбор масштаба шкалы X (список масштабов)
X Zoom Out | Уменьшить | Уменьшить масштаб шкалы X
X Zoom In | Увеличить | Увеличить масштаб шкалы X
Переход к началу записи | В начало | Переход к началу записи
Переход к предыдущей странице | Предыдущая страница | Переход к предыдущей странице
Переход к следующей странице | Следующая страница | Переход к следующей странице
Переход к концу записи | В конец | Переход к концу записи
Сервис
Общее меню каналов и графиков | Каналы и графики | Общее меню каналов и графиков:
Количество графиков | Выбор количества графиков (список от 1 до 32)
Выравнивание | Вертикальное выравнивание графиков:
Распределить графики по вертикали | Распределить по вертикали | Распределить графики по вертикали
Совместить базовые уровни | Совместить базовые уровни | Совместить базовые уровни графиков
Совместить сетки | Совместить сетки | Совместить сетки графиков
Шкала Y | Выбор единого масштаба шкалы Y всех графиков (список масштабов)
Уменьшить все | Уменьшить масштаб шкалы Y всех графиков
Увеличить все | Увеличить масштаб шкалы Y всех графиков
Порядок обработки каналов | Изменить последовательность обработки каналов
Вычислить все | Провести вычисления по формулам во всех каналах
Сохранить все вычисления | Сохранить расчетные данные всех каналов
Очистить все вычисления | Очистить (удалить) расчетные данные всех каналов
Выбор драйвера АЦП | Выбор АЦП... | Вызвать окно Выбор АЦП
Настройки драйвера АЦП | Настройки "АЦП"... | Вызвать окно индивидуальных настроек АЦП
Входной усилитель | Входной Усилитель... | Вызвать окно Входной Усилитель
Частота регистрации | Выбор частоты регистрации данных
Синхронизация | Синхронизация... | Выбор параметров синхронизации
Аналоговые выходы... | Вызвать окно управления аналоговыми выходами
Цифровые выходы... | Вызвать окно управления цифровыми выходами
Список комментариев... | Вызвать окно списка комментариев
Параметры... | Вызвать окно дополнительных параметров программы
Канал | Индивидуальное меню активного канала
График | Выбор канала для активного графика (список каналов от 1 до 32)
Шкала Y | Выбор масштаба шкалы Y активного графика (список масштабов)
Уменьшить масштаб шкалы амплитуды | Уменьшить | Уменьшить масштаб шкалы Y активного графика
Увеличить масштаб шкалы амплитуды | Увеличить | Увеличить масштаб шкалы Y активного графика
Set Base Level | Установить базовый уровень | Установить базовый уровень графика
Показать базовый уровень | Найти базовый уровень графика
Ch... = ... | Обработать данные канала по последней формуле вычислений
Ch...* = ... | Обработать данные канала по формуле вычислений реального времени
Сохранить вычисления | Сохранить все расчетные данные канала
Очистить вычисления | Очистить (удалить) все расчетные данные канала
Удалить все данные | Удалить все данные канала
Настройки канала | Настройки... | Вызвать окно настроек каналов
Блок | Индивидуальное меню активного блока
Найти блок | Отобразить блок на ленте самописца (поиск блока)
Переместить | Переместить блок:
Переместить блок в начало файла в начало | - в начало
Переместить блок назад назад | - назад (влево)
Переместить блок вперед вперед | - вперед (вправо)
Переместить блок в конец файла в конец | - в конец
Создать копию блока | Дублировать блок | Создать копию блока
Объединить с предыдущим | Объединить активный блок с предыдущим блоком
Вычислить | Провести вычисления всех каналов в активном блоке
Сохранить вычисления | Сохранить расчетные данные всех каналов в активном блоке
Очистить вычисления | Очистить (удалить) расчетные данные всех каналов в активном блоке
Удалить блок | Удалить блок | Удалить блок
Изменить частоту регистрации... | Изменить частоту регистрации блока
Свойства блока | Свойства... | Вызвать окно Свойства блока
Обработка Обработка данных
Математическая обработка сигналов | Функции... | Вызвать окно математической обработки сигналов
Полином... | Вызвать окно Полином
Дублирование данных... | Вызвать окно Дублирование данных
Прореживание данных... | Вызвать окно Прореживание данных
Интерполяция данных... | Вызвать окно Интерполяция данных
Анализ Анализ данных
Data Pad | Таблица значений... | Вызвать окно Таблица значений
Zoom View | Анализ сигнала... | Вызвать окно Анализ сигнала
Spectrum | Спектроанализатор... | Вызвать окно Спектроанализатор
XY Scope | X-Y Осциллограф... | Вызвать окно X-Y Осциллограф
Histogram | Гистограмма... | Вызвать окно Гистограмма
Помощь
Справка | Справка... | Вызвать справочное руководство ПО «PowerGraph»
Язык справки | Выбор языка справочного руководства (Автоматически, Русский и Английский)
Драйверы... | Показать список поддерживаемых устройств
Конфигурация... | Вызвать информационное окно

Начало страницы

См. также
Интерфейс программы, Сочетания клавиш


Сочетания клавиш

  • Изменение масштабов
  • Перемещение области просмотра
  • Выбор блоков
  • Перемещение блоков
  • Изменение границ области выделения
  • Выбор каналов и графиков
  • Перемещение каналов
  • Перемещение графиков
  • Вычисления в каналах
  • Дополнительные параметры и настройки

Группы клавиш

  • SHIFT+... - операции с блоками и областью выделения
  • CTRL+... - операции с каналами и графиками
  • ...+[-/+] (клавиши "минус" и "плюс") - изменение масштабов
  • ...+[1-9,0] (цифровые клавиши) - выбор каналов и блоков по номеру
  • ...+[F6-F8] (функциональные клавиши) - вычисления в каналах

Изменение масштабов

Клавиши | Действие
SHIFT+[-/+] | Уменьшить/увеличить масштаб шкалы X
ALT+[-/+] | Уменьшить/увеличить масштаб шкалы Y всех графиков
CTRL+[-/+] | Уменьшить/увеличить масштаб шкалы Y активного графика

Перемещение области просмотра

Клавиши | Действие
↑/↓ | Перемещение вверх/вниз на основное деление шкалы Y
←/→ | Перемещение назад/вперед на основное деление шкалы X
CTRL+[←/→] | Перемещение назад/вперед на промежуточное деление шкалы X
HOME | Переход к началу записи
END | Переход к концу записи
PAGE UP | Переход к предыдущей странице
PAGE DOWN | Переход к следующей странице

Выбор блоков

Клавиши | Действие
SHIFT+[1-9,0] | Выбор блока (от 1-го до 10-го)
SHIFT+HOME | Переход к первому блоку
SHIFT+END | Переход к последнему блоку
SHIFT+PAGE UP | Переход к предыдущему блоку
SHIFT+PAGE DOWN | Переход к следующему блоку

Перемещение блоков

Клавиши | Действие
SHIFT+ALT+HOME | Перемещение блока в начало
SHIFT+ALT+END | Перемещение блока в конец
SHIFT+ALT+PAGE UP | Перемещение блока назад
SHIFT+ALT+PAGE DOWN | Перемещение блока вперед

Изменение границ области выделения

Клавиши | Действие
SHIFT+[←/→] | Изменение границы области выделения на промежуточное деление шкалы X
SHIFT+ALT+[←/→] | Изменение границы области выделения на 1 пиксель
SHIFT+CTRL+[←/→] | Изменение границы области выделения на основное деление шкалы X

Выбор каналов и графиков

Клавиши | Действие
ALT+[1-9,0] | Выбор количества графиков/каналов (от 1 до 10)
CTRL+ALT+[1-9,0] | Изменение канала в активном графике (от 1-го до 10-го)
CTRL+[1-9,0] | Выбор графика по номеру канала (от 1-го до 10-го)
CTRL+HOME | Выбор верхнего графика
CTRL+END | Выбор нижнего графика
CTRL+PAGE UP | Выбор предыдущего графика
CTRL+PAGE DOWN | Выбор следующего графика

Перемещение каналов

Клавиши | Действие
CTRL+ALT+HOME | Перемещение канала в начало
CTRL+ALT+END | Перемещение канала в конец
CTRL+ALT+PAGE UP | Перемещение канала вверх
CTRL+ALT+PAGE DOWN | Перемещение канала вниз

Перемещение графиков

Клавиши | Действие
CTRL+[↑/↓] | Перемещение активного графика вверх/вниз на основное деление шкалы Y
CTRL+ALT+[↑/↓] | Перемещение активного графика вверх/вниз на 1 пиксель

Вычисления в каналах

Клавиши | Действие
F6 | Вызвать окно функций обработки сигналов
CTRL+F6 | Вычислить активный канал во всех блоках
CTRL+ALT+F6 | Вычислить все каналы во всех блоках
SHIFT+F6 | Вычислить все каналы в активном блоке
CTRL+F7 | Сохранить расчетные данные активного канала во всех блоках
CTRL+ALT+F7 | Сохранить расчетные данные всех каналов во всех блоках
SHIFT+F7 | Сохранить расчетные данные всех каналов в активном блоке
CTRL+F8 | Очистить расчетные данные активного канала во всех блоках
CTRL+ALT+F8 | Очистить расчетные данные всех каналов во всех блоках
SHIFT+F8 | Очистить расчетные данные всех каналов в активном блоке

Дополнительные параметры и настройки

Клавиши | Действие
F9 | Дополнительные параметры программы
CTRL+F9 | Настройки каналов
SHIFT+F9 | Свойства блоков

Начало страницы

См. также
Меню и панели инструментов


Дополнительные параметры

Команда Параметры... (Options) в меню Сервис вызывает диалоговое окно Параметры, содержащее дополнительные параметры и настройки программы «PowerGraph». Окно параметров содержит следующие вкладки:

  • Вид (View) - параметры графического отображения данных.
  • Формат (Format) - параметры отображения значений времени и амплитуды сигналов.
  • Печать (Print) - параметры печати данных.
  • Общие (General) - общие параметры работы программы.
  • Автозапуск (Autorun) - параметры автоматического запуска внешних программ после сохранения и экспорта данных.

Вкладка "Вид"

Вкладка Вид (View) содержит параметры графического отображения данных:

Курсор значений

При перемещении курсора мыши над графическим дисплеем по каждому графику перемещается "скользящий" маркер, обозначающий точку данных под курсором. Группа Курсор значений (Waveform Cursor) позволяет выбрать форму скользящего курсора.

Цвет и стиль масштабной сетки

Группа Сетка (Grid) содержит палитру для выбора цвета и переключатели для выбора стиля масштабной сетки:
  1. Нет (None) - масштабная сетка отсутствует.
  2. Точки (Dot) - масштабная сетка в виде точек на пересечении меток осей.
  3. Пунктир (Dot-Line) - масштабная сетка в виде точечных линий.
  4. Линии (Line) - масштабная сетка в виде сплошных линий.
Настройки стиля и цвета масштабной сетки учитываются также при печати данных.

Дополнительные графические элементы

Группа Отображать (Show) позволяет включить или выключить отображение дополнительных графических элементов:
  • Нулевая линия (Zero Line) - нулевая линия графика.
  • Уровни (Levels) - уровни амплитуды (см. Настройки каналов).
  • Линия блока (Block Line) - вертикальная линия в начале каждого блока.
  • Имя блока (Block Title) - название перед началом блока.
  • Комментарии (Comments) - комментарии (см. Комментарии):
    1. Линия (Line) - вертикальная пунктирная линия комментария.
    2. Номер (Index) - порядковый номер комментария.
    3. Время (Time) - время в точке комментария.
    4. Текст (Text) - текст комментария.
    5. Значения (Values) - значения сигналов в точке комментария.
Настройки отображения дополнительных графических элементов учитываются также при печати данных.

Вкладка "Формат"

Вкладка Формат (Format) содержит параметры отображения значений времени и амплитуды сигналов:

Формат шкалы времени

Группа Шкала времени (Time Format) содержит настройки формата значений шкалы времени:
  • От начала блока (From Start of Block) - шкала отображает значения времени, относительно начала каждого блока (первая точка каждого блока соответствует 0 на оси времени). Дополнительно программа позволяет выбрать формат отображения времени:
    1. Автоматически - выбор формата отображения времени осуществляется автоматически.
    2. Часы - время отображается в системном формате (чч:мм:сс).
    3. Минуты - время отображается в минутах (min).
    4. Секунды - время отображается в секундах (s).
    5. Миллисекунды - время отображается в миллисекундах (ms).
    6. Микросекунды - время отображается в микросекундах (mks).
  • Время дня (Time of Day) - шкала отображает значения суточного времени (время в первой точке каждого блока соответствует системному времени по часам компьютера в момент начала регистрации).
  • Индексы точек (Indexes of Samples) - шкала отображает порядковые номера (индексы) точек (индексация точек начинается с 1).
Настройки формата времени учитываются также при экспорте данных в текстовом формате и при печати данных.

Формат значений амплитуды

Группа Значения амплитуды (Values Format) содержит настройки формата значений амплитуды:
  • Значащих цифр (Signed Digits) - значения амплитуды округляются до указанного количества десятичных знаков, исключая предшествующие нули (для значений меньших 1) или учитывая целую часть числа (для значений больших 1). Например, для 3-х значащих цифр округление будет осуществляться следующим образом: 123, 12.3, 1.23, 0.123, 0.0123, 0.00123 и т.д.
  • Десятичных цифр (Decimal Digits) - значения амплитуды округляются до указанного количества десятичных знаков.
Количество цифр для округления выбирается в списке справа. При выборе в этом списке первого пункта Автоматически округление значений амплитуды осуществляется в соответствии с младшим значащим разрядом (МЗР) двоичных данных.

Флажок Масштабировать единицы измерения (Unit Scaling) включает или выключает режим масштабирования единиц измерения. В режиме масштабирования единиц измерения значения амплитуды автоматически делятся или умножаются на коэффициенты 103 или 106, а к названию единицы измерения добавляются приставки: mk (микро = 10-6), m (милли = 10-3), k (кило = 103), M (мега = 106). Масштабированию подвергаются только предопределенные в программе единицы измерения: V (Вольты), A (Амперы), Ohm (Омы), Hz (Герцы), W (Ватты).

Настройки формата значений амплитуды учитываются также при экспорте данных в текстовом формате.

Вкладка "Печать"

Вкладка Печать (Print) содержит параметры печати данных:

Дополнительные элементы страницы

Группа Отображать (Show) позволяет включить или выключить отображение дополнительных элементов на странице при печати:
  • Имя файла (File Name) - имя файла и номер страницы в верхней части листа.
  • Шкала Y (Y Scale) - шкала Y в правой части листа. Дополнительно на шкале Y могут отображаться:
    1. Имя канала (Channel Title) - названия каналов и масштабы графиков.
  • Шкала X (X Scale) - шкала X под графическими данными блока в нижней части листа. Дополнительно на шкале X могут отображаться:
    1. Заголовок (Title) - заголовок шкалы X (например - "Время, s" или "Частота, Hz").
    2. Диапазон (Range) - диапазоны значений шкалы X и индексов точек данных на текущем листе.
  • Заголовок блока (Block Title) - заголовок (имя) блока над графическими данными. Дополнительно в заголовке блока могут отображаться:
    1. Дата/Время (Date/Time) - дата и время начала регистрации блока.
    2. Частота (Rate) - значение частоты регистрации данных в блоке.
    3. Размер (Size) - размер блока в единицах времени и количестве точек данных.
  • Заметки блока (Block Note) - текстовые заметки блока в нижней части листа.
    1. Количество строк (Rows) - количество текстовых строк заметок, печатаемых на листе.

Данные для печати

Программа «PowerGraph» позволяет печатать следующие наборы данных:
  • Весь файл (Whole File) - данные всех блоков файла.
  • Текущий блок (Active Block) - данные одного выбранного блока.
  • Область выделения (Selection) - только выделенный участок данных. Если в файле отсутствует область выделения, то при печати автоматически включается режим печати данных текущего блока.

Расположение блоков

При печати всего файла на одном листе бумаги могут отображаться графические данные нескольких блоков. Программа «PowerGraph» позволяет использовать следующие варианты расположения нескольких блоков на одной странице:
  • До конца страницы (To End of Page) - данные нескольких блоков печатаются до конца страницы, заполняя всю площадь листа. Оставшийся участок данных последнего блока текущей страницы переносится на следующую страницу.
  • Без переносов (No Wrap) - на одной странице печатаются данные нескольких блоков, только если они полностью помещаются на листе. Если данные последнего блока полностью не помещаются на оставшемся пространстве листа, то печать этого блока начинается со следующей страницы.
  • С новой страницы (From New Page) - данные каждого следующего блока печатаются с новой страницы.

Вкладка "Общие"

Вкладка Общие (General) содержит общие параметры работы программы:

Автосохранение

Группа Автосохранение (Autosave) содержит настройки режимов автоматического сохранения:
  • Настройки (Settings) - автоматическое сохранение настроек. При завершении работы программы текущие настройки будут автоматически сохраняться под именем Default (список Загрузить настройки в меню Файл). При каждом запуске программа использует настройки с именем Default для загрузки последней сохраненной конфигурации.
  • Данные (Data) - автоматическое сохранение данных. После записи каждого блока программа будет автоматически сохранять данные в файл. После записи первого блока следует указать имя и расположение файла.
  • Вычисления (Calculations) - автоматическое сохранение расчетных данных. При сохранении данных в файл расчетные данные будут автоматически сохраняться без запроса на сохранение (см. Работа с каналами).

Обновление графиков при записи

Поле Задержка (Delay) позволяет задать минимальное время между обновлениями экрана (перерисовкой графиков) при регистрации данных. Минимальное время обновления задается в секундах от 0 до 1000, допускаются также дробные значения. Например, при значении 0.5 обновление графиков на экране происходит не чаще, чем через 500 миллисекунд.
Значение 0 (используется по умолчанию) выключает ограничение скорости обновления графиков, что позволяет добиться максимальной скорости перерисовки и плавности движения ленты самописца.

Примечания: В режиме просмотра сигналов плавность движения ленты самописца зависит только от производительности графической системы компьютера. В процессе регистрации сигналов максимальная скорость обновления графиков в значительной степени зависит от особенностей функционирования устройства сбора данных (АЦП). В большинстве случаев (особенно при высокой скорости регистрации) АЦП передает данные в компьютер блоками (порциями), предварительно накапливая эти блоки данных в собственном аппаратном буфере. В результате этого при регистрации данных в программе может наблюдаться прерывистое (скачкообразное) движение ленты самописца. Увеличение минимального времени обновления графиков позволяет избавиться от этого эффекта за счет перехода от динамического режима прокрутки к режиму обновления статичного изображения с заданной частотой (осциллографический режим).
Осциллографический режим позволяет улучшить визуальный анализ сигналов при регистрации данных с высокой частотой, когда быстрое движение ленты самописца приводит к "размытию" графиков. Время между обновлениями изображения должно подбираться индивидуально и зависит от особенностей восприятия графических данных пользователем.

Импорт данных

Поле Частота (Sampling Rate) позволяет задать используемое по умолчанию значение частоты регистрации при импорте данных. Если в импортируемом файле отсутствует информация о частоте регистрации, то используется значение, указанное в поле Частота.

Примечания: Большинство файловых форматов содержат информацию о частоте регистрации данных, поэтому при импорте данных программа «PowerGraph» использует значение, указанное в файле. При импорте данных из текстовых файлов частота регистрации определяется автоматически по первому столбцу, содержащему значения времени.
Однако некоторые файлы не содержат информации о частоте регистрации, например, двоичные файлы без параметров (файлы *.dat) и текстовые файлы, не содержащие значения времени. В этом случае используется значение частоты регистрации, указанное в программе по умолчанию.
Программа «PowerGraph» также позволяет изменить частоту регистрации данных с помощью команды Изменить частоту регистрации в меню Блок.

Вкладка "Автозапуск"

Вкладка Автозапуск (Autorun) содержит настройки автоматического запуска внешних программ после сохранения и экспорта данных в файлы:

На вкладке Автозапуск указывается полный путь к программам, запускаемым после следующих операций сохранения и экспорта данных:

  • Сохранение файла (Save File) - сохранение данных в файл формата PowerGraph Chart (собственный формат программы).
  • Экспорт данных (Data Export) - экспорт данных в двоичные и звуковые файлы.
  • Экспорт в текстовом формате (Export to Text) - экспорт данных в текстовый файл.
  • Экспорт спектра (Spectrum Export) - экспорт данных в текстовый файл в окне Спектроанализатор.
После завершения записи данных в файл программа «PowerGraph» автоматически запускает указанную для данной операции программу и передает ей имя созданного файла в качестве аргумента командной строки. Запускаемая программа может извлечь имя файла из аргументов командной строки и открыть этот файл для последующего просмотра, обработки и анализа данных.

Примечания: Наиболее полная информация о записанных данных и условиях проведения измерений сохраняется в файлах собственного формата PowerGraph Chart (файлы *.pgc). Для чтения данных из этих файлов, а также из двоичных и звуковых файлов, Вы можете в собственных программах использовать библиотеку импорта данных - PowerGraph Import Library, входящую в состав ПО «PowerGraph».

См. также
Настройки каналов


Выбор языка

Программное обеспечение «PowerGraph» включает поддержку нескольких языков пользовательского интерфейса и справочного руководства:
  • Русский
  • Английский
Выбор языка справочного руководства осуществляется с помощью команд Язык справки меню Помощь.

Выбор языка пользовательского интерфейса осуществляется автоматически и определяется региональными настройками операционной системы Windows. Для изменения языка пользовательского интерфейса следует в Панели Управления (Control Panel) операционной системы Windows изменить региональные настройки в разделе Язык и Стандарты (Regional Options).

Русифицированные версии Windows

В русифицированных версиях Windows по умолчанию используется русский язык пользовательского интерфейса ПО «PowerGraph».

Выбор английского языка

Для переключения на английский язык пользовательского интерфейса в региональных настройках следует выбрать язык - Английский (США):

Выбор английского языка

Нерусифицированные версии Windows

В нерусифицированных версиях Windows по умолчанию используется английский язык пользовательского интерфейса ПО «PowerGraph».

Выбор русского языка

Для переключения на русский язык пользовательского интерфейса в региональных настройках следует выбрать язык - Russian (Русский):

Выбор руского языка

Для правильного отображения русских символов в нерусифицированных версиях Windows необходимо в языковых параметрах системы установить использование кириллицы по умолчанию - Cyrillic (Default).

См. также
Меню и панели инструментов


Каналы и Графики

PowerGraph, File Recorder

Каналы

Программное обеспечение «PowerGraph» позволяет использовать до 32 каналов данных. Каждый канал имеет свои независимые настройки (название, единицы измерения, формулы расчетов и др.) и может содержать две копии данных: основные (записанные с АЦП) и расчетные (полученные в результате математической обработки).
Подробнее о работе с данными каналов см. в разделе Работа с каналами.

Графики

Для визуального отображения канала в программе используется График (Graph). Графики также имеют свои независимые настройки (цвет и стиль линий, масштаб и положение на ленте самописца) и используются для управления параметрами каналов.

Управление каналами и графиками

Левую часть главного окна программы занимает шкала амплитуды, на которой расположены кнопки графиков (от 1 до 32).
Каждый график может отображать данные одного из 32-х каналов или находится в выключенном состоянии (нижняя кнопка на левом рисунке). Номер выбранного канала указывается слева от кнопки графика. Сверху над кнопкой графика отображается название канала. Справа от кнопки указывается масштаб графика (значение амплитуды между соседними метками шкалы).
Шкала амплитуды | Общее меню графиков | Меню активного графика
Шкала амплитуды | Общее меню каналов | Меню активного канала
Один из каналов всегда является активным - команды меню Канал (Channel) и соответствующие кнопки панели инструментов относятся только к активному каналу. Активный канал обозначается выделением номера канала и изменением цвета масштаба графика (верхняя кнопка графиков на рисунках). Шкала амплитуды отображает значения только для активного канала.
Кнопки на шкале амплитуды используются для быстрого доступа к командам меню:
кнопка в верхней части шкалы амплитуды вызывает общее меню каналов и графиков (меню Сервис/Каналы и Графики - рисунок в центре)
кнопка включенного графика вызывает меню канала (меню Канал - рисунок справа)
кнопка выключенного графика вызывает меню выбора канала

Выбор количества графиков и каналов

Команда Количество графиков (Number of Graphs) в общем меню каналов содержит раскрывающийся список от 1 до 32. Выбор любого значения из списка включает соответствующее количество графиков и каналов для отображения и регистрации данных.

Сочетания клавиш:

ALT+[1-9,0] выбор количества графиков/каналов (от 1 до 10)

Выбор каналов

Программа «PowerGraph» позволяет выбрать произвольный набор каналов для регистрации и отображения.
Для использования заданного набора каналов необходимо установить для каждого графика соответствующий канал. Выбрать канал для графика можно следующими способами:
  • Нажмите левой кнопкой мыши на кнопке графика. Команда График (Graph) в появившемся меню содержит список каналов от 1 до 32 и позволяет выбрать другой канал для графика. Первый пункт Выкл. (Turn Off) в списке каналов позволяет выключить график.
  • Для быстрого доступа к списку каналов нажмите правой кнопкой мыши на номере канала слева от кнопки графика.

Сочетания клавиш:

CTRL+ALT+[1-9,0] выбор канала в активном графике (от 1-го до 10-го)

Выбор активного канала

В процессе работы программы один из каналов (графиков) является активным. Команды меню Канал и значения шкалы амплитуды относятся только к активному каналу. Выбрать активный канал можно следующими способами:
  • Нажмите правой кнопкой мыши на кнопке графика.
  • Нажмите левой кнопкой мыши на номере канала (слева от кнопки графика) или на значении масштаба (справа от кнопки графика).

Сочетания клавиш:

CTRL+[1-9,0] | выбор графика по номеру канала
CTRL+HOME | выбор верхнего графика
CTRL+END | выбор нижнего графика
CTRL+PAGE UP | выбор предыдущего графика
CTRL+PAGE DOWN | выбор следующего графика

Изменение масштаба графиков

Программа «PowerGraph» позволяет масштабировать графики для удобства просмотра записанных данных.
Масштаб каждого графика (значение амплитуды между соседними метками шкалы) указывается справа от кнопки графика. Допустимые значения масштабов находятся в диапазоне от 0,001 до 1000 в единицах измерения канала и составляют градации кратные 2, 5 и 10. Масштаб шкалы для каждого графика устанавливается независимо. Изменить масштаб графиков можно следующими способами:

Команды меню:

  • Команда Шкала Y (Y Scale) в меню канала (Канал) позволяет выбрать масштаб графика из списка допустимых значений.
  • Команда Шкала Y (Y Scale) в общем меню каналов (Сервис/Каналы и Графики) позволяет установить единый масштаб для всех графиков из списка допустимых значений.
  • Команда Уменьшить (Zoom Out) в меню канала (Канал) позволяет уменьшить масштаб активного графика.
  • Команда Уменьшить все (Zoom Out All) в общем меню каналов (Сервис/Каналы и Графики) позволяет уменьшить масштаб всех графиков.
  • Команда Увеличить (Zoom In) в меню канала (Канал) позволяет увеличить масштаб активного графика.
  • Команда Увеличить все (Zoom In All) в общем меню каналов (Сервис/Каналы и Графики) позволяет увеличить масштаб всех графиков.

Кнопки панели инструментов:

Уменьшить масштаб | уменьшить масштаб активного графика
Увеличить масштаб | увеличить масштаб активного графика
CTRL+ Уменьшить масштаб | уменьшить масштаб всех графиков
CTRL+ Увеличить масштаб | увеличить масштаб всех графиков

Сочетания клавиш:

CTRL+[-] | уменьшить масштаб активного графика
ALT+[-] | уменьшить масштаб всех графиков
CTRL+[+] | увеличить масштаб активного графика
ALT+[+] | увеличить масштаб всех графиков

Изменение положения графиков

Программа «PowerGraph» позволяет произвольно перемещать графики по вертикали. Вертикальный размер ленты записи неограничен - он автоматически увеличивается при увеличении вертикального расстояния между графиками. Используйте вертикальную полосу прокрутки у правого края графического дисплея для просмотра графиков, расположенных на различных уровнях.
Наиболее простой способ изменения вертикального положения графика заключается в перемещении шкалы амплитуды по вертикали при нажатой левой кнопки мыши. Для перемещения графиков по вертикали также можно использовать сочетания клавиш на клавиатуре.

Сочетания клавиш:

CTRL+↑ | переместить график вверх на 40 пикселей
CTRL+ALT+↑ | переместить график вверх на 1 пиксель
CTRL+↓ | переместить график вниз на 40 пикселей
CTRL+ALT+↓ | переместить график вниз на 1 пиксель

Установка базового уровня

Базовый уровень это нулевое значение амплитуды. При создании нового файла, базовый уровень каждого графика располагается на уровне соответствующей кнопки (нулевое смещение графика). Изменение вертикального положения графика можно рассматривать как смещение базового уровня относительно кнопки графика.
Меню канала содержит команду Установить базовый уровень (Set Base Level), которая устанавливает базовый уровень на уровне соответствующей кнопки графика. Для этих целей можно также использовать кнопку графика и кнопки панели инструментов:
ALT+ | установить базовый уровень графика
 | установить базовый уровень активного графика
CTRL+ | установить базовые уровни всех графиков

Поиск базового уровня

В случаях, когда графики удалены друг от друга по вертикали, может возникнуть необходимость найти какой-либо график без изменения его положения относительно других графиков. Для этого можно использовать вертикальную полосу прокрутки справа от ленты записи или команду Показать базовый уровень (Find Base Level) в меню активного канала. Кроме того, для этих целей можно использовать кнопку этого графика:
CTRL+ [image] найти базовый уровень графика.

Изменение взаимного положения графиков

В общем меню каналов Сервис/Каналы и Графики содержатся команды Выравнивание (Align) , позволяющие изменить взаимное положение графиков по вертикали. Эти команды также дублируются кнопками панели инструментов:
или команда Распределить по вертикали - установить базовые уровни всех графиков;
или команда Совместить базовые уровни - совместить базовые уровни всех графиков (совместить 0 всех каналов);
или команда Совместить сетки - совместить сетки всех графиков.

Настройки каналов

Изменение индивидуальных настроек каналов смотри в разделе Настройки каналов.

См. также
Настройки входных сигналов, Математическая обработка сигналов


Работа с каналами

Регистрация каналов

Программное обеспечение «PowerGraph» позволяет использовать для регистрации сигналов до 32 каналов.
Управление каналами см. в разделе Каналы и Графики.

Физические и логические каналы

В компьютерных измерительных системах существует разделение каналов на "физические" и "логические":
  • Физические - физические входы на внешнем разъеме устройства, к которым подключаются источники аналоговых сигналов.
  • Логические - программные каналы, в которые осуществляется запись данных.
Настройка физических входов АЦП на логические каналы программы осуществляется драйвером конкретного устройства. Как правило, драйвер устройства позволяет произвольно назначить любому логическому каналу программы любую физическую линию ввода сигналов. Настройки физических и логических каналов описаны в индивидуальных справочных материалах к устройствам сбора данных.
Для доступа к настройкам драйвера АЦП:
  1. Выберите команду Настройки "АЦП"... ("ADC" Setup) в меню Сервис.
  2. Нажмите в панели инструментов кнопку [image].

Настройки входных сигналов

ПО «PowerGraph» позволяет использовать индивидуальные настройки для каждого регистрируемого канала:

  • Диапазон измерения входного сигнала (аппаратный коэффициент усиления АЦП).
  • Линейные коэффициенты калибровки сигнала.
  • Единицы измерения сигнала.
Описание настроек входных сигналов см. в разделе Настройки входных сигналов.

Математическая обработка каналов

Программа «PowerGraph» позволяет проводить математическую обработку сигналов и создавать новые каналы с расчетными данными.
Описание математической обработки см. в разделе Математическая обработка сигналов.

Обработка каналов в процессе регистрации

Программа «PowerGraph» позволяет проводить математическую обработку сигналов в процессе регистрации данных (в режиме реального времени). Для того чтобы включить математическую обработку сигналов в процессе регистрации необходимо определить для канала математическую формулу.
Создание формулы обработки сигнала в процессе регистрации см. в разделе Настройки каналов.

Последовательность обработки каналов

Программа «PowerGraph» позволяет установить последовательность математической обработки каналов. Последовательность обработки устанавливается в дополнительном окне, которое вызывается командой Порядок обработки каналов (Order of Channels Processing) в общем меню каналов и графиков Сервис/Каналы и Графики:

Данное окно содержит список всех каналов с установленными формулами:

  1. Последняя формула вычислений в канале: ChN = ...
  2. Формула вычислений в процессе регистрации: ChN* = ...
Последовательность каналов в списке отражает последовательность вычислений математических формул (сверху вниз). Кнопки панели инструментов, расположенные слева от списка позволяют изменить последовательность обработки каналов:
→ переместить канал в начало списка.
→ переместить канал на одну позицию вверх.
→ переместить канал на одну позицию вниз.
→ переместить канал в конец списка.
→ упорядочить список каналов в порядке возрастания номеров.
→ упорядочить список каналов в порядке убывания номеров.

Вычисления по формулам

Меню каждого канала Канал содержит дополнительные команды математической обработки сигналов:
  1. Последняя формула вычислений в канале: ChN = ...
  2. Формула вычислений в процессе регистрации: ChN* = ...
При выборе этих команд программа запускает процесс обработки данных канала по соответствующей формуле во всех блоках.

Команда Вычислить все (Calculate All) в общем меню каналов и графиков Сервис/Каналы и Графики запускает обработку данных всех каналов во всех блоках, при этом учитывается установленная последовательность обработки каналов.

Команда Вычислить (Calculate) в меню Блок запускает обработку данных всех каналов в активном блоке, при этом учитывается установленная последовательность обработки каналов.

Расчетные данные

В процессе работы программы каждый канал может содержать две копии данных:
  • Основные - данные, записанные с АЦП.
  • Расчетные - данные, полученные в результате математической обработки.
Расчетные данные имеют более высокий приоритет, чем основные, поэтому при визуализации, обработке и анализе сигналов они используются в первую очередь. Основные данные используются, только если канал не содержит расчетных данных.
При математической обработке функция RawData позволяет копировать основные данные любого канала в расчетные данные другого канала, т.е. использовать основные данные, даже если этот канал содержит расчетные данные.
Расчетные данные используются только во время работы программы и в файл не записываются. Чтобы сохранить результаты математической обработки сигналов, необходимо заменить основные данные канала расчетными (см. далее). Использование основных и расчетных данных позволяет проводить в канале неограниченное количество промежуточных вычислений без потери основных данных и в случае необходимости отказаться от проведенной обработки исходных сигналов.

Сохранение расчетных данных

Для сохранения расчетных данных используются следующие команды меню:
  • Команда Сохранить вычисления (Save Calculations) в меню Канал - сохранение расчетных данных активного канала во всех блоках.
  • Команда Сохранить вычисления (Save Calculations) в меню Блок - сохранение расчетных данных всех каналов в активном блоке.
  • Команда Сохранить все вычисления (Save All Calculations) в общем меню каналов и графиков Сервис/Каналы и Графики - сохранение расчетных данных всех каналов во всех блоках.
При сохранении вычислений основные данные канала заменяются расчетными и после этого канал содержит только основную копию данных.
При закрытии файла или при завершении работы программа автоматически предлагает сохранить все расчетные данные.
Сохранение расчетных данных можно автоматизировать - вкладка Общие в дополнительных параметрах программы содержит параметры автосохранения. При включении автосохранения вычислений перед сохранением всего файла программа автоматически заменяет основные данные расчетными во всех каналах и блоках.
В индивидуальных настройках каналов имеется дополнительный атрибут Не сохранять вычисления, который позволяет отключить сохранение расчетных данных для каналов, которые используются только для временных вычислений.

Удаление расчетных данных

Для удаления расчетных данных используются следующие команды меню:
  • Команда Очистить вычисления (Clear Calculations) в меню Канал - удаление расчетных данных активного канала во всех блоках.
  • Команда Очистить вычисления (Clear Calculations) в меню Блок - удаление расчетных данных всех каналов в активном блоке.
  • Команда Очистить все вычисления (Clear All Calculations) в общем меню каналов и графиков Сервис/Каналы и Графики - удаление расчетных данных всех каналов во всех блоках.
После удаления расчетных данных каналы будут содержать только основные данные.

Удаление всех данных

Команда Удалить все данные (Delete All Data) в меню Канал удаляет основные и расчетные данные активного канала во всех блоках. Удаление всех данных канала позволяет уменьшить размеры сохраняемых файлов за счет временных и неиспользуемых каналов.

См. также
Каналы и Графики, Настройки каналов, Математическая обработка сигналов


Настройки каналов

PowerGraph, File Recorder

В программном обеспечении «PowerGraph» каждый канал имеет следующие индивидуальные настройки:

  • название канала и единиц измерения сигнала;
  • входной диапазон измерения (коэффициент усиления) АЦП;
  • цвет и стиль заливки графика;
  • контрольные уровни амплитуды;
  • формулы математической обработки сигналов;
  • дополнительные атрибуты.

Загрузка и сохранение настроек

Программы в составе ПО «PowerGraph» позволяют загружать и сохранять настройки всех каналов с помощью следующих команд меню Файл:
  • Загрузить настройки (Load Settings) - содержит список сохраненных настроек и позволяет загрузить соответствующие настройки при выборе любого элемента списка.
    Настройки с именем Default автоматически загружаются при запуске программы.
  • Сохранить настройки... (Save Settings) - сохранить текущие настройки. Перед сохранением необходимо указать имя для нового файла настроек.
    При завершении работы программа автоматически сохраняет текущие настройки под именем Default (см. Дополнительные параметры: Автосохранение).
  • Сбросить настройки (Reset Settings) - очистить текущие настройки каналов (восстановить настройки по умолчанию).

Окно «Настройки»

Для изменения индивидуальных настроек каналов используется дополнительное окно Настройки каналов (Settings):
  1. Выберите команду Настройки... в меню активного канала (Канал).
  2. Нажмите в панели инструментов кнопку [image].

Свойства Канала: Общие

В левой части окна располагается список всех каналов. Справа от списка каналов располагаются вкладки с различными настройками выбранного канала:

  1. Общие (General) - общие настройки канала.
  2. Вид (View) - визуальные настройки канала.
  3. Обработка RT (Processing RT) - настройки обработки сигналов в процессе регистрации.

Вкладка «Общие»

Вкладка Общие (General) содержит общие настройки канала:

Название канала

Текстовое поле Имя (Title) позволяет ввести название канала. Справа от текстового поля расположена кнопка доступа к меню, содержащего предопределенные названия.

Единицы измерения сигнала

Текстовое поле Ед. (Unit) позволяет указать название единиц измерения сигнала. Справа от текстового поля расположена кнопка доступа к меню, содержащего предопределенные единицы измерения и специальные символы.
Используемые единицы измерения не учитываются при проведении математической обработки сигналов.

Атрибуты канала

Набор флажков позволяет установить дополнительные атрибуты канала:
  • Не регистрировать (Not Recordable) - отключение регистрации сигналов с данного канала АЦП. Позволяет использовать канал только для хранения расчетных данных, полученных в результате обработки сигналов других каналов.
  • Регистрировать всегда (Always Recordable) - включение постоянной регистрации сигналов с данного канала АЦП. Позволяет использовать скрытые каналы для регистрации сигналов без их визуализации. Установка этого атрибута позволяет уменьшить количество отображаемых графиков при многоканальной регистрации данных.
  • Не сохранять вычисления (No Save Calculations) - отключение сохранения расчетных данных канала. Позволяет использовать временные расчетные каналы, содержащие результаты промежуточных вычислений.
    При установке этого атрибута для сохранения расчетных данных используйте команду Сохранить вычисления в меню Канал, во всех остальных случаях расчетные данные канала сохраняться не будут.

Диапазон измерения входного сигнала

Раскрывающийся список Диапазон (Range) позволяет выбрать диапазон измерения входного сигнала (аппартный коэффициент усиления) соответствующего канала АЦП.
Подробнее о настройках входных сигналов смотри в разделе Настройки входных сигналов.

Калибровка сигнала

Поля Умножить (Scale Data) и Прибавить (Offset Data) позволяют указать линейные коэффициенты калибровки регистрируемых сигналов.
Подробнее о калибровке сигналов смотри в разделе Настройки входных сигналов.

Вкладка «Вид»

Вкладка Вид (View) содержит дополнительные параметры визуализации данных канала:

Свойства Канала: Вид

Цвет и стиль заливки графика

Палитры Цвет и Стиль позволяют выбрать цвет и стиль заливки графика. На следующем рисунке изображены некоторые стили графиков, используемые в программе:

Уровни амплитуды

Поля Уровень 1 и Уровень 2 позволяют указать дополнительные значения уровней амплитуды. Уровни амплитуды отображаются на графиках в виде горизонтальных пунктирных линий, соответствующих указанному значению на шкале амплитуды:

Дополнительные графические построения уровней амплитуды позволяют отображать на графиках возможные или допустимые диапазоны изменения сигналов, а также определять точки, в которых сигнал достигает заданного значения.

Вкладка «Обработка RT»

Программа «PowerGraph» позволяет осуществлять математическую обработку сигналов в процессе регистрации данных (в режиме реального времени - Real Time). Вкладка Обработка RT (Processing RT) позволяет задать для выбранного канала формулу математической обработки сигналов:

Свойства Канала: Обработка

Для создания формулы обработки сигнала необходимо выполнить следующие действия:

  1. В поле Функция выбрать категорию и функцию обработки сигнала.
  2. В списках Источник 1 и Источник 2 выбрать каналы-источники, содержащие данные для расчетов.
  3. В полях Амплитуда, Частота, Количество точек и Значение ввести численные аргументы функции.
Для отключения обработки сигналов в процессе регистрации следует в списке категорий функций выбрать первый пункт - Off.

Программа «PowerGraph» позволяет выбрать последовательность (порядок) обработки каналов в процессе регистрации. Изменение последовательности обработки каналов см. в разделе Работа с каналами.

Особенности работы функций обработки сигналов в режиме реального времени описаны в Приложении Г.

См. также
Каналы и Графики, Настройки входных сигналов, Математическая обработка сигналов


Панели значений

PowerGraph, File Recorder

Для удобства просмотра численных значений программное обеспечение «PowerGraph» позволяет использовать дополнительные "плавающие" панели значений:

Панели значений можно перемещать в любую точку экрана, но они всегда располагаются поверх основного окна программы. Размеры панелей можно изменять произвольным образом, при этом размер символов автоматически увеличивается или уменьшается пропорционально вертикальному размеру панели.
Управление панелями значений осуществляется с помощью команд меню Вид\Панели значений:

  • Каскадом - расположить все открытые панели значений в каскадном порядке. Эта команда также сбрасывает установленные пользователем положение и размеры скрытых панелей.
  • Закрыть все - скрыть все открытые панели значений.
  • Время - показать панель времени.
  • #: [Имя канала] - показать панель значений соответствующего канала (список каналов от 1 до 32).
В панели времени непрерывно отображается текущее суточное время. В панелях каналов отображаются значения сигналов, полученные от АЦП в процессе регистрации, или значения сигнала в точке под курсором. Формат значений сигналов задается на вкладке "Формат" в дополнительных параметрах программы.

См. также
Каналы и Графики


Блоки данных и область выделения

Блоки данных

Программа «PowerGraph» позволяет регистрировать в один файл серию измерений в виде независимых блоков данных. Каждый блок представляет собой непрерывный массив данных произвольного набора каналов, записанных с одной частотой.
Далее см. Блоки данных

Область выделения

Программа «PowerGraph» позволяет выделять произвольный участок данных внутри блока. Область выделения используется для редактирования данных, обработки и анализа сигналов, а также для экспорта данных в различных файловых форматах.
Далее см. Область выделения


Блоки данных

Программа «PowerGraph» позволяет регистрировать в один файл серию измерений в виде независимых блоков данных:

Каждый блок представляет собой непрерывный массив данных произвольного набора каналов (от 1 до 32), записанных с одной частотой. Программа «PowerGraph» позволяет записывать в один файл до 32000 блоков данных. Размеры блоков данных не имеют фиксированных ограничений и могут быть произвольным, однако суммарный объем данных всех блоков одного файла ограничен объемом доступной виртуальной памяти.

Параметры блока

Информационная панель Каждый блок данных имеет индивидуальные независимые параметры. При перемещении курсора над графическими данными блока или при выборе активного блока, информация о его параметрах отображается в информационной панели:

  • Имя (Title) - название блока (вводится пользователем).
  • АЦП (ADC) - устройство, которое использовалось для регистрации данных.
  • Дата (Date) - дата начала регистрации блока.
  • Время (Time) - время начала регистрации блока.
  • Длительность (Duration) - длительность регистрации данных.
  • Частота (Rate) - частота регистрации данных (частота дискретизации).
  • Шаг (Step) - интервал времени между соседними значениями.
  • Каналы (Ch-s) - номера записанных каналов.
  • Размер (Size) - количество значений для каждого канала (размер блока).
  • Объем (Volume) - объем данных (в байтах).
  • Заметки (Notes) - текстовое описание (вводится пользователем).

Регистрация блоков

Список блоков В правой нижней части окна программы расположен список всех записанных блоков. Под списком находится кнопка Старт/Стоп, позволяющая начать и остановить запись нового блока.
В каждый момент времени только один блок может быть выбран в списке - этот блок является "активным". Команды меню Блок (Block), соответствующие кнопки панели инструментов и различные команды обработки и анализа данных относятся только к активному блоку.
Над списком блоков расположена кнопка быстрого доступа к меню активного блока (меню Блок). Справа от этой кнопки указывается общее количество блоков, записанных в данном файле. Если файл не содержит записанных данных, все команды для работы с блоками будут отключены.
Программа «PowerGraph» позволяет осуществлять различные операции над блоками: перемещать, копировать, удалять целиком или только часть данных, изменять частоту регистрации данных, экспортировать данные, а также вводить дополнительную текстовую информацию для описания данных блока.

Навигация по записи

Лента записи программы (Chart) содержит последовательность записанных блоков, разделенных вертикальными линиями. В нижней части окна программы, непосредственно под лентой записи, расположена шкала времени, содержащая ось времени для каждого блока и его порядковый номер:

Шкала времени содержит горизонтальную полосу прокрутки для навигации по всей ленте записи. Для перемещения по ленте записи можно также использовать кнопки, расположенные слева от шкалы времени, или команды меню Вид:
Переход к началу записи или команда В начало (To Start) - переход к началу записи;
Переход к предыдущему блоку или команда Предыдущая страница (Previous Page) - переход к предыдущей странице;
Переход к следующему блоку или команда Следующая страница (Next Page) - переход к следующей странице;
Переход к концу записи или команда В конец (To End) - переход к концу записи.

Изменение масштаба шкалы X

Программа «PowerGraph» позволяет изменять масштаб шкалы X как в сторону уменьшения, так и в сторону увеличения. Уменьшение масштаба шкалы X позволяет отображать на экране большие массивы данных в сжатом виде. Увеличение масштаба шкалы X позволяет растягивать на экране короткие сигналы и анализировать отдельные значения.
Масштаб шкалы выбирается командой Масштаб шкалы X (X Zoom) в меню Вид, содержащей список доступных масштабов, кратных 2, 5 и 10. Масштаб 1:1 означает отсутствие сжатия или растяжения сигналов, при этом каждому пикселю экрана по горизонтали соответствует одно значение сигнала. Уменьшенные масштабы шкалы принимают значения от 2:1 (сжатие в 2 раза) до 2k:1 (сжатие в 2000 раз) и обозначают количество значений сигнала соответствующих каждому пикселю экрана по горизонтали. Увеличенные масштабы шкалы принимают значения от 1:2 (растяжение в 2 раза) до 1:20 (растяжение в 20 раз) и обозначают количество пикселей между соседними значениями сигнала.
Слева от полосы прокрутки шкалы времени расположена кнопка быстрого доступа к списку масштабов - Изменить масштаб шкалы времени.
Изменить масштаб можно также с помощью кнопок, расположенных слева и справа от кнопки масштаба:
Уменьшить масштаб шкалы времени - уменьшить масштаб шкалы.
Увеличить масштаб шкалы времени - увеличить масштаб шкалы.

Команды меню:

  • Команда Масштаб шкалы X (X Zoom) в меню Вид - выбрать масштаб шкалы из списка допустимых значений.
  • Команда Уменьшить (Zoom Out) в меню Вид - уменьшить масштаб шкалы.
  • Команда Увеличить (Zoom In) в меню Вид - увеличить масштаб шкалы.

Сочетания клавиш:

SHIFT+[-] | уменьшить масштаб шкалы
SHIFT+[+] | увеличить масштаб шкалы

Перемещение блоков

Программа «PowerGraph» позволяет изменять порядок блоков в соответствии с более логичной последовательностью проведения измерений. Изменение порядка блоков осуществляется перемещением активного блока вперед или назад с помощью кнопок панели инструментов или команд Переместить блок (Move Block) в меню Блок:
или команда в начало (to Start) - переместить блок в начало файла;
или команда назад (Backward) - переместить блок на одну позицию назад (влево);
или команда вперед (Forward) - переместить блок на одну позицию вперед (вправо);
или команда в конец (to End) - переместить блок в конец файла.

Создать копию блока Создание копии блока

Для создания копии активного блока используйте команду Дублировать блок (Duplicate Block) в меню Блок или соответствующую кнопку панели инструментов. Новый блок содержащий копию данных активного блока добавляется непосредственно после активного блока.
Для создания копии участка блока используется область выделения.

Объединение блоков

Для объединения данных двух блоков используйте команду Объединить с предыдущим (Merge with Previous) в меню Блок. При вызове этой команды данные активного добавляются в конец предыдущего блока, а общее количество блоков уменьшается. Первая точка данных, добавленных к предыдущему блоку, автоматически помечается комментарием.
Для объединения двух блоков параметры данных в этих блоках должны быть идентичны, т.е. должны совпадать количество и последовательность записанных каналов, а также масштабные коэффициенты двоичных данных. Идентичность данных обеспечивается только при записи блоков с неизменными настройками с помощью одного устройства. Проведение обработки сигналов после завершения записи может приводить к нарушению идентичности данных. Поэтому рекомендуется объединять блоки до проведения обработки сигналов или перед объединением блоков удалять расчетные каналы, а затем проводить повторную обработку объединенных данных.

Удалить блок Удаление блоков

Для удаления активного блока используйте команду Удалить блок (Delete Block) в меню Блок или соответствующую кнопку панели инструментов.
Для удаления участка блока используется область выделения.

Изменение частоты регистрации

Для изменения значения частоты регистрации блока используйте команду Изменить частоту регистрации (Adjust Sampling Rate) в меню Блок. Изменение частоты регистрации осуществляется в дополнительном диалоговом окне Частота регистрации:

Выбор частоты регистрации

Поле Частота (Rate) позволяет ввести значение частоты регистрации в единицах частоты: /min, Hz, kHz.
Поле Шаг (Step) позволяет ввести значение частоты регистрации в единицах времени между соседними значениями: sec, msec, mksec.
Кнопка Применить (Apply) изменяет частоту регистрации активного блока в соответствии с указанным значением.
Кнопка Применить ко всем (Apply to All) изменяет частоту регистрации всех блоков в соответствии с указанным значением.

Свойства блока

Команда Свойства... (Properties) в меню Блок вызывает дополнительное окно Свойства блока, позволяющее для каждого блока указать название и текстовое описание (заметки), а также редактировать текст комментариев (текстовых меток), установленных внутри блока.

Вкладка "Имя и заметки"

Вкладка Имя и Заметки (Title And Notes) содержит текстовые поля для ввода и редактирования названия и заметок блока:

Дополнительно программа «PowerGraph» позволяет вводить текстовые описания (заметки) ко всему файлу. Окно заметок файла вызывается командой Заметки... (Notes) в меню Файл.

Вкладка "Комментарии"

Вкладка Комментарии (Comments) содержит список всех комментариев (текстовых меток), установленных внутри блока:

Свойства блока: Комментарии

Для каждого комментария в списке указывается порядковый номер, позиция на шкале времени и текст, введенный пользователем. Текстовое поле, расположенное над списком, позволяет редактировать текст выбранного в списке комментария. Кнопка Удалить (Delete) позволяет удалить комментарий, выбранный в списке.

Вкладка "Параметры"

Вкладка Параметры (Parameters) отображает общие параметры блока (дата и время записи, длительность, размер и т.д. - см. выше).

Кнопки Копировать (Copy) и Копировать все (Copy All), расположенные в нижней части окна свойств блока, позволяют копировать в буфер обмена (Clipboard) отображаемую информацию (названия и заметки, комментарии или параметры) выбранного или всех блоков.

Анализ данных блока

Программа «PowerGraph» включает набор специализированных инструментов анализ данных блока.
Подробнее см. Анализ данных.

Копировать значения текущего блока Сохранить значения текущего блока Экспорт данных блока

Программа «PowerGraph» позволяет экспортировать данные блока в различных файловых форматах.
Подробнее см. Файлы, импорт и экспорт данных.

См. также
Область выделения, Комментарии, Анализ данных, Работа с файлами


Область выделения

Программа «PowerGraph» позволяет выделять произвольный участок данных внутри блока. Для выделения какого-либо участка данных перемещайте курсор внутри блока при нажатой левой кнопке мыши.

Область выделения используется для следующих операций:

Создать блок из области выделения Создание нового блока данных

Данные области выделения могут быть скопированы в новый блок, добавляемый к концу записи. Для создания нового блока, содержащего копию данных области выделения, используйте команду Дублировать выделение в Блок (Selection to Block) в меню Правка или соответствующую кнопку панели инструментов.

Удалить данные в области выделения Удаление участка данных

Данные, находящиеся внутри области выделения, могут быть удалены из блока. Для удаления данных области выделения используйте команду Удалить выделенные данные (Delete Selection) в меню Правка или соответствующую кнопку панели инструментов.
Удаление данных зависит от расположения области выделение внутри блока:
  • выделение от начала блока до произвольной точки - удаляются все данные от начала блока до последней точки выделения;
  • выделение от произвольной точки до конца блока - удаляются все данные от первой точки выделения до конца блока;
  • выделен весь блок - удаляется весь блок (общее количество блоков уменьшается);
  • выделен произвольный участок внутри блока - блок содержащий область выделения разбивается на два блока (так как непрерывность данных нарушается): первый из них содержит данные от начала блока до первой точки выделения; второй - от последней точки выделения до конца блока.
Для удаления произвольного участка данных без разделения блока используйте команду Вырезать выделенные данные в меню Правка. При вызове этой команды внутри блока удаляется выделенный участок данных, а размер блока уменьшается. Первая точка данных, располагавшаяся после области выделения, автоматически помечается комментарием.
После удаления данных область выделения автоматически очищается.

Добавить комментарий Удалить комментарии Добавление и удаление комментариев

Область выделения используется для добавления и удаления комментариев (текстовых меток данных) внутри блока.
Подробнее см. Комментарии.

Анализ данных области выделения

Область выделения используется при анализе данных для ограничения размера выборки.
Подробнее см. Анализ данных.

Копировать область выделения Сохранить область выделения Экспорт данных области выделения

Область выделения используется для экспорта данных в различных файловых форматах.
Подробнее см. Работа с файлами.

См. также
Блоки данных, Комментарии, Анализ данных, Работа с файлами


Комментарии

Программа «PowerGraph» позволяет устанавливать на ленте записи комментарии - текстовые метки, обозначающие определенную точку данных внутри блока. Комментарии отображаются на ленте записи как вертикальные линии и пояснительный текст, расположенные в заданных точках шкалы времени.

Использование комментариев позволяет:

  1. Фиксировать различные события, возникающие в процессе регистрации данных.
  2. Разделять непрерывный набор данных блока на логические участки.
  3. Отмечать отдельные значения сигнала (например, максимальное или минимальное).
Каждый комментарий может содержать пояснительный текст до 256 символов. Каждый блок данных может содержать до 20000 комментариев.

Операции с комментариями

Программа «PowerGraph» включает следующие операции с комментариями:

  • Добавление комментариев в блок данных
  • Добавление комментариев в процессе регистрации
  • Удаление комментариев
  • Редактирование комментариев
  • Автоматическая установка комментариев

Добавить комментарий Добавление комментариев

В режиме постобработки для добавления комментариев в любой блок данных используется область выделения. Для добавления комментария необходимо выделить участок данных внутри блока и вызвать команду Добавить комментарий... (Add Comment) в меню Правка. Перед добавлением комментария появляется дополнительное окно Новый комментарий (New Comment):

В верхней части окна находится текстовое поле, которое позволяет ввести или выбрать из списка текст нового комментария. Под текстовым полем располагаются дополнительные переключатели, позволяющие выбрать точку области выделения, в которую будет установлен комментарий:

  • Начало выделения (Start of Selection) - комментарий устанавливается в первую точку области выделения.
  • Центр выделения (Center of Selection) - комментарий устанавливается в центральную точку области выделения.
  • Конец выделения (End of Selection) - комментарий устанавливается в последнюю точку области выделения.
  • Максимальное значение (Maximum) - комментарий устанавливается в точку сигнала, имеющую максимальное значение.
  • Минимальное значение (Minimum) - комментарий устанавливается в точку сигнала, имеющую минимальное значение.
При выборе пунктов Максимальное значение или Минимальное значение следует также выбрать Канал (Channel) для поиска максимального или минимального значения сигнала.
Для добавления нового комментария следует нажать кнопку Добавить (Add).

Добавить комментарий Добавление комментариев в процессе регистрации

Программа «PowerGraph» позволяет добавлять комментарии в процессе регистрации данных. При запуске регистрации над графическим дисплеем появляется текстовое поле, позволяющее ввести или выбрать текст нового комментария:

Добавить комментарий в процессе регистрации

Для добавления комментария в процессе регистрации следует:

  • Нажать клавишу Enter на клавиатуре после ввода текста комментария (когда текстовое поле содержит курсор ввода текста).
  • Вызвать команду Добавить комментарий... (Add Comment) в меню Правка.
Новый комментарий устанавливается в последнюю точку данных, полученных с АЦП, и фиксирует текущий момент времени на ленте записи.

Удалить комментарии Удаление комментариев

Для удаления установленных в блоке комментариев также используется область выделения. Для удаления комментариев следует выделить участок данных, содержащий удаляемые комментарии, и вызвать команду Удалить комментарии (Delete Comments) в меню Правка. После подтверждения все комментарии внутри области выделения будут удалены.

Свойства блоков Редактирование комментариев

Программа «PowerGraph» позволяет редактировать текст комментариев, установленных в блоке. Вкладка Комментарии в окне Свойства блока, которое вызывается командой Свойства... (Properties) в меню Блок, содержит список всех установленных в блоке комментариев:

Свойства блока: Комментарии

Для каждого комментария в списке указывается:

  • Порядковый номер комментария.
  • Позиция комментария на шкале времени.
  • Текст комментария.
Текстовое поле, расположенное над списком комментариев позволяет редактировать текст выбранного в списке комментария.
Кнопка Удалить (Delete), расположенная справа от поля редактирования, позволяет удалить выбранный в списке комментарий.

В нижней части окна свойств блока находятся кнопки Копировать (Copy) и Копировать все (Copy All), позволяющие копировать в буфер обмена (Clipboard) список всех комментариев блока или всего файла.

Настройки комментариев

Программа «PowerGraph» позволяет управлять отображением комментариев на графиках. Команда Параметры... (Options) в меню Сервис вызывает диалоговое окно дополнительных параметров программы «PowerGraph»:

Блок Отображать на вкладке Вид позволяет включить или выключить отображение комментариев:

  • Комментарии (Comments) - отображать комментарии на графиках:
    • Линия (Line) - вертикальная пунктирная линия комментария.
    • Номер (Index) - порядковый номер комментария.
    • Время (Time) - время в точке комментария.
    • Текст (Text) - текст комментария.
    • Значения (Values) - значения сигналов в точке комментария.
Настройки отображения комментариев учитываются также при печати графиков.

Текстовые списки комментариев

Программа «PowerGraph» автоматически запоминает текст добавленных пользователем комментариев в отдельном списке, который сохраняется между сеансами работы программы. Это позволяет при добавлении комментариев вместо повторного ввода с клавиатуры выбирать текст комментария из списка.
Подробнее см. Список комментариев

Автокомментарии

Программа «PowerGraph» предоставляет возможность автоматической установки комментариев через равные интервалы времени, в точках пересечения сигналом контрольного уровня, а также в локальных минимумах и максимумах сигнала.
Подробнее см. Автокомментарии

Статистический анализ комментариев

Программа «PowerGraph» предоставляет возможность статистического анализа установленных комментариев. Функции окна Таблица значений позволяют вычислять статистические параметры амплитуды сигнала в точках комментариев, а также статистические параметры временных интервалов между комментариями.
Подробнее см. Таблица значений: Комментарии

Экспорт комментариев в текстовом формате

Программа «PowerGraph» предоставляет возможность экспорта в текстовом формате отдельных точек данных, в которых установлены комментарии.
Подробнее см. Экспорт данных в текстовом формате

См. также
Блоки данных, Область выделения


Список комментариев

Программа «PowerGraph» автоматически запоминает текст добавленных пользователем комментариев в отдельном списке, который сохраняется между сеансами работы программы. Это позволяет вместо повторного ввода с клавиатуры выбирать текст добавляемых комментариев из списка.

Команда Список комментариев... в меню Сервис вызывает дополнительное окно, содержащее список введенных пользователем комментариев:

Окно Список комментариев позволяет редактировать текущий список комментариев, а также использовать текстовые файлы для загрузки и сохранения используемых комментариев.

Меню и панель инструментов

Файл |  |
Открыть | Открыть... | Загрузить список комментариев из текстового файла (Ctrl+O).
Добавить | Добавить... | Добавить комментарии из текстового файла.
Сохранить как... | Сохранить как... | Сохранить список комментариев в текстовый файл (Ctrl+S).
 | Закрыть | Закрыть окно.
Правка |  |
Копировать | Копировать | Копировать список комментариев в буфер обмена (Ctrl+C).
Вставить | Вставить | Вставить комментарии из буфера обмена (Ctrl+V).
Комментарии |  |
Добавить комментарий | Добавить комментарий... | Добавить новый комментарий в список.
Удалить комментарий | Удалить комментарий | Удалить выбранный в списке комментарий.
 | Очистить | Очистить список комментариев.

См. также
Комментарии, Автокомментарии


Автокомментарии

Программа «PowerGraph» позволяет автоматически устанавливать комментарии в определенных точках сигнала.
Автоматическая установка комментариев осуществляется с помощью дополнительного окна, которое вызывается командой Автокомментарии... (Autocomments) в меню Правка:

Для автоматической установки комментариев необходимо выполнить следующие действия:

  1. Ввести или выбрать общий текст устанавливаемых комментариев.
  2. Выбрать способ установки автокомментариев и указать соответствующие параметры.
  3. Выбрать блоки, в которых будут установлены комментарии.
  4. Нажать кнопку Добавить (Add).

Способы установки автокомментариев

Окно Автокомментарии предлагает несколько способов автоматической установки комментариев:
  • Таймер - установка комментариев через равные интервалы времени.
  • Счетчик - установка комментариев через равное количество точек сигнала.
  • Наклон вверх - установка комментариев в точках пересечения сигналом контрольного уровня снизу-вверх (положительный фронт).
  • Наклон вниз - установка комментариев в точках пересечения сигналом контрольного уровня сверху-вниз (отрицательный фронт).
  • Максимальное - установка комментариев в точках локальных максимумов сигнала.
  • Минимальное - установка комментариев в точках локальных минимумов сигнала.

Таймер

Установка комментариев через равные интервалы времени. Значение интервала времени указывается в формате чч:мм:сс (часы:минуты:секунды) и должно быть больше двойного значения времени между соседними точками сигнала. Значение 00:00:00 соответствует суткам (24 часа).

Счетчик

Установка комментариев через равное количество точек сигнала.

Наклон вверх

Установка комментариев в точках пересечения сигналом контрольного уровня снизу-вверх (положительный фронт):

Автокомментарии: Наклон вверх

Численное значение контрольного уровня вводится или выбирается в поле Уровень. В списке Канал выбирается канал, содержащий сигнал для поиска точек пересечения контрольного уровня.

Наклон вниз

Установка комментариев в точках пересечения сигналом контрольного уровня сверху-вниз (отрицательный фронт):

Автокомментарии: Наклон вниз

Численное значение контрольного уровня вводится или выбирается в поле Уровень. В списке Канал выбирается канал, содержащий сигнал для поиска точек пересечения контрольного уровня.

Максимальное

Установка комментариев в точках локальных максимумов сигнала:

Поиск точек с максимальным значением осуществляется на участках сигнала, расположенных выше указанного контрольного уровня. Если все значения сигнала находятся выше контрольного уровня, то устанавливается только один комментарий в точке абсолютного максимума всего сигнала. Если все значения сигнала находятся ниже контрольного уровня, то комментарии не устанавливаются. Для правильного определения последнего локального максимума контрольный уровень должен быть выше последнего значения сигнала.
Численное значение контрольного уровня вводится или выбирается в поле Уровень. В списке Канал выбирается канал, содержащий сигнал для поиска локальных максимумов.

Минимальное

Установка комментариев в точках локальных минимумов сигнала:

Поиск точек с минимальным значением осуществляется на участках сигнала, расположенных ниже указанного контрольного уровня. Если все значения сигнала находятся ниже контрольного уровня, то устанавливается только один комментарий в точке абсолютного минимума всего сигнала. Если все значения сигнала находятся выше контрольного уровня, то комментарии не устанавливаются. Для правильного определения последнего локального минимума контрольный уровень должен быть ниже последнего значения сигнала.
Численное значение контрольного уровня вводится или выбирается в поле Уровень. В списке Канал выбирается канал, содержащий сигнал для поиска локальных максимумов.

Выбор блоков

В нижней части окна Автокомментарии расположен список всех блоков текущего файла с указанием названия, частоты, размера и длительности каждого блока. Автоматическая установка комментариев осуществляется только в блоках, отмеченных в этом списке. Дополнительные переключатели над списком блоков используются для произвольного или автоматического выбора блоков:
  • Все - выбор всех блоков.
  • Выбрать - произвольный выбор блоков.
  • Текущий - выбор только активного блока.
  • Выделение - выбор блока, содержащего область выделения.
Последний переключатель Выделение доступен только при наличии на ленте записи выделенного участка данных. При выборе этого переключателя комментарии будут устанавливаться только в пределах области выделения.
Двойной щелчок левой кнопкой мыши на любом элементе списка блоков приводит к отображению соответствующего блока в основном окне программы.

Удаление комментариев

Окно Автокомментарии позволяет удалять все установленные комментарии в выбранных блоках или в области выделения с помощью кнопки Удалить (Delete).

См. также
Комментарии, Список комментариев


Выбор и настройки АЦП

PowerGraph, File Recorder, Digital Voltmeter

Программное обеспечение «PowerGraph» позволяет использовать для регистрации данных практически любые источники сигналов: внутренние платы и внешние модули АЦП, цифровые датчики и приборы, виртуальные математические генераторы сигналов, компьютерные устройства ввода и звукозаписи.
Поддержка широкого спектра устройств сбора данных осуществляется за счет универсальной системы драйверов. По вопросам подключения к ПО «PowerGraph» новых устройств сбора данных обращайтесь к разработчикам.

В программном обеспечении «PowerGraph» все устройства сбора данных обозначаются общим термином - АЦП, т.е. Аналого-Цифровой Преобразователь (англ. - ADC, Analog-Digital Converter).
При запуске программа предлагает выбрать устройство для регистрации данных:

Select ADC driver

Диалоговое окно Выбор АЦП содержит список поддерживаемых устройств и управляющие кнопки:

"АЦП" - подключить выбранный АЦП и продолжить работу. Если выбранное устройство отсутствует или работает неправильно, программа сообщит об этом. В этом случае следует выбрать другой АЦП или использовать программу в режиме анализа (см. ниже).

Флажок Автоматически (Set as Default) позволяет использовать выбранный АЦП "по умолчанию", т.е. в следующих сеансах работы программа автоматически будет использовать это устройство для регистрации данных.

Анализ (Analysis) - продолжение работы в режиме анализа (без АЦП), при этом все функции связанные с записью данных будут недоступны. В этом режиме Вы может открывать ранее записанные файлы, а также редактировать и обрабатывать данные.

Отмена (Close) - отказаться от выбора АЦП. При запуске программы эта кнопка также позволяет отказаться от дальнейшей работы с программой.

Выбор АЦП Выбор АЦП

В процессе работы программа позволяет выбрать другой АЦП. Для этого необходимо снова вызвать окно Выбор АЦП с помощью соответствующей кнопки панели инструментов или выбрать команду Выбор АЦП... в меню Сервис.

Настройки АЦП Настройки АЦП

У каждого АЦП есть индивидуальные аппаратные настройки (параметры подключения каналов, управление ЦАП'ом или цифровыми портами и т.д.). Для вызова окна настроек АЦП нажмите соответствующую кнопку панели инструментов или в меню Сервис выберите команду Настройки "АЦП"... (слово "АЦП" будет заменено название конкретного устройства). Несколько примеров настроек АЦП Вы можете посмотреть в разделе Системные прототипы АЦП.

Настройки каналов АЦП Настройки входных сигналов

ПО «PowerGraph» позволяет использовать независимые настройки входных сигналов для каждого канала АЦП.

Далее см. Настройки входных сигналов

См. также
Настройки входных сигналов, Системные прототипы АЦП


Системные прототипы АЦП

F-Generator - виртуальный генератор гармонических функций
F-Modulator - виртуальный модулятор частоты
Sound - регистрация сигналов с устройств звукозаписи
Cursor-XY - регистрация положение курсора мыши на экране
Joystick - регистрация положение рычагов игровых манипуляторов
Usage - монитор использования ресурсов системы
GPS-NMEA - регистрация перемещения по данным GPS-приемников

F-Generator

Разрядность: 4-16 бит
Максимальная частота: 100 кГц
Количество каналов: 8
Диапазоны измерений: ±10, ±5, ±2, ±1, ±0.5, ±0.2 и ±0.1 Вольт

Виртуальный прототип АЦП, генерирующий гармонические сигналы. F-Generator является эмулятором реального АЦП и позволяет определить различные характеристики системы «PowerGraph» и особенности функционирования различных типов АЦП. Кроме того, F-Generator является эталонным источником сигналов, выполняя функции большинства стандартных генераторов сигналов.
F-Generator поддерживает изменение разрядности (от 4 до 16 бит) и имеет 6 диапазонов измерений (коэффициентов усиления): ±10, ±5, ±2, ±1, ±0.5, ±0.2 и ±0.1 Вольт. Для генерации сигнала в драйвере используются 8 функций, описывающих изменение амплитуды сигнала во времени:

  1. Sine - синусоидальный сигнал;
  2. Pulse - импульсный сигнал;
  3. Ramp - пилообразный сигнал;
  4. Triangle - треугольный сигнал;
  5. Arctg - сигнал в форме функции арктангенса;
  6. Exp - сигнал в форме убывающей экспоненты;
  7. Shape - предопределенная функция сигнала;
  8. Noise - генерация случайного сигнала (шум);

F-Generator содержит 8 "аналого-цифровых" каналов, для каждого из которых может быть установлена любая из этих функций с собственной независимой частотой (периодом) и амплитудой сигнала (в соответствии с разрядностью). Однако, конечное значение амплитуды для каждого из каналов будет зависеть от выбранного диапазона измерений (см. Входной Усилитель).

Настройки F-Generator

Настройки драйвера F-Generator вызываются командой Настройки "F-Generator"... в меню Сервис главного окна программы:

Окно настроек позволяет изменять параметры сигналов для всех восьми каналов F-Generator:

Разрядность - разрядность сигнала (единая для всех каналов).
Каналы - список каналов.
Канал # - индивидуальные настройки выбранного в списке канала:
Функция - функция генерируемого сигнала (см. выше).
Амплитуда - амплитуда сигнала (от 0 до значения равного 2 в степени разрядности).
Частота - частота сигнала (от 0,01 Гц до 1 кГц).
Фаза цикла - начальная фаза сигнала (в долях периода - от 0 до 1 с шагом 0,01).
Для ввода численных значений амплитуды, частоты и фазы сигнала можно использовать как горизонтальные регуляторы, так и соответствующие текстовые поля ввода. Поместите курсор в поле, введите с клавиатуры требуемое численное значение, нажмите клавишу Enter (принять новое значение) или Esc (вернуться к предыдущему значению).

F-Modulator

Разрядность: 4-16 бит
Максимальная частота: 100 кГц
Количество каналов: 8
Диапазоны измерений: ±10, ±5, ±2, ±1, ±0.5, ±0.2 и ±0.1 Вольт

Виртуальный прототип АЦП, генерирующий синусоидальный сигнал с изменяющейся частотой (частотная модуляция сигнала). F-Modulator используется для анализа работы различных функций и алгоритмов, связанных с частотными характеристиками сигнала (частотные фильтры, спектральный анализ и т.п.).
В качестве параметров модуляции задается максимальная частота сигнала (F) и количество циклов (N), необходимых для изменения частоты. В драйвере F-Modulator используется 4 способа изменения частоты сигнала в диапазоне от 0 до F:

  1. 0<F>0 - увеличение частоты от 0 до F, затем снижение до 0;
  2. F>0<F - снижение частоты от F до 0, затем увеличение до F;
  3. 0<F - увеличение частоты от 0 до F;
  4. F>0 - снижение частоты от F до 0;

F-Modulator содержит 8 "аналого-цифровых" каналов, для которых максимальная частота F, количество циклов N и способ изменения частоты сигнала устанавливаются независимо.

Настройки F-Modulator

Настройки драйвера F-Modulator вызываются командой Настройки "F-Modulator"... в меню Сервис главного окна программы:

Разрядность - разрядность сигнала (единая для всех каналов).
Каналы - список каналов.
Канал # - индивидуальные настройки выбранного в списке канала:

Функция - способ изменения частоты сигнала в диапазоне от 0 до F (см. выше).
Амплитуда - амплитуда сигнала (от 0 до значения равного 2 в степени разрядности).
Частота - максимальная частота сигнала F (от 0,01 Гц до 1 кГц).
Циклы - количество (N) циклов сигнала при изменении частоты в диапазоне от 0 до F (от 0 до 100). Если N=0 генерируется синусоида с частотой F.

Sound

Разрядность: 16 бит
Максимальная частота: 96 кГц
Количество каналов: 1 (моно) или 2 (левый и правый)
Диапазоны измерений: ±5 V

В качестве источника сигналов используется аналого-цифровой преобразователь звуковой карты компьютера. Запись данных осуществляется в одноканальном (моно) или в двухканальном (стерео) режимах с разрядностью 16-бит. Кроме того, программное обеспечение «PowerGraph» позволяет открывать файлы звуковых форматов (файлы в формате "wav") для импорта аналоговых данных записанных через различные системы звукозаписи.

Wave file Chart

Окно настроек драйвера Sound позволяет выбрать для регистрации данных одно из устройств звукозаписи, присутствующих в системе, и отображает свойства выбранного устройства:

Кнопка Control Panel... вызывает окно мультимедиа настроек в Панели Управления компьютера.
Кнопка Mixer... (Микшер) вызывает окно регуляторов уровня записи.

Cursor-XY

Разрядность: 10 бит
Максимальная частота: 100 Гц
Количество каналов: 2 (ось X и ось Y)
Диапазоны измерений: 1, 5 и 10 мВ на пиксель экрана

Позволяет регистрировать положение курсора мыши относительно центра экрана.

Joystick

Разрядность: до 16 бит
Максимальная частота: 100 Гц
Количество каналов: общее количество осей всех подключенных игровых манипуляторов
Диапазон измерений: 5 В

Позволяет регистрировать положение рычагов игровых манипуляторов.
Игровые манипуляторы могут содержать до 6 осей перемещения рычагов. Оси перемещения обозначаются латинскими буквами - X, Y, Z, R, U, V. Драйвер игровых манипуляторов позволяет одновременно регистрировать положение всех рычагов всех подключенных манипуляторов. Общее количество манипуляторов и соответствующих осей определяется настройками раздела Игровые устройства в Панели управления операционной системы. Каждый канал регистрирует положение рычага игрового манипулятора по одной из осей и обозначается соответствующей буквой и идентификатором устройства:
X1 | Джойстик 1
Y1
Z1
...
X2 | Джойстик 2
Y2
Z2
...
... | ...
XN | Джойстик N

Игровой порт

Стандартный игровой порт, расположенный на звуковой карте, позволяет вводить значения 4-х аналоговых сигналов (положение 4-х рычагов игровых манипуляторов). В отличие от стандартных АЦП работа игрового порта основана на измерении сопротивления переменных резисторов в диапазоне 0-100 кОм. Метод измерения сопротивления заключается в программном определении длительности импульса, пропорциональной сопротивлению. Игровой порт предназначен для подключения аналоговых джойстиков, но может применяться и для подключения «серьезных» резистивных датчиков (фоторезисторы, термопары и т.д.).
Для подключения игровых устройств используется разъем типа DB15 - "мама" на звуковой карте и "папа" на кабеле, идущем к игровым устройствам:
Контакт | Назначение
1 | +5 В
2 | Кнопка 1
3 | Резистор 1
4 | GND
5 | GND
6 | Резистор 2
7 | Кнопка 2
8 | +5 В
9 | +5 В
10 | Кнопка 3
11 | Резистор 3
12 | MIDI-выход (Tx)
13 | Резистор 4
14 | Кнопка 4
15 | MIDI-вход (Rx)

Usage

Разрядность: 10 бит
Максимальная частота: 10 Гц
Количество каналов: 4
Диапазоны измерений: 1 В соответствует 100%

В качестве источника сигналов используются данные операционной системы по использованию системных ресурсов. Данные представлены в %, при этом 1 Вольт соответствует 100%. На данный момент реализованы следующие параметры:

  1. Processor - использование процессора (%);
  2. Memory - использование памяти (%);
  3. MemoryPhys - использование физической памяти (%);
  4. MemoryVirtual - использование виртуальной памяти (%);

Сам процесс получения этих данных влияет на значения этих параметров. Для снижения этого влияния рекомендуется осуществлять запись с частотой не более 1 Гц, а также включить режим Fixed, что снижает затраты операционной системы на отображение данных. При этих условиях использование процессора на мониторинг обычно не превышает 6-8%.
Полный список параметров, которые могут быть использованы в качестве источников данных, можно получить в окне настроек драйвера.

GPS-NMEA

Разрядность: 16 бит
Фиксированная частота: 1 Гц
Количество каналов: 6
Диапазоны измерений: ±50, ±500 и ±5000 км (отклонение и расстояние), ±500 км/ч (скорость), 0-360° (курс)

В качестве источника сигналов используются данные подключенного к COM порту GPS-приемника, передаваемые по стандартному протоколу NMEA со скоростью 4800 бит/c. Позволяет регистрировать отклонение и расстояние от начальной точки, координаты которой запоминаются при запуске регистрации, а также скорость и направление перемещения.
Для регистрации используются 6 каналов:

  1. Юг-Север (South-North) - отклонение от начальной точки в направлении с юга на север (километры);
  2. Запад-Восток (West-East) - отклонение от начальной точки в направлении с запада на восток (километры);
  3. Расстояние (Distance) - расстояние до начальной точки по прямой (километры);
  4. Скорость GPS (GPS Speed) - скорость перемещения (километры в час);
  5. Курс GPS (GPS Cource) - направление перемещения (градусы);
  6. Статус GPS (GPS Status) - состояние данных GPS: 1 - данные достоверны, 0 - данные не достоверны (положение не определено).
Окно настроек драйвера GPS-NMEA содержит текущие данные GPS (дата и время UTC - Universal Time Coordinates, широта, долгота, скорость и курс), а также информацию о всех обнаруженных и используемых навигационных спутниках:

Переключатель Установка UTC включает/выключает режим автоматической корректировки системного времени компьютера по значению времени UTC, полученному от GPS-приемника.

См. также
Выбор АЦП, Настройки входных сигналов


Настройки входных сигналов

PowerGraph, File Recorder

Для изменения настроек входных сигналов в ПО «PowerGraph» используется дополнительное окно, которое вызывается командой Входной Усилитель... (Input Amplifier) в меню Сервис.

Входной Усилитель Окно "Входной Усилитель"

Окно Входной Усилитель (Input Amplifier) позволяет проводить предварительный мониторинг входных сигналов любого канала АЦП, выбирать диапазон измерения сигнала (аппаратный коэффициент усиления АЦП) и использовать программную калибровку и коррекцию входного сигнала.

Центральное место этого окна занимает графический дисплей, на котором отображается график входного сигнала. Слева от графического дисплея располагается шкала амплитуды, а справа - элементы управления позволяющие изменять настройки выбранного канала АЦП. Над графическим дисплеем находится панель инструментов для управления режимами просмотра сигналов. Панель инструментов, расположенная под графическим дисплеем, используется для калибровки входного сигнала.

Выбор канала

В левом верхнем углу окна Входной Усилитель расположен раскрывающийся список, позволяющий выбрать канал АЦП. Для переключения между каналами также можно использовать цифровые клавиши клавиатуры (1-9,0) при нажатой клавише Ctrl:
Ctrl+1 - канал 1,
Ctrl+2 - канал 2,
...
Ctrl+9 - канал 9,
Ctrl+0 - канал 10

Название канала и единицы измерения

Справа от кнопки выбора канала расположены два текстовых поля ввода:
Имя (Title)- название канала.
Ед. (Unit) - название единицы измерения сигнала.
Кнопки, расположенные справа от каждого из этих полей, позволяют выбрать названия канала и единицы измерения из списка предопределенных значений.

Выбор диапазона входного сигнала

Поле Диапазон (Range) содержит список диапазонов измерения входного сигнала (аппаратных коэффициентов усиления) АЦП. При выборе значения из списка графический дисплей очищается и начинает регистрацию новых данных с учетом выбранного диапазона измерений. Под списком диапазонов отображаются значения, полученные в ходе мониторинга входного сигнала:
AI - текущее значение на входе АЦП (Analog Input);
Max - максимальное значение, полученное в ходе мониторинга;
Min - минимальное значение, полученное в ходе мониторинга.

Калибровка входного сигнала

Поля ввода Умножить (Scale Data) и Прибавить (Offset Data) позволяют вводить программные линейные коэффициенты преобразования входного сигнала по формуле:

Y = A * X + B

где X - значение на входе АЦП (AI - Analog Input); Y - калиброванное значение сигнала, записываемое в канале (Ch - Channel); A - линейный коэффициент умножения (поле Умножить); B - линейный коэффициент смещения (поле Прибавить).

Для ввода значений линейных коэффициентов поместите курсор в соответствующее текстовое поле, введите с клавиатуры численное значение, после окончания ввода нажмите клавишу Enter. Чтобы отказаться от введенного значения и вернуться к предыдущему, нажмите клавишу Esc.

Дополнительные возможности автоматического расчета линейных коэффициентов по измеренным калибровочным значениям предоставляет диалоговое окно Калибровка (Calibration), вызываемое кнопкой Калибровка..., расположенной в нижней левой части окна Входной Усилитель.

Подробнее о калибровке см. Калибровка сигналов

Под полями ввода линейных коэффициентов отображаются калиброванные значения (Max - максимальное и Min - минимальное), полученные в ходе мониторинга входного сигнала. Калиброванное текущее значение отображается справа над графическим дисплеем.

Флажки, расположенные возле полей линейных коэффициентов, позволяют отключать соответствующие линейные коэффициенты преобразования для проверки или для полного отключения калибровки. При отсутствии калибровки коэффициент умножения (A) равен 1, а коэффициент смещения (B) равен 0.

Дополнительные возможности управления значениями линейных коэффициентов предоставляют кнопки панели инструментов, расположенной под графическим дисплеем:

→ отключить линейный коэффициент умножения: A = 1.
→ отключить линейный коэффициент смещения: B = 0.
→ выключить калибровку: A = 1, B = 0.
→ восстановить линейные коэффициенты, установленные на канале в данный момент (Reset).

Окно Входной Усилитель предоставляет также возможность визуальной калибровки входных сигналов с помощью мыши - подробнее см. Визуальная калибровка сигналов

Шкала амплитуды

Изменение положения и масштаба графика сигнала осуществляется изменением соответствующих параметров шкалы амплитуды. Для этого используются кнопки, расположенные над и под шкалой амплитуды:
→ увеличить масштаб шкалы амплитуды - Ctrl+[+].
→ уменьшить масштаб шкалы амплитуды - Ctrl+[-].
→ установить 0 шкалы амплитуды по центру дисплея ("биполярное" положение шкалы) - Ctrl+B.
→ найти сигнал - Ctrl+F.
(При использовании этой кнопки масштаб шкалы амплитуды и положение 0 устанавливаются таким образом, чтобы весь диапазон входного сигнала максимально и полностью отображался на графическом дисплее.)

Эти команды, а также список масштабов, доступны через меню, которое вызывается с помощью кнопки, расположенной слева от шкалы амплитуды - [image].

Изменять положение 0 можно также с помощью мыши, нажимая левой кнопкой на шкале амплитуды и перемещая курсор вверх или вниз.

Режимы работы

Окно Входной Усилитель позволяет использовать различные режимы мониторинга, отображения и калибровки сигналов:
  1. Регистрация сигналов может осуществляться непрерывно либо может быть остановлена с помощью клавиши Pause на клавиатуре (например для калибровки записанных данных). Продолжение регистрации после остановки также осуществляется нажатием клавиши Pause. Кнопки панели инструментов:
    → продолжить регистрацию сигналов
    → остановить регистрацию сигналов
  2. Графический дисплей может отображать данные в следующих режимах:
    → Самописец - данные прокручиваются справа налево
    → Осциллограф - данные прорисовываются слева направо
  3. Для облегчения визуального определения общего уровня сигнала, графики можно заливать цветом от 0 до значения сигнала в данной точке:
    → график в виде линии
    → график с заливкой до 0
  4. Вы можете использовать мышь для различных операций управления графическим дисплеем и шкалой амплитуды (прокрутка дисплея и шкалы, визуальная калибровка сигналов, выделение участка данных). Для этого следует перемещать курсор вверх-вниз либо вправо-влево при нажатой левой кнопке мыши.
    Кнопки панели инструментов, расположенные слева под графическим дисплеем, позволяют использовать различные режимы управления графическим дисплеем и шкалой амплитуды:
    → режим автоматического поиска сигнала - в этом режиме все операции с мышью отключены и программа автоматически выбирает масштаб шкалы амплитуды и положение 0 таким образом, чтобы весь диапазон входного сигнала максимально и полностью отображался на графическом дисплее
    → режим смещения шкалы (используется по умолчанию) - в этом режиме с помощью мыши можно перемещать шкалу и график сигнала вверх-вниз для просмотра отдельных участков сигнала на различных уровнях амплитуды (также для этого можно использовать полосу прокрутки, расположенную у правой границы графического дисплея).
    → режим смещения сигнала - подробнее см. Визуальная калибровка сигналов
    → режим масштабирования сигнала - подробнее см. Визуальная калибровка сигналов

Выделение участка сигнала

Окно Входной Усилитель позволяет выделить определенный участок сигнала, отображаемого в графическом дисплее. Выделение осуществляется только в режиме остановки регистрации при нажатой клавише Shift. Нажмите кнопку [image] для остановки записи, поместите курсор мыши над графическим дисплеем, нажмите клавишу Shift, нажмите левую кнопку мыши и перемещайте курсор вправо или влево, чтобы интересующая Вас часть сигнала оказалась в области выделения:

Input Amplifier Selection

Чтобы отказаться от области выделения нажмите и отпустите правую кнопку мыши в области графического дисплея или левую кнопку мыши, удерживая клавишу Shift.

Cтатистические значения

В ходе регистрации Входной Усилитель определяет максимальное (Max) и минимальное (Min) значения сигнала, которые отображаются справа от графического дисплея. Кроме того, на графическом дисплее отображается текущее значение сигнала в виде горизонтальной пунктирной линии (маркер текущего значения).
При выделении участка сигнала максимальное и минимальное значения пересчитываются только для выделенной области. Текущее значение рассчитывается как среднее арифметическое по всем данным области выделения.

Дополнительные кнопки панели инструментов, расположенные под графическим дисплеем, также позволяют рассчитывать некоторые статистические значения всего сигнала или выделенной области:

→ среднее арифметическое значение.
→ середина диапазона сигнала = (Max + Min)/2.
→ максимальное значение.
→ минимальное значение.
Дальнейшее использование этих значений зависит от выбранного режима работы графического дисплея:

Режим автоматического поиска сигнала

Статистические значения игнорируются.

Режим прокрутки

Статистические значения используются для изменения положения графика сигнала по вертикали. При этом 0 шкалы амплитуды устанавливается таким образом, чтобы рассчитанное статистическое значение оказалось в центре графического дисплея. В режиме остановки регистрации маркер текущего значения также устанавливается в положение, соответствующее полученному статистическому значению.

Визуальная калибровка сигналов

Визуальная калибровка используется для облегчения ввода линейных коэффициентов преобразования сигнала.

В основе визуальной калибровки лежит операция перемещения маркера текущего значения относительно шкалы амплитуды с помощью мыши. Поместите курсор над графическим дисплеем, нажмите левую кнопку и перемещайте мышь вверх или вниз, чтобы маркер текущего значения оказался в другой точке шкалы амплитуды. Точность позиционирования маркера текущего значения зависит от масштаба шкалы амплитуды.
В зависимости от выбранного режима при этой операции будут изменяться либо линейный коэффициент смещения (B), либо линейный коэффициент умножения (A), либо оба коэффициента вместе.

Если в любом из режимов визуальной калибровки сигнала удерживать нажатой клавишу Ctrl, то автоматически включится режим смещения шкалы, что позволит изменить видимый уровень шкалы амплитуды.

Для удобства используйте при визуальной калибровке графический режим заливки от 0 до значения сигнала - кнопка [image].

Режим смещения сигнала

В этом режиме можно перемещать весь график сигнала относительно шкалы амплитуды (и наоборот), меняя тем самым линейный коэффициент смещения (B):
ΔB = Y2 - Y1

где ΔB - изменение линейного коэффициента смещения, а Y1 и Y2 - текущее значение до и после перемещения графика.

В режиме смещения сигнала масштаб графика остается постоянным, а изменяется только положение 0 сигнала.

В режиме смещения сигнала кнопки статистических расчетов позволяют автоматически установить значение линейного коэффициента смещения (B):

→ 0 сигнала соответствует среднему арифметическому значению, рассчитанному по всем данным либо по данным в области выделения: B = - Mean.
→ 0 сигнала соответствует значению середины диапазона сигнала, рассчитанному по всем данным либо по данным в области выделения: B = - (Max + Min)/2.
→ 0 сигнала соответствует максимальному значению, рассчитанному по всем данным либо по данным в области выделения: B = - Max.
(Весь сигнал оказывается в области отрицательных значений).
→ 0 сигнала соответствует минимальному значению, рассчитанному по всем данным либо по данным в области выделения: B = - Min.
(Весь сигнал оказывается в области положительных значений).

Режим масштабирования сигнала

В этом режиме можно изменяется текущее значение сигнала относительно шкалы амплитуды (и наоборот), при этом нулевое значение сигнала фиксируется. Изменение текущего значения сигнала (при сохранении положения 0) приводит к изменению линейного коэффициента умножения (A). Если перед этим проводилось смещение сигнала, т.е. текущий 0 не соответствует 0 сигнала на входе АЦП, то линейный коэффициент смещения (B) также будет корректироваться.

В режиме масштабирования сигнала изменяется масштаб графика, а положение 0 сигнала остается неизменным.

В режиме масштабирования сигнала кнопки статистических расчетов позволяют автоматически установить маркер текущего значение в положение, соответствующее рассчитанной статистической величине:

→ положение маркера соответствует среднему арифметическому значению, рассчитанному по всем данным либо по данным в области выделения.
→ положение маркера соответствует значению середины диапазона сигнала, рассчитанному по всем данным либо по данным в области выделения.
→ положение маркера соответствует максимальному значению, рассчитанному по всем данным либо по данным в области выделения.
→ положение маркера соответствует минимальному значению, рассчитанному по всем данным либо по данным в области выделения.

Использование визуальной калибровки

Существует большое количество ситуаций, когда методы визуальной калибровки сигналов существенно облегчает определение линейных коэффициентов преобразования. Рассмотрим наиболее распространенные из них:

Смещение базового уровня сигнала

В ряде случаев регистрируемый параметр измеряется в диапазоне от 0 (базовый уровень) до какой-то величины. Однако, при записи сигнала нулевое значение параметра не всегда соответствует 0 на входе АЦП. В этой ситуации необходимо сместить весь сигнал так, чтобы его базовый уровень был равен нулю. Для этого нужно из каждого значения вычесть значение ошибки 0 на входе АЦП, т.е. использовать линейный коэффициент смещения (B):
  • Пропишите на графическом дисплее базовый уровень сигнала.
  • Включите режим смещения сигнала - кнопка [image].
  • Нажмите кнопку [image] - программа автоматически рассчитает ошибку нуля как среднее арифметическое по всем данным и сместит весь сигнал на эту величину (можно также использовать область выделения).
Таким образом, среднее значение базового уровня сигнала будет соответствовать 0 регистрируемого параметра.

Использование калибровочных сигналов

В ряде случаев имеется возможность калибровки данных с помощью калибровочных сигналов.
Калибровочный сигнал - это, как правило, сигнал в виде импульса, нижний уровень которого соответствует 0 регистрируемого параметра, а верхний уровень равен 1.
В этой ситуации следует использовать и линейный коэффициент смещения (B), и линейный коэффициент умножения (A):
  • Пропишите на графическом дисплее калибровочный сигнал.
  • Выделите на графике участок, содержащий нулевое значение калибровочного сигнала.
  • Сместите базовый уровень сигнала (как это описано в предыдущей части), чтобы нулевой уровень калибровочного сигнала соответствовал 0 на шкале амплитуды.
  • Включите режим масштабирования сигнала - кнопка [image].
  • Выделите на графике участок, содержащий единичное значение калибровочного сигнала.
  • Нажмите кнопку [image] - программа автоматически рассчитает среднее арифметическое значение единичного уровня и установит на этом уровне маркер текущего значения.
  • С помощью мыши переместите маркер на уровень, соответствующий 1 на шкале амплитуды.
Таким образом, весь диапазон калибровочного сигнала окажется в пределах от 0 до 1.
Если калибровочный сигнал достаточно чистый и не содержит шумов, то вместо кнопки [image] (среднее) можно использовать кнопки [image] (минимальное) для нулевого уровня и [image] (максимальное) для единичного уровня калибровочного сигнала.

См. также
Калибровка сигналов, Каналы и Графики


Калибровка сигналов

PowerGraph, File Recorder, Digital Voltmeter

АЦП измеряет поступающие от различных датчиков сигналы в Вольтах, но часто возникает необходимость преобразования этих сигналов реальные единицы измеряемой физической величины. Как правило, такое преобразование или калибровка сигналов осуществляется с помощью линейных коэффициентов по формуле:

Y = A * X + B

где X - полученное от АЦП значение в Вольтах, Y - реальное значение, A - линейный коэффициент умножения, B - линейный коэффициент смещения.

Программное обеспечение «PowerGraph» позволяет осуществлять такое преобразование данных АЦП и записывать сигналы в реальных единицах измерения. Ввод линейных коэффициентов преобразования и название новых единиц измерения осуществляется в специальном окне Входной Усилитель (см. Настройки входных сигналов). Название единиц измерения сигналов и калибровочные коэффициенты также можно указать в общих настройках каналов.

На практике для определения линейных коэффициентов преобразования проводят калибровочные измерения, при этом существует два основных способа калибровки сигналов:

  • По 2-м точкам - когда для двух известных значений регистрируемого параметра измеряется значение на входе АЦП. Например, при регистрации температуры для перехода от вольт к градусам можно измерить напряжение на входе АЦП при двух известных значениях: температура льда (0 °C) и температура кипящей воды (100 °C). Для этих значений измеряется напряжение на входе АЦП и линейные коэффициенты преобразования (A и B) рассчитываются по формулам:
    Y1 = A * X1 + B
    Y2 = A * X2 + B

    где Y1 и Y2 - температура 0 °C и 100 °C, а X1 и X2 - соответствующие этим температурам напряжения.
  • По 1-й точке и приращению - когда линейный коэффициент умножения известен и необходимо определить линейный коэффициент смещения. Например, когда известна выходная характеристика датчика температуры (допустим 1 Вольт на 10 °C) достаточно измерить напряжение на входе АЦП только для одного значения температуры. В этом случае достаточно одной формулы:
    Y1 = A * X1 + B
    A = ΔY / ΔX

    где ΔY и ΔX - характеристика датчика температуры: 10 °C и 1 Вольт соответственно.

Следующий график демонстрирует принципы построения калибровочной прямой и измеряемые при этом параметры:

Калибровка входных сигналов

Окно "Калибровка"

Для упрощения калибровки сигналов и автоматического расчета линейных калибровочных коэффициентов используется дополнительное окно Калибровка (Calibration), доступное через кнопку Калибровка... окна Входной Усилитель:

Калибровка входных сигналов

Это окно содержит текстовые поля для ввода линейных коэффициентов преобразования (A и B), либо измеренных калибровочных значений (X - значения, измеряемые на входе АЦП; Y - реальные значения регистрируемого параметра):

  • Если Вы вводите линейные коэффициенты преобразования A и B, то калибровочные значения Y автоматически рассчитываются в соответствии с установленными значениями X.
  • Если Вы вводите измеренные калибровочные значения X и Y, то автоматически рассчитываются линейные коэффициенты преобразования A и B.

Для ввода значений поместите курсор в текстовое поле, введите с клавиатуры численное значение, после окончания ввода нажмите клавишу Enter. Чтобы отказаться от введенного значения и вернуться к предыдущему, нажмите клавишу Esc.

Флажки Умножить (коэффициент умножения - A) и Прибавить (коэффициент смещения - B) позволяют отключать соответствующие линейные коэффициенты преобразования для проверки или для полного отключения калибровки. При отсутствии калибровки коэффициент умножения (A) равен 1, а коэффициент смещения (B) равен 0.

Флажок D справа от поля Y2 позволяет перейти в режим калибровки по 1 точке и приращению, т.е. значения полей X2 и Y2 будут расцениваться как соответствующие значения D X и D Y.

Текстовые поля [X] и [Y] содержат названия единиц измерений. Единицы измерения X считываются непосредственно из АЦП, поэтому их изменить нельзя. Единицы измерения Y - единицы, получаемые после калибровки. В поле [Y] Вы можете вводить произвольный текст отражающий название новых единиц измерений. Кнопка, расположенная справа от этого поля, позволяет выбрать название из списка предопределенных значений.

См. также
Настройки входных сигналов, Работа с каналами


Управление аналоговыми выходами

PowerGraph, File Recorder

Многие устройства сбора данных кроме аналого-цифрового преобразователя (АЦП) могут также содержать цифро-аналоговый преобразователь (ЦАП), позволяющий использовать выходные аналоговые сигналы для управления внешними приборами.

Программное обеспечение «PowerGraph» предоставляет следующие возможности управления аналоговыми выходами устройства:

  • Изменение выходных аналоговых сигналов.
  • Автоматическое изменение выходных аналоговых сигналов при запуске и остановке регистрации данных.
  • Автоматическое управление выходными аналоговыми сигналами по уровню регистрируемых сигналов.

Автоматическое управление выходными аналоговыми сигналами

Окно «Аналоговые выходы»

Для управления аналоговыми выходами устройства используется дополнительное окно Аналоговые выходы... (Analog Outputs), которое вызывается соответствующей командой в меню Сервис:

Окно Аналоговые выходы содержит таблицу аналоговых выходов, блок состояния, блок автоматического управления и блок настроек.

Управление аналоговыми выходами по уровню регистрируемых сигналов

ПО «PowerGraph» в процессе регистрации данных позволяет автоматически изменять значения аналоговых выходов в соответствии с уровнем регистрируемых сигналов. Для использования этой возможности необходимо установить следующие параметры управления аналоговым выходом:

  1. Управляющий канал - регистрируемый канал, значения которого будут устанавливаться на аналоговом выходе. В качестве управляющего канала может быть выбран любой канал, в том числе используемый для вычислений в режиме реального времени. Если выбранный управляющий канал не содержат данных, то автоматическое управление аналоговыми выходами по этому каналу отключается.
  2. Калибровочные коэффициенты (опционально) - коэффициенты линейного преобразования значений управляющего канала в выходные значения по формуле:

    Y = A * X + B

    где X - значение управляющего канала, Y - устанавливаемое на аналоговом выходе значение, A - линейный коэффициент умножения, B - линейный коэффициент смещения. Если калибровка не используется, то коэффициент умножения (A) равен 1, а коэффициент смещения (B) равен 0.

  3. Минимальное и максимальное выходные значения (опционально) - минимальное (Min) и максимальное (Max) значения, устанавливаемые на аналоговом выходе. Диапазон выходного аналогового сигнала может быть ограничен минимальным и/или максимальным значениями.

Преобразование входного сигнала в выходной

Таблица аналоговых выходов

Содержит список всех аналоговых выходов устройства с установленными параметрами (Действие - изменение параметра всех аналоговых выходов при нажатии на заголовок столбца):
Столбец | Показывает
Выходы | Название и номер аналогового выхода (AO - Analog Output).
Значение | Текущее значение выходного сигнала. Действие: Сбросить значения всех выходов (установить 0).
Старт | Значение выходного сигнала, устанавливаемое при запуске регистрации данных. Действие: Включить/выключить изменение выходного сигнала при запуске регистрации данных.
Стоп | Значение выходного сигнала, устанавливаемое при остановке регистрации данных. Действие: Включить/выключить изменение выходного сигнала при остановке регистрации данных.
Источник | Управление выходным сигналом по уровню регистрируемого сигнала - номер управляющего канала. Действие: Установить/сбросить управляющие каналы для всех аналоговых выходов.
Умножить | Линейный коэффициент умножения (A) значений управляющего канала. Действие: Включить/выключить умножение значений управляющего канала.
Прибавить | Линейный коэффициент смещения (B) значений управляющего канала. Действие: Включить/выключить смещения значений управляющего канала.

Блок состояния аналогового выхода

Для изменения текущих значений выходных сигналов используется ползунковый регулятор, расположенный под таблицей аналоговых выходов. При изменении положения этого регулятора соответствующее значение сигнала устанавливается на выбранном в таблице аналоговом выходе.
Текстовое поле Значение позволяет ввести или выбрать численное значение выходного сигнала. Введенное численное значение устанавливается на аналоговом выходе после нажатия клавиши ENTER.
Раскрывающийся список Диапазон позволяет выбрать диапазон изменения выходного сигнала. Различные диапазоны выходных сигналов соответствуют аппаратным коэффициентам усиления цифро-аналогового преобразователя и доступны не во всех устройствах.

Блок автоматического управления

Параметры автоматического управления аналоговым выходом в процессе регистрации:
Старт | Изменение значения аналогового выхода при запуске регистрации.
Стоп | Изменение значения аналогового выхода при остановке регистрации.
Источник | Выбор управляющего канала для аналогового выхода.
Умножить | Линейный коэффициент умножения (A) значений управляющего канала.
Прибавить | Линейный коэффициент смещения (B) значений управляющего канала.
Max | Ограничение максимального значения выходного сигнала.
Min | Ограничение минимального значения выходного сигнала.

Блок настроек

ПО «PowerGraph» позволяет сохранять и использовать в последующих сеансах работы настройки автоматического управления аналоговыми выходами. Блок настроек содержит список сохраненных настроек, а также позволяет вводить текст с клавиатуры для сохранения текущих настроек под новым именем.
Кнопки, расположенные над списком настроек, выполняют следующие действия:
→ очистить текущие настройки;
→ сохранить текущие настройки;
→ загрузить выбранные в списке настройки;
→ удалить выбранные в списке настройки.

См. также
Выбор и настройки АЦП, Управление цифровыми выходами


Управление цифровыми выходами

PowerGraph, File Recorder

Многие устройства сбора данных кроме аналого-цифрового преобразователя (АЦП) могут также содержать цифровые выходы, позволяющие управлять внешними приборами и устройствами. Каждый из цифровых выходов может находиться в одном из двух состояний:

  • Включенное - логическая 1.
  • Выключенное - логический 0.
Программное обеспечение «PowerGraph» предоставляет следующие возможности управления состоянием цифровых выходов устройства:
  • Изменение состояния отдельных цифровых выходов.
  • Автоматическое изменение состояния цифровых выходов при запуске и остановке регистрации данных.
  • Автоматическое управление состоянием цифровых выходов по уровню входных сигналов в процессе регистрации данных.

Окно «Цифровые выходы»

Для управления цифровыми выходами устройства используется дополнительное окно, которое вызывается командой Цифровые выходы... (Digital Outputs) в меню Сервис:

Окно Цифровые выходы содержит таблицу цифровых выходов, блок состояния, блок автоматического управления и блок настроек.

Переключение цифровых выходов по уровню входных сигналов

ПО «PowerGraph» позволяет автоматически изменять состояние цифровых выходов в процессе регистрации данных в соответствии с уровнем входных аналоговых сигналов. Для использования этой возможности необходимо установить для цифрового выхода следующие параметры:
  1. Контрольный канал - регистрируемый канал, по которому осуществляется переключение состояния цифрового выхода.
  2. Пороговый уровень - уровень сигнала в контрольном канале, при достижении которого изменяется состояние цифрового выхода.
  3. Тип переключения L<H - состояние цифрового выхода если уровень сигнала в контрольном канале ниже (L) или выше (H) заданного порога:
    • 1<0 - включить если ниже, выключить если выше;
    • 0<1 - выключить если ниже, включить если выше.
Временная диаграмма переключения цифрового выхода по уровню входного сигнала представлена на рисунке:

Диаграмма управления цифровым выходом

Таблица цифровых выходов

Содержит список всех цифровых выходов устройства с установленными параметрами (Действие - изменение параметра всех цифровых выходов при нажатии на заголовок столбца):
Столбец Показывает
Выходы Номера и текущее состояние цифровых выходов (DO - Digital Output).
Действие: Включить/выключить все цифровые выходы.
Старт Состояние цифровых выходов при запуске регистрации данных.
Действие: Включить/выключить все цифровые выходы.
Стоп Состояние цифровых выходов при остановке регистрации данных.
Действие: Включить/выключить все цифровые выходы.
Контроль Переключение цифрового выхода по уровню входного сигнала - номер контрольного канала.
Действие: Установить/сбросить контрольные каналы для всех цифровых выходов.
Уровень Пороговый уровень входного сигнала.
Действие: Установить для всех цифровых выходов пороговый уровень равный 0.
L<H Тип переключения - состояние цифрового выхода если уровень сигнала в контрольном канале ниже (L) или выше (H) заданного порога:
  • 1<0 - включить если ниже, выключить если выше;
  • 0<1 - выключить если ниже, включить если выше.
Действие: Изменить тип переключения всех цифровых выходов.

Блок состояния цифровых выходов

Отображает общее состояние всех цифровых выходов в формате Hex (Dec):
Состояние | Текущее состояние всех цифровых выходов.
Старт | Состояние всех цифровых выходов при запуске регистрации данных. Позволяет включить или выключить изменение состояния всех цифровых выходов при запуске регистрации данных.
Стоп | Состояние всех цифровых выходов при остановке регистрации данных. Позволяет включить или выключить изменение состояния всех цифровых выходов при остановке регистрации данных.

Блок автоматического управления

Параметры автоматического управления цифровым выходом, выбранным в таблице:
Старт | Состояние цифрового выхода при запуске регистрации.
Стоп | Состояние цифрового выхода при остановке регистрации.
Контроль Переключение цифрового выхода по уровню входного сигнала:
  • Off - переключение по уровню входного сигнала не используется.
  • Канал N - контрольный канал.
Уровень | Пороговый уровень входного сигнала.
L<H Тип переключения - состояние цифрового выхода если уровень сигнала в контрольном канале ниже (L) или выше (H) заданного порога:
  • 1<0 - включить если ниже, выключить если выше;
  • 0<1 - выключить если ниже, включить если выше.

Блок настроек

ПО «PowerGraph» позволяет сохранять и использовать в последующих сеансах работы настройки автоматического управления состоянием цифровых выходов в процессе регистрации. Блок настроек содержит раскрывающийся список сохраненных настроек, а также позволяет вводить текст с клавиатуры для сохранения текущих настроек под новым именем.
Кнопки, расположенные над списком настроек, выполняют следующие действия:
→ очистить текущие настройки;
→ сохранить текущие настройки;
→ загрузить выбранные в списке настройки;
→ удалить выбранные в списке настройки.

См. также
Выбор и настройки АЦП, Управление аналоговыми выходами


Регистрация данных

Список блоков и кнопка запуска/остановки регистрации Программа «PowerGraph» осуществляет блочную запись результатов аналого-цифрового преобразования. Панель записи, расположенная в правой нижней части окна программы, содержит список всех записанных блоков данных. Под списком блоков находится кнопка запуска и остановки регистрации. Для запуска регистрации нового блока необходимо нажать кнопку Старт (при этом ее название изменится на Стоп). Повторное нажатие на эту кнопку приводит к остановке регистрации блока. После остановки регистрации новый блок автоматически добавляется в список.
Программа «PowerGraph» позволяет осуществлять различные операции над блоками данных: менять взаимный порядок, редактировать, удалять, и копировать. (подробное описание операций с блоками см. в разделе Блоки данных).

В общем случае, регистрацию данных можно начать непосредственно после загрузки программы. Однако программа имеет широкий спектр настроек записи: выбор частоты (скорости) регистрации данных, выбор регистрируемых каналов, настройка входных сигналов, синхронизация запуска и остановки регистрации.

Выбор частоты регистрации

PowerGraph, File Recorder

Меню частоты регистрации Программное обеспечение «PowerGraph» поддерживает любые значения частоты регистрации данных. Однако максимальная частота регистрации ограничена возможностями АЦП (временем, необходимым для одного аналого-цифрового преобразования). Программа автоматически определяет максимально-возможную частоту регистрации для данного АЦП и не позволяет указывать значения частоты, превышающие эту величину.
Кроме того, для многих типов АЦП существенную роль играет количество регистрируемых каналов, т.е. максимальная частота регистрации может быть использована только при записи одного канала. Например, если для АЦП максимальная частота для одного канала составляет 1000 Герц (значений в секунду), тогда для двух каналов эта величина составит - 500 Герц, для 4 каналов - 250 Герц и т.д.
Выбор частоты регистрации осуществляется командой Частота регистрации (Sampling Rate) в меню Сервис. Также для вызова этого меню можно использовать кнопку, расположенную в верхней части информационной панели. Меню содержит набор стандартных значений (кратных 2, 5 и 10) от 1 до максимально-возможного для выбранного АЦП (определяется автоматически). Эти значения соответствуют количеству значений в секунду, регистрируемых для каждого канала (соответствуют частоте регистрации в герцах, Гц). Справа от каждого значения частоты указывается обратная величина - время между соседними значениями сигнала.
Пункт Медленные содержит список частот менее одного значения в секунду, измеряемые в количестве значений в минуту (/min).
Пункт Max позволяет выбрать максимально-возможную частоту регистрации для данного АЦП.
Пункт Другая... вызывает дополнительное диалоговое окно, позволяющее указать произвольное значение частоты регистрации:

Выбор частоты регистрации

Произвольная частота регистрации может быть указана как в единицах частоты (/min, Hz, kHz) в поле Частота, так и в единицах времени между соседними значениями (sec, msec, mksec) в поле Шаг.
Не все устройства сбора (АЦП) позволяют регистрировать данные с любой заданной частотой. Для некоторых устройств, у которых частота регистрации задается целочисленным делителем частоты кварцевого генератора, используется фиксированный набор допустимых значений.
Поэтому реальная частота регистрации данных может отличаться от заданной частоты, выбранной пользователем перед началом регистрации. Значение реальной частоты регистрации указывается в свойствах каждого блока (см. Блоки данных).

Выбор каналов для регистрации

PowerGraph, File Recorder

Количество регистрируемых каналов соответствует количеству включенных графиков. Конкретные каналы, которые будут записываться, определяются графиками, для которых эти каналы назначены. Выбор каналов для регистрации осуществляется следующим образом:

  1. Установите количество графиков, соответствующее количеству каналов, необходимых для записи.
  2. Укажите для каждого графика один из каналов, которые Вы хотите регистрировать.
Дополнительные атрибуты канала позволяют использовать скрытые каналы для регистрации данных с АЦП.

Использование графиков позволяет создавать произвольные наборы каналов для записи. Описание работы с графиками и выбор каналов см. в разделе Каналы и Графики.
Настройки параметров каналов см. в разделе Входной Усилитель.

Synchronization Синхронизация сбора данных

PowerGraph, File Recorder

Программное обеспечение «PowerGraph» позволяет осуществлять автоматическое управление процессом регистрации.

См. раздел Синхронизация

Режимы визуализации сигналов

В процессе регистрации данных программа «PowerGraph» позволяет использовать несколько режимов визуализации сигналов.

Chart mode Режим самописца

В режиме самописца графики сигналов смещаются справа налево, имитируя движение ленты самописца. Режим самописца включается командой Самописец (Chart) в меню Вид.

Scope mode Режим осциллографа

В режиме осциллографа сигналы отображаются в виде неподвижных графиков, которые обновляются слева направо. При достижении графиками правой границы дисплея, отображение поступающих данных снова начинается от левой границы. Режим осциллографа включается командой Осциллограф (Scope) в меню Вид.

Режим просмотра сигналов

Review while Sampling Программа «PowerGraph» позволяет отключить автоматическое обновление графиков в процессе регистрации для просмотра записанных данных. В режиме просмотра программа продолжает записывать данные с АЦП, но позволяет просматривать любой участок данных текущего файла. Режим просмотра включается командой Просмотр при записи (Review while Sampling) в меню Вид или кнопкой-переключателем, расположенной под списком блоков справа от кнопки запуска регистрации.

См. также
Блоки данных, Каналы и Графики, Входной Усилитель


Синхронизация

PowerGraph, File Recorder

Синхронизация - это автоматическое управление процессом регистрации данных. В программном обеспечении «PowerGraph» для синхронизации используются триггеры ("триггер" - устройство, изменяющее свое состояние при определенных условиях). Триггеры синхронизации позволяют автоматически запускать и останавливать регистрацию по времени, по счетчику значений и по уровню сигналов, а также осуществлять последовательную запись данных в серию блоков.

Synchronization Окно «Синхронизация»

Установка параметров синхронизации осуществляется в диалоговом окне Синхронизация:
  1. Выберите команду Синхронизация... (Synchronization) в меню Сервис основного окна программы.
  2. Нажмите в панели инструментов кнопку Synchronization.

Окно синхронизации содержит три набора параметров, определяющих условия запуска и остановки регистрации данных:

  • Старт-Триггер (Start-Trigger) - запуск регистрации данных.
  • Стоп-Триггер (Stop-Trigger) - остановка регистрации данных.
  • Авто-Старт (Auto-Start) - автоматический многократный запуск регистрации данных.
Каждый набор параметров содержит выпадающий список, определяющий тип триггера для данной операции:
  • Выкл. (Off)- синхронизация не используется. Запуск или остановка регистрации осуществляются пользователем.
  • Время/Таймер (Time/Timer) - синхронизация по времени.
  • Счетчик (Counter) - синхронизация по количеству значений.
  • Уровень (Level)- синхронизация по уровню сигнала.

Запуск регистрации (Старт-Триггер)

Синхронизация запуска регистрации позволяет указать условия, при которых необходимо начать запись данных. Визуализация данных начинается непосредственно после нажатия кнопки Старт, однако данные, полученные до возникновения условий синхронизации, являются временным и впоследствии автоматически удаляются.

Запуск по времени

Запуск регистрации по времени означает начало записи блока в указанное время суток по системным часам компьютера:

Поле Время (Time) содержит маску для ввода времени в формате чч:мм:сс (часы:минуты:секунды). Значение 00:00:00 соответствует полночи. Если указанное время меньше текущего времени суток, то запись начнется в указанное время следующих суток.

Запуск по счетчику

Запуск регистрации по счетчику означает начало записи блока после получения от устройства заданного количества значений:

Поле Счетчик (Counter) позволяет ввести и или выбрать количество значений, после получения которых, начнется запись данных в блок. Время, соответствующее указанному количеству значений при текущей частоте регистрации, отображается справа от поля в круглых скобках.
Использование запуска по счетчику позволяет организовать фиксированную задержку записи данных после нажатия кнопки Старт.

Запуск по уровню

Запуск регистрации по уровню означает начало записи блока с того момента, когда входной сигнал в выбранном канале достигнет заданного уровня амплитуды:

Поле Уровень (Level) позволяет ввести или выбрать значение амплитуды, при достижении которого начинается запись данных. Кнопки-переключатели Наклон (Slope) позволяют выбрать направление изменения сигнала, при котором начинается запись - положительный или отрицательный фронт.

Флажок Пре-Триггер (Pre-Trigger) позволяет дополнительно включить режим записи пред-истории (участок сигнала, предшествующий достижению заданного уровня). Размер пред-истории задается в количестве регистрируемых значений в поле под переключателем. Время, соответствующее указанному размеру пред-истории при текущей частоте регистрации, отображается справа от поля в круглых скобках.

Полный просмотр данных

Предварительные данные, получаемые до начала записи, периодически удаляются для экономии ресурсов операционной системы, что позволяет ожидать условий синхронизации "бесконечно долго".
Флажок Полный просмотр данных (Full Data Viewing) включает режим, в котором удаление всех предварительных данных откладывается до момента начала записи, что позволяет просматривать все данные. Режим полного просмотра предварительных данных рекомендуется использовать только при невысоких частотах регистрации или если возникновение условий синхронизации является очевидным фактом.

Остановка регистрации (Стоп-Триггер)

Синхронизация остановки регистрации позволяет указать условия, при которых необходимо прекратить запись данных. Использование этой синхронизации позволяет автоматически останавливать запись без нажатия кнопки Стоп.

Остановка по таймеру

Остановка регистрации по таймеру означает запись блока только в течение указанного времени после начала записи:

Поле Таймер (Timer) содержит маску для ввода времени в формате чч:мм:сс (часы:минуты:секунды). Значение 00:00:00 соответствует суткам (24 часа).

Остановка по счетчику

Остановка регистрации по счетчику означает запись блока фиксированного размера:

Поле Счетчик (Counter) позволяет ввести и или выбрать количество значений, после получения которых, запись данных в текущий блок останавливается. Время, соответствующее указанному количеству значений при текущей частоте регистрации, отображается справа от поля в круглых скобках.

Остановка по уровню

Остановка регистрации по уровню означает запись блока до момента, когда входной сигнал в выбранном канале достигнет заданного уровня амплитуды:

Поле Уровень (Level) позволяет ввести или выбрать значение амплитуды, при достижении которого запись данных останавливается. Кнопки-переключатели Наклон (Slope) позволяют выбрать направление изменения сигнала, при котором останавливается запись - положительный или отрицательный фронт.

Флажок Пост-Триггер (Post-Trigger) позволяет дополнительно включить режим записи пост-истории (участок сигнала, после достижения заданного уровня). Размер пост-истории задается в количестве регистрируемых значений в поле под переключателем. Время, соответствующее указанному размеру пост-истории при текущей частоте регистрации, отображается справа от поля в круглых скобках.

Режим "скользящего" блока

Флажок "Скользящий" блок (Moving Block) включает режим, в котором вместо автоматической остановки записи происходит периодическое удаление начального участка данных записываемого блока. Этот режим позволяет "бесконечно долго" осуществлять регистрацию данных ограниченного размера, т.е. соответствует принципам работы осциллографа. Остановка регистрации в этом режиме происходит только при нажатии кнопки Стоп.
Для использования режима "скользящего" блока необходимо указать минимальную длительность (Таймер) или минимальный размер (Счетчик) данных, остающихся после удаления начального участка. Данный режим не подразумевает фиксированный размер блока, гарантируется только, что оставшийся размер будет не менее указанного.
Режим "скользящего" блока недоступен при использовании синхронизации запуска (Старт-Триггер) и при синхронизации остановки по уровню (Стоп-Триггер: Уровень).

Автозапуск регистрации (Авто-Старт)

Автозапуск регистрации позволяет многократно использовать параметры синхронизации для автоматической записи данных в серию блоков. Для этого необходимо выбрать тип автозапуска (Таймер, Счетчик, Уровень) и указать количество записываемых блоков (не менее 2):

После нажатия кнопки Старт запись первого блока данных осуществляется в соответствии с параметрами запуска (Старт-Триггер). Тип и параметры автозапуска (Авто-Старт) используются для записи второго и последующих блоков серии. Параметры остановки (Стоп-Триггер) используется для всех записываемых блоков.
Автозапуск прекращается после записи указанного количества блоков с момента нажатия кнопки Старт или если общее количество блоков текущего файла достигнет максимального значения (32000).

Автозапуск по таймеру

Автозапуск регистрации по таймеру означает запись серии блоков через указанное время по системным часам компьютера:

Поле Таймер (Timer) содержит маску для ввода времени в формате чч:мм:сс (часы:минуты:секунды). Значение 00:00:00 соответствует суткам (24 часа). Начало записи каждого блока происходит через указанное в этом поле время после начала записи предыдущего блока.

Автозапуск по счетчику

Автозапуск регистрации по счетчику означает запись серии блоков через указанное количество полученных значений:

Поле Счетчик (Counter) позволяет ввести и или выбрать количество значений от начала последнего записанного блока, которое необходимо получить перед записью следующего блока. Время, соответствующее указанному количеству значений при текущей частоте регистрации, отображается справа от поля в круглых скобках.

Автозапуск по уровню

Автозапуск регистрации по уровню означает начало записи каждого блока в серии с того момента, когда входной сигнал в выбранном канале достигает заданного уровня амплитуды. В качестве параметров автозапуска регистрации по уровню используются параметры, выбранные для запуска (Старт-Триггер), что позволяет использовать для всех блоков одинаковые условия синхронизации по уровню.

Использование автозапуска

Автозапуск синхронизации имеет следующие особенности и условия использования:
  1. Автозапуск возможен только при включенной синхронизации остановки (Стоп-Триггер), так как при отсутствии условий остановки записи блока невозможно начать запись следующего блока.
  2. Автозапуск невозможен при использовании режима "скользящего" блока, так как запись текущего блока осуществляется непрерывно.
  3. Если к моменту возникновения условий автозапуска запись текущего блока еще не завершена (например, значение таймера автозапуска меньше значения таймера остановки), то запись следующего блока начинается сразу после завершения записи текущего, т.е. осуществляется непрерывная запись без потерь данных.
  4. Если при автозапуске выбрана синхронизация по уровню сигнала, то в параметрах запуска (Старт-Триггер) также должна быть выбрана синхронизация по уровню.

Настройки синхронизации

Программа «PowerGraph» позволяет сохранять и использовать индивидуальные настройки параметров синхронизации. В правой части окна синхронизации расположен список сохраненных настроек. При выборе любого элемента этого списка под ним отображается текстовое описание соответствующих настроек.
Кнопки, расположенные над списком настроек, выполняют следующие действия:
  • - сохранить текущие настройки синхронизации в выбранный элемент списка;
  • - сохранить текущие настройки синхронизации под новым именем;
  • - загрузить выбранные в списке настройки синхронизации;
  • - удалить выбранные в списке настройки синхронизации.
Загрузить настройки синхронизации можно также двойным нажатием левой кнопки мыши на выбранном элементе списка.

См. также
Регистрация данных


Редактирование данных

Программа «PowerGraph» включает следующие операции редактирования данных:
  • Перемещение блоков
  • Создание копии блока
  • Объединение блоков
  • Создание нового блока из области выделения
  • Удаление блоков
  • Удаление выделенного участка данных
  • Удаление данных канала

Перемещение блоков

Программа «PowerGraph» позволяет изменять порядок блоков в соответствии с более логичной последовательностью проведения измерений. Изменение порядка блоков осуществляется перемещением активного блока вперед или назад с помощью кнопок панели инструментов или команд Переместить блок в меню Блок:
или команда в начало - переместить блок в начало файла;
или команда назад - переместить блок на одну позицию назад (влево);
или команда вперед - переместить блок на одну позицию вперед (вправо);
или команда в конец - переместить блок в конец файла.

Создать копию блока Создание копии блока

Для создания копии активного блока используйте команду Дублировать блок в меню Блок или соответствующую кнопку панели инструментов. Новый блок, содержащий копию данных активного блока, добавляется непосредственно после активного блока.

Объединение блоков

Для объединения данных двух блоков используйте команду Объединить с предыдущим в меню Блок. При вызове этой команды данные активного добавляются в конец предыдущего блока, а общее количество блоков уменьшается. Первая точка данных, добавленных к предыдущему блоку, автоматически помечается комментарием.
Для объединения двух блоков параметры данных в этих блоках должны быть идентичны, т.е. должны совпадать количество и последовательность записанных каналов, а также масштабные коэффициенты двоичных данных. Идентичность данных обеспечивается только при записи блоков с неизменными настройками с помощью одного устройства. Проведение обработки сигналов после завершения записи может приводить к нарушению идентичности данных. Поэтому рекомендуется объединять блоки до проведения обработки сигналов или перед объединением блоков удалять расчетные каналы, а затем проводить повторную обработку объединенных данных.

Создать блок из области выделения Создание нового блока из области выделения

Данные области выделения могут быть скопированы в новый блок, добавляемый к концу записи. Для создания нового блока, содержащего данные из области выделения, используйте команду Дублировать выделение в Блок в меню Правка или соответствующую кнопку панели инструментов.

Удалить блок Удаление блоков

Для удаления активного блока используйте команду Удалить блок в меню Блок или соответствующую кнопку панели инструментов.

Удалить данные в области выделения Удаление выделенного участка данных

Данные, находящиеся внутри области выделения, могут быть удалены из блока. Для удаления данных области выделения используйте команду Удалить выделенные данные в меню Правка или соответствующую кнопку панели инструментов.
Удаление данных зависит от расположения области выделение внутри блока:
  • выделение от начала блока до произвольной точки - удаляются все данные от начала блока до последней точки выделения;
  • выделение от произвольной точки до конца блока - удаляются все данные от первой точки выделения до конца блока;
  • выделен весь блок - удаляется весь блок (общее количество блоков уменьшается);
  • выделен произвольный участок внутри блока - блок содержащий область выделения разбивается на два блока: от начала блока до первой точки выделения и от последней точки выделения до конца блока.
Для удаления произвольного участка данных без разделения блока используйте команду Вырезать выделенные данные в меню Правка. При вызове этой команды внутри блока удаляется выделенный участок данных, а размер блока уменьшается. Первая точка данных, располагавшаяся после области выделения, автоматически помечается комментарием.

Удаление данных канала

Для удаления всех данных активного канала используйте команду Удалить все данные в меню Канал.

См. также
Блоки данных, Область выделения


Обработка данных

Математическая обработка сигналов

Программа «PowerGraph» позволяет проводить математическую обработку сигналов, создавать новые каналы с расчетными данными, а также создавать и использовать различные алгоритмы обработки сигналов.
Далее см. "Математическая обработка сигналов"

Функции обработки сигналов

Программа «PowerGraph» включает обширную библиотеку функций математической и цифровой обработки сигналов: копирование, калибровка и нормализация; амплитудная и частотная фильтрация; дифференцирование и интегрирование; обработка циклических и модулированных сигналов; арифметические и логические операции; тригонометрические, логарифмические и другие математические функции.
Далее см. "Функции обработки сигналов".

Вычисление полинома

Программа «PowerGraph» позволяет проводить обработку сигналов по формуле полинома.
Далее см. "Вычисление полинома"

Дублирование данных

Программа «PowerGraph» позволяет копировать данные в другие каналы и блоки с применением дополнительной математической обработки копируемых сигналов.
Далее см. "Дублирование данных"

Прореживание данных

Программа «PowerGraph» позволяет осуществлять прореживание (децимацию) данных с заданным целочисленным коэффициентом.
Далее см. "Прореживание данных"

Интерполяция данных

Программа «PowerGraph» позволяет осуществлять интерполяцию данных (восстановление промежуточных значений) с заданным целочисленным коэффициентом.
Далее см. "Интерполяция данных"


Математическая обработка сигналов

Программа «PowerGraph» позволяет осуществлять математическую обработку сигналов, создавать новые каналы с расчетными данными, а также создавать и использовать различные алгоритмы обработки сигналов.

На следующем рисунке показан простой пример операции сложения двух сигналов. Два верхних канала содержат исходные сигналы - синусоидальный и пилообразный, нижний канал (расчетный) содержит результат сложения этих сигналов:

Математическая обработка сигналов

Окно "Функции"

Для проведения математической обработки сигналов в программе «PowerGraph» используется дополнительное окно, которое вызывается командой Функции... (Functions) в меню Обработка:

Цифровая обработка сигналов

Окно Функции позволяет создавать математические формулы и производить расчеты по этим формулам. Результаты расчетов могут быть скопированы в любой из каналов.
Для создания формулы необходимо выполнить следующие действия:

  1. Выбрать функцию математической обработки.
  2. Выбрать каналы-источники, в которых содержатся исходные данные для обработки.
  3. Выбрать канал-приемник, в который будут помещены результаты вычислений.
  4. Указать численные аргументы функции. Некоторые функции используют в расчетах дополнительные численные значения (например, уровень амплитуды сигнала или количество точек).
В общем случае формула выглядит следующим образом:

Канал-приемник = Функция (Канал-источник [; Численный аргумент])

Элементы управления

Верхнюю часть окна занимают четыре списка:
  • Категория - выбор категории (группы) функций.
  • Функция - выбор функции математической обработки.
  • Источник 1 и Источник 2 - выбор каналов-источников, содержащих исходные данные для обработки.
Под списком категорий находится список Приемник, в котором выбирается канал-приемник данных.
Под списком функций располагается текстовое поле - строка формулы, которое содержит текущую формулу вычислений и автоматически заполняется при выборе функции, каналов-источников и численных аргументов.
Под строкой формулы находятся отдельные текстовые поля для ввода различных типов численных аргументов:
  • Амплитуда - уровень амплитуды сигнала (A) в единицах измерения канала.
  • Частота - значения частоты (F) в герцах (Гц).
  • Кол-во точек - количество точек (N).
  • Значение - произвольное численное значение (K).
Кнопка Вычислить запускает процесс обработки данных по текущей формуле. Результаты вычислений копируются в канал-приемник.

Опции

В нижней части окна Функции находятся вкладки с дополнительными параметрами и настройками обработки сигналов:
  • Алгоритмы - список алгоритмов обработки.
  • Каналы - список каналов с установленными формулами.
  • Блоки - выбор блоков для проведения вычислений.
  • Описание - описание функций математической обработки сигналов.

Алгоритмы

Программа «PowerGraph» позволяет сохранять различные наборы формул вычислений в виде отдельных алгоритмов обработки сигналов. Сохраненные алгоритмы можно использовать для проведения автоматизированных вычислений и записи протоколов обработки.

Вкладка Алгоритмы (Algorithms) содержит список сохраненных алгоритмов обработки и позволяет загружать, редактировать и создавать различные наборы формул:

Вкладка Алгоритмы содержит два списка - список алгоритмов (слева) и список формул (справа). Список алгоритмов содержит названия созданных алгоритмов и заполняется автоматически. Список формул заполняется соответствующими формулами при выборе того или иного алгоритма.
Кнопки, расположенные слева от списка алгоритмов, выполняют следующие операции:

→ создать новый алгоритм. В списке алгоритмов появится новый элемент с указанным названием и пустым списком формул. Добавление формул в алгоритм см. ниже.
→ сохранить выбранный алгоритм под другим названием.
→ удалить выбранный алгоритм.
→ включить/выключить режим записи формул (переключатель). Режим записи формул позволяет при проведении вычислений автоматически добавлять используемые формулы в список формул выбранного алгоритма и может быть использован для записи протокола обработки сигналов.
Кнопки, расположенные справа от списка формул, выполняют следующие операции:
→ запустить алгоритм. Запуск алгоритма означает автоматическое проведение вычислений по всем формулам алгоритма (последовательно сверху-вниз).
Для использования отдельных формул алгоритма необходимо двойным щелчком мыши загрузить выбранную формулу в строку формулы и нажать кнопку Вычислить.
→ добавить в список формулу, установленную в строке формулы.
→ удалить из списка выбранную формулу.
→ переместить выбранную формулу на одну позицию вверх.
→ переместить выбранную формулу на одну позицию вниз.

Каналы

При проведении математической обработки сигналов программа «PowerGraph» автоматически запоминает для каждого канала последнюю формулу вычислений. Установленную в канале формулу можно использовать для быстрого пересчета всего канала в основном окне программы - команда Ch = ... в меню Канал.
Кроме того, программа «PowerGraph» позволяет определить последовательность обработки каналов (см. Работа с каналами), которая используется при автоматическом пересчете всех каналов (команда Вычислить все в общем меню каналов Сервис/Каналы и Графики основного окна программы) и при обработке сигналов в процеccе регистрации (в режиме реального времени).

Вкладка Каналы (Channels) содержит список всех каналов с установленными формулами:

Список каналов отражает заданную последовательность обработки каналов. Для каждого канала в списке указывается название и формула, которая может иметь следующий вид:

  • Ch# - формула не установлена.
  • Ch# = Функция(...) - формула последних вычислений в канале.
  • Ch#* = Функция(...) - формула вычислений в режиме реального времени (см. Настройки каналов).

Кнопки, расположенные слева от списка позволяют изменять последовательность обработки каналов:

→ переместить канал в начало списка.
→ переместить канал на одну позицию вверх.
→ переместить канал на одну позицию вниз.
→ переместить канал в конец списка.
Справа от списка располагаются кнопки для управления установленными в каналах формулами:
→ запустить процесс вычислений по всем каналам.
→ установить в выбранный канал текущую формулу.
→ удалить формулу последних вычислений в выбранном канале.
→ очистить формулы последних вычислений во всех каналах.

Блоки

Вкладка Блоки (Blocks) содержит список всех записанных блоков текущего файла с указанием названия, частоты, размера и длительности каждого блока:

Обработка сигналов производится только в блоках, отмеченных в этом списке. Дополнительные переключатели над списком блоков используются для произвольного или автоматического выбора блоков:

  • Все - выбор всех блоков.
  • Выбрать - произвольный выбор блоков пользователем.
  • Текущий - выбор только активного блока.
Двойной щелчок левой кнопкой мыши на любом элементе списка приводит к отображению соответствующего блока в основном окне программы.

Описание

Вкладка Описание (Description) содержит контекстную подсказку по функциям обработки сигналов:

При выборе функции в списке Функция, контекстная подсказка к ней автоматически появляется в этой вкладке.
Полное описание функций смотри в разделе Функции обработки сигналов.

См. также
Обработка данных, Функции обработки сигналов, Работа с каналами, Настройки каналов


Функции обработки сигналов

Этот раздел содержит описание функций математической обработки сигналов.

Категории функций:

  • Data - операции копирования и корректировки данных.
  • Arithmetics - арифметические операции над каналами.
  • Math - различные математические функции.
  • Smoothing - функции сглаживания сигналов.
  • Filters - функции амплитудной фильтрации сигналов.
  • FIR Filters - функции частотной фильтрации сигналов (КИХ-фильтры).
  • FIRN Filters - функции частотной фильтрации сигналов (КИХ-фильтры).
  • IIR Filters - функции частотной фильтрации сигналов (БИХ-фильтры).
  • Hilbert Filters - функции, использующие преобразование Гильберта.
  • Levels - расчетные уровни сигналов и константы.
  • Statistic - статистические функции.
  • Differential - функции дифференцирования сигналов.
  • Integral - функции интегрирования сигналов.
  • Cyclic - функции обработки циклических сигналов.
  • CyclicA - функции обработки циклических сигналов.
  • Shift - функции смещения данных по оси X.
  • Comparison - функции сравнения сигналов.
  • Generators - функции-генераторы сигналов различной формы.
  • Windowing - оконные функции.
Используемые обозначения:
RT - функция доступна для использования в режиме реального времени (Real Time)
Y - данные канала-приемника
X - данные канала-источника
A - амплитуда
F - частота в герцах (Гц)
N - количество значений (точек) сигнала
K - произвольное численное значение
…1,2 - несколько однотипных аргументов

Data

Общие операции над данными: копирование, масштабирование, смещение, нормализация.

CopyRT - копирование данных из одного канала в другой:

Y = X
Синтаксис:
Copy(X)

RawDataRT - загрузка основных данных одного канала в расчетные данные другого. Функция позволяет использовать основные данные канала-источника в случаях, когда канал-источник содержит расчетные данные. Если канал-источник не содержит расчетных данных, функция RawData аналогична функции Copy (см. выше). Если канал-источник не содержит основных данных, функция RawData игнорируется.
Для всех других функций расчетные данные имеют более высокий приоритет, чем основные, т.е. если канал-источник содержит основные и расчетные данные для обработки используются расчетные.

Синтаксис:
RawData(X)

InvertRT - инвертирование данных (умножение на -1):

Y = - X
Синтаксис:
Invert(X)

CalibrateRT - калибровка данных, т.е. умножение на масштабный коэффициент (K) и прибавление смещения (A):

Y = X * K + A
Синтаксис:
Calibrate(X;K;A)

ScaleRT - масштабирование данных (умножение на число K):

Y = X * K
Синтаксис:
Scale(X;K)

OffsetRT - смещение данных по шкале амплитуды (прибавление числа A):

Y = X + A
Синтаксис:
Offset(X;A)

OffsetMax - вычитание максимального значения из всего набора данных. Максимальное значение полученных данных равно 0.

Y = X - Max
где Max - максимальное значение.
Синтаксис:
OffsetMax(X)

OffsetMin - вычитание минимального значения из всего набора данных. Минимальное значение полученных данных равно 0.

Y = X - Min
где Min - минимальное значение.
Синтаксис:
OffsetMin(X)

OffsetMean - вычитание среднего арифметического значения из всего набора данных. Среднее арифметическое полученных данных равно 0.

Y = X - Mean
где Mean - среднее арифметическое значение.
Синтаксис:
OffsetMean(X)

OffsetMedian - вычитание медианы из всего набора данных. Медиана (значение амплитуды, которое разбивает выборку на две равные части) полученных данных равна 0.

Y = X - Median
где Median - медиана.
Синтаксис:
OffsetMedian(X)

OffsetMiddle - вычитание из всего набора данных значения соответствующего середине диапазона амплитуды сигнала. Центрирование сигнала относительно нуля - минимальное и максимальное значения полученных данных равны по модулю (Max = - Min).

Y = X - (Min + Max) / 2
где Max и Min - максимальное и минимальное значения.
Синтаксис:
OffsetMiddle(X)

OffsetMode - вычитание моды из всего набора данных. Мода (значение, наиболее часто встречающееся в выборке) полученных данных равна 0.

Y = X - Mode
где Mode - мода.
Синтаксис:
OffsetMode(X)

Normalize - нормализация данных. Среднее арифметическое полученных данных равно 0, а стандартное отклонение равно 1.

Y = (X - Mean) / StdDev
где Mean - среднее значение,
а StdDev - стандартное отклонение.
Синтаксис:
Normalize(X)

NormalizeByMax - нормализация данных относительно наибольшего по модулю значения. Наибольшее значение соответствует либо максимальному значению (если |Max|>|Min|), либо минимальному значению (если |Max|<|Min|). Значения амплитуды полученных данных находятся в диапазоне от -1 до 1.

Y = X / |Am|
где Am - наибольшее по модулю значение.
Синтаксис:
NormalizeByMax(X)

NormalizeByRange - нормализация всего диапазона амплитуды. Все значения проецируются на диапазон от -1 (минимальное) до 1 (максимальное).

Y = 2 * (X - Min) / (Max - Min) - 1
где Max и Min - максимальное и минимальное значения.
Синтаксис:
NormalizeByRange(X)

NormalizeByRate - нормализация данных по частоте регистрации.

Y = X / Fs или Y = X * dT
где Fs - частота регистрации данных,
а dT = 1 / Fs - время между двумя соседними точками.
Синтаксис:
NormalizeByRate(X)

NormalizeByTime - нормализация данных по времени.

Y = X / dT или Y = X * Fs
где Fs - частота регистрации данных,
а dT = 1 / Fs - время между двумя соседними точками.
Синтаксис:
NormalizeByTime(X)

Nothing - удаление расчетных данных канала. Функция дублирует команду удаления расчетных данных в меню канала, но может быть использована при работе с алгоритмами (списками формул) для удаления промежуточных вычислений.

Синтаксис:
Nothing

Arithmetics

Арифметические операции над каналами (X1 - первый канал-источник, X2 - второй канал-источник).

+RT - сложение двух сигналов: Y = X1 + X2

Синтаксис:
X1 + X2

−RT - вычитание двух сигналов: Y = X1 - X2

Синтаксис:
X1 - X2

*RT - умножение сигнала на сигнал: Y = X1 * X2

Синтаксис:
X1 * X2

/RT - деление сигнала на сигнал: Y = X1 / X2

Синтаксис:
X1 / X2

^RT - возведение сигнала в степень, равную другому сигналу: Y = X1 ^ X2

Синтаксис:
X1 ^ X2

QuotientRT - целочисленное деление сигнала на сигнал (целое частное).

Y = Fix(X1 / X2)
Синтаксис:
Quotient(X1;X2)

RemainderRT - остаток от целочисленного деления сигнала на сигнал.

Y = X1 - X2 * Fix(X1 / X2)
Синтаксис:
Remainder(X1;X2)

MagnitudeRT - модуль двух сигналов (квадратный корень суммы квадратов):

Y = (X12 + X22)½
Синтаксис:
Magnitude(X1;X2)

PhaseRT - фаза двух сигналов в радианах (арктангенс отношения). Результат вычислений принимает значения от -3.141593 до +3.141593:

Y = arctg(X1 / X2)
Синтаксис:
Phase(X1;X2)

PhasePIRT - фаза двух сигналов в единицах p (≈ 3.141593 радиан). Результат вычислений принимает значения от -1 до +1:

Y = arctg(X1 / X2)
Синтаксис:
PhasePI(X1;X2)

AddCalibrateRT - сложение двух сигналов и калибровка результата:

Y = (X1 + X2) * K + A
Синтаксис:
AddCalibrate(X1;X2;K;A)

SubCalibrateRT - вычитание двух сигналов и калибровка результата:

Y = (X1 - X2) * K + A
Синтаксис:
SubCalibrate(X1;X2;K;A)

MpyCalibrateRT - умножение сигнала на сигнал и калибровка результата:

Y = (X1 * X2) * K + A
Синтаксис:
MpyCalibrate(X1;X2;K;A)

DivCalibrateRT - деление сигнала на сигнал и калибровка результата:

Y = (X1 / X2) * K + A
Синтаксис:
DivCalibrate(X1;X2;K;A)

CalibrateAddRT - калибровка и сложение двух сигналов:

Y = (X1 * K1) + (X2 * K2) + A
Синтаксис:
CalibrateAdd(X1;X2;K1;K2;A)

CalibrateSubRT - калибровка и вычитание двух сигналов:

Y = (X1 * K1) - (X2 * K2) + A
Синтаксис:
CalibrateSub(X1;X2;K1;K2;A)

CalibrateMpyRT - калибровка и умножение сигнала на сигнал:

Y = (X1 * K1 + A1) * (X2 * K2 + A2)
Синтаксис:
CalibrateMpy(X1;X2;K1;K2;A1;A2)

CalibrateDivRT - калибровка и деление сигнала на сигнал:

Y = (X1 * K1 + A1) / (X2 * K2 + A2)
Синтаксис:
CalibrateDiv(X1;X2;K1;K2;A1;A2)

Math

Математические функции.

AbsRT - модуль числа (абсолютное значение, т.е. число без знака):

Y = |X|
Синтаксис:
Abs(X)

SignRT - знак числа:

Y = 1 если X > 0
Y = 0 если X = 0
Y = -1 если X < 0
Синтаксис:
Sign(X)

ReciprocalRT - обратное значение числа:

Y = 1 / X
Синтаксис:
Reciprocal(X)

ReciproCalibrateRT - калибровка обратного значения числа:

Y = K / X + A
Синтаксис:
ReciproCalibrate(X;K;A)

Power2RT - число в квадрате:

Y = X2
Синтаксис:
Power2(X)

PowerRT - число в степени (K - показатель степени):

Y = XK
Синтаксис:
Power(X;K)

SqrtRT - квадратный корень числа:

Y = √X
Синтаксис:
Sqrt(X)

SqrtPIRT - квадратный корень числа, умноженного на p (≈ 3.141593 радиан):

Y = √p * X
Синтаксис:
SqrtPI(X)

SqrtCalibrateRT - калибровка квадратного корня числа:

Y = √X * K + A
Синтаксис:
SqrtCalibrate(X;K;A)

CalibrateSqrtRT - квадратный корень калиброванного числа:

Y = √X * K + A
Синтаксис:
CalibrateSqrt(X;K;A)

RoundRT - округление числа до ближайшего целого.

Синтаксис:
Round(X)

FixRT - целая часть числа.

Синтаксис:
Fix(X)

IntRT - округление до ближайшего меньшего целого (например Int(-8.3) = -9).

Синтаксис:
Int(X)

SinRT - синус угла, выраженного в радианах:

Y = sin(X)
Синтаксис:
Sin(X)

SinPIRT - синус угла, выраженного в единицах p (≈ 3.141593 радиан):

Y = sin(X)
Синтаксис:
SinPI(X)

CosRT - косинус угла, выраженного в радианах:

Y = cos(X)
Синтаксис:
Cos(X)

CosPIRT - косинус угла, выраженного в единицах p (≈ 3.141593 радиан):

Y = cos(X)
Синтаксис:
CosPI(X)

TanRT - тангенс угла, выраженного в радианах:

Y = tg(X)
Синтаксис:
Tan(X)

TanPIRT - тангенс угла, выраженного в единицах p (≈ 3.141593 радиан):

Y = tg(X)
Синтаксис:
TanPI(X)

ATanRT - арктангенс числа, результат в радианах:

Y = arctg(X)
Синтаксис:
ATan(X)

ATanPIRT - арктангенс числа, результат в единицах p (≈ 3.141593 радиан):

Y = arctg(X)
Синтаксис:
ATanPI(X)

RadToPIRT - преобразование радиан в единицы p (≈ 3.141593 радиан):

Y = X / p
Синтаксис:
RadToPI(X)

PIToRadRT - преобразование единиц p (≈ 3.141593 радиан) в радианы:

Y = X * p
Синтаксис:
PIToRad(X)

RadToDegRT - преобразование радиан в градусы:

Y = X * 180° / p
Синтаксис:
RadToDeg(X)

DegToRadRT - преобразование градусов в радианы:

Y = X * p / 180°
Синтаксис:
DegToRad(X)

Log10RT - десятичный логарифм числа:

Y = log10(X)
Синтаксис:
Log10(X)

LnRT - натуральный логарифм числа:

Y = ln(X)
Синтаксис:
Ln(X)

ExpRT - экспонента числа (возведение e в степень числа). Значение e равняется 2.71828182845904, основанию натурального логарифма:

Y = eX
Синтаксис:
Exp(X)

RandRT - случайное значение в диапазоне от 0 до числа:

Y = X * Krand
где Krand - случайное значение в диапазоне от 0 до 1.
Синтаксис:
Rand(X)

Smoothing

Функции сглаживания (усреднения) сигналов. Эта категория содержит функции расчета среднего значения сигнала по заданному количеству точек N (фильтры скользящего среднего). Единственным численным аргументом для всех функций этой категории является количество точек для усреднения (размер окна). Между собой функции этой категории отличаются весовыми коэффициентами (типом окна), используемыми для расчета среднего значения.
Все функции сглаживания сигналов могут быть представлены следующей общей формулой:
Y = Σ(wj * Xj)
где wj - весовые коэффициенты.
Синтаксис:
Smooth...(X;N)
В функции Smooth все весовые коэффициенты равны 1/N, что соответствует расчету среднего арифметического значения.

Дополнительно см. - Приложение Б и Приложение В.

Filters

Функции фильтрации данных:

PositiveRT - копирование только положительных значений:

Y = X если X > 0
Y = 0 если X ≤ 0
Синтаксис:
Positive(X)

NegativeRT - копирование только отрицательных значений:

Y = X если X < 0
Y = 0 если X ≥ 0
Синтаксис:
Negative(X)

AboveRT - копирование значений выше заданного уровня амплитуды (A):

Y = X если X > A
Y = A если X ≤ A
Синтаксис:
Above(X;A)

BelowRT - копирование значений ниже заданного уровня амплитуды (A):

Y = X если X < A
Y = A если X ≥ A
Синтаксис:
Below(X;A)

RangeFilterRT - копирование значений в заданном диапазоне амплитуды (от A1 до A2):

Y = A1 если X ≤ A1
Y = A2 если X ≥ A2
Y = X если A1 < X < A2
Синтаксис:
RangeFilter(X;A1;A2)

MedianFilterRT - медианный фильтр сигнала (расчет медианы по заданному количеству точек N).

Синтаксис:
MedianFilter(X;N)

NoiseFilter - удаление из сигнала высокочастотных шумов и случайных выбросов.

Синтаксис:
NoiseFilter(X)

Trend - выделение линейного тренда из сигнала.

Синтаксис:
Trend(X)

NoTrend - удаление линейного тренда из сигнала.

Синтаксис:
NoTrend(X)

AC - выделение из сигнала составляющей с заданной частотой (F, Гц).

Синтаксис:
AC(X;F)

ACFilter - удаление из сигнала составляющей с заданной частотой (F, Гц).

Синтаксис:
ACFilter(X;F)

ACSelectMax - выделение из сигнала составляющей c максимальной амплитудой в заданном диапазоне частот. В аргументах функции задаются крайние значения диапазона частот (F1 и F2, Гц), а также целочисленный коэффициент К, указывающий общее количество частот без учета начальной. Функция вычисляет амплитуды составляющих для набора частот от F1 до F2 с шагом ΔF = (F2 - F1) / K и в результате выделяет составляющую с максимальной амплитудой. Если количество частот не указано (К ≤ 1), то максимальная составляющая выбирается только из двух указанных частот F1 и F2.

Синтаксис:
ACSelectMax(X;F1;F2;K)

FIR Filters

Функции частотной фильтрации сигналов (см. также FIRN Filters).
Эта категория функций представляет собой нерекурсивные частотные фильтры (фильтры с конечной импульсной характеристикой, КИХ-фильтры) и содержит четыре группы функций:
  • LowPass - фильтры, пропускающие нижние частоты (НЧ фильтры);
  • HighPass - фильтры, пропускающие верхние частоты (ВЧ фильтры);
  • BandPass - полосовые пропускающие фильтры;
  • BandStop - полосовые задерживающие (режекторные) фильтры.
Внутри каждой группы фильтры отличаются типом весовой функции (типом окна), используемой при вычислении коэффициентов фильтра. Для фильтров верхних и нижних частот единственным численным аргументом функции является частота среза фильтра (F, Гц), которая должна быть меньше половины частоты оцифровки сигнала. Для полосовых фильтров численными аргументами функций являются верхняя и нижняя частоты среза фильтра (F1 и F2, Гц), причем верхняя частота среза фильтра должна быть меньше половины частоты оцифровки сигнала.
Каскадные фильтры могут быть получены последовательным применением функций к одному сигналу.

LowPassRT - фильтр нижних частот (прямоугольное окно).

Синтаксис:
LowPass(X;F)

LowPassTriangleRT - фильтр нижних частот (треугольное окно).

Синтаксис:
LowPassTriangle(X;F)

LowPassHannRT - фильтр нижних частот (окно Ханна).

Синтаксис:
LowPassHann(X;F)

LowPassHammingRT - фильтр нижних частот (окно Хэмминга).

Синтаксис:
LowPassHamming(X;F)

LowPassBlackmanRT - фильтр нижних частот (окно Блэкмена).

Синтаксис:
LowPassBlackman(X;F)

HighPassRT - фильтр верхних частот (прямоугольное окно).

Синтаксис:
HighPass(X;F)

HighPassTriangleRT - фильтр верхних частот (треугольное окно).

Синтаксис:
HighPassTriangle(X;F)

HighPassHannRT - фильтр верхних частот (окно Ханна).

Синтаксис:
HighPassHann(X;F)

HighPassHammingRT - фильтр верхних частот (окно Хэмминга).

Синтаксис:
HighPassHamming(X;F)

HighPassBlackmanRT - фильтр верхних частот (окно Блэкмена).

Синтаксис:
HighPassBlackman(X;F)

BandPassRT - полосовой пропускающий фильтр (прямоугольное окно).

Синтаксис:
BandPass(X;F1;F2)

BandPassTriangleRT - полосовой пропускающий фильтр (треугольное окно).

Синтаксис:
BandPassTriangle(X;F1;F2)

BandPassHannRT - полосовой пропускающий фильтр (окно Ханна).

Синтаксис:
BandPassHann(X;F1;F2)

BandPassHammingRT - полосовой пропускающий фильтр (окно Хэмминга).

Синтаксис:
BandPassHamming(X;F1;F2)

BandPassBlackmanRT - полосовой пропускающий фильтр (окно Блэкмена).

Синтаксис:
BandPassBlackman(X;F1;F2)

BandStopRT - полосовой задерживающий фильтр (прямоугольное окно).

Синтаксис:
BandStop(X;F1;F2)

BandStopTriangleRT - полосовой задерживающий фильтр (треугольное окно).

Синтаксис:
BandStopTriangle(X;F1;F2)

BandStopHannRT - полосовой задерживающий фильтр (окно Ханна).

Синтаксис:
BandStopHann(X;F1;F2)

BandStopHammingRT - полосовой задерживающий фильтр (окно Хэмминга).

Синтаксис:
BandStopHamming(X;F1;F2)

BandStopBlackmanRT - полосовой задерживающий фильтр (окно Блэкмена).

Синтаксис:
BandStopBlackman(X;F1;F2)

FIRN Filters

Функции частотной фильтрации сигналов.
Функции этой категории аналогичны функциям предыдущей категории FIR Filters, но позволяют управлять количеством коэффициентов КИХ-фильтра.
Все функции этой категории содержат дополнительный целочисленный аргумент - количество точек N, соответствующее количеству коэффициентов фильтра. Этот аргумент позволяет управлять крутизной амплитудно-частотной характеристики фильтра. Увеличение количества коэффициентов фильтра приводит к увеличению крутизны АЧХ, а уменьшение количества коэффициентов фильтра соответственно к снижению крутизны АЧХ.
Увеличение крутизны АЧХ применяется для выделения узкополосных синусоидальных сигналов. Снижение крутизны АЧХ применяется для фильтрации широкополосных сигналов (прямоугольный, треугольный, пилообразный, затухающий и т.п.)

LowPassNRT - фильтр нижних частот (прямоугольное окно).

Синтаксис:
LowPassN(X;F;N)

LowPassTriangleNRT - фильтр нижних частот (треугольное окно).

Синтаксис:
LowPassTriangleN(X;F;N)

LowPassHannNRT - фильтр нижних частот (окно Ханна).

Синтаксис:
LowPassHannN(X;F;N)

LowPassHammingNRT - фильтр нижних частот (окно Хэмминга).

Синтаксис:
LowPassHammingN(X;F;N)

LowPassBlackmanNRT - фильтр нижних частот (окно Блэкмена).

Синтаксис:
LowPassBlackmanN(X;F;N)

HighPassNRT - фильтр верхних частот (прямоугольное окно).

Синтаксис:
HighPassN(X;F;N)

HighPassTriangleNRT - фильтр верхних частот (треугольное окно).

Синтаксис:
HighPassTriangleN(X;F;N)

HighPassHannNRT - фильтр верхних частот (окно Ханна).

Синтаксис:
HighPassHannN(X;F;N)

HighPassHammingNRT - фильтр верхних частот (окно Хэмминга).

Синтаксис:
HighPassHammingN(X;F;N)

HighPassBlackmanNRT - фильтр верхних частот (окно Блэкмена).

Синтаксис:
HighPassBlackmanN(X;F;N)

BandPassNRT - полосовой пропускающий фильтр (прямоугольное окно).

Синтаксис:
BandPassN(X;F1;F2;N)

BandPassTriangleNRT - полосовой пропускающий фильтр (треугольное окно).

Синтаксис:
BandPassTriangleN(X;F1;F2;N)

BandPassHannNRT - полосовой пропускающий фильтр (окно Ханна).

Синтаксис:
BandPassHannN(X;F1;F2;N)

BandPassHammingNRT - полосовой пропускающий фильтр (окно Хэмминга).

Синтаксис:
BandPassHammingN(X;F1;F2;N)

BandPassBlackmanNRT - полосовой пропускающий фильтр (окно Блэкмена).

Синтаксис:
BandPassBlackmanN(X;F1;F2;N)

BandStopNRT - полосовой задерживающий фильтр (прямоугольное окно).

Синтаксис:
BandStopN(X;F1;F2;N)

BandStopTriangleNRT - полосовой задерживающий фильтр (треугольное окно).

Синтаксис:
BandStopTriangleN(X;F1;F2;N)

BandStopHannNRT - полосовой задерживающий фильтр (окно Ханна).

Синтаксис:
BandStopHannN(X;F1;F2;N)

BandStopHammingNRT - полосовой задерживающий фильтр (окно Хэмминга).

Синтаксис:
BandStopHammingN(X;F1;F2;N)

BandStopBlackmanNRT - полосовой задерживающий фильтр (окно Блэкмена).

Синтаксис:
BandStopBlackmanN(X;F1;F2;N)

IIR Filters

Функции частотной фильтрации сигналов. Эта категория функций представляет собой рекурсивные частотные фильтры (фильтры с бесконечной импульсной характеристикой, БИХ-фильтры) и содержит две группы функций:
  • RC-фильтры - аналоги электронных RC-цепей;
  • NarrowBand - узкополосные фильтры.
Единственным численным аргументом этих функций является частота среза фильтра (F, Гц), которая должна быть меньше половины частоты оцифровки сигнала.
Каскадные фильтры могут быть получены последовательным применением функций к одному сигналу.

FilterRC - универсальный БИХ-фильтр первого порядка:

Yi = K1 * Xi + K2 * Yi-1
Синтаксис:
FilterRC(X;K1;K2)

LowPassRC - однополюсный фильтр нижних частот (аналог интегрирующей RC-цепи).

Синтаксис:
LowPassRC(X;F)

HighPassRC - однополюсный фильтр верхних частот (аналог дифференцирующей RC-цепи).

Синтаксис:
HighPassRC(X;F)

NarrowBandPass - узкополосный пропускающий фильтр.

Синтаксис:
NarrowBandPass(X;F)

NarrowBandStop - узкополосный задерживающий (режекторный) фильтр или Notch-фильтр.

Синтаксис:
NarrowBandStop(X;F)

Hilbert Filters

Функции, использующие преобразование Гильберта.
Суть преобразования Гильберта заключается в формировании комплексного аналитического сигнала, состоящего из исходного сигнала (вещественная часть) и сопряженного сигнала (мнимая часть). Сопряженный сигнал вычисляется путем смещения всех частот исходного сигнала на 90° (идеальный фазовращатель). Полученный в результате преобразования Гильберта комплексный аналитический сигнал позволяет вычислить амплитудную огибающую и полную фазу исходного сигнала:
S(t) = A(t) * sin(Ψ(t)), где

S(t) - исходный сигнал,
A(t) - амплитудная огибающая сигнала,
Ψ(t) - полная фаза сигнала.
Преобразование Гильберта хорошо работает с сигналами, имеющими ограниченный спектр, поэтому к широкополосным сигналам рекомендуется предварительно применять полосовые фильтры (например, BandPass...) для выделения анализируемого диапазона частот.
Возможное применение преобразования Гильберта: выделение амплитудной огибающей - анализ амплитудно-модулированных сигналов; выделение фазы - определение разности фаз синусоидальных сигналов.

HilbertMag - вычисление амплитудной огибающей сигнала. Предполагается, что сигнал центрирован относительно нуля и не имеет постоянной составляющей.

Синтаксис:
HilbertMag(X)

HilbertMagDC - вычисление амплитудной огибающей сигнала с учетом постоянной составляющей. Амплитудная огибающая сигнала вычисляется относительно постоянной составляющей, которая добавляется к результату вычислений.

Синтаксис:
HilbertMagDC(X)

HilbertMagNoDC - вычисление амплитудной огибающей сигнала с удалением постоянной составляющей. Вычисляется только амплитудная огибающая сигнала относительно постоянной составляющей.

Синтаксис:
HilbertMagNoDC(X)

HilbertPhase - вычисление фазы сигнала в радианах. Результат вычислений принимает значения от -3.141593 до +3.141593.

Синтаксис:
HilbertPhase(X)

HilbertPhasePI - вычисление фазы сигнала в единицах p (≈ 3.141593 радиан). Результат вычислений принимает значения от -1 до +1.

Синтаксис:
HilbertPhasePI(X)

HilbertImag - вычисление сопряженного сигнала преобразования Гильберта (мнимая часть аналитического сигнала).

Синтаксис:
HilbertImag(X)

Levels

Функции категории Levels ("Уровни") заполняют данные канала-приемника одним значением - уровнем сигнала. В качестве уровня сигнала могут быть использованы расчетные статистические значения, а также пользовательские и математические константы.

ConstRT - уровень, указанный пользователем (константа - A).

Синтаксис:
Const(A)

Max - уровень максимального значения.

Синтаксис:
Max(X)

Min - уровень минимального значения.

Синтаксис:
Min(X)

Range - диапазон амплитуды сигнала (Max-Min).

Синтаксис:
Range(X)

Mean - уровень среднего арифметического значения.

Синтаксис:
Mean(X)

Middle - уровень середины диапазона амплитуды ([Max + Min] / 2).

Синтаксис:
Middle(X)

Median - уровень медианы (значение амплитуды, которое разбивает выборку на две равные части).

Синтаксис:
Median(X)

Mode - уровень моды (значение, наиболее часто встречающееся в выборке).

Синтаксис:
Mode(X)

RMS - уровень среднеквадратического значения (RMS):

RMS = [image], где N - все точки.
Синтаксис:
RMS(X)

Variance - уровень, соответствующий значению дисперсии:

Variance =
где N - все точки, mean - среднее значение.
Синтаксис:
Variance(X)

StdDev - уровень, соответствующий значению стандартного отклонения:

StdDev =
где N - все точки, mean - среднее значение.
Синтаксис:
StdDev(X)

StdError - уровень, соответствующий значению стандартной ошибки.

Синтаксис:
StdError(X)

Sum - уровень суммы всех значений.

Синтаксис:
Sum(X)

SumAbs - уровень суммы абсолютных значений.

Синтаксис:
SumAbs(X)

SumPositive - уровень суммы положительных значений.

Синтаксис:
SumPositive(X)

SumNegative - уровень суммы отрицательных значений.

Синтаксис:
SumNegative(X)

NULLRT - уровень нуля (0).

Синтаксис:
NULL

TRUERT - значение "истина" логической операции (1).

Синтаксис:
TRUE

2PIRT - значение 2p.

Синтаксис:
2PI

PIRT - значение p.

Синтаксис:
PI

PI_2RT - значение p/2.

Синтаксис:
PI_2

PI_4RT - значение p/4.

Синтаксис:
PI_4

Statistic

Функции статистической обработки сигналов.

RMSPtRT - вычисление среднеквадратичного значения по заданному количеству точек N (скользящее среднеквадратичное значение):

Yi =
где N - размер выборки (количество точек).
Синтаксис:
RMSPt(X;N)

StdDevPt - вычисление стандартного отклонения по заданному количеству точек N (скользящее стандартное отклонение):

Yi =
где N - размер выборки (количество точек), mean - среднее значение.
Синтаксис:
StdDevPt(X;N)

MaxPt - вычисление максимального значения по заданному количеству точек N (скользящее максимальное).

Синтаксис:
MaxPt(X;N)

MinPt - вычисление минимального значения по заданному количеству точек N (скользящее минимальное).

Синтаксис:
MinPt(X;N)

RangePt - вычисление диапазона значений (Max - Min) по заданному количеству точек N (скользящий диапазон значений).

Синтаксис:
RangePt(X;N)

AutoCorrelation - вычисление автокорреляции сигнала. Функция рассчитывает коэффициенты корреляции двух копий исходного сигнала последовательно смещая данные относительно друг друга на одно значение (последовательное увеличение порядка коэффициента автокорреляции). Порядок коэффициента автокорреляции (лаг) для первой точки полученных данных равен 0, для второй точки равен 1, и т.д.

Синтаксис:
AutoCorrelation(X)

CrossCorrelation - вычисление взаимной корреляции двух сигналов. Функция рассчитывает коэффициенты корреляции двух сигналов последовательно смещая данные относительно друг друга на одно значение (последовательное увеличение порядка коэффициента корреляции). Порядок коэффициента корреляции (лаг) для первой точки полученных данных равен 0, для второй точки равен 1, и т.д.

Синтаксис:
CrossCorrelation(X1;X2)

CrossCorrelationPt - вычисление взаимной корреляции двух сигналов по заданному количеству точек N (скользящий коэффициент корреляции). Функция рассчитывает для каждой точки шкалы времени коэффициенты корреляции двух сигналов на участке заданного размера. Порядок коэффициента корреляции (лаг) для всех полученных данных равен 0.

Синтаксис:
CrossCorrelationPt(X1;X2;N)

Differential

Функции дифференцирования сигналов:

Diff1PtRT - дифференцирование данных (вычисление разности двух соседних значений):

Yi = Xi - Xi-1
Синтаксис:
Diff1Pt(X)

Diff1PtNormRT - дифференцирование данных с нормализацией по времени:

Yi = (Xi - Xi-1) / dT
где dT - время между двумя соседними точками
(dT = 1/Fs, где Fs - частота регистрации данных).
Синтаксис:
Diff1PtNorm(X)

Diff3PtRT - дифференцирование данных с использованием 3-х точечного алгоритма:

Yi = (Xi+1 - Xi-1) / 2
Синтаксис:
Diff3Pt(X)

Diff3PtNormRT - дифференцирование данных с нормализацией по времени (3-х точечный алгоритм):

Yi = (Xi+1 - Xi-1) / 2 / dT
где dT - время между двумя соседними точками
(dT = 1/Fs, где Fs - частота регистрации данных).
Синтаксис:
Diff3PtNorm(X)

Diff5PtRT - дифференцирование данных с использованием 5-ти точечного алгоритма;

Yi = [(Xi-2 - Xi+2) - 8 * (Xi-1 - Xi+1)] / 12
Синтаксис:
Diff5Pt(X)

Diff5PtNormRT - дифференцирование данных с нормализацией по времени (5-ти точечный алгоритм);

Yi = [(Xi-2 - Xi+2) - 8 * (Xi-1 - Xi+1)] / 12 / dT
где dT - время между двумя соседними точками
(dT = 1/Fs, где Fs - частота регистрации данных).
Синтаксис:
Diff5PtNorm(X)

DiffPtRT - скользящее дифференцирование данных в диапазоне точек N;

Yi = 6 * [Σ(2 * j - 1 - N) * Xj] / [(N - 1) * N * (N + 1)]
Синтаксис:
DiffPt(X;N)

DiffPtNormRT - скользящее дифференцирование данных в диапазоне точек N с нормализацией по времени;

Yi = 6 * [Σ(2 * j - 1 - N) * Xj] / [(N - 1) * N * (N + 1)] / dT
где dT - время между двумя соседними точками
(dT = 1/Fs, где Fs - частота регистрации данных).
Синтаксис:
DiffPtNorm(X;N)

DiffRC - скользящее дифференцирование данных в диапазоне точек N (аналог фильтра высоких частот RC-цепи):

Yi = (1 - 1/N) * Yi-1 + (Xi - Xi-1)
Синтаксис:
DiffRC(X;N)

Integral

Функции интегрирования сигналов:

Integral1Pt - интегрирование данных (суммирование значений с накоплением):

Yi = Yi-1 + Xi
Синтаксис:
Integral1Pt(X)

Integral1PtNorm - интегрирование данных c нормализацией по времени:

Yi = (Yi-1 + Xi) * dT
где dT - время между двумя соседними точками
(dT = 1/Fs, где Fs - частота регистрации данных).
Синтаксис:
Integral1PtNorm(X)

IntegralRC - интегрирование данных в диапазоне точек N (аналог фильтра низких частот RC-цепи):

Yi = [(N - 1) * Yi-1 + Xi] / N
Синтаксис:
IntegralRC(X)

AreaPtRT - расчет относительной площади под кривой в диапазоне точек N (сумма абсолютных значений, деленная на N).

Синтаксис:
AreaPt(X;N)

AreaPositivePtRT - расчет относительной положительной площади под кривой в диапазоне точек N (сумма положительных значений, деленная на N).

Синтаксис:
AreaPositivePt(X;N)

AreaNegativePtRT - расчет относительной отрицательной площади под кривой в диапазоне точек N (сумма отрицательных значений, деленная на N).

Синтаксис:
AreaNegativePt(X;N)

Cyclic

Функции обработки циклических сигналов (см. также CyclicA).
Функции этой категории разбивают исходный сигнал на циклы по положительному и отрицательному фронту амплитуды. Для каждого цикла вычисляется выбранное функцией значение (частота, период, максимум, минимум и т.д.), которое записывается во все точки этого цикла.
Численным аргументом функций этой категории является количество точек - N (2 и более), которое определяет наименьший размер циклов, на которые разбивается сигнал. Ограничение наименьшего размера циклов позволяет исключить из обработки случайные выбросы и высокочастотные шумы.
Примечания: Для правильной работы циклических функций предварительно используйте функцию NoiseFilter (категория Filters) для устранения высокочастотных шумов и случайных выбросов сигнала. Для исключения из сигнала высокочастотных составляющих используйте также функции частотной фильтрации LowPass... (НЧ-фильтры, категория FIR Filters)
Для устранения ступенчатого характера результатов циклических функций используйте функции сглаживания сигналов (категория Smoothing).

CyclePhase - фаза цикла:

Y = 1 от минимума до максимума (положительный фронт)
Y = -1 от максимума до минимума (отрицательный фронт)
Синтаксис:
CyclePhase(X;N)

CycleFrequency - частота каждого цикла, частотомер (Гц).

Синтаксис:
CycleFrequency(X;N)

CyclePeriod - период каждого цикла (сек).

Синтаксис:
CyclePeriod(X;N)

CycleHalfPeriod - полупериод каждого цикла, отдельно рассчитывается длительность положительного и отрицательного фронтов цикла (сек).

Синтаксис:
CycleHalfPeriod(X;N)

CycleExtremum - позиция экстремумов цикла:

Y = 1 в точке максимума
Y = -1 в точке минимума
Y = 0 во всех остальных точках цикла
Синтаксис:
CycleExtremum(X;N)

CyclePointMax - позиция максимального значения цикла:

Y = Max в точке максимума цикла
Y = 0 во всех остальных точках цикла
Синтаксис:
CyclePointMax(X;N)

CyclePointMin - позиция минимального значения цикла:

Y = Min в точке минимума цикла
Y = 0 во всех остальных точках цикла
Синтаксис:
CyclePointMin(X;N)

CycleMax - максимальное значение цикла.

Синтаксис:
CycleMax(X;N)

CycleMin - минимальное значение цикла.

Синтаксис:
CycleMin(X;N)

CycleMinMax - минимальное и максимальное значения цикла:

Y = Max от минимума до максимума (положительный фронт)
Y = Min от максимума до минимума (отрицательный фронт)
Синтаксис:
CycleMinMax(X;N)

CycleRange - амплитудный диапазон цикла (разность максимального и минимального значений = Max-Min).

Синтаксис:
CycleRange(X;N)

CycleMiddle - центральное значение цикла (среднее между максимальным и минимальным значениями = (Max+Min)/2).

Синтаксис:
CycleMiddle(X;N)

CycleMean - среднее арифметическое значение всех точек цикла.

Синтаксис:
CycleMean(X;N)

CycleRMS - среднеквадратичное значение (RMS) всех точек цикла.

Синтаксис:
CycleRMS(X;N)

CyclicA

Функции обработки циклических сигналов (см. также Cyclic).
Функции этой категории разбивают исходный сигнал на циклы по положительному и отрицательному фронту амплитуды. Для каждого цикла вычисляется выбранное функцией значение (частота, период, максимум, минимум и т.д.), которое записывается во все точки этого цикла.
Численным аргументом функций этой категории является амплитуда - A , которая соответствует наименьшей разнице между масимумом и минимумом каждого цикла. Выделение участка сигнала в отдельный цикл осуществляется только при условии того, что разница между двумя соседними экстремумами превышает указанный уровень амплитуды. Ограничение наименьшей амплитуды циклов позволяет исключить из обработки шумы, амплитуда которых меньше амплитуды полезного сигнала.
Для устранения ступенчатого характера результатов циклических функций используйте функции сглаживания сигналов (категория Smoothing).

CyclePhaseA - фаза цикла:

Y = 1 от минимума до максимума (положительный фронт)
Y = -1 от максимума до минимума (отрицательный фронт)
Синтаксис:
CyclePhaseA(X;A)

CycleFrequencyA - частота каждого цикла, частотомер (Гц).

Синтаксис:
CycleFrequencyA(X;A)

CyclePeriodA - период каждого цикла (сек).

Синтаксис:
CyclePeriodA(X;A)

CycleHalfPeriodA - полупериод каждого цикла, отдельно рассчитывается длительность положительного и отрицательного фронтов цикла (сек).

Синтаксис:
CycleHalfPeriodA(X;A)

CycleExtremumA - позиция экстремумов цикла:

Y = 1 в точке максимума
Y = -1 в точке минимума
Y = 0 во всех остальных точках цикла
Синтаксис:
CycleExtremumA(X;A)

CyclePointMaxA - позиция максимального значения цикла:

Y = Max в точке максимума цикла
Y = 0 во всех остальных точках цикла
Синтаксис:
CyclePointMaxA(X;A)

CyclePointMinA - позиция минимального значения цикла:

Y = Min в точке минимума цикла
Y = 0 во всех остальных точках цикла
Синтаксис:
CyclePointMinA(X;A)

CycleMaxA - максимальное значение цикла.

Синтаксис:
CycleMaxA(X;A)

CycleMinA - минимальное значение цикла.

Синтаксис:
CycleMinA(X;A)

CycleMinMaxA - минимальное и максимальное значения цикла:

Y = Max от минимума до максимума (положительный фронт)
Y = Min от максимума до минимума (отрицательный фронт)
Синтаксис:
CycleMinMaxA(X;A)

CycleRangeA - амплитудный диапазон цикла (разность максимального и минимального значений = Max-Min).

Синтаксис:
CycleRangeA(X;A)

CycleMiddleA - центральное значение цикла (среднее между максимальным и минимальным значениями = (Max+Min)/2).

Синтаксис:
CycleMiddleA(X;A)

CycleMeanA - среднее арифметическое значение всех точек цикла.

Синтаксис:
CycleMeanA(X;A)

CycleRMSA - среднеквадратичное значение (RMS) всех точек цикла.

Синтаксис:
CycleRMSA(X;A)

Shift

Функции смещения и изменения последовательности данных.

Reverse - переворачивание сигнала по горизонтали (первая точка становится последней, а последняя - первой):

Yi = X(N - i + 1)
где N - общее количество точек.
Синтаксис:
Reverse(X)

ShiftLeft - смещение сигнала влево на заданное количество точек N (начальные N точек переносятся в конец сигнала):

Yi = X(i + N)
Синтаксис:
ShiftLeft(X;N)

ShiftRight - смещение сигнала вправо на заданное количество точек N (конечные N точек переносятся в начало сигнала):

Yi = X(i - N)
Синтаксис:
ShiftRight(X;N)

ShiftLeftFill - смещение сигнала влево на заданное количество точек N (конечные N точек заполняются последним значением):

Yi = X(i + N)
Синтаксис:
ShiftLeftFill(X;N)

ShiftRightFill - смещение сигнала вправо на заданное количество точек N (начальные N точек заполняются первым значением):

Yi = X(i - N)
Синтаксис:
ShiftRightFill(X;N)

ShiftToMax - смещение сигнала влево на Nmax точек, где Nmax - индекс точки с максимальным значением (точка с максимальным значением становится первой в блоке):

Yi = X(i + Nmax)
Синтаксис:
ShiftToMax(X)

ShiftToMin - смещение сигнала влево на Nmin точек, где Nmin - индекс точки с минимальным значением (точка с минимальным значением становится первой в блоке):

Yi = X(i + Nmin)
Синтаксис:
ShiftToMin(X)

ShiftToAbove - смещение сигнала влево на Namp точек, где Namp - индекс точки, в которой значение амплитуды сигнала достигает или переходит заданный уровень амплитуды A снизу вверх (эта точка становится первой в блоке):

Yi = X(i + Namp) где XNamp ≥ A, а X(Namp-1) < A
Синтаксис:
ShiftToAbove(X;A)

ShiftToBelow - смещение сигнала влево на Namp точек, где Namp - индекс точки, в которой значение амплитуды сигнала достигает или переходит заданный уровень амплитуды A сверху вниз (эта точка становится первой в блоке):

Yi = X(i + Namp) где XNamp ≤ A, а X(Namp-1) > A
Синтаксис:
ShiftToBelow(X;A)

SortAsc - сортировка значений сигнала в порядке возрастания.

Синтаксис:
SortAsc(X)

SortDesc - сортировка значений сигнала в порядке убывания.

Синтаксис:
SortDesc(X)

Comparison

Функции сравнения сигналов в двух каналах (X1 - первый канал-источник, X2 - второй канал-источник). В качестве результата сравнения эти функции возвращают:
  • Логические значения: 0 ("ложь") - если условие сравнения ошибочно; 1 ("истина") - если условие сравнения верно. Результаты работы этих функций можно использовать для фильтрации данных, удовлетворяющих определенным условиям (например, последующее умножение на 0 значений, которые не удовлетворяют заданным условиям сравнения).
  • Значение одного из каналов в зависимости от условия сравнения.

<RT - значение в первом канале меньше значения во втором:

Y = 1 если X1 < X2
Y = 0 если X1 ≥ X2
Синтаксис:
X1 < X2

<=RT - значение в первом канале меньше или равно значению во втором:

Y = 1 если X1 ≤ X2
Y = 0 если X1 > X2
Синтаксис:
X1 <= X2

>RT - значение в первом канале больше значения во втором:

Y = 1 если X1 > X2
Y = 0 если X1 ≤ X2
Синтаксис:
X1 > X2

>=RT - значение в первом канале больше или равно значению во втором:

Y = 1 если X1 ≥ X2
Y = 0 если X1 < X2
Синтаксис:
X1 >= X2

=RT - значение в первом канале равно значению во втором:

Y = 1 если X1 = X2
Y = 0 во всех остальных случаях
Синтаксис:
X1 = X2

<>RT - значение в первом канале неравно значению во втором:

Y = 0 если X1 = X2
Y = 1 во всех остальных случаях
Синтаксис:
X1 <> X2

RangeInRT - значение сигнала принадлежит диапазону амплитуды от A1 до A2:

Y = 1 если A1 ≤ X ≤ A2
Y = 0 если X < A1 или X > A2
Синтаксис:
RangeIn(X;A1;A2)

RangeOutRT - значение сигнала не принадлежит диапазону амплитуды от A1 до A2:

Y = 1 если X < A1 или X > A2
Y = 0 если A1 ≤ X ≤ A2
Синтаксис:
RangeOut(X;A1;A2)

SelectMaxRT - выбор большего значения (сравнение двух каналов):

Y = X1 если X1 ≥ X2
Y = X2 если X1 < X2
Синтаксис:
SelectMax(X1;X2)

SelectMinRT - выбор меньшего значения (сравнение двух каналов):

Y = X1 если X1 ≤ X2
Y = X2 если X1 > X2
Синтаксис:
SelectMin(X1;X2)

Generators

Функции-генераторы сигналов различной формы.

GenSineRT - генерация синусоидального сигнала. Аргументы функции:

A - амплитуда сигнала
F - частота сигнала (Гц)
K - фаза сигнала (от 0 до 1)
Синтаксис:
GenSine(A;F;K)

GenTriangleRT - генерация треугольного сигнала. Аргументы функции:

A - амплитуда сигнала
F - частота сигнала (Гц)
K - фаза сигнала (от 0 до 1)
Синтаксис:
GenTriangle(A;F;K)

GenRampRT - генерация пилообразного сигнала. Аргументы функции:

A - амплитуда сигнала
F - частота сигнала (Гц)
K - фаза сигнала (от 0 до 1)
Синтаксис:
GenRamp(A;F;K)

GenRandomRT - генерация случайного сигнала. Аргументы функции:

A - амплитуда сигнала (-A ≤ Y ≤ A)
Синтаксис:
GenRandom(A)

GenRandomGausRT - генерация случайного сигнала с Гаусовским распределением. Аргументы функции:

A - амплитуда сигнала (стандартное отклонение)
Синтаксис:
GenRandomGaus(A)

Windowing

Весовые (оконные) функции - умножение значений сигнала на весовые коэффициенты w(i):
Yi = Wi * Xi
Синтаксис:
Win...(X)
Подробнее см. - Приложение В. Весовые (оконные) функции.

Вопросы, замечания и предложения по работе функций математической обработки сигналов Вы можете направлять по электронной почте на адрес: soft@powergraph.ru.


Вычисление полинома

Программа «PowerGraph» позволяет проводить обработку сигналов по формуле полинома:

Y = A0 + A1X + A2X2 + A3X3 + ... + AnXn

Для вычисления полинома используется дополнительное окно, которое вызывается командой Полином... (Polynomial) в меню Обработка:

Для вычисления полинома необходимо выполнить следующие действия:

  1. Выбрать канал-источник, содержащий исходные данные для вычисления полинома (X).
  2. Выбрать канал-приемник, в который будут помещены результаты вычислений (Y).
  3. Выбрать члены полинома (произвольный набор от 0-го до 7-го).
  4. Указать численные коэффициенты полинома (A0-A7).

Элементы управления

Окно Полином содержит следующие элементы управления:
  • Список Источник - выбор канала-источника.
  • Список Приемник - выбор канала-приемника.
  • Флажки Порядок - выбор членов полинома.
  • Текстовые поля Множитель - ввод численных коэффициентов полинома.
Для запуска процесса вычисления полинома следует нажать кнопку Вычислить.
Кнопка Очистить сбрасывает все флажки членов полинома и устанавливает все коэффициенты равными 1.

Опции

В нижней части окна Полином находятся вкладки с дополнительными параметрами и настройками вычислений:
  • Полиномы - список сохраненных полиномов.
  • Блоки - выбор блоков для проведения вычислений.

Полиномы

Программа «PowerGraph» позволяет сохранять текущие параметры полинома для использования в следующих сеансах работы с программой.

Вкладка Полиномы содержит список сохраненных полиномов (слева) и список членов полинома (справа). При выборе любого элемента левого списка члены выбранного полинома отображаются в правом списке в виде математического выражения. Двойной щелчок на элементах обоих списков устанавливает соответствующие параметры полинома в элементах управления.
Кнопки, расположенные слева от списка полиномов, выполняют следующие операции:

→ сохранить текущие параметры полинома.
→ создать новый полином и сохранить в него текущие параметры.
→ загрузить параметры выбранного в списке полинома в элементы управления.
→ удалить выбранный полином из списка.

Блоки

Вкладка Блоки содержит список всех записанных блоков текущего файла с указанием названия, частоты, размера и длительности каждого блока:

Вычисление полинома производится только в блоках, отмеченных в этом списке. Дополнительные переключатели над списком блоков используются для произвольного или автоматического выбора блоков:

  • Все - выбор всех блоков.
  • Выбрать - произвольный выбор блоков пользователем.
  • Текущий - выбор только активного блока.
Двойной щелчок левой кнопкой мыши на любом элементе списка приводит к отображению соответствующего блока в основном окне программы.

См. также
Обработка данных, Математическая обработка сигналов


Дублирование данных

Программа «PowerGraph» позволяет копировать данные в другие каналы и блоки с применением дополнительной математической обработки копируемых сигналов.
Для копирования данных в другие каналы и блоки используется дополнительное окно, которое вызывается командой Дублирование данных... (Duplication) в меню Обработка:

Для дублирования данных необходимо выполнить следующие действия:

  1. Выбрать канал-источник, содержащий исходные данные для дублирования.
  2. Выбрать канал-приемник, в который будут вставлены дублируемые данные.
  3. Выбрать функцию обработки дублируемых данных.
  4. Выбрать блоки, в которых будет осуществляться дублирование данных.
  5. Выбрать блок-источник, если осуществляется перенос данных в другие блоки.

Выбор каналов

Канал-источник и канал-приемник выбираются в списках каналов Источник и Приемник. При нажатии кнопки Выполнить данные из канала-источника копируются в расчетные данные канала-приемника.
Подробнее о расчетных данных см. раздел - Работа с каналами: Расчетные данные.

Выбор функции

Копирование данных может осуществляться с применением дополнительной математической обработки: инвертирование, смещение и нормализация сигналов. Функция обработки копируемых сигналов выбирается в списке Функции. При дублировании данных по умолчанию используется функция Copy, которая копирует данные из канала-источника в канал-приемник без какой-либо математической обработки.
Описание функции обработки см. в разделе - Функции обработки: Категория Data.

Выбор блоков

В центральной части окна Дублирование данных расположен список всех блоков текущего файла с указанием названия, частоты, размера и длительности каждого блока. Двойной щелчок левой кнопкой мыши на любом элементе этого списка приводит к отображению соответствующего блока в основном окне программы. Копирование данных из канала-источника в канал-приемник осуществляется только в блоках, отмеченных в этом списке. Дополнительные переключатели над списком блоков используются для произвольного или автоматического выбора блоков:
  • Все - выбор всех блоков.
  • Выбрать - произвольный выбор блоков пользователем.
  • Текущий - выбор только активного блока.
По умолчанию данные из канала-источника каждого блока, отмеченного в списке блоков, копируются в канал-приемник этого же блока.

Копирование данных в другие блоки

Окно Дублирование данных также предоставляет возможность обмена данными между блоками. В этом случае данные из одного блока (блок-источник) копируются во все блоки, отмеченные в списке (блоки-приемники). Копирование данных в другие блоки может быть использовано для решения следующих задач:
  • Объединение серии измерений - данные какого-либо канала, последовательно записанные в нескольких блоках, копируются в один блок, но в разные каналы. Объединение последовательности измерений в итоговом блоке позволяет сопоставить и сравнить сигналы от одного источника, записанные в разное время.
  • Использование "эталонного" сигнала - копирование "эталонного" сигнала в другие блоки позволяет сравнить результат каждого измерения с контрольным образцом или использовать его для стандартизации обработки всех измерений.
Для включения режима копирование данных из блока-источника в блоки-приемники используется флажок Источник из одного блока. Блок-источник выбирается в дополнительном списке блоков, расположенном в нижней части окна.

При копировании данных из блока-источника в блоки-приемники копируется только массив значений амплитуды без учета частоты регистрации данных. Такое копирование предполагает, что блок-источник и блок-приемник имеют одинаковую частоту регистрации. Если частота регистрации блока-источника отличается от частоты регистрации блока-приемника, то скопированные в блок-приемник сигналы будут иметь неверные временные характеристики. В этом случае перед копированием данных необходимо привести в соответствие частоту регистрации блока-приемника и блока-источника. Например, осуществить прореживание данных блока, имеющего большее значение частоты регистрации.

Выравнивание данных

Размеры блоков могут отличаться, поэтому при копировании данных в другие блоки возможны следующие ситуации несоответствия размеров:
  • Избыток данных - размер блока-источника больше размера блока-приемника.
  • Недостаток данных - размер блока-источника меньше размера блока-приемника.
В случае избытка данных в блок-приемник копируется только часть данных блока-источника, а в случае недостатка данных избыточный участок блока-приемника заполняется первым или последним значением копируемых данных. Список Выравнивание позволяет выбрать метод сопоставления размеров блока-источника и блока-приемника:

Выравнивание | Избыток данных | Недостаток данных
Начало | Копируется только начальный участок блока-источника, соответствующий размеру блока-приемника. | Все данные блока-источника вставляются в начало блока-приемника, недостаток данных в конце блока-приемника заполняется последним значением копируемых данных.
Конец | Копируется только конечный участок блока-источника, соответствующий размеру блока-приемника. | Все данные блока-источника вставляются в конец блока-приемника, недостаток данных в начале блока-приемника заполняется первым значением копируемых данных.
По центру | Копируется только центральный участок блока-источника, соответствующий размеру блока-приемника. | Все данные блока-источника вставляются в середину блока-приемника, недостаток данных в начале блока-приемника заполняется первым значением копируемых данных, а недостаток данных в конце блока-приемника заполняется последним значением копируемых данных.

Для выравнивания размеров блоков можно также использовать область выделения для удаления избыточного участка блока-источника или блока-приемника.
Для выравнивания размеров блоков при проведении серии однотипных измерений рекомендуется применять синхронизацию регистрации данных с использованием фиксированного размера блоков (Стоп-Триггер).

См. также
Обработка данных, Математическая обработка сигналов, Работа с каналами


Прореживание данных

Прореживание данных с заданным целочисленным коэффициентом ("децимация") позволяет сократить объем записанных данных и уменьшить частоту дискретизации сигналов.

В программе «PowerGraph» для прореживания данных используется дополнительное окно, которое вызывается командой Прореживание данных... (Decimation) в меню Обработка:

Прореживание и усреднение данных

Для прореживания следует выбрать блок исходных данных (список в верхней части окна), а также указать коэффициент и способ прореживания:

Фактор (Factor) - целочисленный коэффициент прореживания данных (N), который указывает, во сколько раз следует сократить объем данных. Например, если коэффициент прореживания равен 5, то каждое значение прореженных данных будет соответствовать 5-ти значениям исходных данных. При этом в 5 раз уменьшится частота регистрации данных, а временной интервал между значениями в 5 раз увеличится.

Окно прореживания позволяет выбрать следующие способы формирования каждого значения прореженных данных:

  • Среднее (Mean) - среднее значение каждых N значений исходных данных.
  • Максимальное (Maximum) - максимальное значение из каждых N значений исходных данных.
  • Минимальное (Minimum) - минимальное значение из каждых N значений исходных данных.
  • Медиана (Median) - медиана каждых N значений исходных данных.
  • Первое (First Value) - первое значение из каждых N значений исходных данных.
  • Последнее (Last Value) - последнее значение из каждых N значений исходных данных.
  • Центральное (Central Value) - центральное значение из каждых N значений исходных данных.

Справа под списком блоков отображаются статистические и временные характеристики блока до (Before) и после (After) прореживания:

  • Частота (Rate) - частота регистрации блока.
  • Шаг (Step)- интервал времени между соседними значениями.
  • Размер (Size) - количество значений для каждого канала (размер блока).
  • Объем (Volume) - объем данных (в байтах).

Создать блок (Create New Block) - режим создания нового блока. Прореженные данные будут помещены в новый блок, который добавляется после блока с исходными данными.

Выполнить (Decimate) - запустить процесс прореживания.

См. также
Обработка данных, Интерполяция данных


Интерполяция данных

Интерполяция данных с заданным целочисленным коэффициентом позволяет увеличить частоту дискретизации сигналов за счет добавления промежуточных значений сигнала.

В программе «PowerGraph» для интерполяции данных используется дополнительное окно, которое вызывается командой Интерполяция данных... (Interpolation) в меню Обработка:

Для интерполяции следует выбрать блок исходных данных (список в верхней части окна), а также указать коэффициент и способ интерполяции:

Фактор (Factor) - целочисленный коэффициент интерполяции данных (N), который указывает, во сколько раз следует увеличить объем данных. Например, если коэффициент интерполяции равен 5, то между соседними значениями исходных данных будут вставлены 4 новых значения. При этом в 5 раз увеличится частота регистрации данных, а временной интервал между значениями в 5 раз уменьшится.

Программа позволяет использовать следующие способы интерполяции:

  • Гладкая (Smooth) - интерполяция всего сигнала синусоидальной функцией.
  • Линейная (Linear) - интерполяция промежуточных значений линейной функцией.
  • Ступенчатая (Step) - заполнение промежуточных значений одним исходным значением.

Справа под списком блоков отображаются статистические и временные характеристики блока до (Before) и после (After) интерполяции:

  • Частота (Rate) - частота регистрации блока.
  • Шаг (Step)- интервал времени между соседними значениями.
  • Размер (Size) - количество значений для каждого канала (размер блока).
  • Объем (Volume) - объем данных (в байтах).

Создать блок (Create New Block) - режим создания нового блока. Интерполированные данные будут помещены в новый блок, который добавляется после блока с исходными данными.

Выполнить (Interpolate) - запустить процесс интерполяции.

См. также
Обработка данных, Прореживание данных


Анализ данных

Для анализа данных в программе «PowerGraph» используются дополнительные окна, предоставляющие специализированные функции (расчет статистических значений, дополнительные графические построения, спектральный анализ сигналов, построение графиков зависимостей, построение гистограмм распределения).
Доступ к функциям анализа данных осуществляется через команды меню Анализ (Analysis):

Data Pad Таблица значений

Окно Таблица значений позволяет работать с индивидуальными таблицами значений каждого блока.
Дополнительная библиотека информационных и расчетных функций окна Таблица значений позволяет добавлять в таблицу новые значения (параметры блока данных и области выделения; статистические, дифференциальные и интегральные характеристики сигналов).
Далее см. Таблица значений

Zoom View Анализ сигнала

Окно Анализ сигнала позволяет работать с данными в увеличенном масштабе, анализировать и редактировать отдельные участки сигнала, а также проводить дополнительные графические построения (проекции, касательные и др.).
Далее см. Анализ сигнала

Спектральный анализ Спектроанализатор

Окно Спектроанализатор предназначено для спектрального анализа сигналов.
Далее см. Спектроанализатор

X-Y Plot X-Y Осциллограф

Окно X-Y Осциллограф предназначено для построения графиков зависимости амплитуды сигналов.
Далее см. X-Y Осциллограф

Histigram Гистограмма

Окно Гистограмма предназначено для построения гистограмм распределения сигнала по амплитуде.
Далее см. Гистограмма

Все инструменты анализа программы «PowerGraph» позволяют экспортировать результаты как в графическом, так и в текстовом формате.

Программа «PowerGraph» постоянно совершенствуется и дополняется. По вопросам обновления программы, а также с предложениями создания новых инструментов анализа, обращайтесь к разработчикам.


Таблица значений

В программе «PowerGraph» каждый блок данных содержит индивидуальную текстовую таблицу значений, которая используются для накопления и хранения следующих значений:

  • Параметры блока данных и области выделения.
  • Расчетные статистические, дифференциальные и интегральные характеристики сигналов.
  • Отдельные значения записанных сигналов.
  • Произвольные значения, введенные пользователем.
Содержимое всех таблиц значений может быть скопировано в буфер обмена (Clipboard) или сохранено в текстовый файл для последующей обработки и анализа в других программах.

DataPad Окно «Таблица значений»

Для работы с таблицами значений используется дополнительное окно Таблица значений:
  1. Выберите команду Таблица значений... (Data Pad) в меню Анализ основного окна программы.
  2. Нажмите в панели инструментов кнопку [image].

Список блоков

В левой части окна Таблица значений находится список всех записанных блоков текущего файла. При выборе любого элемента списка содержимое таблицы значений данного блока отображается в текстовом поле, расположенном в правой части окна.
Флажки, расположенные напротив каждого элемента списка, позволяют выбирать произвольный набор блоков для общих операций с таблицами значений.

Первый элемент списка блоков - Весь файл (Whole File) содержит общую таблицу значений всего файла, которая используется для хранения и вычисления значений нескольких блоков.

Таблицы значений

Таблица значений каждого блока представляет собой обычный текст объемом до 32 КБайт, состоящий из столбцов и строк. В качестве разделителя столбцов используется символ табуляции.
Для работы с таблицами значений используются стандартные операции редактирования, копирования и сохранения текста, а также специальные операции, позволяющие добавлять в таблицу расчетные значения и значения отдельных точек сигналов.

Редактирование таблиц значений

Для изменения содержимого таблиц значений используются стандартные операции редактирования текста с помощью клавиатуры и мыши. Сохранение внесенных в текст изменений происходит автоматически. Для удаления всего содержимого таблиц значений используются следующие кнопки панели инструментов и команды меню Файл:
Clear | Очистить (Clear) - очистить таблицу значений выбранного блока.
Clear All | Очистить все (Clear All) - очистить таблицы значений всех блоков, отмеченных в списке.

Экспорт таблиц значений

Окно Таблица значений позволяет экспортировать содержимое таблиц значений для последующей обработки и анализа в других программах.
Для сохранения содержимого таблиц значений в текстовый файл используются следующие кнопки панели инструментов и команды меню Файл:
Save | Сохранить... (Save) - сохранить в текстовый файл таблицу значений выбранного блока.
Save All | Сохранить все... (Save All) - сохранить в текстовый файл таблицы значений всех блоков, отмеченных в списке.
Для копирования содержимого таблиц значений в буфер обмена (Clipboard) используются следующие кнопки панели инструментов и команды меню Правка:
Copy | Копировать (Copy) - копировать таблицу значений выбранного блока.
Copy All | Копировать все (Copy All) - копировать таблицы значений всех блоков, отмеченных в списке.

Добавление отдельных значений сигналов

Программа «PowerGraph» позволяет добавлять в таблицу каждого блока отдельные значения всех видимых сигналов:
  1. В главном окне программы поместите курсор мыши над графиками в соответствующей точке оси X.
  2. Удерживая клавишу CTRL, нажмите левую кнопку мыши в этой точке.
Добавляемые в таблицу данные состоят из двух строк (строка заголовков и строка значений), каждая из которых содержит столбцы значений: первый столбец - значение оси X, остальные - значения каналов в выбранной точке. Если одновременно удерживать клавиши CTRL и SHIFT, то в таблицу будет помещена только строка значений (без строки заголовков).

Расчетные значения

Окно Таблица значений имеет собственную библиотеку функций, которые могут быть использованы для анализа данных и добавления результатов вычислений в таблицу значений каждого блока.
В правой верхней части окна располагаются три списка, которые используются для проведения вычислений:
  • Категория - список категорий функций.
  • Функция - список функций выбранной категории. Флажки, расположенные напротив каждого элемента списка, позволяют выбирать произвольный набор функций для проведения вычислений.
  • Источник данных - список каналов, содержащих данные для вычислений.
Для добавления в таблицу расчетных значений используются следующие кнопки панели инструментов и команды меню Функция:
Calculate | Вычислить (Calculate) - вычислить и добавить в таблицу значение одной функции, выбранной в списке.
Calculate All | Вычислить все (Calculate All) - вычислить и добавить в таблицу значения нескольких функций, отмеченных в списке.

Область вычислений

Окно Таблица значений позволяет выбрать набор данных для проведения вычислений - все данные блока или выделенный участок данных (блок должен содержать область выделения). Для выбора области вычислений используются следующие кнопки панели инструментов и команды меню Блок:
Whole Block | Весь блок (Whole Block) - для вычислений используются все данные блока.
Selection | Выделенная область (Selection) - для вычислений используется только выделенный участок данных.

Структура таблиц расчетных значений

При проведении вычислений в таблицу значений добавляется новый текст, состоящий из столбцов и строк, содержащих номер канала, номера блоков, названия функций, расчетные значения и единицы измерения. Структура добавляемых столбцов и строк зависит от количества функций и выбранной таблицы значений:

1. При вычислении одной функции в таблицу значений блока добавляется одна строка, содержащая следующие столбцы:
Номер канала - Функция Значение Единица измерения

2. При вычислении нескольких функций в таблицу значений блока добавляется две строки (строка заголовков и строка значений), содержащие отдельные столбцы для каждой функции:
 | Функция 1, Единица измерения | Функция 2, Единица измерения | ...
Номер канала | Значение 1 | Значение 2 | ...

3. При вычислении одной функции в таблицу значений всего файла добавляется строка заголовков и по одной строке значений для каждого блока:
Номер канала | Функция |
Блок 1 | Значение | Единица измерения
Блок 2 | Значение | Единица измерения
... | ... | ...

4. При вычислении нескольких функций в таблицу значений всего файла добавляется строка заголовков и по одной строке значений для каждого блока, содержащих отдельные столбцы для каждой функции:
Номер канала | Функция 1, Единица измерения | Функция 2, Единица измерения | ...
Блок 1 | Значение 1 | Значение 2 | ...
Блок 2 | Значение 1 | Значение 2 | ...
... | ... | ... | ...

Строка состояния

Строка состояния содержит следующую информацию:
Элемент | Показывает
Блок # | Номер выбранного блока.
Операция: .... | Вычисляемая функция.
## из ##### | Использованный и максимальный размеры таблицы значений выбранного блока.

Меню и панель инструментов

Файл |  |
Clear | Очистить | Очистить таблицу значений выбранного блока (Ctrl+N).
Clear All | Очистить все | Очистить таблицы значений всех блоков, отмеченных в списке.
Save... | Сохранить... | Сохранить в файл таблицу значений выбранного блока (Ctrl+S).
Save All... | Сохранить все... | Сохранить в файл таблицы значений всех блоков, отмеченных в списке.
 | Закрыть | Закрыть окно.
Правка |  |
Copy | Копировать | Копировать таблицу значений выбранного блока (Ctrl+C).
Copy All | Копировать все | Копировать таблицы значений всех блоков, отмеченных в списке.
Блок |  |
Whole Block | Весь блок | Использовать для вычислений все данные блока.
Selection | Выделенная область | Использовать для вычислений только выделенный участок данных.
Select All | Выбрать все | Выбрать (отметить) все блоки в списке (Ctrl+A).
Deselect All | Очистить выбор | Очистить выбор блоков в списке (Ctrl+D).
Invert All | Инвертировать выбор | Инвертировать выбор блоков в списке (Ctrl+I).
Функция |  |
Calculate | Вычислить | Вычислить выбранную функцию (F5).
Calculate All | Вычислить все | Вычислить все функции, отмеченные в списке (Ctrl+F5).
Select All | Выбрать все | Выбрать (отметить) все функции в списке (Ctrl+A).
Deselect All | Очистить выбор | Очистить выбор функций в списке (Ctrl+D).
Invert All | Инвертировать выбор | Инвертировать выбор функций в списке (Ctrl+I).
Помощь |  |
Help | Справка... | Вызвать справку окна Таблица значений.

Начало страницы

Расчетные функции

Категории расчетных функций окна Таблица значений:
  • Statistic - статистические функции.
  • Slope - дифференциальные функции.
  • Integral - интегральные функции.
  • Sum - функции расчета суммы.
  • Comments - статистические функции комментариев.
  • Block - параметры блока данных.
  • Selection - параметры области выделения.

Statistic (Статистические)

Функции расчета статистических значений. В качестве статистической выборки используются данные выбранного канала.

Number of Points
Количество значений - размер статистической выборки.

Maximum
Максимальное значение в выборке.

X at Maximum
Значение на оси X в точке с максимальным значением.

Minimum
Минимальное значение в выборке.

X at Minimum
Значение на оси X в точке с минимальным значением.

Max – Min
Разность максимального и минимального значений.

(Max + Min)/2
Среднее значение между максимальным и минимальным значениями.

1/3Max + 2/3Min
Сумма 1/3 максимального и 2/3 минимального значений выборки.

Mean
Среднее арифметическое значение выборки, рассчитанное по формуле:

Mean =
где N – количество элементов в выборке x.

Median
Значение медианы выборки. Медиана – это значение, которое разбивает выборку на две равные части. Половина наблюдений лежит ниже медианы, и половина наблюдений лежит выше медианы.

Mode
Значение моды выборки. Мода – это значение, наиболее часто встречающееся в выборке.

RMS
Среднее квадратическое значение выборки, рассчитанное по формуле:

RMS =
где N – количество элементов в выборке x.

Variance
Значение дисперсии (s 2) выборки, рассчитанное по формуле:

Variance =
где mean - среднее арифметическое, а N – количество элементов в выборке x.

Std Deviation
Значение стандартного отклонения (s x) - меры разброса или вариабельности (изменчивости) данных. Стандартное отклонение определяется как квадратный корень из дисперсии.

Std Error
Значение стандартной ошибки среднего (sm). Эта величина характеризует стандартное отклонение выборочного среднего, рассчитанное по выборке размера n из генеральной совокупности, и зависит от дисперсии генеральной совокупности (s2) и объема выборки (n):

где s2 - дисперсия, а n – количество элементов в выборке.

Slope (Наклон)

Функции расчета дифференциальных значений (наклона кривой).

Average Slope
Значение среднего наклона по всей кривой (угол наклона линейного тренда).

Maximum Slope
Значение максимального наклона кривой.

X at Maximum Slope
Значение на оси X в точке с максимальным наклоном.

Minimum Slope
Значение минимального наклона кривой.

X at Minimum Slope
Значение на оси X в точке с минимальным наклоном.

Integral (Интеграл)

Функции расчета интегральных значений (площади под кривой).

Integral
Значение интеграла как сумма всех значений, умноженная на временной интервал между значениями.

Integral from Minimum
Значение интеграла как сумма всех значений минус минимальное значение, умноженная на временной интервал между значениями.

Integral from Start
Значение интеграла как сумма всех значений минус первое значение, умноженная на временной интервал между значениями.

Positive Integral
Значение интеграла как сумма всех положительных значений, умноженная на временной интервал между значениями.

Negative Integral
Значение интеграла как сумма всех отрицательных значений, умноженная на временной интервал между значениями.

Sum (Сумма)

Функции расчета суммы значений.

Sum
Сумма всех значений.

Absolute Sum
Сумма абсолютных значений.

Positive Sum
Сумма положительных значений.

Negative Sum
Сумма отрицательных значений.

Comments (Комментарии)

Функции статистического анализа комментариев.
В качестве статистической выборки используются точки, в которых установлены комментарии. Функции этой категории позволяют вычислять статистические параметры амплитуды сигнала в точках комментариев, а также статистические параметры временных интервалов между комментариями.

Number of Comments
Количество комментариев в блоке или в области выделения.

Maximum
Максимальное значение сигнала в точках комментариев.

Minimum
Минимальное значение сигнала в точках комментариев.

Max – Min
Разность максимального и минимального значений сигнала в точках комментариев.

Mean
Среднее арифметическое значение сигнала в точках комментариев.

RMS
Среднее квадратическое значение сигнала в точках комментариев, рассчитанное по формуле:

RMS =

RMSSD
Среднее квадратическое значение разности значений сигнала в соседних точках комментариев, рассчитанное по формуле:

RMSSD =

Std Deviation
Стандартное отклонение сигнала в точках комментариев.

Std Error
Стандартная ошибка среднего значения сигнала в точках комментариев.

Maximum Interval
Максимальный интервал между комментариями.

Minimum Interval
Минимальный интервал между комментариями.

Interval Max - Min
Разность максимального и минимального интервалов между комментариями.

Interval Mean
Среднее значение интервалов между комментариями.

Interval RMS
Среднее квадратическое значение интервалов между комментариями, рассчитанное по формуле:

RMS =

Interval RMSSD
Среднее квадратическое значение разности соседних интервалов между комментариями, рассчитанное по формуле:

RMSSD =

Interval Std Deviation
Значение стандартного отклонения интервалов между комментариями.

Interval Std Deviation
Значение стандартной ошибки интервалов между комментариями.

Block (Блок)

Функции, предоставляющие информацию о параметрах выбранного блока.

Title
Заголовок блока.

ADC
Тип АЦП.

Start Date
Дата начала записи блока.

Start Time
Время начала записи блока.

Duration
Длительность блока.

Rate
Частота регистрации данных в блоке.

Interval
Временной интервал между значениями.

Size
Количество значений в блоке (размер блока).

Volume
Объем данных блока в байтах.

Selection (Область выделения)

Функции, предоставляющие информацию о параметрах области выделения выбранного блока (блок должен содержать выделенный участок данных).

X at Start
Значение первой точки области выделения на оси X.

X at End
Значение последней точки области выделения на оси X.

Duration
Длительность области выделения на оси X.

Start Index
Индекс первой точки области выделения.

End Index
Индекс последней точки области выделения.

Size
Количество значений в области выделения (размер области выделения).

Volume
Объем данных области выделения в байтах.

Начало страницы

См. также
Анализ данных


Анализ сигнала

Программа «PowerGraph» позволяет анализировать и редактировать отдельные участки и значения сигнала, а также проводить дополнительные графические построения и расчеты:

  • построение проекций на оси времени и амплитуды;
  • расчет угла наклона и построение касательной в точке;
  • поиск максимального, минимального и среднего значений с построением соответствующей проекции;
  • построение произвольной прямой, а также прямой, проходящей через две точки данных;
  • расчет и построением линейного тренда;
  • определение точек пересечения касательных и проекций.

Zoom View Окно «Анализ сигнала»

Анализ и редактирование сигналов осуществляется в дополнительном окне Анализ сигнала:
  1. Выберите команду Анализ сигнала... (Zoom View) в меню Анализ основного окна программы.
  2. Нажмите в панели инструментов кнопку Zoom View.

Графический дисплей окна Анализ сигнала аналогичен графическому дисплею главного окна программы, но содержит график только одного канала в одном блоке. Выбор канала осуществляется списке Ch, расположенном в верхней правой части окна.
Графический дисплей окна Анализ сигнала позволяет изменять масштаб шкалы X только в сторону увеличения (от 1:1 до 1:100). При увеличении масштаба шкалы X (начиная с 1:5) на графике отображаются маркеры отдельных значений сигнала.

Графические инструменты

Графические инструменты окна Анализ сигнала используются для проведения дополнительных графических построений, облегчающих визуальную обработку и анализ данных. Принцип работы графических инструментов заключается в построении на графике прямых линий, характеризующих те или иные параметры исходной кривой: уровень амплитуды сигнала, положение точки на оси времени, угол наклона кривой и др.
Все графические инструменты окна Анализ сигнала образуют две основные группы:
  • инструменты, работающие с отдельными значениями (точками) сигнала;
  • инструменты, анализирующие выделенный участок данных;

Выбор текущего инструмента осуществляется в меню Инструменты (Tools) или с помощью панели инструментов, расположенной у левой границы окна Анализ сигнала.

Анализ отдельных значений

Для использования инструментов, работающих с отдельными значениями сигнала, следует поместить курсор в графическом дисплее над требуемой точкой данных и нажать левую кнопку мыши. Для плавного перехода к соседним точкам следует перемещать курсор вдоль оси X, удерживая левую кнопку мыши. Точка, в которой установлен графический инструмент, называется - активной точкой.

Маркер в точке (Marker in Point)

Построение проекций на оси X и Y, проходящих через заданную точку сигнала.

Касательная в точке (Slope in Point)

Построение касательной, проходящей через заданную точку сигнала. Данный инструмент позволяет определить угол наклона касательной, который соответствует углу наклона прямой, проходящей через две соседние точки.

Редактирование точки (Editing of Point)

Изменение положения точки по оси Y (редактирование амплитуды сигнала). Перемещение курсора мыши при нажатой левой кнопке проводит к изменению положения точки по вертикали. Для продолжения редактирования выбранной точки (для предотвращения выбора другой точки) следует удерживать на клавиатуре клавишу Shift.

Анализ участка сигнала

Для использования инструментов, работающих с участком сигнала, следует выделить на графике область данных, перемещая курсор мыши вдоль оси X при нажатой левой кнопке. Первая точка выделенной области называется - начальной точкой участка, а последняя точка выделенной области - конечной точкой участка. Для изменения границ существующего выделенного участка следует нажать на клавиатуре клавиши Ctrl (изменение начальной точки) или Shift (изменение конечной точки).
Часть графических инструментов этой группы также имеют активную точку, которая может совпадать с одной из точек исследуемого участка или являться произвольной точкой, полученной в результате анализа данных.

Участок (Range)

Выделение участка сигнала с построением проекций на оси X и Y, проходящих через начальную и конечную точки участка.

Максимальное на участке (Maximum in Range)

Выделение участка сигнала с определением максимального значения и построением соответствующей проекции на ось Y.
Активная точка: совпадает с точкой выделенного участка, имеющей максимальное значение.

Среднее на участке (Mean in Range)

Выделение участка сигнала с вычислением среднего арифметического значения и построением соответствующей проекции на ось Y.
Активная точка: располагается в центре выделенного участка на уровне среднего арифметического значения.

Минимальное на участке (Minimum in Range)

Выделение участка сигнала с определением минимального значения и построением соответствующей проекции на ось Y.
Активная точка: совпадает с точкой выделенного участка, имеющей минимальное значение.

Линия (Line)

Построение прямой, проходящей через две точки на границах участка с произвольными значениями по оси Y. Для изменения положения точек по оси Y следует нажать на клавиатуре клавиши Ctrl (начальная точка) или Shift (конечная точка) и перемещать курсор мыши по вертикали при нажатой левой кнопке.

Соединительная линия (Connecting Line)

Выделение участка сигнала с построением прямой, проходящей через начальную и конечную точки участка.

Линейный тренд (Linear Trend)

Выделение участка сигнала с построением линейного тренда сигнала (линейная интерполяция данных). Позволяет определить среднее арифметическое значения выделенного участка и угол наклона линейного тренда.
Активная точка: располагается на линии тренда в центре выделенного участка на уровне среднего арифметического значения.

Касательные в точках (Slope And Slope)

Выделение участка сигнала с построением касательных, проходящих через начальную и конечную точки участка.
Активная точка: является точкой пересечения касательных.

Максимальное и Касательная (Maximum And Slope)

Выделение участка сигнала с определением максимального значения и построением касательной, проходящей через конечную точку участка.
Активная точка: является точкой пересечения касательной и проекции максимального значения на ось Y.

Минимальное и Касательная (Minimum And Slope)

Выделение участка сигнала с определением минимального значения и построением касательной, проходящей через конечную точку участка.
Активная точка: является точкой пересечения касательной и проекции минимального значения на ось Y.

На следующем рисунке представлено несколько простых примеров графических инструментов ("Касательная в точке", "Минимальное на участке", "Соединительная линия", "Максимальное и Касательная"):

Использование графических инструментов

Кроме графических построений окно Анализ сигнала позволяет использовать инструменты анализа для следующих операций:
  • определение характеристик сигнала в виде численных значений;
  • выделение участка данных в основном окне программы;
  • графическое редактирование данных - изменение сигналов в соответствии с графическими построениями.

Численные значения

В нижней части окна Анализ сигнала под графическим дисплеем располагается текстовая таблица, которая содержит численные значения параметров используемого инструмента. Формат таблицы численных значений зависит от выбранного инструмента, но имеет общую структуру:
1-й столбец - заголовки строк;
2-й столбец - значение по оси X;
3-й столбец - значение по оси Y;
4-й столбец - угол наклона dY/dX.
Первая строка содержит заголовки столбцов, содержимое остальных строк определяется типом выбранного инструмента:
Start - значения начальной точки выделенного участка;
End - значения конечной точки выделенного участка;
Point - значения активной точки инструмента;
Max - значения точки с максимальным значением;
Min - значения точки с минимальным значением;
Slope - параметры касательной, проходящей через точку.
Первая ячейка (1-й столбец 1-й строки) содержит идентификатор данных в формате - B[номер блока]Ch[номер канала].
Дополнительные кнопки, расположенные слева от таблицы численных значений, позволяют копировать полученные значения для дальнейшего использования:
→ копировать значения в буфер обмена
→ копировать значения в таблицу значений блока (см. раздел Таблица значений)
При выделении части таблицы (например одно значение или одна строка) будет копироваться только выделенный фрагмент. Также для копирования отдельных значений можно использовать клавиатуру и контекстное меню.

Выделение участка данных

Графические инструменты окна Анализ сигнала можно использовать для выделения участка данных в основном окне программы. Возможность увеличения масштаба данных по оси X и просмотра отдельных значений позволяет точно позиционировать границы области выделения внутри блока.
Для выделения части блока могут быть использованы координаты активной точки инструмента, а также начальной и конечной точек выделенного участка. Соответствующие кнопки расположены в панели инструментов над графическим дисплеем:
→ выделить область от начала блока до активной точки инструмента
→ выделить область соответствующую текущему участку сигнала
→ выделить область от активной точки инструмента до конца блока

Графическое редактирование данных

Кроме изменения значений отдельных точек (инструмент "Редактирование точки") окно Анализ сигнала предоставляет возможность изменения сигналов в соответствии с параметрами и графическими построениями выбранного инструмента. Этот процесс графического редактирования данных включает следующие операции:
  • Применение инструмента - значение каждой точки сигнала изменяется таким образом, чтобы точка оказалась на прямой, построенной с помощью графического инструмента. Для комплексных инструментов, позволяющих определить точку пересечения двух прямых, используются обе прямые - одна до точки пересечения, а другая после (точка пересечения должна находиться в выделенном участке).
    После применения инструмента данные изменяются, поэтому параметры инструмента пересчитываются и положение расчетных прямых может измениться.
    Пример использования: устранение шумов и случайных значений на линейных участках сигнала.
  • Смещение данных - из каждого значения вычитается величина, равная значению активной точки инструмента. После смещения данных значение активной точки становится равным нулю.
    Пример использования: удаление постоянной составляющей и калибровка 0 по выделенному участку сигнала.
  • Вращение данных - данные поворачиваются вокруг активной точки инструмента на угол, соответствующий углу наклона прямой, проходящей через эту точку.
    Пример использования: удаление линейного тренда данных.
Графическое редактирование может быть использовано для следующих наборов данных:
  • Выделенный участок - изменяются данные, входящие в выделенный участок между начальной и конечной точками.
  • Все данные канала - изменяются все данные канала.
Для выполнения операций графического редактирования используются следующие кнопки панели инструментов и команды меню Правка:
Применить инструмент | - изменить данные выделенного участка в соответствии с текущими графическими построениями.
Сместить участок | - сместить данные выделенного участка на значение активной точки.
Повернуть участок | - повернуть данные выделенного участка относительно активной точки.
Сместить канал | - сместить все данные канала на значение активной точки.
Повернуть канал | - повернуть все данные канала относительно активной точки.

Восстановление данных и сохранение изменений

В процессе графического редактирования программа запоминает несколько последних операций и позволяет отменить внесенные изменения с помощью команды Отменить (Undo) в меню Правка. Команда Повторить (Redo) в меню Правка позволяет вернуть отмененные изменения.

Изменения, осуществляемые в процессе графического редактирования, запоминаются локально в окне Анализ сигнала и не отражаются на данных канала. Это позволяет полностью отказаться от всех изменений и в случае необходимости вернуться к редактированию неизмененных данных канала. Команда Восстановить канал (Reload Channel) в меню Файл позволяет загрузить оригинальные данные канала без сохранения внесенных изменений.

Для сохранения внесенных изменений в основной набор данных канала (отображаемый в главном окне программы) следует использовать команду Сохранить канал (Save Channel) в меню Файл. При сохранении измененные данные копируются в расчетные данные текущего канала и могут быть использованы для дальнейшей обработки и анализа.
Команда Сохранить все каналы (Save All Channels) в меню Файл сохраняет все изменения во всех каналах. При закрытии окно Анализ сигнала автоматически предлагает сохранить измененные данные, нажмите кнопку Нет если Вы хотите отказаться от всех изменений или кнопку Да если изменения необходимо сохранить.

Строка состояния

Строка состояния содержит контекстную информацию о текущем состоянии окна:
Элемент | Показывает
Ch# | Текущий канал.
N: ### | Порядковый номер точки под курсором.
X: #,## | Значение X точки под курсором.
Y: #,## | Значение Y точки под курсором.
... | Используемый инструмент.
S: ### | Размер блока (общее количество точек).
T: #,## s | Длительность блока в единицах времени.
Fs: ##,# Hz | Частота регистрации данных (Гц).

Меню и панели инструментов

Файл |  |
 | Восстановить канал | Восстановить данные канала - удаление изменений (Ctrl+N).
 | Сохранить канал | Сохранить изменения текущего канала (Ctrl+S).
 | Сохранить все каналы | Сохранить изменения всех каналов.
 | Закрыть | Закрыть окно.
Правка |  |
Undo | Отменить | Отменить последние изменения (Ctrl+Z).
Redo | Повторить | Повторить отмененную операцию (Ctrl+R).
Copy Image | Копировать изображение | Копировать изображение в буфер обмена.
 | Скрыть инструмент(ы) | Скрыть графические построения текущего инструмента.
 | Очистить отмены | Очистить список отмен.
 | Выделение от начала | Выделить участок данных от начала блока до активной точки инструмента.
 | Выделить участок | Выделить участок данных текущего блока, соответствующий участку инструмента.
 | Выделение до конца | Выделить участок данных от активной точки инструмента до конца блока.
 | Применить инструмент(ы) | Изменить участок данных в соответствии с графическими построениями текущего инструмента.
 | Сместить участок | Сместить участок данных на величину амплитуды активной точки текущего инструмента (вычитание значения расчетной точки).
 | Повернуть участок | Повернуть участок данных относительно активной точки текущего инструмента на угол соответствующий углу наклона расчетной линии.
 | Сместить канал | Сместить все данные канала на величину амплитуды активной точки текущего инструмента (вычитание значения расчетной точки).
 | Повернуть канал | Повернуть все данные канала относительно активной точки текущего инструмента на угол соответствующий углу наклона расчетной линии.
Вид |  |
X Zoom | Масштаб шкалы X | Выбрать масштаб шкалы X.
X Zoom Out | Уменьшить | Уменьшить масштаб шкалы X (Shift+[-]).
X Zoom In | Увеличить | Увеличить масштаб шкалы X (Shift+[+]).
 | В начало | Переход к началу блока(Home).
 | Предыдущая страница | Показать предыдущую страницу (PgUp).
 | Следующая страница | Показать следующую страницу (PgDn).
 | В конец | Переход к концу блока (End).
График |  |
 | Шкала Y | Выбрать масштаб шкалы Y.
Y Zoom Out | Уменьшить | Уменьшить масштаб шкалы Y (Ctrl+[-]).
Y Zoom In | Увеличить | Увеличить масштаб шкалы Y (Ctrl+[+]).
Set Bipolar | Биполярное положение | Установить биполярное положение шкалы Y (Ctrl+B).
Find Data | Показать данные | Найти данные (Ctrl+F).
Инструменты |  |
 | Маркер в точке | Построение проекций на оси X и Y, проходящих через заданную точку.
 | Касательная в точке | Построение касательной, проходящей через заданную точку (определение угла наклона касательной).
 | Редактирование точки | Изменение положения точки по оси Y (редактирование амплитуды сигнала).
 | Участок | Выделение участка сигнала с построением проекций, проходящих через крайние точки.
 | Максимальное на участке | Выделение участка сигнала с определением точки, имеющей максимальное значение.
 | Среднее на участке | Выделение участка сигнала с определением среднего арифметического значения данных внутри участка.
 | Минимальное на участке | Выделение участка сигнала с определением точки, имеющей минимальное значение.
 | Линия | Построение произвольной прямой.
 | Соединительная линия | Построение прямой, проходящей через две точки сигнала.
 | Линейный тренд | Выделение участка сигнала с построением линейного тренда данных (определение среднего арифметического значения участка данных и угла наклона линейного тренда).
 | Касательные в точках | Выделение участка сигнала с построением касательных, проходящих через крайние точки (определение точки пересечения касательных).
 | Максимальное и Касательная | Выделение участка сигнала с определением максимального значения и построением касательной в крайней точке (определение точки пересечения касательной и максимального уровня сигнала).
 | Минимальное и Касательная | Выделение участка сигнала с определением минимального значения и построением касательной в крайней точке (определение точки пересечения касательной и минимального уровня сигнала).
Помощь |  |
Help | Справка... | Вызвать справку окна Анализ сигнала.

Начало страницы

См. также
Анализ данных


Спектральный анализ

Программа «PowerGraph» позволяет проводить спектральный анализ сигналов, а также осуществлять регистрацию данных с построением спектров в режиме реального времени.

Spectrum Окно «Спектроанализатор»

Спектральный анализ сигналов осуществляется в дополнительном окне Спектроанализатор:
  1. Выберите команду Спектроанализатор... (Spectrum) в меню Анализ основного окна программы.
  2. Нажмите в панели инструментов кнопку Spectrum.

Окно Спектроанализатора состоит из следующих функциональных частей:

  1. Меню и панели инструментов - обеспечивают доступ ко всем командам окна.
  2. Осциллографический дисплей - содержит графики исходных сигналов и позволяет выделять участки данных для анализа.
  3. Спектральный дисплей - содержит расчетные спектральные графики.
  4. Таблица расчетных значений - содержит статистические значения каналов.
  5. Параметры спектрального анализа - выбор типа и размера спектра, весовой функции и усреднения спектральных окон.
  6. Список каналов и список блоков - выбор каналов и блоков для анализа.
  7. Кнопки записи - управление регистрацией данных.
  8. Строка состояния - содержит вспомогательную информацию.

Спектральный анализ сигналов

Для спектрального анализа в программе «PowerGraph» используется алгоритм Быстрого Преобразования Фурье (рус.- БПФ, англ. - FFT).
Спектроанализатор позволяет строить различные типы спектральных графиков, проводить дополнительные статистические вычисления в заданных частотных полосах, а также использовать различные настройки спектрального анализа:
  • выбор размера БПФ (размера спектрального окна);
  • выбор весовой функции;
  • усреднение спектральных окон с различными способами перекрытия;
  • дополнительные расчеты с использованием частотных значений.
Спектроанализатор позволяет одновременно рассчитывать спектры любого количества каналов одного из записанных блоков данных, а также регистрировать новые данные с построением спектров в режиме реального времени. Выбор каналов для анализа осуществляется в списке каналов Каналы (Channels), а выбор блока данных - в списке блоков Блоки (Blocks). Элемент <Новый блок> в списке блоков обозначает запись нового блока.

Осциллографический дисплей

Осциллографический дисплей содержит осциллограммы сигналов (амплитудно-временное представление) и позволяет просматривать исходные данные каналов, подвергающиеся спектральному анализу. Включение и выключение осциллографического дисплея осуществляется командой Сигнал (Signal) в меню Вид.

Область выделения

Осциллографический дисплей позволяет выделять произвольный участок сигнала для ограничения размера анализируемых данных. Выделение участка сигнала осуществляется перемещением курсора над осциллографическим дисплеем при нажатой левой кнопке мыши. Для изменения границы существующей области выделения следует дополнительное удерживать на клавиатуре клавишу SHIFT. Изменение положения существующей области выделения осуществляется следующими сочетаниями клавиш:
SHIFT+[←/→] | - перемещение области выделения назад/вперед;
SHIFT+PAGE UP | - перемещение области выделения назад на размер области выделения;
SHIFT+PAGE DOWN | - перемещение области выделения вперед на размер области выделения;
SHIFT+HOME | - перемещение области выделения в начало блока;
SHIFT+END | - перемещение области выделения в конец блока.

Команды меню Спектр позволяют выбрать дополнительные режимы анализа - все данные блока или данные области выделения:
Весь блок (Whole Block) - анализ всех данных блока.
Выделенная область (Selection) - анализ данных только в области выделения.

Спектральный дисплей

Спектральный дисплей содержит амплитудно-частотное представление сигналов, полученное в результате БПФ, и имеет несколько режимов визуализации:
Спектр (Spectrum) - только спектр.
Спектр и Максимум (Spectrum And Maximum) - спектр и маркеры максимальных значений.
Спектр и Полосы (Spectrum And Bands) - спектр и уровни в частотных полосах.
Полосы (Bands) - только уровни в частотных полосах.

Регистрация данных

Спектроанализатор позволяет осуществлять регистрацию данных с построением спектральных графиков в режиме реального времени. Кнопка Старт, расположенная под списком блоков, запускает и останавливает процесс регистрации новых данных.

Режимы регистрации

Кнопка-переключатель, расположенная в правой нижней части окна Спектроанализатора позволяет использовать два режима регистрации данных:
Режим мониторинга (верхнее положение) - построение спектров без сохранения данных. Спектроанализатор временно сохраняет только последний участок данных необходимый для БПФ, предыдущие данные удаляются.
Режим записи блока (нижнее положение) - построение спектров с непрерывной записью данных в новый блок.

Параметры спектрального анализа

В правой верхней части окна Спектроанализатора расположены 4 раскрывающихся списка с различными параметрами спектрального анализа:
  • Тип спектра (Spectrum Type):
    1. Amplitude - спектр амплитуды: A = Sqrt(Re*Re + Im*Im).
    2. Power - спектр мощности: P = Re*Re + Im*Im.
    3. Log of Power, dB - логарифм спектра мощности в децибелах: dB =10*Log10(P).
    4. Attenuation, dB - нормализованный спектр усиления в децибелах: dB = 20*Log10(A/Aref).
    5. Abs Re - абсолютное значение реальной составляющей БПФ: Abs(Re).
    6. Abs Im - абсолютное значение мнимой составляющей БПФ: Abs(Im).
    7. Re - реальная составляющая БПФ: Re.
    8. Im - мнимая составляющая БПФ: Im.
    9. Phase ±1, Pi - фазово-частотный спектр в диапазоне от -p до +p: φ = Atan(Im/Re).
    10. Phase, Pi - неразрывный фазово-частотный спектр.
  • Размер БПФ (FFT Size) - количество значений, используемых при БПФ (размер спектрального окна). Этот список содержит значения равные 2 в степени N (это требование налагается алгоритмом БПФ) в диапазоне от 128 (N=7) до 1048576 (N=20).
    Регистрация данных в режиме спектроанализатора возможна только при размере БПФ равном или меньшем 16384 (N=14).
  • Весовая функция (Window) - тип весовой (оконной) функции, используемой при БПФ. Команда Весовая функция... (Data Tapering Window) в меню Спектр (Spectrum) предоставляет дополнительный способ выбора весовой функции с возможностью визуализации и сравнения.
    Подробнее см. - Приложение В. Весовые (оконные) функции.
  • Усреднение (Averaging) - режим усреднения спектральных окон:
    1. Нет (None) - без усреднения. Анализируется только начальный участок сигнала, соответствующий размеру БПФ.
    2. 0% Перекрытие (No Overlap) - усреднение без перекрытия спектральных окон.
    3. 25% Перекрытие (25% Overlap) - усреднение с перекрытием в 25%.
    4. 50% Перекрытие (50% Overlap) - усреднение с перекрытием в 50%.
    5. 75% Перекрытие (75% Overlap) - усреднение с перекрытием в 75%.
    6. Авто Перекрытие (Auto Overlap) - усреднение с автоматическим выбором размера области перекрытия. Область перекрытия соответствует минимальному количеству спектральных окон равномерно распределенных по всему сигналу.

Общие настройки Дополнительные параметры спектра (Spectrum Options)

Команда Параметры спектра... в меню Спектр позволяет открыть диалоговое окно с дополнительными настройками спектрального анализа:

  • Дополнительные вычисления (Additional Calculation) - дополнительные математические расчеты с использованием частотных значений спектрального анализа:
    1. Спектр - частотные значения не используются.
    2. Спектр*dF - умножение каждого значения спектра на шаг по частоте. Шаг по частоте (dF) - разница частот между двумя соседними точками спектра.
    3. Спектр/dF - деление каждого значения спектра на шаг по частоте (плотность спектра).
    4. Спектр/F - деление каждого значения спектра на значение частоты в данной точке.
    5. Спектр/F^2 - деление каждого значения спектра на квадрат частоты в данной точке.
    Дополнительные поля позволяют использовать линейную калибровку спектра:
    Умножить на (Scale Data) - линейный коэффициент масштабирования спектра (умножение на число).

    Ед. измерения (Custom Units) - пользовательские единицы измерения спектра.
  • Уровень нормализации (Attenuation Reference) - уровень амплитуды (Aref), используемый для нормализации спектра усиления в децибелах (см. выбор типа спектра - Attenuation, dB):
    1. Max - максимальное значение спектра.
    2. Другой (Level) - заданное значение амплитуды.
  • Регистрация (Recording) - дополнительные настройки, используемые при регистрации данных:
    Усреднение (Averaging) - количество спектральных окон, усредняемых при регистрации данных.

    МногоПоточность (MultiThreading) - использование режима многопоточности. Режим многопоточности позволяет увеличить производительность при регистрации данных за счет использования механизма параллельных вычислений.

Частотные полосы Частотные полосы (Bands Options)

Команда Частотные полосы... в меню Спектр вызывает дополнительное диалоговое окно с настройками расчетов в частотных полосах:

В программе используются несколько вариантов определения частотных полос:

  • Октавы (Octaves) - границы частотных полос соответствуют границам музыкальных октав.
  • 1/3 Октавы (1/3 Octaves) - границы частотных полос соответствуют третьоктавным границам.
  • Шаг (Step) - границы частотных полос расположены через равные интервалы. Например, при значении шага 100 (Гц) границы частотных полос будут равны: 100, 200, 300, 400, ... Гц.
  • Гармоники (Harmonics) - границы частотных полос расположены через равные интервалы со смещением, равным половине шага. Например, при значении шага 100 (Гц) границы частотных полос будут равны: 50, 150, 250, 350, ... Гц.
  • Другие (Custom) - позволяет задавать произвольные границы частотных полос. Для определения новой границы необходимо ввести в поле ввода новое значение и нажать кнопку Добавить (Add), при этом новая граница появится в списке частот. Кнопка Удалить (Remove) позволяет удалить выбранное значение из этого списка. Кнопка Очистить (Clear) позволяет полностью очистить список пользовательских частотных полос.
    Новые границы частотных полос можно вводить в произвольном порядке, так как программа автоматически сортирует эти значения в порядке возрастания.
Группа переключателей Вычислить (Calculate) позволяет выбрать статистический параметр, который будет рассчитываться для каждой частотной полосы:
  • Maximum - максимальное значение.
  • Minimum - минимальное значение.
  • Mean - среднее арифметическое значение.
  • 10Lg(Mean) - значение, рассчитанное по формуле среднего уровня звукового давления:
  • 10Lg(Sum) - значение, рассчитанное по формуле суммарного уровня звукового давления:

Весовая функция Весовая функция (Data Tapering Window)

Команда Весовая функция... в меню Спектр вызывает дополнительное диалоговое окно, предоставляющее возможность визуализации, сравнения и выбора весовой функции:

Верхний график окна содержит представление весовой функции во временной области, а нижний - в частотной.
Дополнительный список Функция сравнения (Compare Window) позволяет выбрать весовую функцию для сравнения с текущей.

Экспорт результатов спектрального анализа

Спектроанализатор позволяет сохранять и экспортировать результаты спектральных вычислений для последующей обработки и анализа.

Создание блока данных

Команда Конвертировать спектр в Блок (Convert Spectrum to Block) в меню Файл создает в текущем файле новый блок данных, содержащий значения спектра для каждого канала. В отличие от блоков данных записанных с АЦП, шкала X создаваемого блока содержит значения частоты, а не времени. Таким образом, конвертирование спектра в отдельный блок позволяет хранить в одном файле как амплитудно-временное представление сигналов, так и амплитудно-частотное.

Экспорт спектра

Для экспорта значений спектра используются следующие команды:
Сохранить спектр в файл | Сохранить спектр... (Save Spectrum) в меню Файл - сохранить значения спектра в текстовый файл.
Копировать значения спектра | Копировать спектр (Copy Spectrum Data) в меню Правка - копировать значения спектра в буфер обмена (Clipbord).
Значения спектра экспортируются в текстовом формате в виде таблицы состоящей из следующих столбцов:
  • F, Hz - значения частоты в Герцах (Hz).
  • Канал N - значения спектра (для каждого канала создается отдельный столбец).

Экспорт частотных полос

Для экспорта значений частотных полос используются следующие команды:
Сохранить значения частотных полос в файл | Сохранить полосы... (Save Bands Data...) в меню Файл - сохранить значения частотных полос в текстовый файл.
Копировать значения частотных полос | Копировать полосы (Copy Bands Data) в меню Правка - копировать значения частотных полос в буфер обмена (Clipbord).
Значения частотных полос экспортируются в текстовом формате в виде таблицы состоящей из следующих столбцов:
  • F1, Hz - начальная граница частотной полосы в Герцах (Hz).
  • F2, Hz - конечная граница частотной полосы в Герцах (Hz).
  • Fb, Hz - центральная частота полосы в Герцах (Hz).
  • Канал N - значение в частотной полосе (для каждого канала создается отдельный столбец).

Экспорт отдельных значений спектра

Спектроанализатор позволяет копировать отдельные значения спектра в таблицу значений блока (DataPad). Для копирования отдельных значений спектра следует удерживая клавишу CTRL нажать левую кнопку мыши на спектральном дисплее в заданное точке шкалы частот. При этом в таблицу значений блока будут добавлены две строки - строка заголовков и строка значений, состоящие из следующих столбцов:
  • F, Hz - значение частоты в Герцах (Hz).
  • Канал N - значение спектра на этой частоте (для каждого канала создается отдельный столбец).
Если при нажатии левой кнопки мыши одновременно удерживать клавиши CTRL и ALT, то в таблицу значений блока будет добавлена только строка значений без строки заголовков.
Таблица значений блока позволяет накопить значения спектра на нескольких выбранных частотах для последующего сохранения в файл или копирования в другие программы.

Таблица расчетных значений

Таблица, расположенная в нижней части окна спектроанализатора, отображает значения, полученные в результате вычисления спектров, и состоит из следующих столбцов:
Столбец | Показывает
Ch | Номер канала.
DC | Постоянная составляющая сигнала.
Max | Максимальное значение спектра (кроме DC).
Fmax | Частота соответствующая максимальному значению спектра.
##,# Hz | Значение спектра в точке под курсором. Заголовок столбца - частота в точке под курсором.

Копирование расчетных значений

Для копирования расчетных значений используются следующие команды в меню Правка:
Копировать расчетные значения | Копировать значения (Copy Table to Clipboard) - копировать расчетные значения в буфер обмена (Clipboard).
Копировать таблицу в DataPad | Добавить значения в таблицу (Copy Table to DataPad) - добавить расчетные значения в таблицу значений блока (DataPad).

Строка состояния

Строка состояния содержит контекстную информацию о текущем состоянии спектроанализатора:
Элемент | Показывает
#‡ | Масштаб шкалы Y активного дисплея.
dF: ##,# Hz | Шаг спектра по частоте (Гц).
F: ##,# Hz | Значение частоты в точке под курсором (Гц).
Y: #,## | Значение амплитуды в точке под курсором.
S: ###/### | Размер данных: размер анализируемого участка сигнала/размер блока.
W:##/##/## | Параметры спектрального окна: количество усредненных окон/размер окна/размер области перекрытия.
T: #,## | Время, соответствующее размеру БПФ.
Fs: ##,# Hz | Частота регистрации данных (Гц).

Меню и панели инструментов

Файл |  |
Сохранить спектр в файл | Сохранить спектр... | Сохранить спектр в файл (Ctrl+S).
Сохранить значения частотных полос в файл | Сохранить полосы... | Сохранить значения частотных полос в файл.
 | Конвертировать спектр в Блок | Конвертировать спектр в блок данных.
 | Закрыть | Закрыть окно.
Правка |  |
Копировать значения спектра | Копировать спектр | Копировать значения спектра в буфер обмена (Ctrl+C).
Копировать значения частотных полос | Копировать полосы | Копировать значения частотных полос в буфер обмена.
 | Копировать изображение | Копировать изображение спектра в буфер обмена.
Копировать расчетные значения | Копировать значения | Копировать расчетные значения в буфер обмена.
Копировать таблицу в DataPad | Добавить значения в таблицу | Добавить расчетные значения в таблицу значений (DataPad).
Вид |  |
Signal | Сигнал | Скрыть/показать осциллографический дисплей.
X Zoom | Масштаб шкалы X | Выбрать масштаб шкалы X активного дисплея.
X Zoom Out | Уменьшить | Уменьшить масштаб шкалы X активного дисплея (Shift+[-]).
X Zoom In | Увеличить | Увеличить масштаб шкалы X активного дисплея (Shift+[+]).
 | В начало | Переход к началу спектра (Home).
 | Предыдущая страница | Показать предыдущую страницу (PgUp).
 | Следующая страница | Показать следующую страницу (PgDn).
 | В конец | Переход к концу спектра (End).
График |  |
 | Шкала Y | Выбрать масштаб шкалы Y.
Y Zoom Out | Уменьшить | Уменьшить масштаб шкалы Y (Ctrl+[-]).
Y Zoom In | Увеличить | Увеличить масштаб шкалы Y (Ctrl+[+]).
Set Bipolar | Биполярное положение | Установить биполярное положение шкалы Y (Ctrl+B).
Find Data | Показать данные | Найти данные (Ctrl+F).
Спектр |  |
 | Весь блок | Анализ данных всего блока.
 | Выделенная область | Анализ данных области выделения.
 | Спектр | Визуализация: только спектр.
 | Спектр и Максимум | Визуализация: спектр и маркеры максимальных значений.
 | Спектр и Полосы | Визуализация: спектр и частотные полосы.
 | Полосы | Визуализация: только частотные полосы.
 | Параметры спектра... | Дополнительные настройки спектрального анализа.
 | Частотные полосы... | Настройки частотных полос.
 | Весовая функция... | Выбор весовой функции с визуализацией.
Помощь |  |
Help | Справка... | Вызвать справку окна Спектроанализатор.

Начало страницы

См. также
Анализ данных


X-Y Осциллограф

Построение зависимостей

Программа «PowerGraph» позволяет отображать графики зависимости одного сигнала от другого, а также осуществлять построение графиков зависимости в процессе регистрации данных.

X-Y Scope Окно «X-Y Осциллограф»

Построение графиков межсигнальных зависимости осуществляется в дополнительном окне X-Y Осциллограф:
  1. Выберите команду X-Y Осциллограф... (X-Y Scope) в меню Анализ основного окна программы.
  2. Нажмите в панели инструментов кнопку X-Y Scope.

Графический дисплей окна X-Y Осциллограф представляет собой двухкоординатный самописец. В качестве X координат графиков могут быть использованы сигналы от 1 до 4 каналов - X1-X4. Список Y Каналы позволяет выбрать каналы для построения графиков зависимости от соответствующего канала X.

Выбор блока данных

Список Блок (Block) позволяет выбрать блок данных для построения графиков зависимости каналов.

Изменение начальной позиции и размера графиков

Графический дисплей окна X-Y Осциллограф содержит графики зависимости для произвольного участка данных внутри блока.
Расположенный под шкалой X горизонтальный регулятор, позволяет указать начальную позицию графиков зависимости на шкале времени.
Поле Размер (Size), расположенное слева от регулятора позиции, позволяет ввести или выбрать размер графиков в количестве значений. Регулятор позиции содержит выделенную область, относительный размер которой соответствует размеру графиков. Регулятор позиции также позволяет изменить размер графиков зависимости с помощью правой кнопки мыши. Максимальный размер графиков зависимости составляет 20000 значений. Последнее значение каждого графика обозначается круглым маркером.

Регистрация графиков зависимости

Окно X-Y Осциллограф позволяет строить графики зависимости в режиме реального времени. Кнопка Старт (Start), расположенная под списком блоков, запускает и останавливает процесс построения графиков в режиме реального времени.
Кнопка-переключатель, расположенная справа от кнопки Старт, позволяет дополнительно использовать два режима:
Мониторинг - построение графиков без сохранения данных.
Регистрация - построение графиков с записью данных в новый блок.

Изменение масштабов и положения графиков

Графический дисплей окна X-Y Осциллограф содержит общую координатную плоскость для всех выбранных X-Y зависимостей. При этом все графики имеют общее положение 0, но для каждого набора зависимостей X1-X4 может быть использован индивидуальный масштаб графиков по X и Y. На каждой шкале отображаются значения только одного выбранного набора зависимостей X#, который обозначается фокусной рамкой на соответствующей управляющей кнопке. Переключение между индивидуальными масштабами осуществляется командами X1-X4 в меню График X (для шкалы X) и Y1-Y2 в меню График Y (для шкалы Y).
Окно X-Y Осциллограф также позволяет использовать единые масштабы графиков для всех наборов зависимостей X1-X4. Включение единого масштаба осуществляется командами Общий X в меню График X (для шкалы X) и Общий Y в меню График Y (для шкалы Y).

Для изменения масштабов графиков используются следующие кнопки панелей инструментов и сочетания клавиш:
CTRL+[-/+] | уменьшить/увеличить масштаб шкалы Y
SHIFT+[-/+] | уменьшить/увеличить масштаб шкалы X
Изменить положение графиков можно с помощью мыши, перемещая шкалу X, шкалу Y и графический дисплей при нажатой левой кнопке.
Для изменения положения графиков также используются следующие кнопки панелей инструментов и сочетания клавиш:
CTRL+Y | установить биполярное положение шкалы Y
CTRL+X | установить биполярное положение шкалы X
CTRL+B | установить биполярное положение шкалы Y и шкалы X
↑/↓ | перемещение графиков вверх/вниз на основное деление шкалы Y
CTRL+[↑/↓] | перемещение графиков вверх/вниз на промежуточное деление шкалы Y
CTRL+ALT+[↑/↓] | перемещение графиков вверх/вниз на 1 пиксель
←/→ | перемещение графиков влево/вправо на основное деление шкалы X
CTRL+[←/→] | перемещение графиков влево/вправо на промежуточное деление шкалы X
CTRL+ALT+[←/→] | перемещение графиков влево/вправо на 1 пиксель
Дополнительные команды позволяют автоматически установить масштабы и положения графиков, при которых все графические данные максимально и полностью отображаются на графическом дисплее:
Find Data CTRL+F показать данные

Использование фонового изображения

Окно X-Y Осциллограф позволяет отображать на графическом дисплее дополнительное фоновое изображение, которое может использоваться для сравнения с текущими графиками. Фоновое изображение загружается из графического файла (bmp, jpg или gif) командой Загрузить фон... в меню Правка. Удаление фонового изображения осуществляется командой Очистить фон в меню Правка.
При загрузке фоновое изображение центрируется относительно нулевого значения шкал X и Y и в дальнейшем автоматически перемещается по графическому дисплею вместе с координатной сеткой. Изменение положения фонового изображения относительно нулевого значения шкал осуществляется командой Переместить фон в меню Правка, при этом в графическом дисплее включается однократный режим смещения фонового изображения с помощь левой кнопки мыши.
Имя файла и положение фонового изображения автоматически запоминаются между вызовами окна X-Y Осциллограф.

Строка состояния

Строка состояния, расположенная в нижней части окна X-Y Осциллограф, содержит следующую информацию:
Элемент | Показывает
Блок # | Номер текущего блока данных.
Точки: ## из ### | Индексы точек.
От: #,## s | Начальное время участка данных.
До: #,## s | Конечное время участка данных.
#,## s | Длительность участка данных.
##,# Hz | Частота регистрации данных (Гц).

Меню и панели инструментов

Файл |  |
Save As... | Сохранить как... | Сохранить данные или изображение в файл (Ctrl+S).
Печать | Печать | Печатать изображение.
 | Закрыть | Закрыть окно.
Правка |  |
Copy Data | Копировать данные | Копировать данные в буфер обмена (Ctrl+С).
Copy Image | Копировать изображение | Копировать изображение в буфер обмена.
 | Загрузить фон... | Загрузить фоновое изображение.
 | Очистить фон | Очистить фоновое изображение.
 | Переместить фон | Переместить фоновое изображение.
График X |  |
 | Шкала X | Выбрать масштаб шкалы X.
Zoom Out | Уменьшить | Уменьшить масштаб шкалы X (Shift+[-]).
Zoom In | Увеличить | Увеличить масштаб шкалы X (Shift+[+]).
Set Bipolar | Биполярное положение | Установить биполярное положение шкалы X (Ctrl+X).
Find Data | Показать данные | Найти данные.
 | Общий X | Установить общий масштаб шкалы X.
 | X1-X4 | Выбрать индивидуальный масштаб шкалы X.
График Y |  |
 | Шкала Y | Выбрать масштаб шкалы Y.
Zoom Out | Уменьшить | Уменьшить масштаб шкалы Y (Ctrl+[-]).
Zoom In | Увеличить | Увеличить масштаб шкалы Y (Ctrl+[+]).
Set Bipolar | Биполярное положение | Установить биполярное положение шкалы Y (Ctrl+Y).
Find Data | Показать данные | Найти данные (Ctrl+F).
 | Общий Y | Установить общий масштаб шкалы Y.
 | Y1-Y4 | Выбрать индивидуальный масштаб шкалы Y.
Каналы |  |
 | Выбрать все | Показать графики всех каналов.
 | Очистить выбор | Скрыть графики всех каналов.
 | Инвертировать выбор | Скрыть видимые каналы и показать скрытые.
Помощь |  |
Help | Справка... | Вызвать справку окна X-Y Осциллограф.

Начало страницы

См. также
Анализ данных


Гистограмма распределения

Программа «PowerGraph» позволяет строить гистограмму распределения значений сигнала.

Histogram Окно «Гистограмма»

Построение гистограммы распределения осуществляется в дополнительном окне Гистограмма:
  1. Выберите команду Гистограмма... (Histogram) в меню Анализ основного окна программы.
  2. Нажмите в панели инструментов кнопку Гистограмма....

Гистограмма распределения отражает количество значений сигнала, соответствующих определенному уровню амплитуды. Для построения гистограммы распределения вся шкала амплитуды разбивается на равномерные участки - диапазоны, а затем подсчитывается количество значений сигнала, попадающих в каждый диапазон.
Выбор размера диапазонов, на которые разбивается шкала амплитуды, осуществляется с помощью раскрывающегося списка Шаг (Step), расположенного в правой нижней части окна Гистограмма.

Выбор анализируемых данных

Список Канал (Channel) позволяет выбрать канал, содержащий данные для построения гистограммы.
Список Блок (Block) позволяет выбрать блок данных для построения гистограммы.
Следующие команды меню Гистограмма (Histogram) позволяют ограничить объем анализируемых данных:
Весь блок (Whole Block) - построение гистограммы по всем данным блока.
Выделенная область (Selection) - построение гистограммы только по данным в области выделения.
Комментарии (Comments Only) - построение гистограммы только по точкам комментариев.
Построение гистограммы по точкам комментариев позволяет анализировать распределение выборочных параметров сигналов, например, распределение максимумов или минимумов в периодических сигналах. Для проведения такого выборочного анализа необходимо предварительно установить комментарии в характерных точках сигнала. Для этого можно использовать функции автоматической установки комментариев с помощью окна Автокомментарии.

Выбор типа диаграммы

Окно Гистограмма позволяет отображать один из двух количественных вариантов гистограммы распределения:
Quantity | Гистограмма количества значений - каждый столбец гистограммы отражает абсолютное количество значений, содержащихся в этом диапазоне амплитуды.
Density | Гистограмма плотности распределения - каждый столбец гистограммы отражает долю значений, содержащихся в этом диапазоне амплитуды, т.е. результат деления каждого столбца гистограммы количества на общее количество анализируемых значений.

Окно Гистограмма позволяет отображать две формы гистограммы распределения:
Differential | Дифференциальная гистограмма - отражает количество или долю значений, содержащихся только в данном диапазоне амплитуды.
Integral | Интегральная гистограмма - отражает количество или долю значений, содержащихся в данном и во всех меньших диапазонах амплитуды.
Дифференциальная и интегральная формы гистограммы распределения могут отображаться как поочередно, так и одновременно.

Выбор количественного варианта и формы гистограммы осуществляется соответствующими командами меню Гистограмма.

Исключение значений

Окно Гистограмма позволяет при построении гистограммы исключить из анализа определенные значения исходных данных. Выбор исключаемых значений осуществляется следующими командами меню Гистограмма:
Exclude Mode | Исключить Моду (Exclude Mode) - исключить все значения соответствующие моде исходных данных, т.е. наиболее часто встречающиеся значения.
Exclude 0 | Исключить 0 (Exclude Zero) - исключить все нулевые значения.
Исключение моды или нулевых значений позволяет анализировать распределение выборочных параметров сигналов, например, распределение максимумов или минимумов в периодических сигналах. Для проведения такого выборочного анализа необходимо предварительно обнулить значения, которые следует исключить из анализа. Для этого можно использовать функции математической обработки CyclePointMax и CyclePointMin (категории Cyclic и CyclicA), которые обнуляют все значения сигнала кроме максимума или минимума каждого цикла.

Экспорт гистограммы

Окно Гистограмма позволяет экспортировать результаты построения гистограммы распределения в текстовом и графическом форматах. Для экспорта данных гистограммы используются следующие команды:
Save | Команда Сохранить как... (Save As) в меню Файл - сохранить численные данные гистограммы в текстовый файл или изображение гистограммы в графический файл.
Copy Data | Команда Копировать данные (Copy Data) в меню Правка - копировать численные данные гистограммы в буфер обмена (Clipboard) в текстовом формате.
Copy Image | Команда Копировать изображение (Copy Image) в меню Правка - копировать графическое изображение гистограммы в буфер обмена (Clipboard).

Строка состояния

Строка состояния, расположенная в нижней части окна Гистограмма, содержит следующую информацию:
Элемент | Показывает
Ch# | Номер выбранного канала.
Min | Минимальное значение анализируемых данных.
Max | Максимальное значение анализируемых данных.
Mean | Среднее арифметическое значение анализируемых данных.
Mode | Значение моды исходных данных.
X | Значение оси Х в столбце гистограммы под курсором.
D | Дифференциальное значение распределения под курсором.
I | Интегральное значение распределения под курсором.
H | Количество столбцов гистограммы.
S | Общее количество анализируемых значений.

Меню и панель инструментов

Файл |  |
Save As... | Сохранить как... | Сохранить данные или изображение в файл (Ctrl+S).
 | Закрыть | Закрыть окно.
Правка |  |
Copy Data | Копировать данные | Копировать данные в буфер обмена (Ctrl+С).
Copy Image | Копировать изображение | Копировать изображение в буфер обмена.
График |  |
 | Шкала | Выбрать масштаб шкалы Y.
Y Zoom Out | Уменьшить | Уменьшить масштаб шкалы Y (Ctrl+[-]).
Y Zoom In | Увеличить | Увеличить масштаб шкалы Y (Ctrl+[+]).
Find Data | Показать данные | Найти данные (Ctrl+F).
Гистограмма |  |
Block | Весь блок | Анализ данных всего блока.
Selection | Выделенная область | Анализ данных области выделения.
Comments | Комментарии | Анализ только точек комментариев.
Quantity | Количество | Гистограмма количества значений (Ctrl+F1).
Density | Плотность | Гистограмма плотности распределения (Ctrl+F2).
Differential | Дифференциальная | Дифференциальная гистограмма распределения (Ctrl+F3).
Integral | Интегральная | Интегральная гистограмма распределения (Ctrl+F4).
Exclude Mode | Исключить Моду | Исключить из распределения моду исходных данных (Ctrl+F5).
Exclude 0 | Исключить 0 | Исключить из распределения нулевое значение (Ctrl+F6).
Помощь |  |
Help | Справка... | Вызвать справку окна Гистограмма.

См. также
Анализ данных


Печать данных

Программа «PowerGraph» позволяет печатать графические данные на бумаге с помощью любого принтера, подключенного к компьютеру. Для печати данных используются следующие команды в меню Файл:

  • Параметры страницы... (Page Setup) - выбор параметров страницы: тип бумаги, ориентация, размеры полей.
  • Предварительный просмотр... (Print Preview) - предварительный просмотр страниц перед печатью.
  • Печать... (Print) - печать данных.

Параметры страницы

Перед выводом графиков на печать следует выбрать параметры страницы в дополнительном диалоговом окне, которое вызывается командой Параметры страницы... в меню Файл:

Тип бумаги

Выбранный тип бумаги определяет физические размеры страницы печати. Список допустимых типов бумаги зависит от выбранного принтера. Для большинства принтеров стандартом является бумага формата A4, имеющая размеры 297x210 мм.

Ориентация страницы

Ориентация страницы определяет способ расположения данных на листе. Существует два стандартных значения ориентации страницы - Книжная и Альбомная.

Поля страницы

Поля страницы представляют собой пустое пространство возле краев страницы, не используемое при печати. Размеры полей задаются в миллиметрах (мм) независимо для левого, правого, верхнего и нижнего краев. По умолчанию для всех полей в программе используется одинаковый размер равный 10 мм (1 см), минимальный размер полей составляет 5 мм. Увеличение размера одного из полей позволяет создать на листе свободное дополнительное пространство, используемое для подшивки страниц или для пометок.

Тип бумаги, ориентация страницы и размеры полей в совокупности определяют размер печатной области страницы, от которого зависит количество данных, размещенных на одном листе, и общее количество страниц, на которые разбиваются все данные.

После загрузки программы для печати используется принтер, установленный в операционной системе по умолчанию. Выбранные параметры страницы сохраняются между сеансами работы программы.

Разметка страницы

При печати графических данных в программе «PowerGraph» используется стандартная разметка страницы, показанная на следующей схеме:

Основным обязательным элементом страницы является область построения, содержащая масштабную сетку и графики каналов. Остальные элементы страницы являются информационными и могут быть изменены или исключены из печати. К информационным элементам страницы относятся:

  • Имя файла - текстовая строка в верхней части страницы, содержащая имя текущего файла. Дополнительно вместе с именем файла у правого края страницы печатается номер текущей страницы и общее количество страниц печати.
  • Заголовок блока - текстовая строка над областью построения, содержащая номер текущего блока или его название, указанное пользователем. Дополнительно в строке заголовка блока могут отображаться дата и время начала регистрации блока, частота регистрации данных в блоке, а также размер блока в единицах времени и количестве точек данных.
  • Шкала Y - располагается слева от области построения и содержит индивидуальную ось Y для каждого графика. Дополнительно для каждого графика на шкале Y может отображаться имя канала (цвет надписи соответствует цвету графика) и масштаб (значение основного деления оси графика).
  • Шкала X - располагается под областью построения и содержит индивидуальную ось X для каждого блока данных. Дополнительно на шкале X могут отображаться заголовок шкалы (например - "Время, s" или "Частота, Hz") и диапазон времени и индексов точек данных на текущей странице.
  • Заметки блока (по умолчанию не печатается) - область в нижней части листа, содержащая текстовые заметки, указанные пользователем для каждого блока. Вертикальный размер области заметок задается в количестве текстовых строк.
Изменение параметров печати информационных элементов страницы осуществляется в дополнительных параметрах программы, а также в окне предварительного просмотра.

Физические размеры графиков и сетки

Особенностью программы «PowerGraph» является возможность печати графических данных в масштабе стандартной миллиметровой бумаги, используемой в аналоговых ленточных самописцах. При печати расстояние между промежуточными делениями осей X и Y на бумаге составляет 5 мм, между основными делениями оси Y - 10 мм, а между основными делениями оси X - 25 мм. Таким образом, сетка графиков печатается в масштабе реальных физических единиц с размером ячейки равным 5x5 мм. Масштаб графиков (цена основных делений оси Y), используемый в программе и отображаемый при печати, на бумаге соответствует значению амплитуды в 1 см.
Незначительные отклонения физических размеров графиков и сетки на бумаге могут быть связаны с нарушением скорости или неравномерностью протяжки бумаги в принтере при печати. Такие явления наблюдаются, как правило, на устаревших моделях или при износе механических деталей принтеров.

Настройки печати

Программа «PowerGraph» использует при печати текущие настройки визуализации данных, установленные в главном окне программы. Это позволяет получить на бумаге практически точную копию экранного изображения и облегчает процесс изменения параметров печати.
Следующие настройки программы автоматически используются при печати:
  • количество графиков;
  • цвет графиков;
  • цвет и стиль масштабной сетки;
  • номера и порядок расположения каналов;
  • масштабы и формат значений шкал амплитуды и времени;
  • взаимное положение графиков в режимах совмещения сеток и нулевых линий;
  • отображение дополнительных графических элементов: комментарии, нулевые линии графиков и уровни амплитуды.
Для изменения этих настроек при печати следует изменить их в главном окне программы.

Положение графиков

В программе «PowerGraph» используется система динамического переключения шкалы Y и масштабной сетки активного графика, что позволяет свободно перемещать и позиционировать графики с различными масштабами по вертикали. В отличие от "живой" компьютерной программы, изображение на листе бумаги является статичным, поэтому на бумаге для каждого из графиков печатается индивидуальная шкала Y.
При печати в программе «PowerGraph» область шкалы Y печатной страницы (см. выше) равномерно распределяется по вертикали между графиками, для каждого из которых отображается собственная ось амплитуды, название канала и масштаб шкалы. Однако положение графиков и масштабных сеток на странице зависят от используемого в данный момент режима совмещения графиков (см. Каналы и Графики). Печать графиков в различных режимах показана на следующем рисунке:

Режимы печати графиков

Режим независимых графиков

В режиме независимых графиков (свободное перемещение) область построения равномерно распределяется по вертикали между графиками, так же как и шкала Y. Для каждого из графиков в соответствующей области печатается индивидуальная масштабная сетка, но сам график может располагаться в любой позиции области построения по вертикали. Смещение каждого графика на листе относительно положения его шкалы Y равно смещению этого графика на экране относительно соответствующей цветной кнопки графика:

Режим независимых графиков

Для изменения положения графика на странице следует изменить его положение на экране относительно цветной кнопки графика. Для перемещения одного графика достаточно перемещать его шкалу вверх-вниз при нажатой левой копке мыши. Для одновременного перемещения всех графиков используется вертикальная полоса прокрутки у правого края графического дисплея главного окна программы.
Видимое на экране взаимное положение всех графиков при печати в этом режиме не сохраняется.

Режим совмещения сеток

В режиме совмещения сеток область построения содержит общую масштабную сетку для всех графиков, а деления шкалы Y каждого графика соответствуют горизонтальным линиям общей сетки. При печати в этом режиме сохраняется взаимное положение графиков, поэтому изображение на бумаге полностью соответствует изображению графического дисплея главного окна программы. Положение графиков на бумаге по вертикали определяется положением графиков на экране, при этом центр области построения печатной страницы совмещается с центром графического дисплея:

Режим совмещения сеток

Для изменения положения графика на странице по вертикали следует изменить его положение на экране относительно центра графического дисплея. Для перемещения одного графика достаточно перемещать его шкалу вверх-вниз при нажатой левой копке мыши. Для одновременного перемещения всех графиков используется вертикальная полоса прокрутки у правого края графического дисплея.

Режим совмещения нулей

Режим совмещения нулей полностью соответствует режиму совмещения сеток, но все графики независимо от масштаба имеют общее положение уровня нуля на странице. Перемещение по вертикали осуществляется только одновременно для всех графиков.

Печать полной шкалы Y

В программе «PowerGraph» также используется дополнительный режим печати, в котором шкала Y каждого графика занимает все пространство области построения по вертикали. В этом режиме шкалы графиков располагаются слева направо в соответствии с порядком следования графиков сверху вниз:

Режим полной шкалы Y

Включение режима печати полной шкалы Y осуществляется в окне предварительного просмотра.

Данные для печати

Программа «PowerGraph» позволяет печатать следующие наборы данных:
  • Весь файл - данные всех блоков файла (используется по умолчанию).
  • Данные одного выбранного блока.
  • Выделенный участок данных.
Выбор данных для вывода на печать осуществляется в дополнительных параметрах программы, а также в окне предварительного просмотра.

Расположение блоков на странице

При печати всего файла на одном листе бумаги могут отображаться графические данные нескольких блоков. Программа «PowerGraph» позволяет использовать различные варианты расположения нескольких блоков на одной печатной странице.

Печать до конца страницы

Данные нескольких блоков печатаются до конца страницы, заполняя всю полезную площадь листа. Оставшийся участок данных последнего блока текущей страницы переносится на следующую страницу:

Печать до конца страницы

Печать без переносов

Запрещается перенос оставшейся части блока на следующую страницу. На одной странице печатаются данные нескольких блоков, только если они полностью помещаются на листе. Если данные последнего блока полностью не помещаются на оставшемся пространстве листа, то печать этого блока начинается со следующей страницы.

Печать без переносов

Печать с новой страницы

Данные каждого следующего блока печатаются с новой страницы.

Печать с новой страницы

Выбор режима расположения нескольких блоков на странице осуществляется в дополнительных параметрах программы, а также в окне предварительного просмотра.

Предварительный просмотр

Программа «PowerGraph» позволяет перед выводом графических данных на печать увидеть на экране монитора, как будут выглядеть страницы после печати. Предварительный просмотр страниц перед печатью осуществляется в дополнительном окне программы - Предварительный просмотр, которое вызывается командой Предварительный просмотр... в меню Файл.
Окно предварительного просмотра позволяет увидеть изображение каждой печатной страницы, а также изменить параметры страницы и выбрать отображаемые элементы разметки, набор данных для печати и режим расположения блоков (см. выше).

Экспорт изображения страниц

Окно предварительного просмотра предоставляет дополнительную возможность экспорта изображения страниц печати в виде векторных рисунков - метафайлов. Преимуществом векторных рисунков перед растровыми (например, копирование изображение экрана) является возможность масштабирования (изменения размеров) без ухудшения качества изображения. Экспорт изображения печатных страниц в виде векторных рисунков может быть использован при подготовке отчетов и презентаций для переноса графических данных в другие программы.

Печать

Вывод графических данных на печать осуществляется командой Печать... (Print) в меню Файл в главном окне программы, а также в окне предварительного просмотра. Перед запуском процесса печати программа вызывает стандартное диалоговое окно печати, позволяющее выбрать принтер, номера страниц для печати и количество копий:

Выбор принтера

Программа «PowerGraph» позволяет использовать для вывода графических данных на печать любые принтеры, установленные в операционной системе (см. раздел "Принтеры" в Панели управления). После загрузки программы для печати используется принтер, установленный в операционной системе по умолчанию. Если в операционной системе установлено несколько принтеров, то программа позволяет изменить выбор принтера непосредственно перед запуском процесса печати. Выбор принтера для печати сохраняется в течение всего сеанса работы программы.
Дополнительную возможность выбора принтера для печати предоставляет окно параметров страницы (см. выше), в котором выбирается тип бумаги, соответствующий конкретному принтеру.
Стандартное диалоговое окно печати позволяет изменить индивидуальные настройки выбранного принтера (например, включение/выключение функции цветной печати и т.п.). Изменение индивидуальных настроек принтера также влияет на процесс печати графических данных в программе.

Выбор страниц для печати

Диалоговое окно печати позволяет выбрать номера печатаемых страниц. Выбор страниц осуществляется переключателями:
  • Все - печать всех страниц.
  • Страницы: - печать указанного диапазона страниц.

Выбор количества копий

Диалоговое окно печати позволяет указать количество печатаемых копий страниц. По умолчанию печатается только одна копия. Флажок Разобрать по копиям включает режим разделения копий, т.е. сначала будут напечатаны все страницы первой копии, затем все страницы второй копии и т.д. Если флажок сброшен, то сначала печатается указанное количество копий первой страницы, затем второй и т.д.

Процесс печати

После запуска процесса печати появляется дополнительное окно, информирующее пользователя о ходе подготовки страниц для печати. Кнопка Отмена позволяет остановить процесс подготовки страниц и их печать на принтере.
В многозадачной операционной системе Windows взаимодействие нескольких программ с одним принтером осуществляется с помощью очереди печати. Программа только добавляет подготовленные страницы в общую очередь печати, а непосредственную печать этих страниц на принтере осуществляет операционная система в фоновом режиме. Печать первой страницы начинается только после того, как в очередь печати будет добавлена последняя страница (весь документ), поэтому остановка процесса подготовки страниц в программе позволяет полностью остановить вывод всех страниц на принтер.

См. также
Предварительный просмотр, Дополнительные параметры: Печать


Предварительный просмотр

Программа «PowerGraph» позволяет перед выводом графических данных на печать увидеть на экране монитора, как будут выглядеть страницы после печати.

Подробнее о функциях и возможностях печати см. Печать данных

Окно «Предварительный просмотр»

Для предварительного просмотра страниц перед печатью используется дополнительное окно, которое вызывается командой Предварительный просмотр... (Print Preview) в меню Файл главного окна программы:

Окно предварительного просмотра содержит изображение одной из страниц печати. Выбор страницы для просмотра осуществляется с помощью вертикальной полосы прокрутки, расположенной у правого края окна, или с помощью следующих кнопок панели инструментов и команд меню Вид (View):
Переход к первой странице | В начало (To Start) - переход к первой странице.
Переход к предыдущей странице | Предыдущая страница (Previous Page) - переход к предыдущей странице.
Переход к следующей странице | Следующая страница (Next Page) - переход к следующей странице.
Переход к последней странице | В конец (To End) - переход к последней странице.

Окно предварительного просмотра также позволяет использовать следующие функции печати:

  • Изменение параметров страницы.
  • Выбор информационных элементов страницы.
  • Выбор набора данных для печати.
  • Выбор режима расположения нескольких блоков на странице.
  • Запуск процесса печати.
  • Экспорт изображения страниц.

Page Setup... Параметры страницы

Команда Параметры страницы... в меню Файл вызывает дополнительное диалоговое окно, позволяющее изменить текущие параметры страницы: тип бумаги, ориентацию и размеры полей страницы.

Элементы страницы

Включение и выключения печати информационных элементов страницы осуществляется следующими кнопки панели инструментов и командами меню Вид (View):
File Name | Имя файла (File Name) - показать/спрятать имя файла.
Y Scale | Шкала Y (Y Scale) - показать/спрятать шкалу Y.
X Scale | Шкала X (X Scale) - показать/спрятать шкалу X.
Block Title | Заголовок блока (Block Title) - показать/спрятать заголовок блока.
Block Note | Заметки блока (Block Note) - показать/спрятать текстовые заметки блока.
Изменение индивидуальных настроек информационных элементов страницы осуществляется в дополнительных параметрах программы.

Full Y Scale Печать полной шкалы Y

Команда Полная шкала Y в меню Вид позволяет использовать дополнительный режим печати, в котором шкала Y каждого графика занимает все пространство области построения по вертикали.

Данные для печати

Выбор данных для печати осуществляется следующими кнопками панели инструментов и командами меню Данные (Data):
Whole Fle | Весь файл (Whole File) - печать всего файла.
Active Block | Текущий блок (Active Block)- печать только текущего блока.
Selection | Область выделения (Selection) - печать только выделенного участка данных.

Расположение блоков на странице

Выбор режима расположения нескольких блоков на одной странице осуществляется следующими кнопками панели инструментов и командами меню Данные (Data):
To End of Page | До конца страницы (To End of Page) - данные нескольких блоков печатаются до конца страницы, заполняя всю площадь листа. Оставшийся участок данных последнего блока переносится на следующую страницу.
No Wrap | Без переносов (No Wrap) - на одной странице печатаются данные нескольких блоков, только если они полностью помещаются на листе. Если данные последнего блока полностью не помещаются на оставшемся пространстве листа, то печать этого блока начинается со следующей страницы.
From New Page | С новой страницы (From New Page) - данные каждого следующего блока печатаются с новой страницы.

Печать

Запуск процесса печати из окна предварительного просмотра осуществляется командой Печать... в меню Файл. Перед запуском процесса печати программа вызывает стандартное диалоговое окно, позволяющее выбрать принтер, номера страниц для печати и количество копий.

Экспорт изображения страниц

Окно предварительного просмотра предоставляет дополнительную возможность экспорта изображения печатных страниц в виде векторных рисунков - метафайлов. В отличие от растровых рисунков (например, копирование изображение экрана), в которых содержатся только значения цвета для каждой точки изображения, в векторных рисунках содержатся относительные координаты графических элементов, а также позиции и размеры текстовых надписей на изображении. Преимуществом векторных рисунков перед растровыми является возможность свободного масштабирования (изменения размеров) без потери качества изображения. Другим преимуществом векторных рисунков перед растровыми является меньший размер занимаемого дискового пространства.
Окно предварительного просмотра позволяет копировать изображения печатных страниц в буфер обмена (Clipboard) и сохранять в файлы (WMF - Windows MetaFile) в формате векторных рисунков. Для экспорта изображения печатных страниц используются следующие кнопки панели инструментов и команды меню:
Save... | Сохранить... в меню Файл - сохранение изображения текущей страницы в файл.
Save All... | Сохранить все... в меню Файл - сохранение изображений всех страниц в файлы. Изображение каждой страницы сохраняется в отдельный файл, при этом к указанному имени файла добавляется номер страницы.
Copy | Копировать в меню Правка - копирование изображения текущей страницы в буфер обмена (Clipboard).
Экспорт изображения печатных страниц в виде векторных рисунков может быть использован для переноса графических данных в другие программы при подготовке отчетов и презентаций. Например, в приложениях MS Office для вставки изображения из файла используйте команду Рисунок/Из файла... в меню Вставка. Для вставки векторного изображения из буфера обмена используйте команду Специальная Вставка... в меню Правка и в появившемся списке форматов выберите - Метафайл Windows (EMF).
При вставке векторного рисунка из буфера обмена с помощью стандартной команды Вставить в ряде случаев может происходить автоматическое преобразование векторного изображения в растровый формат, что приведет к потере возможности качественного масштабирования. Для непосредственной вставки векторного изображения без автоматического преобразования в растровый формат следует использовать команду Специальная Вставка.

Строка состояния

Строка состояния, расположенная в нижней части окна Предварительный просмотр, содержит следующую информацию:
Элемент | Показывает
A# | Тип выбранной бумаги.
###x### mm | Размер бумаги в миллиметрах.
###x### mm | Размер печатной области бумаги в миллиметрах.
Страница # из ## | Номер текущей страницы и общее количество страниц.
Принтер | Название выбранного принтера.

Меню и панели инструментов

Файл |  |
Save... | Сохранить... | Сохранить текущую страницу в виде векторного рисунка (метафайла).
Save All... | Сохранить все... | Сохранить все страницы в виде векторных рисунков (метафайлов).
Page Setup... | Параметры страницы... | Вызвать диалоговое окно параметров страницы.
Print... | Печать... | Запустить процесс печати.
 | Закрыть | Закрыть окно.
Правка |  |
Copy | Копировать | Копировать текущую страницу в буфер обмена в виде векторного рисунка (метафайла).
Вид |  |
File Name | Имя файла | Показать/спрятать имя файла на странице.
Y Scale | Шкала Y | Показать/спрятать шкалу Y на странице.
X Scale | Шкала X | Показать/спрятать шкалу X на странице.
Block Title | Заголовок блока | Показать/спрятать заголовок блока на странице.
Block Note | Заметки блока | Показать/спрятать заметки блока на странице.
Full Y Scale | Полная шкала Y | Включить/выключить режим печати полной шкалы Y.
 | В начало | Показать первую страницу (Home).
 | Предыдущая страница | Показать предыдущую страницу (PgUp).
 | Следующая страница | Показать следующую страницу (PgDn).
 | В конец | Показать последнюю страницу (End).
Данные |  |
Whole Fle | Весь файл | Печатать весь файл.
Active Block | Текущий блок | Печатать только текущий блок.
Selection | Область выделения | Печатать только выделенный участок данных.
To End of Page | До конца страницы | Печатать блоки до конца страницы.
No Wrap | Без переносов | Печатать блоки до конца страницы без переносов.
From New Page | С новой страницы | Печатать каждый блок с новой страницы.
Помощь |  |
Help | Справка... | Вызвать справку окна Предварительный просмотр.

Начало страницы

См. также
Печать данных, Дополнительные параметры: Печать


Файлы

Работа с файлами

Программа «PowerGraph» включает следующие операции с файлами:

Создание нового файла

  1. Выберите команду Создать (New) в меню Файл.
  2. Нажмите в панели инструментов кнопку Создать новый файл.
  3. Нажмите не клавиатуре сочетание клавиш Ctrl+N.

Открытие файла

  1. Выберите команду Открыть... (Open) в меню Файл.
  2. Нажмите в панели инструментов кнопку Открыть файл.
  3. Нажмите не клавиатуре сочетание клавиш Ctrl+O.

Добавление файлов

Программа «PowerGraph» позволяет добавлять к текущему файлу данные из других файлов в виде отдельных блоков:
  1. Выберите команду Добавить... (Append) в меню Файл.
  2. Нажмите в панели инструментов кнопку Добавить файлы.
Для добавления нескольких файлов используйте клавиши Ctrl (выбор отдельных файлов) и Shift (выбор группы файлов).

Сохранение файла

  1. Выберите команду Сохранить... (Save) в меню Файл.
  2. Нажмите в панели инструментов кнопку Сохранить файл.
  3. Нажмите не клавиатуре сочетание клавиш Ctrl+S.
  4. Выберите команду Сохранить как... (Save As) в меню Файл для сохранение текущего файла под другим именем.

Сохранение блока данных (экспорт)

  1. Выберите команду Сохранить блок... (Save Block) в меню Файл.
  2. Нажмите в панели инструментов кнопку Сохранить данные блока.

Сохранение выделенного участка данных (экспорт)

  1. Выберите команду Сохранить выделение... (Save Selection) в меню Файл.
  2. Нажмите в панели инструментов кнопку Сохранить выделенные данные.

Поддерживаемые форматы файлов

Программа «PowerGraph» использует для хранения данных собственный формат файлов, а также позволяет импортировать и экспортировать данные в файлы общедоступных форматов (текстовые, звуковые и двоичные).

Файлы данных (*.pgc)

Для хранения данных программа «PowerGraph» использует собственный формат файлов - "PowerGraph Chart" (расширение pgc). Этот формат позволяет записывать в один файл несколько блоков данных, а также хранить вместе с данными различные настройки, дополнительный текст и таблицы расчетных значений.

Текстовые файлы (*.txt)

Программа «PowerGraph» позволяет импортировать и экспортировать данные в текстовом формате.
См. раздел «Текстовые файлы»

Звуковые файлы (*.wav)

Программа «PowerGraph» позволяет импортировать и экспортировать данные звуковых файлов.
См. раздел «Звуковые файлы»

Двоичные файлы (*.bin, *.dat)

Программа «PowerGraph» позволяет импортировать и экспортировать двоичные данные.
См. раздел «Двоичные файлы»

Программа «PowerGraph» постоянно совершенствуется и дополняется. По вопросам обновления программы, а также с предложениями поддержки новых форматов файлов, обращайтесь к разработчикам.

См. также
Текстовые файлы, Звуковые файлы, Двоичные файлы


Текстовые файлы

Импорт данных в текстовом формате

Программа «PowerGraph» позволяет импортировать данные из текстовых файлов, содержащих столбцы численных значений, разделенных символами табуляции. Текстовый файл может содержать несколько блоков данных, которые должны быть разделены текстовой строкой. Программа автоматически пытается определить является ли первый столбец данных столбцом времени и вычислить значение частоты регистрации. Если столбец времени отсутствует или частота регистрации данных была определена неправильно, это значение можно скорректировать с помощью команды Изменить частоту регистрации... (Adjust Sampling Rate) в меню Блок.

Программа «PowerGraph» позволяет также импортировать данные в текстовом формате из буфера обмена (Clipboard) - команда Вставить из буфера обмена... (Paste from Clipboard) в меню Правка. Импортируемые данные вставляются в виде отдельного блока в конец записи. Импорт данных из буфера обмена осуществляется таким же образом, что и при загрузке из текстового файла.

Экспорт данных в текстовом формате

Программа «PowerGraph» позволяет экспортировать данные в текстовом формате, содержащем столбцы численных значений, разделенных символом табуляции. Для экспорта можно использовать следующие наборы данных:

  • Все данные файла.
  • Данные активного блока.
  • Данные области выделения.
Кроме того, экспорт данных можно осуществлять двумя способами:
  • Сохранение данных на диске в текстовом файле.
  • Копирование данных в буфер обмена для последующей вставки в других программах.

Сохранение данных в текстовый файл

Для сохранения всех данных в текстовом формате выберите команду Сохранить как... (Save As) в меню Файл. При сохранении данных укажите тип файла Text (файлы *.txt).

Экспорт данных активного блока

Для экспорта данных активного блока используйте следующие кнопки панели инструментов и команды меню:
Сохранить значения активного блока или команда Сохранить блок... (Save Block) в меню Файл - сохранить данные активного блока.
Копировать значения активного блока или команда Копировать блок... (Copy Block) в меню Правка - копировать данные активного блока.

Экспорт выделенных данных

Для экспорта данных области выделения используйте следующие кнопки панели инструментов и команды меню:
Сохранить данные области выделения или команда Сохранить выделение... (Save Selection) в меню Файл - сохранить данные области выделения.
Копировать данные области выделения или команда Копировать выделение... (Copy Selection) в меню Правка - копировать данные области выделения.

Параметры экспорта данных

При экспорте данных в текстовом формате появляется диалоговое окно с дополнительными параметрами экспорта:

Окно экспорта данных

Каналы (Channels) - список записанных в блоке каналов. Флажки, расположенные слева от названия каналов, позволяют выбрать отдельные каналы для экспорта в текстовый файл. Порядок каналов в списке (сверху-вниз) соответствует порядку расположения столбцов каналов в текстовом файле (слева-направо).
Кнопки панели инструментов, расположенные слева от списка каналов, позволяют изменить выбор и порядок следования каналов:

→ выбрать (отметить) все каналы в списке.
→ очистить выбор каналов в списке.
→ переместить канал в начало списка.
→ переместить канал на одну позицию вверх.
→ переместить канал на одну позицию вниз.
→ переместить канал в конец списка.
→ упорядочить список каналов в порядке возрастания номеров.
→ упорядочить список каналов в порядке убывания номеров.

Текстовый формат (Text Format) - дополнительные элементы текстового формата:

  • Параметры блока (Block Information) - включить перед численными данными информацию о блоке (дата и время начала записи, параметры регистрации и др.).
  • Заголовки столбцов (Headers of Columns) - включить строку заголовков столбцов, содержащую названия каналов и единицы измерений.
  • X Столбец (X Column)- включить значения оси X (первый столбец). Формат экспортируемых значений оси X выбирается в дополнительных параметрах программы на вкладке Формат.
Выборка (Sampling) - параметры уменьшения объема экспортируемых данных:
  • Все данные (All Data) - экспорт всех данных блока или области выделения.
  • Только комментарии (Comments Only) - экспорт точек данных, в которых установлены комментарии.
  • Прореживание (Decimation) - прореживание экспортируемых данных с заданным целочисленным коэффициентом. Например, при коэффициенте прореживания равном 10 экспортируются значения только каждой 10-й точки данных.
Формат экспортируемых значений каналов выбирается в дополнительных параметрах программы на вкладке Формат и предусматривает округление значений до заданного количества значащих или десятичных цифр.

Один файл (Single File) - экспорт данных всех блоков в один текстовый файл (при сохранении всего файла в текстовом формате).
Если этот флажок не установлен, данные каждого блока экспортируются в отдельные текстовые файлы (к указанному имени текстового файла добавляется номер блока, например - Export1.txt, Export2.txt,...).

Кроме экспорта записанных данных, программа «PowerGraph» позволяет экспортировать в текстовом формате результаты полученные, при анализе данных.

См. также
Работа с файлами


Звуковые файлы

Импорт звуковых файлов

Программа «PowerGraph» позволяет открывать WAV файлы, содержащие звуковые данные.

Wave file Chart

Следует иметь в виду, что форматы файлов с расширением WAV могут существенно различаться (в некоторых из них используются различные алгоритмы сжатия звуковых данных, например файлы MP3 также являются разновидностью WAV файлов). Программа «PowerGraph» правильно распознает любые WAV файлы, имеющие внутренний формат представления данных Windows PCM (данные без сжатия).
Для конвертирования звуковых файлов в формат Windows PCM используйте дополнительные программы, предназначенные для работы со звуком (например Sound Forge или Cool Edit).
Звуковые файлы открываются в программе «PowerGraph» как единый блок данных, так как WAV файлы не поддерживают многоблочную запись данных. Программа поддерживает 8 и 16 разрядные звуковые файлы с любым количеством каналов (обычно 1 - моно или 2 - стерео) и любой частотой регистрации.

Экспорт данных в звуковые файлы

Программа «PowerGraph» позволяет сохранять данные блока или области выделения в звуковом формате. При сохранении следует указать тип файлов - Waveform Audio (файлы *.wav).
Для экспорта звуковых данных используйте следующие кнопки панели инструментов и команды меню:
Сохранить значения активного блока или команда Сохранить блок... (Save Block) в меню Файл - сохранить данные активного блока.
Сохранить данные области выделения или команда Сохранить выделение... (Save Selection) в меню Файл - сохранить данные области выделения.

Параметры экспорта данных

При сохранении данных в звуковом формате появляется диалоговое окно с дополнительными параметрами экспорта:

Экспорт данных в звуковые файлы

Каналы (Channels) - список записанных в блоке каналов. Флажки, расположенные слева от названия каналов, позволяют выбрать отдельные каналы для экспорта в звуковой файл.
Кнопки панели инструментов, расположенные слева от списка каналов, позволяют изменить выбор и порядок следования каналов:
→ выбрать (отметить) все каналы в списке.
→ очистить выбор каналов в списке.
→ переместить канал в начало списка.
→ переместить канал на одну позицию вверх.
→ переместить канал на одну позицию вниз.
→ переместить канал в конец списка.
→ упорядочить список каналов в порядке возрастания номеров.
→ упорядочить список каналов в порядке убывания номеров.
Не все программы, работающие со звуковыми файлами, способны работать с файлами, содержащими более двух каналов. Стандартный звуковой файл должен содержать 1 (Моно) или 2 (Стерео) канала.

Для сохранения данных в звуковом формате, необходимо выбрать частоту регистрации звуковых данных - Частота (Sampling Rate):

  • Реальная (Real) - указывается реальная частота регистрации данных в блоке.
  • Стандартная (Standard) - указывается стандартная частота звуковых данных.

Не все программы, работающие со звуковыми файлами, способны работать с файлами, имеющими нестандартную частоту регистрации. Стандартными значениями частоты звуковых данных являются: 6000, 8000, 11025, 16000, 22050, 32000, 44100, 64000, 88200, 96000 и 192000 Гц.

Звуковые файлы не позволяют хранить реальные характеристики сигналов (единицы измерения, амплитуда, базовый уровень сигнала и т.д.), поэтому при сохранении данных в звуковом формате будет записана только форма сигнала в единицах разрядности.

См. также
Работа с файлами


Двоичные файлы

Импорт двоичных файлов

Программа «PowerGraph» поддерживает следующие типы двоичных файлов:

  • Бинарные файлы с расширением BIN - содержат двоичные данные, а также полную информацию о параметрах регистрации (количество и номера каналов, частота регистрации, названия и калибровочные коэффициенты каналов).
  • Двоичные файлы с расширением DAT - содержат только двоичные данные.
Файлы BIN, записанные утилитой «File Recorder», позволяют автоматически определить количество и номера каналов, частоту регистрации и другие параметры. Бинарные файлы, записанные утилитой «File Recorder», поддерживаются во всех версиях и редакциях программы «PowerGraph».

Файлы DAT содержат только двоичные данные, поэтому для правильного распознавания этих файлов необходимо предварительно указать количество каналов, а после загрузки данных скорректировать значения частоты регистрации и амплитуды сигналов.
Программы «L-Graph» (ЗАО «Л-Кард») и «RTViewer» (НПГ «R-Technology») вместе с файлом данных (DAT) создают также файл параметров (PAR, RVP). При наличии такого файла распознавание и корректировка данных и осуществляются автоматически.

Экспорт двоичных данных

Программа «PowerGraph» позволяет сохранять данные блока или области выделения в двоичном формате. При сохранении следует выбрать тип файлов - Binary (файлы *.bin) или Raw Data (файлы *.dat).

Для экспорта данных используйте следующие кнопки панели инструментов и команды меню:
Сохранить значения активного блока или команда Сохранить блок... (Save Block) в меню Файл - сохранить данные активного блока.
Сохранить данные области выделения или команда Сохранить выделение... (Save Selection) в меню Файл - сохранить данные области выделения.

Параметры экспорта данных

При сохранении данных в двоичном формате появляется диалоговое окно с дополнительными параметрами экспорта:

Экспорт двоичных данных

Каналы (Channels) - список записанных в блоке каналов. Флажки, расположенные слева от названия каналов, позволяют выбрать отдельные каналы для экспорта в двоичный файл.
Кнопки панели инструментов, расположенные слева от списка каналов, позволяют изменить выбор и порядок следования каналов:

→ выбрать (отметить) все каналы в списке.
→ очистить выбор каналов в списке.
→ переместить канал в начало списка.
→ переместить канал на одну позицию вверх.
→ переместить канал на одну позицию вниз.
→ переместить канал в конец списка.
→ упорядочить список каналов в порядке возрастания номеров.
→ упорядочить список каналов в порядке убывания номеров.

Двоичный формат (Data Format) - формат двоичного файла:

  • Тип (Type) - тип сохраняемого файла:
    1. PowerGraph Binary - бинарный файл в формате утилиты «File Recorder» (*.bin).
    2. Raw Data - двоичный файл, содержащий только данные (*.dat).
  • Размер файла (Size) - размер сохраняемых данных.
  • Файл параметров (Parameters) - сохранение файла параметров (только для файлов *.dat). Программа позволяет дополнительно создавать информационный файл с параметрами записанных данных:
    1. Нет - не создавать файл параметров.
    2. L-Graph - создать файл параметров в формате программы «L-Graph» (*.par).
    3. RTViewer - создать файл параметров в формате программы «RTViewer» (*.rvp).
    4. Text - создать файл параметров в текстовом формате (*.ini).
См. также
Работа с файлами


Утилиты

В состав ПО «PowerGraph» входит набор дополнительных утилит, выполняющих специализированные функции:

«Digital Voltmeter» (Цифровой Вольтметр)

Утилита «Digital Voltmeter» предназначена для отображения численных значений входных сигналов и позволяет использовать АЦП в качестве обычного цифрового тестера. Поддерживается до 16 цифровых дисплеев, калибровка входных сигналов, однократный и циклический режимы измерений.

Далее см. «Digital Voltmeter»

«File Recorder» (Запись Файлов)

Утилита «File Recorder» предназначена для непосредственной регистрации сигналов в файл. Позволяет осуществлять автоматическую запись серии файлов с синхронизацией по времени, счетчику значений и уровню сигналов. Может использоваться для автономного сбора данных, не требующего присутствия оператора.
Далее см. «File Recorder»

«File Viewer» (Просмотр Файлов)

Утилита «File Viewer» предназначена для быстрого просмотра и поиска файлов, содержащих аналоговые сигналы. Позволяет одновременно визуализировать данные в режимах осциллограммы и спектрограммы, экспортировать данные в текстовом, звуковом и двоичном форматах, а также разделять длинные файлы на серию файлов меньшего размера с заданным шагом.
Далее см. «File Viewer»

«License Query» (Запрос Лицензии)

Утилита «License Query» предназначена для создания запроса в службу технической поддержки на получение лицензии ПО «PowerGraph». Позволяет определить тип, серийный номер и технические параметры всех поддерживаемых устройств сбора данных, подключенных к компьютеру.
Далее см. «License Query»

Программное обеспечение «PowerGraph» постоянно совершенствуется и дополняется новыми утилитами. По вопросам обновления программы, а также с предложениями о создании новых утилит, обращайтесь к разработчикам.

См. также
ПО «PowerGraph», Работа с файлами


Утилита «Digital Voltmeter»

Утилита Digital Voltmeter (Цифровой Вольтметр) входит в состав ПО «PowerGraph» и предназначена для отображения численных значений входных сигналов, позволяя использовать АЦП в качестве обычного цифрового тестера.

Digital Voltmeter позволяет:

  • Использовать от 1 до 16 каналов АЦП в режиме однократного и циклического измерения.
  • Считывать и отображать численные значения входных сигналов.
  • Осуществлять линейную калибровку входных сигналов.

Алгоритм работы

Общий алгоритм работы с Digital Voltmeter выглядит следующим образом:

  1. Выбрать АЦП для проведения измерений.
  2. Выбрать количество цифровых дисплеев.
  3. Выбрать для каждого дисплея канал АЦП и диапазон измерения входного сигнала.
  4. Установить для каждого дисплея калибровочные коэффициенты.
  5. Выполнить однократное измерение или запустить циклические измерения.

Дополнительные возможности Digital Voltmeter включают:

  • Сохранение и загрузку настроек.
  • Ввод индивидуального имени для каждого канала.
  • Выбор стиля цифровых дисплеев.

Select ADC Выбор АЦП

На первом этапе работы с программой необходимо выбрать АЦП для проведения измерений. Команда Выбор АЦП... (ADC Select) в меню Сервис вызывает диалоговое окно, содержащее список всех поддерживаемых устройств:

Выберите в списке АЦП и нажмите кнопку с названием этого устройства в правой верхней части окна. После этого программа попытается обнаружить данное устройство и установить с ним связь. Если связь с устройством будет успешно установлена, окно выбора АЦП закроется и в заголовке программы появится название выбранного устройства. Если по каким-либо причинам установить связь с устройством не удалось (например, устройство не подключено к компьютеру или используется другой программой), то появится соответствующее информационное сообщение.

Флажок Автоматически позволяет использовать указанное устройство по умолчанию - при следующих запусках программа будет выбирать его автоматически.

ADC setting Аппаратные настройки АЦП

Каждое устройства имеет индивидуальные аппаратные настройки, связанные с его функциональными особенностями. Командой Настройки "АЦП"... (ADC Setup) в меню Сервис вызывает окно аппаратных настроек используемого устройства.
Индивидуальные аппаратные настройки зависят от типа устройства и используемого драйвера, подробное описание аппаратных настроек Вы можете найти в справочной документации к поддерживаемому оборудованию (см. например - Системные прототипы АЦП).

Выбор количества дисплеев

Digital Voltmeter позволяет использовать от 1 до 16 цифровых дисплеев для отображения численных значений входных сигналов. Выбор количества дисплеев осуществляется в раскрывающемся списке, расположенном в начале панели инструментов. После выбора в списке любого значения от 1 до 16 в окне программы появляется соответствующее количество панелей цифровых дисплеев.

Выбор каналов и диапазонов измерений

Каждая панель цифрового дисплея содержит в левом верхнем углу кнопку управления и строку заголовка. При нажатии на кнопку управления появляется индивидуальное меню дисплея, в котором необходимо выбрать один из каналов АЦП, значения которого будут отображаться в этом дисплее, или отключить дисплей (команда Выкл.). Сразу после загрузки программы все дисплеи находятся в выключенном состоянии.
После выбора канала в меню дисплея появляется команда Имя..., которая позволяет указать текстовое название дисплея, отображаемое в строке заголовка. Если название дисплея не указано, в строке заголовка отображается название выбранного канала, предоставляемое драйвером устройства.
После выбора канала необходимо выбрать диапазон измерений входного сигнала АЦП в раскрывающемся списке Диапазон, расположенном под строкой заголовка.

Калибровка входных сигналов

Digital Voltmeter позволяет осуществлять линейную калибровку входных сигналов по формуле:

Y = A * X + B

где X - измеренное значение входного сигнала; Y - отображаемое на экране калиброванное значение; A - линейный коэффициент усиления; B - линейный коэффициент смещения.
Каждая панель цифрового дисплея содержит справа два дополнительных поля для ввода калибровочных коэффициентов:
  • x: значение линейного коэффициента усиления A (умножение сигнала на число);
  • +: значение линейного коэффициента смещения B (прибавление числа к сигналу);
При вводе калибровочных коэффициентов измеренное значение сигнала перед отображением на экране будет умножаться на значение поля x, а затем к результату будет прибавляться значение поля +.

Проведение измерений

В утилите Digital Voltmeter используется два режима проведения измерений:
Get Values | Однократное измерение - численные значения дисплеев обновляются только один раз после выполнения однократного измерения входных сигналов.
 | Циклические измерения (мониторинг) - численные значения дисплеев обновляются непрерывно после каждого цикла измерений. Измерения осуществляются в асинхронном режиме, поэтому частота обновления значений зависит от времени одиночного преобразования АЦП, но не чаще 5 раз в секунду. Запуск циклических измерений осуществляется командой Старт, а остановка - командой Стоп.

Change Display Style Стиль цифрового дисплея

Digital Voltmeter позволяет использовать несколько стилей цифровых дисплеев. Выбор единого стиля всех цифровых дисплеев осуществляется командой Стиль дисплея... (Display Style) в меню Сервис:

В индивидуальном меню каждого дисплея также содержится команда Стиль дисплея... (Display Style), которая позволяет выбрать индивидуальный стиль для данного дисплея.

Использование настроек

Digital Voltmeter позволяет использовать для различных типов измерений индивидуальные настройки:
  • Количество цифровых дисплеев.
  • Номер канала, диапазон измерения и калибровочные коэффициенты каждого дисплея.
  • Название и стиль каждого дисплея.
Для работы с настройками используются следующие команды меню Файл:
  • Загрузить настройки (Load Settings) - содержит список сохраненных настроек и загружает настройки при выборе любого элемента списка. Настройки с именем Default автоматически загружаются при запуске программы, если используется АЦП по умолчанию (см. выше).
  • Сохранить настройки... (Save Settings) - сохраняет текущие настройки. Перед сохранением следует указать имя настроек. При завершении работы программа автоматически сохраняет текущие настройки под именем Default.
  • Сбросить настройки (Reset Settings) - очищает текущие настройки.

Меню и панель инструментов

Файл |  |
 | Загрузить настройки | Загрузить настройки (выбор из списка)
 | Сохранить настройки... | Сохранить текущие настройки
 | Сбросить настройки | Сбросить текущие настройки
 | Выход | Завершить работу с программой.
Правка |  |
 | Копировать | Копировать численные значения всех дисплеев в буфер обмена (Ctrl+C).
 | Очистить дисплей | Очистить значения всех цифровых дисплеев (F8).
 | Очистить калибровку | Отключить калибровку всех дисплеев и сбросить значения калибровочных коэффициентов.
Сервис |  |
Display Style | Стиль дисплея... | Изменить стиль всех цифровых дисплеев (F9).
Select ADC | Выбор АЦП... | Выбор устройства регистрации данных.
ADC Setup | Настройки "АЦП"... | Индивидуальные аппаратные настройки АЦП.
Измерения |  |
Get Values | Однократное измерение | Однократное измерение и обновление цифровых дисплеев (F5).
Monitoring | Старт/Стоп | Запуск/остановка циклических измерений (F6).
Помощь |  |
Справка | Справка... | Вызвать справку Digital Voltmeter.
 | Язык справки | Выбор языка справочного руководства (Автоматически, Русский и Английский)

Начало страницы

См. также
Утилиты


Утилита «File Recorder»

Утилита File Recorder (Запись файлов) входит в состав ПО «PowerGraph» и предназначена для непосредственной регистрации данных в файл.

Функциональные возможности

  • Предварительный мониторинг и калибровка входных сигналов.
  • Регистрация и визуализация произвольного набора каналов.
  • Сохранение данных в файл непосредственно в процессе регистрации.
  • Автоматическая запись серии файлов с синхронизацией по времени, счетчику значений и уровню сигналов.
  • Автозапуск регистрации данных при включении и перезагрузке компьютера.
  • Автозапуск программ обработки после завершения записи каждого файла.
  • Автоматическое управление состоянием аналоговых и цифровых выходов в процессе регистрации.

Алгоритм работы

  1. Выбрать АЦП, используемый для регистрации данных.
  2. Изменить настройки входных сигналов и каналов.
  3. Выбрать каналы для регистрации и визуализации.
  4. Установить частоту регистрации данных.
  5. Указать расположение и базовое имя записываемых файлов.
  6. Выбрать параметры синхронизации записи файлов.
  7. Выбрать дополнительные параметры.
  8. Запустить и остановить процесс регистрации.

Select ADC ADC setting Выбор и настройки АЦП

См. раздел Выбор и настройки АЦП

Настройки входных сигналов Настройки входных сигналов

См. раздел Настройки входных сигналов

Настройки каналов Общие настройки каналов

См. раздел Настройки каналов

Общее меню каналов и графиков Выбор каналов для регистрации и визуализации

См. раздел Каналы и Графики

Выбор частоты регистрации Выбор частоты регистрации

См. раздел Регистрация данных: Выбор частоты регистрации

Расположение и базовое имя файлов

В процессе регистрации File Recorder осуществляет автоматическую запись данных в серию файлов с общим базовым именем. Перед началом регистрации данных необходимо указать расположение и базовое имя записываемых файлов с помощью команды Создать... (New) в меню Файл. При создании файлов к базовому имени добавляется порядковый номер или время и дата создания файла. Например, если указано базовое имя файлов "data", то данные будет последовательно записываться в файлы: data_01, data_02, data_03 и т.д. Способ формирования имени файлов выбирается в окне дополнительных параметров.
Расположение и базовое имя файлов достаточно выбрать только один раз после установки программного обеспечения «PowerGraph» на компьютер. File Recorder автоматически запоминает текущие расположение и базовое имя файлов и использует их в следующих сеансах работы.

См. также формат файлов

Запуск и остановка регистрации данных

Для запуска и остановки регистрации данных используются:
Кнопка "Start/Stop" Кнопка Старт/Стоп в правой нижней части окна программы.
Команда Старт/Стоп в меню Регистрация.
Функциональная клавиша F5 на клавиатуре компьютера.
При запуске регистрации данных File Recorder запускает процесс аналого-цифрового преобразования в АЦП, принимает данные от устройства и отображает их на экране.
Количество регистрируемых каналов и частота регистрации данных отображаются в строке состояния.

Сохранение данных в файл

File Recorder позволяет управлять сохранением данных в файл независимо от запуска и остановки регистрации. Для включения и выключения режима сохранения данных используются:
Переключатель "Включить/выключить сохранение данных в файл"
Кнопка-переключатель, расположенная справа от кнопки Старт/Стоп.
Команда Запись данных в меню Регистрация.
Функциональная клавиша F6 на клавиатуре компьютера.
Запись данных в файл осуществляется только при включенном режиме сохранения. Имя текущего файла, размер, длительность и объем записанных в файл данных отображаются в строке состояния.
При выключении режима сохранения данные в файл не записываются. Выключение записи данных может быть использовано в следующих случаях:
  • Применение File Recorder только для визуализации данных - режим сохранения выключен.
  • Предварительный мониторинг сигналов - режим сохранения выключается перед запуском регистрации данных и включается в процессе регистрации.
  • Принудительный переход к записи следующего файла - режим сохранения выключается на короткое время для завершения записи текущего файла.

Synchronization Синхронизация записи файлов

File Recorder позволяет осуществлять запись данных в серию файлов с автоматической синхронизацией по определенным условиям. В качестве таких условий синхронизации могут быть использованы:
  • Суточное время – управление записью файлов по системным часам компьютера.
  • Количество значений – управление записью файлов по счетчику значений, полученных от устройства.
  • Уровень сигнала – управление записью файлов по результатам сравнения амплитуды входного сигнала с контрольным значением.
Команда Синхронизация... (Synchronization) в меню Сервис вызывает диалоговое окно параметров синхронизации. Описание параметров синхронизации см. в разделе - Синхронизация.

В File Recorder используются общие с программой PowerGraph параметры и настройки синхронизации. Однако, есть ряд особенностей, связанных с записью данных в файлы.

Старт-триггер

При синхронизации старта по уровню размер пред-истории ограничен размером буфера, используемого для приема данных от АЦП. В параметрах синхронизации может быть указан любой размер пред-истрории старта по уровню, но реальный размер пред-истории, сохраняемой в файл, будет зависеть от текущего количества данных в буфере. Гарантируемый размер сохраняемой в файл пред-истории составляет около 10000 значений.

При использовании пред-истории синхронизации старта по уровню возможна последовательная запись файлов с перекрытием данных. Если размер пред-истории превышает количество значений полученных с момента завершения записи предыдущего файла, то в начале нового файла и в конце предыдущего файла будут записаны одни и те же данные.

Авто-Старт

File Recorder позволяет использовать авто-старт синхронизации без ограничения количества записываемых файлов:
  • Если флажок Количество файлов установлен, то регистрация данных автоматически останавливается после записи указанного количества файлов.
  • Если флажок Количество файлов сброшен, то регистрация данных останавливается только по команде пользователя.

Дополнительный флажок Добавить к предыдущему позволяет осуществлять запись данных в один файл - при каждом возникновении условий авто-старта данные будут дописываться в текущий файл.

Состояние триггеров синхронизации

В правой нижней части главного окна File Recorder расположен цветной индикатор, отображающий состояние триггеров синхронизации в процессе регистрации данных. Индикатор синхронизации имеет два цвета:
  • Желтый - запись данных в файл не производится, ожидание условий начала записи нового файла (старт-триггер или авто-старт).
  • Зеленый - данные записываются в файл, ожидание условий завершения записи текущего файла (стоп-триггер).
Возможные состояния индикатора синхронизации показаны в следующей таблице:
 | Таймер | Счетчик | Уровень
Ожидание начала записи файла | Старт-триггер по таймеру | Старт-триггер по счетчику | Старт-триггер по уровню
Ожидание завершения записи файла | Стоп-триггер по таймеру | Стоп-триггер по счетчику | Стоп-триггер по уровню

Количество записанных файлов и общее количество файлов для записи отображаются в строке состояния.

Options Дополнительные параметры

Команда Параметры... (Options) в меню Сервис вызывает диалоговое окно дополнительных параметров File Recorder. Окно параметров содержит следующие вкладки:
  • Файл (File) - параметры записи данных в файлы.
  • Вид (View) - параметры графического отображения данных.
  • Формат (Format) - параметры отображения значений времени и амплитуды сигналов.
  • Автозапуск (Autorun) - параметры автоматического запуска.

Вкладка "Файл" (File)

Вкладка Файл содержит параметры записи данных в файлы:

Формат имени файла - способ формирования имени файлов:

  • Номер файла - к базовому имени файла добавляется порядковый номер файла (1, 2, ..., 11, 12, ..., 101, 102, ...). Список Формат номера позволяет выбрать количество символов, используемых для обозначения порядкового номера. Одинаковое количество символов в номерах файлов (001, 002, ..., 011, 012, ..., 101, 102, ...) имеет существенное значение для последующей сортировки большого количества файлов по именам.
  • Время - к базовому имени файла добавляется время начала записи файла в формате "hh-mm-ss" (h - часы, m - минуты, s - секунды).
  • Дата и Время - к базовому имени файла добавляется дата и время начала записи файла. Список Формат даты позволяет выбрать способ обозначения даты в имени файла (D - день, M - месяц, Y - год).
  • Папка с датой - файлы записываются в отдельные папки, соответствующие дате начала записи файла. В указанном пользователем расположении файлов программа автоматически создает дополнительные папки, в которые записывает все файлы в течение суток. Имена создаваемых папок соответствуют текущей дате с учетом формата, выбранного в списке Формат даты. Если новые сутки наступают в процессе записи очередного файла, то сохранение данных продолжается в этот же файл, а папка с наступившей датой создается только при записи следующего файла.
  • Базовое имя - имя каждого файла начинается с указанного базового имени.
Звук - звуковое сопровождение записи файлов:
  • Начало файла - звуковой сигнал при создании файла.
  • Конец файла - звуковой сигнал при завершении записи файла.
Отключить кэширование - отключение функции кэширования (буферизации) при сохранении данных в файл (режим прямой записи данных на жесткий диск). Кэширование используется операционной системой Windows для увеличения производительности за счет механизма отложенной записи - данные записываются в файл только когда программа завершает другие операции и снижает загрузку центрального процессора. Режим кэширования следует отключать только при частом возникновении сбоев системы для снижения потерь данных.

Вкладка "Вид" (View)

Вкладка Вид содержит параметры графического отображения данных.
См. раздел Дополнительные параметры: Вкладка "Вид"

Вкладка "Формат" (Format)

Вкладка Формат содержит параметры отображения значений времени и амплитуды сигналов.
См. раздел Дополнительные параметры: Вкладка "Формат"

Вкладка "Автозапуск" (Autorun)

Вкладка Автозапуск содержит параметры автоматического запуска:

Для автоматического возобновления регистрации данных при включении или перезагрузке компьютера File Recorder позволяет использовать следующие дополнительные параметры:

  • Автозапуск программы - автоматический запуск File Recorder после загрузки операционной системы.
  • Автозапуск регистрации данных - автоматический запуск процесса регистрации данных после загрузки File Recorder.
Работа File Recorder начинается с выбора АЦП, поэтому для автоматического запуска регистрации данных без участия пользователя необходимо в предыдущем сеансе работы выбрать АЦП по умолчанию (см. раздел - Выбор АЦП). Если используемый по умолчанию АЦП не установлен, то автоматическая регистрация данных начинается только после выбора АЦП пользователем в списке поддерживаемых устройств.

Параметр Автозапуск обработки файлов позволяет организовать автоматическую обработку записанных файлов с помощью других программ. После завершения записи данных в файл File Recorder запускает указанную программу и передает ей полный путь и имя созданного файла в качестве аргумента командной строки. Запускаемая программа может извлечь имя файла из командной строки и использовать его для любых файловых операций или открыть этот файл для последующей обработки данных.
В процессе регистрации данных File Recorder может создавать большое количество файлов, запуская для каждого файла отдельный экземпляр программы обработки. Если используемая программа обработки не выгружается из памяти автоматически или требуют участия пользователя, то запуск многочисленных экземпляров этой программы может привести к сбоям операционной системы и прекращению регистрации данных. Для автоматической обработки файлов рекомендуется применять небольшие программы без пользовательского интерфейса, выполняющие простые функции. Например, копирование записанных файлов с локального компьютера на сервер.

Панели значений

См. раздел Панели значений

Аналоговые выходы

См. раздел Управление аналоговыми выходами

Цифровые выходы

См. раздел Управление цифровыми выходами

Форматы файлов

File Recorder поддерживает следующие форматы файлов для записи данных:
  • Бинарные файлы с расширением BIN - содержат двоичные данные, а также полную информацию о параметрах регистрации (количество и номера каналов, частота регистрации данных, калибровочные коэффициенты и т.п.).
  • Файлы в формате Windows PCM - стандартные звуковые WAV файлы без сжатия.
  • Файлы данных с расширением DAT - содержат только двоичные данные.
  • Файлы программы «L-Graph» (ЗАО «Л-Кард») - данные сохраняются в два файла с одинаковыми именами, но разными расширениями: файл с расширением DAT содержит двоичные данные, файл с расширением PAR содержит служебную информацию о параметрах регистрации.
  • Файлы программы «RTViewer» (НПГ «R-Technology») - данные сохраняются в два файла с одинаковыми именами, но разными расширениями: файл с расширением DAT содержит двоичные данные, файл с расширением RVP содержит служебную информацию о параметрах регистрации.
Все эти форматы файлов также поддерживаются программой PowerGraph, что позволяет использовать File Recorder в качестве дополнительного инструмента для автоматизированной регистрации данных.

Если Вы собираетесь записывать данные, размер которых превышает объем оперативной памяти вашего компьютера, используйте для записи утилиту File Recorder, так как это позволит снизить использование системных ресурсов компьютера и уменьшить риск потери данных при регистрации.

Строка состояния

В нижней части окна File Recorder расположена строка состояния:

File Recorder Stasus Bar

В строке состояния отображается следующая информация:
Элемент | Показывает
Каналы: # из ## Файлы: # из ## | Каналы - количество выбранных для регистрации каналов АЦП (из общего количества), включая каналы с установленным атрибутом "регистрировать всегда", и исключая каналы с установленным атрибутом "не регистрировать". Файлы - в процессе регистрации количество файлов, записанных с момента нажатия кнопки Старт. Второе значение соответствует фиксированному количеству файлов, указанному в параметрах автозапуска синхронизации.
[имя]_### | Имя текущего файла.
## ### | Размер записанных данных текущего файла (количество значений для каждого канала).
##:##:## | Длительность записанных данных текущего файла.
#,## MB | Объем записанных данных текущего файла.
# Ch | Количество регистрируемых каналов.
##,# Hz | Реальная частота регистрации данных (Гц).
[АЦП] | Тип используемого АЦП.
#% | Степень заполнения буфера данных, поступающих от АЦП. При переполнении буфера (100%) возможна потеря части данных, если программа не успеет освободить буфер до получения новых данных. Зеленый цвет индикатора, расположенного справа от этого поля, означает, что переполнения буфера не происходило. При переполнении буфера индикатор загорается красным цветом и не меняется до остановки регистрации. Чтобы сбросить индикатор и продолжить обнаружение фактов переполнения буфера в процессе регистрации необходимо нажать на индикаторе левой кнопкой мыши.

Меню и панель инструментов

Файл
Создать... | Выбор расположения и базового имени файлов (Ctrl+N).
Загрузить настройки | Загрузить сохраненные ранее настройки (выбор из списка)
Сохранить настройки... | Сохранить текущие настройки
Сбросить настройки | Сбросить текущие настройки
Выход | Завершение работы с программой (Ctrl+Q).
Вид
Панели значений | Меню управления панелями значений.
Каскадом | Расположить все открытые панели значений в каскадном порядке.
Закрыть все | Скрыть все панели значений.
Время | Показать панель времени.
#: [Имя канала] | Показать панель значений соответствующего канала (список каналов от 1 до 32).
Изменить масштаб шкалы времени | Масштаб шкалы X | Выбор масштаба шкалы X (список масштабов)
X Zoom Out | Уменьшить | Уменьшить масштаб шкалы X (Shift+[-])
X Zoom In | Увеличить | Увеличить масштаб шкалы X (Shift+[+])
Сервис
Общее меню каналов и графиков | Каналы и графики | Общее меню каналов и графиков:
Количество графиков | Выбор количества графиков (от 1 до 32)
Выравнивание | Вертикальное выравнивание графиков:
Распределить графики по вертикали | Распределить по вертикали | Распределить графики по вертикали
Совместить базовые уровни | Совместить базовые уровни | Совместить базовые уровни графиков
Совместить сетки | Совместить сетки | Совместить сетки графиков
Шкала Y | Выбор единого масштаба шкалы Y для всех графиков (список масштабов)
Уменьшить все | Уменьшить масштаб шкалы Y всех графиков (Alt+[-])
Увеличить все | Увеличить масштаб шкалы Y всех графиков (Alt+[+])
Выбор драйвера АЦП | Выбор АЦП... | Вызвать окно выбора АЦП
Настройки драйвера АЦП | Настройки "АЦП"... | Вызвать окно индивидуальных настроек АЦП
Входной усилитель | Входной Усилитель... | Вызвать окно Входной Усилитель (Ctrl+I)
Частота регистрации | Выбор частоты регистрации данных
Синхронизация | Синхронизация... | Вызвать окно синхронизации записи файлов
Аналоговые выходы... | Вызвать окно управления аналоговыми выходами
Цифровые выходы... | Вызвать окно управления цифровыми выходами
Options | Параметры... | Вызвать окно дополнительных параметров (F9)
Канал | Индивидуальное меню активного канала
График | Выбор канала для активного графика (список каналов от 1 до 32)
Шкала Y | Выбор масштаба шкалы Y активного графика (список масштабов)
Уменьшить масштаб шкалы амплитуды | Уменьшить | Уменьшить масштаб шкалы Y активного графика (Ctrl+[-])
Увеличить масштаб шкалы амплитуды | Увеличить | Увеличить масштаб шкалы Y активного графика (Ctrl+[+])
Set Base Level | Установить базовый уровень | Установить базовый уровень графика (Ctrl+B)
Показать базовый уровень | Найти базовый уровень графика (Ctrl+F)
Настройки канала | Настройки... | Вызвать окно настроек каналов (Ctrl+F9)
Регистрация
Старт/Стоп | Запустить/остановить регистрацию данных (F5).
Запись данных | Включить/выключить сохранение данных в файл (F6).
Помощь
Справка | Справка... | Вызвать справку File Recorder (F1)
Язык справки | Выбор языка справочного руководства (Автоматически, Русский и Английский)
Конфигурация... | Дополнительная информация

Начало страницы

См. также
Утилиты


Утилита «File Viewer»

Утилита File Viewer (Просмотр файлов) входит в состав ПО «PowerGraph» и предназначена для быстрого просмотра и поиска файлов, содержащих аналоговые сигналы.

File Viewer осуществляет непосредственное чтение данных из файла без загрузки больших объемов данных в память компьютера, что позволяет максимально повысить быстродействие при работе с большим количеством файлов. Максимальный размер файлов, с которым может работать File Viewer, составляет около 2 ГБ.

Функциональные возможности

  • Быстрый переход по каталогам и файлам с одновременным графическим отображением данных.
  • Амплитудно-временное представление данных - осциллограмма сигнала.
  • Амплитудно-частотно-временное представление данных - спектрограмма сигнала.
  • Выделение произвольного участка сигнала для сохранения и экспорта данных.
  • Сохранение и копирование данных в текстовом формате.
  • Сохранение данных в звуковом и двоичном форматах.
  • Разделение длинных файлов на серию файлов меньшего размера с заданным шагом.

Поддерживаемые форматы файлов

  • PowerGraph Chart (*.pgс) - файлы программы «PowerGraph» (начиная с версии 3.2). Могут содержать несколько независимых блоков данных и текстовые метки (комментарии) отдельных точек сигнала.
  • Binary (*.bin) - бинарные файлы, записанные утилитой «File Recorder».
  • Raw Data (*.dat) - произвольные двоичные файлы. В случае файлов, записанных программами «L-Graph» (ЗАО «Л-Кард») и «RTViewer» (НПГ «R-Technology»), параметры данных (количество каналов, частота регистрации и т.д.) считываются из соответствующего файла параметров (*.par, *.rvp). В остальных случаях двоичные данные интерпретируются как один канал.
  • Waveform Audio (*.wav) - звуковые файлы в формате Windows PCM. Поддерживаются несжатые 16-битные звуковые данные до 32 каналов.
  • WinDaq (*.wdq) - файлы программы «WinDaq» (DATAQ Instruments, Inc.).
  • Axon Binary(*.abf) - файлы Axon Binary (Axon Instruments, Inc.).
  • Peak Files (*.pk, *.sfk) - образы сигналов, созданные для ускорения загрузки файлов различными звуковыми редакторами («Cool Edit», «Sound Forge»).

Пользовательский интерфейс

Главное окно File Viewer состоит из следующих функциональных частей:
  1. Меню и панель инструментов - обеспечивают доступ ко всем операциям.
  2. Служебные панели - позволяют выбирать каталоги, файлы и каналы для просмотра данных.
  3. Осциллографический дисплей - содержит осциллограммы сигналов выбранного файла.
  4. Спектральный дисплей - содержит спектрограмму одного из каналов выбранного файла.
  5. Строка состояния - отображает параметры открытого файла.

Служебные панели

Служебные панели расположены в правой части окна File Viewer:

Панель "Папки" (Folders)

Панель Папки (активация клавишей F5) содержит список дисков и дерево каталогов компьютера, позволяющие выбрать текущую папку для просмотра файлов. Кнопка, расположенная в левой верхней части панели, вызывает список папок, в которых были обнаружены файлы с данными.

Панель "Файлы" (Files)

Панель Файлы (активация клавишей F6) содержит список всех файлов выбранной папки. При выборе любого элемента списка соответствующий файл автоматически открывается для просмотра.

Панель "Блоки" (Blocks)

В панели Блоки (активация клавишей F7) содержит список блоков данных открытого файла. Некоторые файлы, например файлы программы «PowerGraph», могут содержать несколько независимых блоков данных. При открытии очередного файла программа автоматически отображает данные первого блока, список блоков позволяет выбирать остальные блоки для просмотра данных.

Панель "Каналы" (Channels)

Панель Каналы (активация клавишей F8) содержит список всех каналов открытого файла и выбранного блока. Список каналов содержит цвет графика, порядковый номер канала АЦП и название канала. Флажок напротив каждого канала позволяет включить или отключить отображение графика в осциллографическом дисплее, а выбор любого элемента в списке позволяет выбрать соответствующий канал для отображения спектрограммы.

Панель значений

Панель значений - дополнительная "всплывающая" панель, автоматически появляющаяся в правой нижней части окна программы при перемещении курсора мыши над областью графических данных. Содержит численные значения времени и амплитуды сигналов в точке под курсором, а также параметры области выделения.

Осциллографический дисплей

Осциллографический дисплей содержит амплитудно-временное представление данных - осциллограммы сигналов. Осциллографический дисплей состоит из области построения графиков, шкалы амплитуды и шкалы времени и может отображать графики одного или нескольких каналов, отмеченных в списке каналов (панель "Каналы"). При выборе другого файла или блока графические данные осциллографического дисплея автоматически обновляются.

При перемещении курсора мыши над графическим дисплеем, по каждому из графиков перемещается "скользящий" маркер, указывающий соответствующую точку данных. Численные значения времени и амплитуды сигналов в точке под маркером отображаются в панели значений.
Перемещение курсора в области шкалы амплитуды или шкалы времени при нажатой левой кнопе мыши позволяет изменять положение данных в графическом дисплее по вертикали или горизонтали. Кнопки навигации, расположенные слева от шкалы времени, предоставляют возможность быстрого перехода к различным участкам файла (предыдущая или следующая страница, начало или конец файла). Для перемещения области просмотра данных также можно использовать клавиши навигации на клавиатуре: ←, →, ↑, ↓, HOME, END, PAGE UP и PAGE DOWN.

Дополнительные команды управления осциллографическим дисплеем содержатся в меню Вид, График и Каналы.

Options... Дополнительные параметры отображения

File Viewer позволяет выбрать параметры графического отображения данных (формат шкалы времени и шкалы амплитуды, цвет и стиль масштабной сетки, форму маркеров значений). Команда Параметры... (Options) в меню Файл вызывает дополнительное диалоговое окно параметров. Вкладка Общие - содержит общие настройки визуализации данных:

Формат шкалы времени

Группа Шкала времени (Time Format) содержит настройки формата значений на шкале времени:
  • От начала блока (From Start of Block) - шкала отображает значения времени, относительно начала файла. Дополнительно программа позволяет выбрать формат отображения времени:
    1. Автоматически - выбор формата отображения времени осуществляется автоматически.
    2. Часы - время отображается в системном формате (чч:мм:сс).
    3. Минуты - время отображается в минутах (min).
    4. Секунды - время отображается в секундах (s).
    5. Миллисекунды - время отображается в миллисекундах (ms).
    6. Микросекунды - время отображается в микросекундах (mks).
  • Время дня (Time of Day) - шкала отображает значения суточного времени (время в первой точке файла соответствует системному времени по часам компьютера в момент начала регистрации).
Настройки формата значений времени используются также при экспорте данных в текстовом формате (см. далее).

Формат шкалы амплитуды

Группа Шкала Амплитуды (Amplitude Format) содержит настройки формата значений на шкале амплитуды.
  • Реальные значения (Real values) - значения амплитуды отображаются в реальных единицах измерения.
  • Коды (Codes) - значения амплитуды отображаются в целочисленных кодах, соответствующих двоичным данным.
Настройки формата значений амплитуды используются также при экспорте данных в текстовом формате (см. далее).

Цвет и стиль масштабной сетки

Группа Сетка (Grid) содержит палитру для выбора цвета и переключатели для выбора стиля масштабной сетки графического дисплея:
    1. Нет (None) - масштабная сетка отсутствует.
    2. Точки (Dot) - масштабная сетка в виде точек на пересечении меток осей.
    3. Пунктир (Dot-Line) - масштабная сетка в виде точечных линий.
    4. Линии (Line) - масштабная сетка в виде сплошных линий.

Курсор значений

При перемещении курсора мыши над графическим дисплеем на каждом графике отображается "скользящий" курсор, обозначающий точку на графике. Группа Курсор значений (Waveform Cursor) позволяет выбрать форму скользящего курсора.

Spectrogram Options... Спектральный дисплей

Спектральный дисплей содержит амплитудно-частотно-временное представление данных - спектрограмму сигнала. Для спектрального анализа в программе «File View» используется алгоритм Быстрого Преобразования Фурье (рус.- БПФ, англ. - FFT).
Включение и выключение режима спектрограммы осуществляется командой Спектрограмма (Spectrogram) в меню Вид или соответствующей кнопкой панели инструментов.

Спектральный дисплей состоит из области графических данных, шкалы частот (слева) и цветовой палитры амплитуды (справа). Шкала частот содержит значения частоты в Герцах (Hz) от 0 до половины частоты дискретизации (частота Найквиста). Палитра амплитуды содержит градации цвета, соответствующие амплитуде сигнала от 0 до максимального значения.

Шкала времени спектрального дисплея соответствует шкале времени осциллографического дисплея, что позволяет одновременно сравнивать осциллограмму и спектрограмму сигнала. При построении спектрограммы рассчитывается амплитудно-частотный спектр сигнала для каждой точки шкалы времени, значение каждой спектральной составляющей отображается в виде интенсивности цвета в соответствующей точке шкалы частот.
Шаг (количество значений) между соседними спектральными окнами соответствует масштабу шкалы времени - каждому пикселю экрана по горизонтали соответствует один спектр.

В отличие от осциллографического дисплея спектральный дисплей может отображать спектрограмму только одного канала, выбор которого осуществляется в списке каналов (панель "Каналы"). Для построения спектрограммы требуется определить максимальное значение амплитуды на всем протяжении сигнала, поэтому при открытии очень больших файлов может возникать ощутимая задержка отображения данных. В этом случае для быстрого перемещении по списку файлов следует временно отключить режим спектрограммы.

Дополнительные параметры спектрограммы

Дополнительные настройки спектрального отображения сигналов содержатся на вкладке Спектрограмма окна параметров, которое вызывается командой Параметры... (Options) в меню Файл:

Тип спектра

Группа Тип спектра (Spectral Plot Style) позволяет выбрать тип шкалы амплитуды при отображении спектра:
  • Линейная шкала (Linear Energy Plot) - линейная шкала амплитуды. Масштаб (Scaling) задается в процентах (%) от максимального значения и позволяет изменить интенсивность различных уровней амплитуды.
  • Логарифмическая шкала (Logarithmic Energy Plot) - логарифмическая шкала амплитуды. Диапазон (Range) задается в децибелах (dB) от максимального значения.

Цветовая схема

Группа Палитра (Palette) позволяет выбрать цветовую схему палитры спектрограммы. Изменить цветовую схему можно также щелчком мыши на палитре спектрального дисплея.

Весовая функция

Раскрывающийся список Весовая функция (Window) - позволяет выбрать тип весовой (оконной) функции, используемой при спектральном анализе.

Размер спектрального окна

Раскрывающийся список Размер БПФ (FFT Size) - позволяет выбрать количество значений, используемых при БПФ (размер спектрального окна, размер выборки). Количество частотных полос, полученных при спектральном анализе, соответствует половине размера БПФ плюс одна полоса постоянной составляющей (DC). Увеличение размера БПФ приводит к увеличению разрешающей способность по частоте (увеличению количества частотных полос), но требует большего времени для проведения вычислений.

Выделение участка сигнала

File Viewer позволяет выделить в графическом дисплее произвольный участок данных. Для выделения участка необходимо перемещать курсор в области данных удерживая левую кнопку мыши. Для изменения границы существующей области выделения следует нажать на клавиатуре клавишу Shift.
При изменении границ области выделения, а также при перемещении курсора над областью выделения, в панели значений отображаются параметры выделенного участка данных.
Область выделения используется для сохранения или копирования только выделенного участка данных:
  • Команда Сохранить как... (Save As...) в меню Файл - сохранить выделенный участок данных в файл.
  • Команда Копировать данные (Copy Data) в меню Правка - копировать выделенный участок данных в буфер обмена (Clipboard) в текстовом формате.
При отсутствии области выделения в графическом дисплее эти команды осуществляют сохранение и копирование всех данных открытого файла.

Экспорт данных в текстовом формате

File Viewer позволяет экспортировать данные открытого файла в текстовом формате. Если графический дисплей содержит область выделения, то в тестовый формат экспортируется только выделенный участок данных. Если область выделения отсутствует, то в тестовый формат экспортируются все данные файла.
Для экспорта данных в текстовом формате используются следующие команды меню:
  • Команда Копировать данные (Copy Data) в меню Правка - копировать данные в буфер обмена (Clipboard).
  • Команда Сохранить как... (Save As...) в меню Файл - сохранить данные в тестовый файл. В появляющемся диалоговом окне следует указать имя нового файла и выбрать текстовый тип файла (Text).
  • Команда Быстрый экспорт (Fast Export) в меню Файл - сохранить данные в текстовый файл, указанный в настройках экспорта данных (см. далее). File Viewer предоставляет дополнительную возможность "быстрого" экспорта данных в текстовом формате, которая позволяет избежать появления стандартного окна выбора файла при сохранении. Функция быстрого экспорта позволяет также уменьшить количество временных файлов при переносе данных в другие программы, так как экспортируемые данные сохраняются в предварительно указанный файл ("быстрый" файл), который перезаписывается при каждой операции экспорта.
Дополнительные настройки экспорта данных в текстовом формате содержатся на вкладке Экспорт в текст окна параметров, которое вызывается командой Параметры... (Options) в меню Файл:

Export to Text

Текстовый формат

Группа Текстовый формат (Text Format) позволяюет включить в текстовый файл дополнительную информацию:
  • Размер (Size) - включить строку, содержащую количество записываемых значений.
  • Частота (Rate) - включить строку, содержащую частоту регистрации (в Герцах).
  • Шаг (Step) - включить строку, содержащую шаг по времени между соседними значениями (в секундах).
  • Заголовки (Headers) - включить строку с заголовками столбцов.
  • Столбец X (X Column) - включить столбец, содержащий значения шкалы X (первый столбец):
    1. Время (Time) - первый столбец содержит значения времени.
    2. Индексы (Indexes) - первый столбец содержит порядковые номера строк (начиная с 0).

Экспортируемые каналы

Группа Каналы (Channels) позволяет выбрать режим экспорта каналов:
  • Видимые (Selected) - экспортируются только видимые каналы.
  • Все (All) - экспортируются все каналы.

Запись данных в файлы

Группа Файлы (Files) позволяет выбрать режим записи данных в файл:
  • Один файл (Single File) - все данные записываются в один файл.
  • Файл на канал (File by Channel) - данные каждого канала записываются в отдельный файл (к базовому имени файла добавляется номер канала).

Быстрый экспорт данных

Группа "Быстрый" файл (Fast file) - позволяет указать имя файла для быстрого экспорта данных в текстовом формате.

Split File... Разделение файлов

File Viewer позволяет разделять (разрезать) длинные файлы на серию файлов меньшего размера. При разделении все данные исходного файла разбиваются на равные участки, которые сохраняются в отдельные файлы. Исходный файл, подвергающийся разделению, называется - "разделяемым", а файлы образующиеся в результате разделения - "разделенными".

Операции разделения осуществляются в дополнительном диалоговом окне программы, которое вызывается командой Разделить файл... (Split File) в меню Файл:

Способ разделения файла

Группа Параметры разделения (Split by) позволяет выбрать способ и параметры разделения исходного файла:
  • По количеству точек (Number of Samples) - при разделении исходных данных на участки используется количество точек.
  • По времени (Time) - при разделении исходных данных на участки используются значения времени (в секундах).
Параметры разделения:
  • Шаг (Step) - шаг между началом двух соседних участков (в количестве точек или в секундах).
  • Размер (Size) - размер каждого участка данных (в количестве точек или в секундах).
Параметры Шаг и Размер являются независимыми, поэтому исходные данные могут быть записаны в разделенные файлы с пропусками (Шаг > Размер), с перекрытиями (Шаг < Размер) или непрерывно (Шаг = Размер).

Имена разделенных файлов

Группа Формат имени файла (File Name Format) позволяет выбрать способ формирования имени разделенного файла:
  • Базовое имя (Base Name) - имя разделенного файла будет начинаться с имени исходного файла.
  • Номер файла (Index of File) - имя разделенного файла будет включать порядковый номер файла (начиная с 1).
  • Индексы точек (Indexes of Samples) - имя разделенного файла будет включать индексы первой и последней точек, сохраняемых в этом файле (начиная с 0).

Расположение разделенных файлов

Группа Путь к файлам (Path) отображает путь к папке, в которую будут записаны разделенные файлы, а также имена файлов в процессе разделения.
File Viewer создает в папке с исходным файлом новую папку с именем этого файла (базовое имя) и записывает в нее разделенные файлы. Флажок Удалить предыдущие файлы (Delete previous files) позволяет удалить все файлы, записанные в результате предыдущих операций разделения данного файла.

Строка состояния

Строка состояния отображает параметры открытого файла:
Элемент | Показывает
R: # | Текущий масштаб шкалы амплитуды: R - реальные значения, C - целочисленные коды.
#,##% | Видимая часть открытого файла.
... | Статус текущей операции.
S: # ### | Размер открытого файла (количество значений для каждого канала).
T: #,### s | Длительность записи файла (в единицах времени).
Fs: ##,# Hz | Частота регистрации данных (Гц).
V: #,## KB | Объем данных (в байтах).
DD.MM.YY hh:mm:ss | Дата и время начала записи файла.

Меню и панель инструментов

Файл |  |
Save As... | Сохранить как... | Сохранить все данные или выделенный участок в указанный файл (Ctrl+S).
Fast Export | Быстрый экспорт | Сохранить все данные или выделенный участок в файл быстрого экспорта (Ctrl+E).
Split File... | Разделить файл... | Разделить файл на части (Ctrl+R).
Options... | Параметры... | Дополнительные параметры программы (F9).
 | Выход | Завершение работы с программой (Ctrl+Q).
Правка |  |
Copy Data | Копировать данные | Копировать все данные или выделенный участок в буфер обмена (Ctrl+C).
Copy Image | Копировать изображение | Копировать изображение графического дисплея в буфер обмена.
Вид |  |
 | Папки | Активировать панель "Папки" (F5).
 | Каналы | Активировать панель "Каналы" (F8).
 | Файлы | Активировать панель "Файлы" (F6).
 | Блоки | Активировать панель "Блоки" (F7).
Spectrogram | Спектрограмма | Включить/выключить режим спектрограммы.
X Zoom | Масштаб шкалы X | Выбрать масштаб шкалы X.
X Zoom Out | Уменьшить | Уменьшить масштаб шкалы X (Shift+[-]).
X Zoom In | Увеличить | Увеличить масштаб шкалы X (Shift+[+]).
Start of File | В начало | Переход к началу файла/блока (Home).
Previous Page | Предыдущая страница | Показать предыдущую страницу (PgUp).
Next Page | Следующая страница | Показать следующую страницу (PgDn).
End of File | В конец | Переход к концу файла/блока (End).
График |  |
 | Шкала Y | Выбрать масштаб шкалы Y.
Y Zoom Out | Уменьшить | Уменьшить масштаб шкалы Y (Ctrl+[-]).
Y Zoom In | Увеличить | Увеличить масштаб шкалы Y (Ctrl+[+]).
Set Bipolar | Биполярное положение | Биполярное положение шкалы Y (Ctrl+B).
Find Data | Показать данные | Найти данные (Ctrl+F).
Каналы |  |
 | Выбрать все | Показать графики всех каналов (Ctrl+A).
 | Очистить выбор | Скрыть графики всех каналов (Ctrl+D).
 | Инвертировать выбор | Скрыть графики видимых каналов и показать графики скрытых каналов (Ctrl+I).
Помощь |  |
Help | Справка... | Вызвать справку File Viewer.
 | Язык справки | Выбор языка справочного руководства (Автоматически, Русский и Английский)

Начало страницы

См. также
Утилиты


Утилита «License Query»

Утилита License Query (Запрос Лицензии) предназначена для создания запроса в службу технической поддержки на получение OEM-лицензий ПО «PowerGraph».
Коммерческие версии ПО «PowerGraph» работают только с устройствами сбора данных, для который предоставлена OEM-лицензия (право на использование ПО с данным оборудованием). Для получения OEM-лицензий необходимо передать в службу технической поддержки информацию об используемых устройствах сбора данных.
Подробнее о лицензиях см. раздел - «Лицензирование ПО».

License Query позволяет обнаружить все устройства сбора данных, подключенные к компьютеру, а также определить их тип, серийный номер и технические параметры:

Поиск подключенных устройств начинается непосредственно при запуске License Query, поэтому для продолжения работы необходимо дождаться завершения процедуры поиска.
Для правильного определения подключенных устройств, перед запуском License Query необходимо завершить работу всех программ, использующих устройства сбора данных.
В верхней части окна License Query находится таблица, содержащая параметры обнаруженных устройств. Эту информацию следует передать в службу технической поддержки ПО «PowerGraph» в виде запроса.

Создание запроса

Для создания запроса на получение лицензии необходимо выполнить следующие действия:
  1. Выбрать устройства сбора данных - в списке обнаруженных устройств следует отметить устройства, для которых Вы хотите получить лицензию ПО «PowerGraph».
  2. Заполнить информацию о пользователе - под списком обнаруженных устройств находятся текстовые поля, в которые следует ввести информацию о пользователе (поля помеченные жирным шрифтом - обязательны для заполнения):
    • Фамилия - фамилия пользователя.
    • Имя - имя (отчество) пользователя.
    • E-Mail - электронный адрес пользователя. В этом поле необходимо указать действительный адрес электронной почты, на который будет отправлена вся необходимая информация о лицензии.
    • Код - междугородний (международный) телефонный код города.
    • Телефон - городской номер телефона.
    • Факс - городской номер факса.
    • Организация, адрес, примечания - дополнительная информация, которую необходимо передать в службу технической поддержки (реквизиты для выставления счета, информация об оплате, почтовый адрес получателя программы и др.).
  3. Сохранить запрос в файл - после выбора устройств и заполнения информации о пользователе следует нажать кнопку Сохранить запрос..., расположенную в нижней части окна, и указать имя файла.
Сохраненный файл запроса следует отправить по электронной почте в службу технической поддержки ПО «PowerGraph»:
soft@powergraph.ru

См. также
Техническая поддержка, Лицензирование ПО


Приложения

А. Определения и обозначения.
Б. Функции скользящего значения.
В. Весовые (оконные) функции.
Г. Обработка сигналов в режиме реального времени.


Приложение А. Определения и обозначения

ADC
Baseline, Block
Chart, Channel, Correlation, Covariation
Deviation, Duration
Graph
Input Amplifier
Maximum, Mean, Median, Minimum, Mode
Range, Resolution
Samples, Sampling Rate, Scale, Selection
Variance

  • ADC - Аналого-Цифровой Преобразователь (АЦП). Физическое устройство осуществляющее аналого-цифровое преобразование сигналов и ввод их в компьютер. Основные характеристики: разрядность (разрешающая способность), количество аналого-цифровых каналов, диапазоны измерений (коэффициенты усиления) каналов, максимальная частота преобразований и т.д.
  • Resolution - разрешающая способность АЦП, измеряемая в битах (bit), т.е. показатель степени числа 2.
  • Channel, Ch - аналого-цифровой канал, осуществляющий прием данных от одного источника сигналов. Количество аналого-цифровых каналов зависит только от типа АЦП. Максимальное количество аналого-цифровых каналов, поддерживаемых программой «PowerGraph», составляет 32 (начиная с версии 3.2, в предыдущих версиях - 16). Программа поддерживает произвольный выбор каналов для записи, обозначение каналов осуществляется нумерацией от 1 до 32 (Ch1-Ch32), а также собственными названиями каналов (указывается пользователем или предопределено в драйвере АЦП). Каждый канал имеет следующие независимые параметры: диапазон измерения (коэффициент усиления - см. ниже), настройки входной коррекции сигнала (смещение, инвертирование) цвет графика и тип заливки (заливка цветом осуществляется от 0 до текущего значения амплитуды, что существенно облегчает определение текущего уровня сигнала), позицию и масштаб графика (по вертикали).
  • Range - диапазон амплитуды, в переделах которого осуществляется регистрация входного сигнала. В программе «PowerGraph» при изменении этого диапазона происходит переключение коэффициента усиления для соответствующего аналого-цифрового канала.
  • Input Amplifier - входной усилитель. В программе «PowerGraph» используется программный входной усилитель, позволяющий провести мониторинг входного сигнала для каждого из каналов, установить диапазон измерений и провести первичную коррекцию сигнала.
  • Graph, G - график одного из аналого-цифровых каналов. Каждый график может содержать данные любого (но только одного) аналого-цифрового канала, или вообще не содержать данных. Данные каждого аналого-цифрового канала могут отображаться в только в одном графике. Максимальное количество графиков, поддерживаемых программой «PowerGraph», также составляет 32, обозначение графиков осуществляется нумерацией от 1 до 32 (G1-G32). Количество графиков, отображаемых на ленте самописца, может отличаться от количества записанных каналов.
  • Scale - масштаб шкалы.
  • Baseline - базовая линия (нулевое значение амплитуды).
  • Chart - общий набор записанных данных и их графическое представление (лента самописца). Chart содержит данные всех записанных блоков и параметры каналов.
    Chart - это также название основного документа программы «PowerGraph». Программа использует свой собственный формат файлов ("PowerGraph Chart", файлы с расширением "pgc"), разработанный для наиболее эффективного хранения аналого-цифровых данных, параметров отображения и пользовательских настроек.
  • Block, B - непрерывный набор данных (блок). Программа «PowerGraph» осуществляет запись сигналов блоками. Каждый блок содержит данные одной записи, которая характеризуется следующими параметрам: тип АЦП, количество и номера аналого-цифровых каналов, частота регистрации, количество записанных значений, время записи (зависит от двух предыдущих). Для каждого из блоков эти параметры независимы. Для каждого блока фиксируется дата и время начала записи. Последовательность блоков в общей записи может быть изменена в соответствии с более логичной последовательностью измерений. Большинство операций редактирования и обработки также осуществляется с блоками данных.
  • Sampling Rate, Rate - частота регистрации данных, соответствует определению "частота дискретизации", т.е. количество записанных значений в единицу времени. Важное практическое значение имеет параметр "максимальная частота регистрации", который полностью зависит от типа АЦП и характеризуется временем, за которое осуществляется одно аналого-цифровое преобразование. Программа «PowerGraph» поддерживает любые частоты регистрации данных.
  • Duration - продолжительность записи в единицах времени.
  • Samples - количество записанных значений.
  • Selection - область выделения.

Статистические определения

  • Maximum, Max - максимальное значение.
  • Minimum, Min - минимальное значение.
  • Mean - среднее значение.
  • Median - медиана выборки.
  • Mode - мода выборки.
  • Variance - дисперсия выборки.
  • Deviation, Standard Deviation - стандартное отклонение.
  • Correlation - корреляция (линейный коэффициент корреляции).
  • Covariation - ковариация.

См. также
ПО «PowerGraph»


Приложение Б. Функции скользящего значения.

К функциям скользящего значения относятся функции, в которых для получения одного расчетного значения используется несколько последовательных значений исходного сигнала - окно заданного размера N. Для вычисления каждого очередного значения окно смещается вдоль исходного сигнала (скользящее окно):

В режиме пост-обработки результат вычисления скользящего значения соответствует центральной точке окна. При вычислении каждого значения используются как предшествующие, так и последующие значения исходного сигнала, что приводит к точному соответствию исходных и расчетных данных на оси времени.

В режиме реального времени при вычислении скользящего значения могут быть использованы только предшествующие значения исходного сигнала, что приводит к смещению расчетных данных относительно исходных на величину, равную половине скользящего окна - N/2.
Особенности работы функций математической обработки сигналов в режиме реального времени описаны в Приложении Г.

Краевые эффекты

При вычислении скользящего значения для начального и конечного участков сигнала возникает проблема отсутствия предшествующих и последующих значений:

Отсутствие предшествующих и последующих значений может приводить в некоторых случаях к погрешностям вычислений, которые наблюдаются на начальном и конечном участках сигнала, соответствующим половине скользящего окна - N/2.

Список функций скользящего значения

В состав библиотеки функций математической обработки сигналов программы «PowerGraph» входят следующие функции вычисления скользящего значения:

Категория | Функция | Описание
Smoothing | Smooth... | вычисление скользящего среднего значения с использованием различных весовых коэффициентов
Filters | MedianFilter | вычисление скользящей медианы (медианный фильтр)
Statistic | RMSPt | вычисление скользящего среднеквадратичного значения
 | StdDevPt | вычисление скользящего значения стандартного отклонения
 | MaxPt | вычисление скользящего максимального значения
 | MinPt | вычисление скользящего минимального значения
 | RangePt | вычисление скользящего диапазона значений (Max - Min)
 | CrossCorrelationPt | вычисление скользящего коэффициента корреляции двух сигналов
Differential | DiffPt DiffPtNorm DiffRC | дифференцирование данных по заданному количеству точек
Integral | IntegralRC | интегрирование данных по заданному количеству точек
 | AreaPt | вычисление общей площади под кривой по заданному количеству точек
 | AreaPositivePt | вычисление положительной площади под кривой по заданному количеству точек
 | AreaNegativePt | вычисление отрицательной площади под кривой по заданному количеству точек

Функции частотной фильтрации

К функциям скользящего значения также относятся функции частотной фильтрации (категория FIR Filters), в которых размер скользящего окна выбирается автоматически в зависимости от частоты фильтра.


Приложение В. Весовые (оконные) функции.

При анализе длительных сигналов, как правило, обработке подвергается не весь сигнал целиком, а его последовательные выборки, т.е. участки сигнала определенного размера. Участок сигнала, используемый для обработки и анализа, называется окном.
При работе с окнами используют также взвешивание - каждое значение выборки умножается на определенный весовой коэффициент:

X'i = Wi * Xi
Взвешивание обычно используют для обнуления сигнала на краях выборки, что позволяет устранить разрывы между последовательными выборками (окнами) сигнала, поэтому весовые коэффициенты, как правило, принимают значения от 0 (на краях выборки) до 1 (в центре выборки).

Определенный набор весовых коэффициентов называется весовой функцией. Весовые функции используются при спектральном анализе сигналов для уменьшения явления растекания спектра, а также при цифровой фильтрации сигналов для формирования коэффициентов фильтров.

Аналитические выражения весовых функций.

Triangle - треугольное окно:

Wi = 1 - |2 * i - N| / N

Hann - окно Ханна:

Wi = 0.5 - 0.5 * cos(2p * i / N)

Hamming - окно Хемминга:

Wi = 0.54 - 0.46 * cos(2p * i / N)

Blackman - стандартное окно Блэкмана:

Wi = 0.42 - 0.5 * cos(2p * i / N) + 0.08 * cos(4p * i / N)

BlackmanOpt - оптимальное окно Блэкмана.

BlackmanExact - точное окно Блэкмана:

Wi = A1 - A2 * cos(2p * i / N) + A3 * cos(4p * i / N)
где A1 = 7938/18608, A2 = 9240/18608, A3 = 1430/18608

BlackmanHarris - окно Блэкмана-Харриса:

Wi = 0.42323 - 0.49755 * cos(2p * i / N) + 0.07922 * cos(4p * i / N)

Bisquare - биквадратное окно:

Wi = (1 - (i - 0.5 * N + 0.5)² / (0.5 * N - 0.5)²)²

KaiserX - окно Кайзера (X - параметр окна).

KaiserBessel - окно Кайзера-Бесселя:

Wi = 0.40243 - 0.49804 * cos(2p * i / N) + 0.09831 * cos(4p * i / N) - 0.09831 * cos(6p * i / N)

Nuttall3 - 3-х компонентное окно Наттолла:

Wi = 0.4243801 - 0.4973406 * cos(2p * i / N) + 0.0782793 * cos(4p * i / N)

Nuttall4 - 4-х компонентное окно Наттолла:

Wi = 0.3635819 - 0.4891775 * cos(2p * i / N) + 0.1365995 * cos(4p * i / N) - 0.0106411 * cos(6p * i / N)

RifeVincentX - степенное окно Ханна (X - показатель степени):

Wi = (0.5 - 0.5 * cos(2p * i / N))X

WelchX - окно Уэлча (X - показатель степени):

Wi = 1 - ((N - 2 * i) / N)X

FlatWelch - 50% окно Уэлча.

FlatTriangle - 50% треугольное окно.

FlatCosine - 50% окно Ханна.

FlatBisquare - 50% биквадратное окно.


Приложение Г. Обработка сигналов в режиме реального времени.

В состав программы «PowerGraph» входит библиотека функций математической и цифровой обработки сигналов, предназначенных для проведения вычислений и получения расчетных данных. Функции обработки сигналов могут быть использованы как после окончания регистрации (режим пост-обработки), так и непосредственно в процессе получения данных с различных устройств (режим реального времени).

В отличие от пост-обработки, обработка сигналов в режиме реального времени имеет следующие существенные особенности:

  • Ограниченное время вычислений. В процессе регистрации основной задачей компьютера является своевременное считывание данных из устройства, осуществляющего измерение и преобразование входных сигналов. В режиме реального времени результат расчетов должен быть получен до поступления очередной части данных, так как чрезмерная загрузка центрального процессора вычислениями может приводить к пропускам и потерям данных.
    В режиме пост-обработки время вычислений неограниченно и зависит только от производительности компьютера.
  • Отсутствие полной информации о сигнале. В режиме реального времени обработке могут подвергаться только данные, полученные к текущему моменту, последующие изменения сигнала остаются неизвестными.
    В режиме пост-обработки в вычислениях могут быть использованы все данные.
Эти факторы определенным образом ограничивают использование функций обработки сигналов в режиме реального времени.

Формулы вычислений

В связи с ограничением времени вычислений в программе «PowerGraph» общее количество формул, используемых для вычислений в режиме реального времени, не превышает максимального количества каналов. Для каждого канала в режиме реального времени допускается использовать только одну формулу вычислений.
Подробнее о выборе формул обработки в режиме реального времени см. в разделе "Настройки каналов: Обработка RT"

Функции обработки сигналов

Ограничение времени вычислений и отсутствие полной информации о сигнале не позволяет использовать в режиме реального времени следующие функции:
  • Использующие сложные алгоритмы обработки сигналов, требующие существенного времени для вычислений.
  • Использующие для вычислений все данные - от первого до последнего значения сигнала (например, определение максимального значения).
В связи с этим, в программе «PowerGraph» ограничен набор функций обработки сигналов, используемых в режиме реального времени. Функции, доступные для использования в режиме реального времени, отмечены в описании функций символом RT (англ. - Real Time).

Функции скользящего значения

К функциям скользящего значения относятся функции, в которых для получения одного расчетного значения используется несколько последовательных значений исходного сигнала - окно заданного размера N. Для вычисления каждого очередного значения окно смещается вдоль исходного сигнала (скользящее окно). К функциям скользящего значения относятся сглаживающие и частотные фильтры, а также статистические, дифференцирующие и интегрирующие функции (см. также Приложение Б).
Использование функций скользящего значения в режиме пост-обработки и в режиме реального времени имеет принципиальные отличия.

Режим пост-обработки

В режиме пост-обработки результат вычисления скользящего значения соответствует центральной точке окна на оси времени. При вычислении каждого значения используются как предшествующие, так и последующие значения исходного сигнала.

Режим реального времени

В режиме реального времени результат вычисления скользящего значения соответствует последней точке окна на оси времени. При вычислении каждого значения используются только предшествующие значения исходного сигнала, так как последующие значения в момент вычислений неизвестны.

Использование в вычислениях только предшествующих значений приводит к смещению расчетных данных относительно исходных на величину, равную половине скользящего окна - N/2:

Точность вычислений

В режиме пост-обработки известна все последовательность сигнала, в том числе его минимальное и максимальное значения. Это позволяет наиболее точно преобразовать реальные аналоговые сигналы в цифровую дискретную форму, имеющую фиксированные пределы возможных значений.
В режиме реального времени точные максимальное и минимальное значения неизвестны, так как в момент вычислений неизвестна вся последовательность сигнала. Для преобразования аналоговых сигналов в цифровую дискретную форму в режиме реального времени в качестве минимального и максимального значений используются допустимые (предполагаемые) пределы амплитуды, которые могут отличаться от реального диапазона изменения сигнала. Это может приводить к меньшей точности вычислений в режиме реального времени по сравнению с режимом пост-обработки.

Рекомендации

Использование обработки сигналов в режиме реального времени позволяет наиболее полно контролировать процесс измерений и анализировать состояние исследуемых объектов, однако вычисления в режиме реального времени имеют ряд описанных выше особенностей и ограничений. Для получения более точных и адекватных результатов вычислений рекомендуется проводить повторную обработку сигналов после окончания регистрации (в режиме пост-обработки).


Техническая поддержка ПО «PowerGraph»

Пользователи коммерческих версий ПО «PowerGraph» имеют право на получение технической поддержки. Любые вопросы, пожелания и предложения по работе ПО «PowerGraph» Вы можете направлять в службу технической поддержки по электронной почте:

soft@powergraph.ru
Письма, которые Вы направляете в службу технической поддержки, должны содержать понятные формулировки вопросов, подробное описание возникшей ситуации, тип используемого устройства, а также версии операционной системы и ПО «PowerGraph».

Справочное руководство

Данное справочное руководство содержит следующие разделы технической поддержки ПО «PowerGraph»:
  • Вопросы и Ответы - ответы на часто задаваемые вопросы (FAQ).
  • Проблемы и Решения - причины и способы решения возникающих проблем.
  • Обновление ПО - условия и правила обновления программного обеспечения.
  • Лицензирование ПО - условия и правила получения лицензий на программное обеспечение.

Техническая поддержка в Интернет

Дополнительную информацию о программном обеспечении «PowerGraph» Вы можете получить на Интернет-сайте программы:
http://www.powergraph.ru
Разделы технической поддержки ПО «PowerGraph» в Интернет:
  • Новости - информация о новых возможностях ПО.
  • Конференция - публичное обсуждение технических вопросов.
  • Вопросы и Ответы - ответы на часто задаваемые вопросы (FAQ).
  • Отправить письмо - страница, позволяющая отправить письмо в службу технической поддержки.
  • Обновление ПО - получение новых версий ПО через Интернет.

Услуги по разработке программного обеспечения

Подключение новых устройств сбора данных

Программное обеспечение «PowerGraph» позволяет использовать для регистрации данных практически любые источники сигналов: внутренние платы и внешние модули АЦП, цифровые датчики и приборы, компьютерные устройства ввода и звукозаписи, виртуальные генераторы сигналов и др. Поддержка широкого спектра устройств сбора данных осуществляется за счет расширяемой библиотеки драйверов. Процесс подключения нового устройства включает разработку PowerGraph-совместмого драйвера, после чего устройство становится доступным для всех программ, входящих в состав ПО "PowerGraph".

Доработка ПО «PowerGraph» по индивидуальному заказу

Программное обеспечение «PowerGraph» постоянно развивается и совершенствуется. Тем не менее, если функциональных возможностей текущей версии недостаточно для решения ваших задач, программное обеспечение «PowerGraph» может быть доработано по индивидуальному техническому заданию. Доработка ПО «PowerGraph» включает: добавление новых функций и алгоритмов обработки сигналов, разработку новых инструментов анализа и визуализации данных, поддержку различных файловых форматов и др.

Создание специализированного ПО

Программное обеспечение «PowerGraph» обладает широкими возможностями для регистрации, визуализации, обработки и анализа данных, что позволяет создавать на его основе законченные специализированные программы любого уровня - от простых утилит регистрации данных до мощных программ, реализующих комплексные методы обработки сигналов по заданному алгоритму.
Адаптация существующего универсального программного обеспечения к специализированным системам сбора данных позволяет получить значительный экономический эффект за счет уменьшения затрат на разработку собственных программ "с нуля".


Вопросы и ответы

Этот раздел содержит ответы на часто задаваемые вопросы:
  1. Почему программа не находит АЦП?
  2. Могу ли я записывать данные со звуковой карты?
  3. Как увеличить чувствительность измерения входного сигнала?
  4. Как избавиться от постоянной составляющей сигнала?
  5. Как удалить из сигнала шумы?
  6. Как получить в третьем канале сумму двух других каналов?
  7. Как перенести данные из одного блока в другой?

1. Почему программа не находит АЦП?

Смотри раздел «Проблемы и решения».

2. Могу ли я записывать данные со звуковой карты?

Да. При загрузке программы выберите драйвер звуковой карты - Sound.

3. Как увеличить чувствительность измерения входного сигнала?

Для увеличения чувствительности необходимо изменить диапазон измерения амплитуды входного сигнала (коэффициента усиления канала АЦП) в дополнительном окне программы Входной усилитель (Input Amplifier). Поле Диапазон (Range) содержит доступные для данного АЦП диапазоны измерения амплитуды сигнала.

4. Как избавиться от постоянной составляющей сигнала?

Чтобы избавиться от постоянной составляющей сигнала необходимо из каждого значения данных вычесть величину среднего арифметического, рассчитанного по всем данным. Если Вы хотите убрать постоянную составляющую записанных данных, используйте функцию математической обработки сигналов - OffsetMean.
Другой способ менее точен, но позволяет установить уровень смещения данных по оси амплитуды в ходе записи - используйте поле Смещение (Offset Data) окна Входной усилитель (Input Amplifier).

5. Как удалить из сигнала шумы?

Используйте функции математической обработки сигналов:
  • функция NoiseFilter (категория Filters) позволяет удалить из сигнала случайные выбросы и высокочастотные шумы;
  • функции категории Smoothing позволяют проводить сглаживание (усреднение) сигналов;
  • функции фильтрации LowPass (категория FIR Filters) позволяют удалить из сигнала высокочастотные составляющие.

6. Как получить в третьем канале сумму двух других каналов?

Используйте функции математической обработки сигналов - категория Arithmetics содержит функции арифметических операций с каналами. Функция "+" (оператор сложения - "плюс") позволяет вычислить сумму двух каналов. Результат вычислений может быть скопирован в любой канал.

7. Как перенести данные из одного блока в другой?

Используйте окно Дублирование данных для копирования сигналов между блоками.

См. также:
Техническая поддержка, Проблемы и решения


Проблемы и решения

Этот раздел содержит возможные причины и способы решения возникающих проблем:
  1. Программа не может обнаружить АЦП
  2. Один или несколько каналов "не регистрируются"
  3. Сигнал регистрируется "неправильно"
  4. Сигнал на экране очень "маленький"
  5. Программа "отказывается" сохранять данные

1. Программа не может обнаружить АЦП

  1. Причина: АЦП не подключен к компьютеру.
    Решение: Подключить АЦП к компьютеру.
  2. Причина: АЦП используется другой программой. Некоторые типы АЦП одновременно могут использоваться только одной программой.
    Решение: Завершить работу другой программы, использующей этот АЦП.
  3. Причина: Драйвер АЦП не установлен или функционирует некорректно.
    Решение: Установить (переустановить) драйвер АЦП.
    В комплекте с дистрибьютивом программного обеспечения «PowerGraph» поставляются системные драйвера для всех поддерживаемых устройств АЦП (файлы inf и sys в папке Drivers установочного диска). При первом подключении АЦП может появиться сообщение - «Обнаружено новое устройство», предлагающее установить драйвер для этого устройства. В этом случае укажите путь к соответствующему inf файлу, дальнейшая установка драйвера АЦП будет проходить автоматически. Для установки драйвера АЦП также можно использовать пункт «Установка оборудования» в «Панели управления» вашего компьютера.
    В ряде случаев проблемы с обнаружением АЦП могут возникать из-за несовместимости различных версий драйверов. Производители АЦП постоянно совершенствуют драйверы для своих устройств, что иногда приводит к нарушению совместимости между старыми и новыми версиями. Если на вашем компьютере уже установлено другое программное обеспечение для данного АЦП, это может вызвать нарушение установки драйвера, необходимого для правильной работы ПО «PowerGraph». В этом случае необходимо удалить другое программное обеспечение и переустановить ПО «PowerGraph».

2. Один или несколько каналов "не регистрируются"

  1. Причина: Канал регистрируется, но график сигнала находится выше или ниже области просмотра.
    Решение: Изменить положение графика по вертикали (см. раздел - Каналы и Графики) так, чтобы график был виден в области просмотра.
    Проверить, что канал действительно регистрируется, можно перемещая курсор мыши в графическом дисплее - если канал содержит данные, то значение амплитуды сигнала под курсором будет отображаться на шкале амплитуды (справа от кнопки графика).
  2. Причина: Отключена регистрация этого канала.
    Решение: Включить в настройках этого канала регистрацию данных с АЦП (см. раздел - Настройки каналов).
    Программа «PowerGraph» позволяет отключить регистрацию данных в любом из каналов АЦП, если этот канал используется только для расчетных данных. Отключение регистрации данных в канале сохраняется в настройках каналов, используемых по умолчанию.

3. Сигнал регистрируется "неправильно"

  1. Причина: Сигнал не подключен к входу АЦП.
    Решение: Проверить целостность аналоговых цепей измерительной установки. Убедиться, что измеряемый сигнал "доходит" до входных цепей АЦП (можно использовать стандартные аналоговые осциллографы, вольтметры, тестеры и др.).
  2. Причина: Неправильные настройки входов АЦП.
    Решение: Проверить, что способ подключения сигналов к АЦП соответствует установленному в настройках устройства.
    Многие АЦП позволяют использовать различные способы подключения сигналов - однополюсное ("земля" и 1 сигнальный вход) или дифференциальное ("земля" и 2 сигнальных входа). В ПО «PowerGraph» способ подключения сигналов задается в настройках драйвера устройства - команда Настройки "<Имя устройства>"... в меню Сервис.
    Кроме того, многие АЦП позволяют произвольно настраивать "физические" линии подключения сигналов на "логические" каналы программы. В случае полного отсутствия сигнала в настройках драйвера необходимо также проверить, что используемый вход АЦП соответствует номеру регистрируемого канала в программе.
  3. Причина: Неправильный выбор диапазона измерения амплитуды сигнала.
    Решение: Установить наиболее подходящий диапазон измерения амплитуды сигнала.
    Многие АЦП имеют несколько диапазонов измерения (коэффициентов усиления) сигнала, например: ±10В; ±5В; ±2В; ±1В. Выбор диапазона измерения осуществляется в дополнительном окне Входной усилитель (Input Amplifier), которое также позволяет провести предварительный мониторинг входного сигнала и определить его амплитудные параметры.
    Возможны следующие проявления неправильного выбора диапазона измерений:
    1. Сигнал "обрезается" сверху и/или снизу.
      Амплитуда сигнала превышает диапазон измерения, необходимо увеличить диапазон измерения амплитуды сигнала. Если АЦП не позволяет этого сделать, необходимо уменьшить амплитуду сигнала аналоговыми методами (например использовать делитель перед входом АЦП).
    2. Сигнал имеет "ступенчатую" форму.
      Чувствительности АЦП не хватает для регистрации сигнала с хорошим разрешением по амплитуде, необходимо уменьшить диапазон измерения для повышения чувствительности. Если АЦП не позволяет этого сделать, необходимо увеличить амплитуду сигнала аналоговыми методами (например использовать предварительный усилитель).
  4. Причина: Неправильный выбор частоты регистрации данных.
    Решение: Увеличить частоту регистрации.
    При низких значениях частоты регистрации сигналы записываются с недостаточным разрешением по времени и могут иметь искаженную форму. Для правильной записи сигналов частота регистрации должна превышать частоту полезного сигнала как минимум в 2 раза (теорема Котельникова). Для записи сигналов с хорошим разрешением рекомендуется использовать более высокие значения частоты регистрации.
    В программе «PowerGraph» выбор частоты регистрации осуществляется командой Частота регистрации (Sampling Rate) в меню Сервис (подробнее см. раздел - Регистрация данных).

4. Сигнал на экране очень "маленький"

Причина: Маленький масштаб шкалы амплитуды.
Решение: Увеличить масштаб шкалы амплитуды (подробнее см. раздел - Каналы и Графики).

5. Программа "отказывается" сохранять данные

  1. Причина: Вы используете демонстрационную версию программы.
    Решение: Приобрести рабочую версию программы, в демонстрационной версии все функции сохранения и экспорта данных отключены.
  2. Причина: Функции сохранения и экспорта данных не активированы.
    Решение: Коммерческие версии ПО «PowerGraph» после установки на компьютер дополнительно требуют активации функций сохранения и экспорта данных (для подтверждения вашей лицензии). Подробнее см. раздел - Активация функций сохранения и экспорта данных.

См. также:
Техническая поддержка, Вопросы и ответы


Обновление ПО «PowerGraph»

Пользователи коммерческих версий ПО «PowerGraph» имеют право на бесплатное получение обновлений через Интернет. Доступ к файлам обновлений предоставляется пользователям, имеющим действительную лицензию на использование программного обеспечения «PowerGraph».

Регистрация пользователя

Для получения доступа к файлам обновлений новые пользователи должны пройти процедуру регистрации на Интернет-сайте программного обеспечения «PowerGraph».

Как обновить программное обеспечение

Для обновления программного обеспечения «PowerGraph» необходимо выполнить следующие действия:
  1. Открыть страницу "Обновление ПО" на Интернет-сайте программного обеспечения «PowerGraph».
  2. Вести логин и пароль (указанные при регистрации) для авторизации пользователя.
  3. Загрузить файлы обновлений на локальный компьютер.
    Внимание! Обновление программного обеспечения «PowerGraph» может состоять из нескольких частей: обновление программ, обновление драйверов и др.
  4. Запустить программы установки обновлений.
    Файлы обновлений представляют собой самостоятельные программы, которые следует запускать на компьютере с установленной коммерческой версией ПО «PowerGraph».
Программное обеспечение «PowerGraph» постоянно развивается и дополняется новыми возможностями. Информацию о выходе новых версий и обновлений Вы можете получить на Интернет-сайте ПО «PowerGraph» в разделе Новости.

Предупреждение

Программное обеспечение защищено законами РФ и международными соглашениями об авторских правах, а также другими законами и договорами, регулирующими отношения авторского права.
Установка и использование обновлений программного обеспечения «PowerGraph» свидетельствует о Вашем согласии с условиями лицензионного соглашения. Нарушение любых условий и требований лицензионного соглашения приводит к немедленному и автоматическому прекращению действия Вашей лицензии на ПО «PowerGraph» и может повлечь за собой уголовное и/или гражданское преследование.

См. также:
Техническая поддержка, Лицензирование ПО


Лицензирование ПО

Лицензия - это право на использование программного обеспечения в соответствии с условиями и правилами лицензионного соглашения. Приобретая программный продукт, Вы приобретаете только лицензию (право) на его использование. Все права собственности и авторские права на программное обеспечение принадлежат его разработчикам.

Лицензии ПО «PowerGraph»

Для программного обеспечения «PowerGraph» предоставляются два типа лицензий:
  • HL-лицензия предоставляет право использования программного обеспечения «PowerGraph» с любыми поддерживаемыми устройствами сбора данных.
  • OEM-лицензия предоставляет право использования программного обеспечения «PowerGraph» только с одним определенным устройством сбора данных.

Как получить HL-лицензию

HL-лицензия предоставляется при покупке ПО «PowerGraph» и включает аппаратный USB-ключ.

Как получить OEM-лицензию

OEM-лицензия предоставляется индивидуально для каждого устройства. Для получения OEM-лицензии необходимо передать в службу технической поддержки ПО «PowerGraph» параметры используемого устройства сбора данных. После подтверждения вашей лицензии вся необходимая информация будет отправлена Вам по электронной почте.
В состав ПО «PowerGraph» входит дополнительная утилита «License Query» (Запрос Лицензии), позволяющая определить параметры используемых устройств сбора данных и создать файл запроса на получение OEM-лицензий.

Дополнительная информация о лицензиях находится в папке LICENSES на установочном диске ПО «PowerGraph».

См. также:
Техническая поддержка, Утилита «License Query»


От авторов

Программное обеспечение «PowerGraph» постоянно совершенствуется и дополняется новыми возможностями, поэтому мы заранее приносим Вам свои извинения за возможные ошибки и неточности в этом справочном руководстве.
Любые вопросы, замечания, пожелания и предложения по работе ПО «PowerGraph» Вы можете направлять нам по электронной почте:
soft@powergraph.ru
Дополнительную информацию Вы можете получить в разделе «Техническая поддержка».

Спасибо за использование программного обеспечения «PowerGraph»!

ООО «ДИСофт»


Активация функций сохранения и экспорта данных

Активация функций сохранения и экспорта данных необходима для подтверждения Вашей OEM-лицензии на использование коммерческой версии ПО «PowerGraph».

Как активировать функции сохранения и экспорта данных

Активация функций сохранения и экспорта данных осуществляется автоматически при использовании устройства, имеющего действительную OEM-лицензию на использование в ПО «PowerGraph»:
  1. Подключите Ваше устройство сбора данных (АЦП) к компьютеру, на котором установлена коммерческая версия ПО «PowerGraph».
  2. Укажите это устройство в диалоговом окне Выбор АЦП, появляющемся при запуске программы или при использовании команды Выбор АЦП... в меню Сервис.
Для получения OEM-лицензии ПО «PowerGraph» необходимо обратиться в службу технической поддержки.

Подробнее о лицензиях см. в разделе - Лицензирование ПО.

См. также
Техническая поддержка, Лицензирование ПО